• Register
  • TOS
  • Privacy
  • @NeoGAF
  • Like

Parsnip
Member
(02-12-2016, 03:21 PM)
Parsnip's Avatar

Originally Posted by opticalmace

Brand new here. It is still locked at 30fps in-game, though the menu was 60fps for some reason?

This is what I've done:
- installed DS
- set it to use the beta version in Steam
- installed DSfix, set resolution to 2560x1440. framerate to unlocked, default at 60fps.
- turned off AA in-game

Any suggestions? Thanks.

edit: if it matters, I'm using a 2500k @ 4.3ghz and a 970.

No need to use the beta branch anymore, the default public branch is steamworks and newer.

What other settings are you using, I don't remember specifically how taxing they are but you could try turning some of that other stuff off and see if it makes a difference.
opticalmace
Member
(02-12-2016, 04:13 PM)
opticalmace's Avatar

Originally Posted by Parsnip

No need to use the beta branch anymore, the default public branch is steamworks and newer.

What other settings are you using, I don't remember specifically how taxing they are but you could try turning some of that other stuff off and see if it makes a difference.

Ohh I see. I'll try that when I get home. Thanks!

I'll also lower the settings to see if that helps. I left everything in DSfix default for AA and SSAO and all that.
Shuggananas
Banned
(02-19-2016, 05:50 PM)
Alright here we go

Been using DSFix for a while but noticed some huge performance issues in some areas, thought it was related to my screen (144 Hz G-sync), because game should run nicely on a GTX 970 right ?
Tried to tweak things a bit in my .ini files, game seems to run better but I have some weird gameplay issues like my running speed is slower, what do you recommend ?

Here's my .ini :
http://pastebin.com/9T5gfRAc

From what I gather I should keep "fullScreenHz" at 144 but lower "FPSlimit" to 60 so it runs better ?
Also which is better between SMAA and FXAA, and can I expect performance drops at "aaQuality 4" ? Any performance hit I should expect ? Thanks !
Slick Butter
Member
(02-19-2016, 06:37 PM)
Slick Butter's Avatar

Originally Posted by Shuggananas

From what I gather I should keep "fullScreenHz" at 144 but lower "FPSlimit" to 60 so it runs better ?
Also which is better between SMAA and FXAA, and can I expect performance drops at "aaQuality 4" ? Any performance hit I should expect ? Thanks !

SMAA vs. FXAA is entirely your choice. Most prefer SMAA because it is less blurry. Also, rather than using anti-aliasing at all, try instead downsampling.
Try having renderWidth and renderHeight at 5120 and 2880 respectively, or 3840 and 2160, and change the other width/height to your actual resolution. Don't do this and use AA at the same time though, as you might imagine it will cause a huge hit to your performance.

Definitely turn you FPSlimit to 60 and keep fullscreenHz at 144. I got a high refresh rate monitor myself recently and had to really fumble with the game to get it to even start on it with DSFix. Also try turning off the extra DoF blurring as well as the DoF start resolution just to see if it causing the FPS problem. The blurring can lower FPS a bit but normally I guess it really should be as bad as you described as in the other thread.

Other than these and checking temps/usage, check your NVIDIA GPU settings. I am unfamiliar with them (have only used AMD cards) but I imagine something strange could be set there.
Last edited by Slick Butter; 02-19-2016 at 06:49 PM.
Parsnip
Member
(02-19-2016, 07:15 PM)
Parsnip's Avatar

Originally Posted by Shuggananas

From what I gather I should keep "fullScreenHz" at 144 but lower "FPSlimit" to 60 so it runs better ?

Do this. In my experience the physics will get wonkier the higher you go, and 60 seems like the sweet spot where some things are a bit off but in general the experience is superior.

I tested some stuff at 120 (I think) once and running around and colliding with a door frame for example made me lose all momentum, essentially, and I would be running in place for as long as I kept the stick pressed in some direction. Only way to "reset" the movement speed was to let stick go neutral. I imagine all things associated with 60 fps would also get worse at higher framerates too.

Higher than 60 is pretty neat if you want to take some video and then make some cool slow motion gifs out of it though. But actually playing through the game at higher than 60, just seems like asking for trouble.
Shuggananas
Banned
(02-19-2016, 11:26 PM)
Thanks for the advice, rendering at 5120*2880 and turned off AA, runs really well except when there's a lot of effects like a bonfire but I don't care too much !

Now I just hope DS2 runs better
Last edited by Shuggananas; 02-19-2016 at 11:38 PM.
Slick Butter
Member
(02-20-2016, 02:45 AM)
Slick Butter's Avatar

Originally Posted by Shuggananas

Now I just hope DS2 runs better

Dark Souls 2 runs much better in general except for a couple of areas. Overall much easier to run though. And a better port.
opticalmace
Member
(02-27-2016, 03:29 AM)
opticalmace's Avatar
Is there any need for the internal rendering resolution to be a multiple of my screen resolution (in each dimension)?
DieNgamers
Member
(03-22-2016, 09:19 AM)
DieNgamers's Avatar

Originally Posted by zXe



So if my vertical rendering res is 1080, what would be the right alternative? 810/540? what if I set this higher than 1080, so 2160?

I have a similar question: I play with 1440p and I have the feeling that the preset is a bit too much.

Compare this (a random gif I found)


...to my screenshots:
http://imgur.com/a/1FOTA

Maybe I'm seeing things. Those are my settings:

Code:

############# Depth of field

# Depth of Field resolution override, possible values:
# 0 = no change from default (DoF pyramid starts at 512x360)
# 540 = DoF pyramid starts at 960x540
# 810 = DoF pyramid starts at 1440x810
# 1080 = DoF pyramid starts at 1920x1080
# 2160 = DoF pyramid starts at 3840x2160
# higher values will decrease performance
# do NOT set this to the same value as your vertical rendering resolution!
dofOverrideResolution 540

# Depth of Field scaling override (NOT RECOMMENDED)
# 0 = DoF scaling enabled (default, recommended)
# 1 = DoF scaling disabled (sharper, worse performance, not as originally intended)
disableDofScaling 0

# Depth of field additional blur
# allows you to use high DoF resolutions and still get the originally intended effect
# suggested values:
# o (off) at default DoF resolution
# 0 or 1 at 540 DoF resolution
# 1 or 2 above that
# 3 or 4 at 2160 DoF resolution (if you're running a 680+)
dofBlurAmount 1
Sini
Member
(04-02-2016, 04:05 PM)
Sini's Avatar
How to get vsync working? Neither .ini option or enabling it from Nvidia control panel works.

Edit: noticed that .ini option is in non-working section :(
Last edited by Sini; 04-02-2016 at 04:13 PM.
Kudo
Member
(04-03-2016, 01:39 PM)
Kudo's Avatar
While not DSfix related I'd assume people here are well-versed with the game so asking for help here:

Originally Posted by Kudo

Ok, having some weird problems with Dark Souls 1-2 now.
Haven't played them in some time tried to play today, Dark Souls 1 gets stuck in black screen - if I leave it on for 5 minutes I get the "This game uses Auto Save..." and when I press OK it gets stuck again, not interested in finding out for how long.
Dark Souls 2 seems to work somehow, but in the beginning "Checking Save Data" and when loading save it takes longer than before and the animation stops, so I assume it gets stuck too.
HDD croaking or something else? Only thing I remember changing is getting new sound card, no idea if that can be causing it.
Updating my drivers to 362.00 right now and checking if reboot helps..

EDIT: Reboot and newer drivers had no effect. Any ideas?
Could be happening in other games too, haven't tried.

Afterwards tried several other games and I can definitely say it's not happening in other games, Fallout 4 works smoother and better than ever, load times are so fast.
I've tried disabling other sound controllers from Device Manager so I assume it's not audio problem either.
Also, I tried and if I wait 5 minutes in the Dark Souls 1 intro the black screen goes away and the game works normally.
I have tried with and without DSfix and occurs on both so DSfix is not causing it, I think. (Renamed the DINPUT8.dll)

i7-6700k, GTX 780, Asus Z170-A, Windows 10 64-bit, Dualshock 4 with DS4Windows.
Chris R
Member
(04-17-2016, 11:41 PM)
Chris R's Avatar
So, how playable is the game if I can only get like 40~ fps at 2880p? I'm on a 1440p monitor so I figure that running the game at 2x would be best for scaling. I get 60fps no problem at 1440p but only 40 at 2880p.

Or could I render it at 2160p without it looking funky due to scaling?
Unai
Member
(04-17-2016, 11:43 PM)
Unai's Avatar
A lot of people only played this game at 30, so you are good to go if want the extra image quality.
CHC
Member
(04-21-2016, 01:17 PM)
CHC's Avatar
So is there any trick to using the UI scaling feature or is it just screwy? I always get weird misaligned / yellow boss health bars and stuff like that. Are there only certain multiples that work or is the whole feature just kind of buggy?
Korosenai
Member
(05-30-2016, 09:17 PM)
Korosenai's Avatar
Is there a good youtube guide on how to install and use this mod? I'm a pc noob.
Patrick S.
Member
(05-30-2016, 09:34 PM)
Patrick S.'s Avatar

Originally Posted by Korosenai

Is there a good youtube guide on how to install and use this mod? I'm a pc noob.

It's not really needed. The readme and the explanations in the .ini file you can tweak are easy enought to understand.
Korosenai
Member
(05-30-2016, 10:38 PM)
Korosenai's Avatar

Originally Posted by Patrick S.

It's not really needed. The readme and the explanations in the .ini file you can tweak are easy enought to understand.

Do I paste the files over into the data folder or outside the data folder. I watched two videos and they both did it one of the two ways.
Erheller
Member
(05-30-2016, 10:41 PM)

Originally Posted by Korosenai

Do I paste the files over into the data folder or outside the data folder. I watched two videos and they both did it one of the two ways.

This is what my folders look like:

ctw0e
Member
(05-30-2016, 10:42 PM)
ctw0e's Avatar

Originally Posted by Korosenai

Do I paste the files over into the data folder or outside the data folder. I watched two videos and they both did it one of the two ways.

Place the files in the same folder as DARKSOULS.exe.
Carlius
Junior Member
(05-30-2016, 10:44 PM)
Carlius's Avatar
make sure you disbale AA in the game.
Korosenai
Member
(05-31-2016, 12:08 AM)
Korosenai's Avatar
Should I turn off motion blur also, or just AA?
Sinatar
Official GAF Bottom Feeder
(05-31-2016, 12:09 AM)
Sinatar's Avatar

Originally Posted by Korosenai

Should I turn off motion blur also, or just AA?

Turning off AA is required, motion blur is up to you.
Korosenai
Member
(05-31-2016, 12:19 AM)
Korosenai's Avatar
And one last dumb question.... but how do I get rid of the mouse cursor on the screen when playing -.-
Erheller
Member
(05-31-2016, 12:35 AM)

Originally Posted by Korosenai

And one last dumb question.... but how do I get rid of the mouse cursor on the screen when playing -.-

It's in DSfix.ini. Mine was on line 153.

http://i.imgur.com/lZlqXJE.png
Korosenai
Member
(05-31-2016, 01:47 AM)
Korosenai's Avatar

Originally Posted by Erheller

It's in DSfix.ini. Mine was on line 153.

http://i.imgur.com/lZlqXJE.png

Thank you, and also thanks to everybody for the help!
Jedi2016
Member
(05-31-2016, 01:52 AM)
Jedi2016's Avatar
I didn't even realize that was in there.. I always just pushed the cursor off the screen in the corner.
Orin GA
I wish I could hat you to death
(10-23-2016, 06:33 PM)
Orin GA's Avatar
Im already done with the game but was there a way to have the mouse cursor only show up when in the menus?
prudislav
Member
(10-23-2016, 06:44 PM)
prudislav's Avatar
Iirc mousefix was able to do that - there should be link to working one somewhere in steamforums
Orin GA
I wish I could hat you to death
(10-23-2016, 10:39 PM)
Orin GA's Avatar
Tried it but it disables mouse look for whatever reason. Downloaded the steamworks mouse patch and changed the mouse input line in the dsfix ini. Tried turning off UI mouse as well, but no go. A well, no biggie.
Last edited by Orin GA; 10-23-2016 at 10:46 PM.
Steiner84
All 26 hours. Multiple times.
(12-25-2016, 01:40 PM)
Steiner84's Avatar
So i bought DS1 Prepare to die edition and booted it up and it worked. i disabled AA, started my character and went to the first bonfire. Saved there and quit the game.
Installed DSFix, configured it and now my screen just stays black wehn i try to run the game.
Is this a known issue and what would be the solution?
Lazaro
Member
(12-25-2016, 01:48 PM)
Lazaro's Avatar

Originally Posted by Steiner84

So i bought DS1 Prepare to die edition and booted it up and it worked. i disabled AA, started my character and went to the first bonfire. Saved there and quit the game.
Installed DSFix, configured it and now my screen just stays black wehn i try to run the game.
Is this a known issue and what would be the solution?

It may take awhile for the game to actually start/run,have you tried waiting?
When I set the game to borderless it would always takelike 30sec-1min to actually run.
Last edited by Lazaro; 12-25-2016 at 01:50 PM.
Steiner84
All 26 hours. Multiple times.
(12-25-2016, 01:51 PM)
Steiner84's Avatar

Originally Posted by Lazaro

It may take awhile for the game to actually start/run,have you tried waiting?

I waited for like 3 minutes, becasue ive seen the exe still utilizing my cpu. but nothing happened.
I have renamed the dll and the game starts again.
I then reinstlled the fix to have the default ini. The game starts but accepts no input at all. neither keyboard, mouse nor gamepad..


for what its worth im on a 6700K and gtx 1070 with latest drivers..
Steiner84
All 26 hours. Multiple times.
(12-25-2016, 02:21 PM)
Steiner84's Avatar
ok, so i got it to run, but now its looking like this:




any way to fix this?

this are my settings


# internal rendering resolution of the game
# higher values will decrease performance
renderWidth 2560
renderHeight 1440

# The display width/height
# 0 means use the same resolution as renderWidth/Height
# (use for downscaling - if in doubt, leave at 0)
presentWidth 0
presentHeight 0
Lazaro
Member
(12-25-2016, 02:23 PM)
Lazaro's Avatar

Originally Posted by Steiner84

I waited for like 3 minutes, becasue ive seen the exe still utilizing my cpu. but nothing happened.
I have renamed the dll and the game starts again.
I then reinstlled the fix to have the default ini. The game starts but accepts no input at all. neither keyboard, mouse nor gamepad..


for what its worth im on a 6700K and gtx 1070 with latest drivers..

I think Dark souls has issues with HID gamepads or something. You may have to disable any HID game controllers.

Go to Device Manager
Go toHuman Interface Devices
Disable HID-compliant game controller.

EDIT: Try turning off AA in the in-game menu.
Last edited by Lazaro; 12-25-2016 at 02:26 PM.
nynt9
Member
(12-25-2016, 02:24 PM)
nynt9's Avatar

Originally Posted by Steiner84

ok, so i got it to run, but now its looking like this:




any way to fix this?

this are my settings


# internal rendering resolution of the game
# higher values will decrease performance
renderWidth 2560
renderHeight 1440

# The display width/height
# 0 means use the same resolution as renderWidth/Height
# (use for downscaling - if in doubt, leave at 0)
presentWidth 0
presentHeight 0

Originally Posted by Parsnip

Disable in-game AA.

.
potatohead
Banned
(12-25-2016, 02:26 PM)

Originally Posted by Steiner84

ok, so i got it to run, but now its looking like this:




any way to fix this?

this are my settings


# internal rendering resolution of the game
# higher values will decrease performance
renderWidth 2560
renderHeight 1440

# The display width/height
# 0 means use the same resolution as renderWidth/Height
# (use for downscaling - if in doubt, leave at 0)
presentWidth 0
presentHeight 0

You might have forgot to turn off in game AA settings or forced AA somewhere else
Steiner84
All 26 hours. Multiple times.
(12-25-2016, 02:34 PM)
Steiner84's Avatar

Originally Posted by Lazaro

EDIT: Try turning off AA in the in-game menu.

woah thanks. i had it turned off in the beginning. it somehow turned on again.. works now! thanks.


edit: I HAD it disabled! I dont know with it reenabled on its own.
Patrick S.
Member
(12-25-2016, 07:11 PM)
Patrick S.'s Avatar

Originally Posted by Steiner84

woah thanks. i had it turned off in the beginning. it somehow turned on again.. works now! thanks.


edit: I HAD it disabled! I dont know with it reenabled on its own.

I think if you disable it after you have already saved it doesn't stick.
Steiner84
All 26 hours. Multiple times.
(12-29-2016, 07:46 AM)
Steiner84's Avatar
ok, so i have it now running fine and can enjoy DS from my couch in all its 4k 60fps glory (thanks durante).
But i fell trough the floor once i decended a ladder quick. I have read somewhere (?) that dsfix has an option to limit fps temporarily somehow? I cant find this.
Is this true? How to do it?
Elixist
Member
(12-29-2016, 08:06 AM)
Elixist's Avatar

Originally Posted by Steiner84

ok, so i have it now running fine and can enjoy DS from my couch in all its 4k 60fps glory (thanks durante).
But i fell trough the floor once i decended a ladder quick. I have read somewhere (?) that dsfix has an option to limit fps temporarily somehow? I cant find this.
Is this true? How to do it?

lol i thought that was a myth. i always slide and never had that happen in hundreds of hours. there is a hotkey i cant remember it, look through the fix i think it lists it.
Brhoom
Banned
(12-29-2016, 08:07 AM)

Originally Posted by Steiner84

ok, so i have it now running fine and can enjoy DS from my couch in all its 4k 60fps glory (thanks durante).
But i fell trough the floor once i decended a ladder quick. I have read somewhere (?) that dsfix has an option to limit fps temporarily somehow? I cant find this.
Is this true? How to do it?

Backspace?
CruelTott
Junior Member
(12-29-2016, 08:07 AM)
I think it's just one specific ladder, or maybe two that it happens on.

I believe the default key is backspace to activate the 30 fps limit.
You can change it in DSfixKeys.ini.
Steiner84
All 26 hours. Multiple times.
(12-29-2016, 08:15 AM)
Steiner84's Avatar
thanks guys. ill try when im home.
I had it glitch on the ladder that leads from under the bridge with the hellkite dragon to undead parish in that rondell with the blackknight at the top.

Killed the blacknight and went back to the bonfire to level up my dex and fell trough the map at the bottom of the ladder.



Just discovered the donation link on durantes blog. 5 from me. this is so good.
Morrigan Stark
Arrogant Smirk
(12-29-2016, 09:38 PM)
Morrigan Stark's Avatar
Yep that ladder is glitched. Just hit backspace, slide down, hit backspace again and you're good.

There's also one jump/roll to cross a gap to reach a secret area that is supremely difficult to do in 60 fps for some reason, but works like a charm in 30 fps. The roll you have to do to reach the crow's nest and return to the Undead Asylum
daninthemix
Member
(08-07-2017, 12:29 PM)
daninthemix's Avatar
Just thought I'd drop my findings in here for others.

I'm replaying DS at 4K on a G-sync monitor, and was getting very severe frame-drops when looking at fog gates. Tried lots of things, but in the end switching from borderless windowed to exclusive fullscreen fixed it.

Thread Tools