• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.

Call of Duty Black Ops 3 Beta | PC Performance Thread

VisceralBowl

Member
Sep 30, 2012
7,384
1
600
earth
Beta, I know. Let's talk about it though.
Runs like garbage on my system (3570k/980 TI). Unplayable levels of stuttering. Will play around with it to see if it's something specific.

update: Turning off Vsync and going borderless window made it much more stable for me. Still get it though.
 

Bunta

Fujiwara Tofu Shop
Mar 27, 2013
8,816
0
0
I'm downloading it right now. Will be able to report how a 4790k/r9 290 on windows 10 runs it.
 

Nyteshade517

Member
Oct 23, 2013
7,625
0
0
SC
i5-4690K
R9 290X 4GB
8GB RAM
Windows 10 Pro

I had to set the Textures to just High...Extra High caused stuttering and drops. The AA is set to either SMAAx1 or the Scenic one of that so I'm not trying to max everything out. Things seemed stable as far as I could tell after those changes.

My main issue with the game is that I'm terrible at it...lol
 

Elixist

Member
Apr 6, 2010
4,991
0
570
resolution slider to half, shadows med, no aa everything else maxed 1080p, im gettin about 40- 45 fps on a 7950 and i5. seems okish def not the worst optimization ive seen. runs well on ps4 so hopefully pc sees some more love.
 

VisceralBowl

Member
Sep 30, 2012
7,384
1
600
earth
I had to set the Textures to just High...Extra High caused stuttering and drops. The AA is set to either SMAAx1 or the Scenic one of that so I'm not trying to max everything out. Things seemed stable as far as I could tell after those changes.
This was the solution to my unplayable stuttering problem.
 

therealminime

Member
Jul 9, 2011
4,532
1
0
GTX 980ti
i7-2600k @ 4GHz
8GB RAM
Windows 10

Have everything turned up with Filmic SMAAx2 at 1440p and it runs perfectly for me.

High: 140fps
Low: 67fps
Average: 90fps
 
D

Deleted member 325805

Unconfirmed Member
Runs absolutely terribly for me, I don't remember any game ever running this bad on my machine in fact.

. Constant micro freezing so it feels like I'm jolting around the screen
. Constant frame rate drops
. Terrible performance in general
. CTDs
. Massive memory usage

Basically it's unplayable for me, mostly because of the freezing issue.

i5 3570k @ 4.3GHz
GTX 970
8GB DDR3
SSD
Windows 10 64
355.60
 

Naedtrax

Banned
May 20, 2014
234
0
0
Uses over 8gb Vram at 1080p maxed out at 144hz with SMAAx2

Runs flawlessly on a titan x, but people with 980 ti's i was playing with were complaining about micro stutter which i assume is also your issue Steve
 

Mechazawa

Member
May 31, 2011
8,137
1
545
I'm at max settings, except textures are High(saw the mention of stuttering and didn't even bother with Extra) and AA is 2x SMAA.

At 120fps, the lowest I've seen it go to is 98fps across two maps(the beaten up skyscraper rooftop map seemed to run worse than the map with the house on the canyon). Usually it was around 110ish. This is all with shadowplay on.

I didn't check my framerate much during moments where I'd get blown up by something so I don't know if that had any real effect. Probably should've paid closer attention to that.

When I lock the framerate in game to 90, I didn't see any framedrops.

System:

980 4GB
i5 4570
12GB RAM
Win10 Pro
353.62
 

Coolbgdog12

Member
Oct 10, 2011
4,676
0
0
Runs absolutely terribly for me, I don't remember any game ever running this bad on my machine in fact.

. Constant micro freezing so it feels like I'm jolting around the screen
. Constant frame rate drops
. Terrible performance in general
. CTDs
. Massive memory usage

Basically it's unplayable for me, mostly because of the freezing issue.

i5 3570k @ 4.3GHz
GTX 970
8GB DDR3
SSD
Windows 10 64
355.60
Upgrade your system bro


;p
 

Conor_Fool

Banned
Nov 27, 2012
4,677
1
0
Denver, CO
I started the game assuming it would start with decent graphics. Turned out it looks absolutely horrible and everything was on low. I turned everything to high and nothing changed, and the game crashed after my first match. My FPS is fine but dear god it looks bad.

It says my video card drivers are out of date when I run it. Is this a problem with my computer or with this beta? Before this I've been able to run every [not too demanding] game at the highest settings. This is my laptop by the way:

http://store.hp.com/us/en/pdp/Laptops/hp-omen-notebook---15-5110nr-(touch)-(energy-star)

I'm a total noob and don't even know how to update my video card drivers. Any advice or am I SOL?

EDIT: Shit, mine is actually the 5010nr model
 
Jul 30, 2010
8,269
0
0
GTX 970 and 4670k, getting a ton of stuttering, but the game is totally playable. Maxed settings and resolution scale at 1.0

I have framerate capped at 60 and vsync off, since CoD vsync introduces a MASSIVE amount of input lag.
 

Hip Hop

Member
Jan 14, 2013
10,816
2
655
U.S.A.
GTX 670 and i5 3570k.


I get decent frames max, but the stuttering and mouse lag killed me.

Running everything on low, and it's fine and gets rid of the stuterring somewhat. but there's a bit of mouse lag still.

this game has potential because it's a blast, but they better get to fixing this at launch.
 

RyudBoy

Member
Apr 28, 2010
5,073
0
585
1080p @ high settings, 2x Filmic SMAA. Runs perfect for me. I have the frame rate capped @ 60fps.

GTX 970 / i7-4790k
 

baphomet

Member
Oct 29, 2011
6,053
1,096
755
Denver, CO
I'm getting random frame drops every now and then. Otherwise I'm staying 120-144fps settings max at 1440p with sli msi 980 ti's and 4690k @ 4.4ghz.
 

wrongway

Member
Jul 17, 2013
1,339
0
0
Reposting from the other thread for sake of more data:

i7-860 (3.3ghz)
GTX 970 (slightly above factory clocks)
353.62 drivers
8GB RAM
Win10

Running at 1080, Windowed Fullscreen, 1.0 render ratio. High preset, 2x SMAA. Getting 80-120 FPS at all times from what I've noticed. Had one CTD with no message, and one Windows out of memory error in ~3 hours. Regarding the latter, task manager showed System sitting at almost 2GB. Rebooted and it didn't happen again.
 
Jul 30, 2010
8,269
0
0
Reposting from the other thread for sake of more data:

i7-860 (3.3ghz)
GTX 970 (slightly above factory clocks)
353.62 drivers
8GB RAM
Win10

Running at 1080, Windowed Fullscreen, 1.0 render ratio. High preset, 2x SMAA. Getting 80-120 FPS at all times from what I've noticed. Had one CTD with no message, and one Windows out of memory error in ~3 hours. Regarding the latter, task manager showed System sitting at almost 2GB. Rebooted and it didn't happen again.
My system is very slow to respond after I exit the game, think it's related to the process?
 

Revengineer

Unconfirmed Member
May 5, 2013
1,059
0
0
For those having issues, does capping the framrate ingame to 60 do anything? I set that for my rig and have had no issues.. I have had plenty of stuttering and choppiness in other games though.

i5 4670k
970 GTX
16 GB RAM
SSD
Win 10 Home updated fully
Asus Motherboard, all components fully updated driver-wise

EDIT: Derp. Running everything as high as it can go except for VSYNC (off) and max frames (60)

EDIT2: Double derp. Been having beers. 1080p resolution, full screen, 1.00 scaling, 85 FOV.
 

wrongway

Member
Jul 17, 2013
1,339
0
0
My system is very slow to respond after I exit the game, think it's related to the process?
Not sure, my system didn't seem sluggish after that crash, but I did just go straight to rebooting. I have noticed that System sucking up memory in Win10 is a trend though. I don't know enough about it, but it makes me think Win10 has a memory leak. My System process is just 60MB now with 3 hours uptime, but I've noticed it taking up 1-3GB on several occasions. If System is hogging your RAM, try a reboot and see if the game plays and exits happily.
 

bbd23

Member
Jan 24, 2014
7,993
0
0
3570k
970
8gb RAM
(all stock)

Windows 10

settings high, 2x smaa, framerate locked to 60, borderless window

runs pretty damn perfect.

game looks disgusting though. looks like a smeared mess.
 

Smushroomed

Banned
Jan 15, 2013
1,241
0
0
Spent a short time playing:

MASSIVE frame drops when looking at waterfalls: 140 to 70 fps drop

Some frame drops when in a firefight

Settings: everything completely maxed out on 1440p/144fps limit on max FOV

i5 4670k
980ti sli
16gb ram
SSD
win 10
gsync rog swift

SLI usage varies, but the 2nd card is utilized about 10-20% less
 

Hip Hop

Member
Jan 14, 2013
10,816
2
655
U.S.A.
For those having issues, does capping the framrate ingame to 60 do anything? I set that for my rig and have had no issues.. I have had plenty of stuttering and choppiness in other games though.
Wow.

the 60 fps cap makes all the difference. the stutter is almost gone with this.

It makes it a bit annoying with a 144hz monitor, but it will do for now.
 

luckygodzilla

Member
Oct 24, 2012
1,294
0
0
360 controller shows this:



Maybe there is PS4 controller support for this game?
Funny thing is, when I booted the game up for the first time, all the menu prompts were for a dualshock 4 for a brief moment before the PC overlay kicked in.

As for performance, slightly north of 50 is what I get on my 880m (with several severe drops when aiming down particularly long sightlines).
 

ILoveBish

Member
Feb 1, 2010
4,224
0
675
Runs like BUTTER for me. Not a SINGLE dropped frame in 3 hours of playing.

Windows 10
Skylake i5-6600k @ 4.3
660ti
8gb ddr4-2400
SSD for boot and games

Seriously runs flawless.
 

wbEMX

Member
Apr 7, 2014
1,174
0
355
Straubing, Germany
i7-4790K @4,2GHz
ASUS GTX 970 OC
8 GB RAM (1333MHz)
Installed on a 7200rpm HDD
Windows 10 Pro x64

Runs like pure butter for me with everything maxed out in 1920x1080 except for textures. Extra quality for textures causes stuttering for me. With resolution scale set to 1,00 and a FOV of 85 I get 90-120fps, it never goes under that. Now if the netcode would be better this would be perfect.
 

cripterion

Banned
May 15, 2010
6,654
0
0
Osaka, Japan
i7 4790K
16GB ram
GTX 970 SLI
Acer XBU270HU
Windows 10 pro x64

So running this at 1440p and It runs like hot crap. Keeps stuttering everytime I fire a weapon. Sitting on specialists menu, runs about 46fps.

Will try to lower the texture resolutions but holy hell wasn't expecting that performance after enjoying the PS4 beta.

EDIT : setting the texture to high and it's about 124fps on specialist screen
 

Pjsprojects

Member
Feb 6, 2013
2,613
12
470
AMD FX8350 Black

R9 290x 4gb

8gb ram

Windows 10 64bit

Game runs spot on at the extra high and high settings with filmic aa. Running at 1080p with 60fps.Vsync on.
 

Mahnmut

Member
Apr 10, 2013
177
0
440
Try to launch the game > black screen > back to desktop...

GTX670 with updated drivers, win 8.1.

Any idea ?
 

Pjsprojects

Member
Feb 6, 2013
2,613
12
470
Try to launch the game > black screen > back to desktop...

GTX670 with updated drivers, win 8.1.

Any idea ?
Seems best to do a cold boot before you load the game. Mine black screened on the very first start up but a reboot sorted it.
Pretty sure the Beta has a memory leak because if you exit out the game and then reload it stutters. A reboot sorts it completely.
 

Tovarisc

Member
Jul 1, 2014
16,139
0
0
i5 6600K @ 4.4GHz
16GB DDR4
980Ti
W10 Pro

Game maxed out on 1080p runs at around ~110FPS with major dips in certain areas of maps, when close to large explosions etc. and game has constant micro stuttery feel to it making it feel unresponsive and inaccurate. Trying to downsample from e.g. 1440p caused insane drop in FPS, for comparison e.g. BF4 doesn't take such major nosedive when downscaling.

Going to play with settings today and see if I can get better performance out of this.

Seeing how much CPU, RAM and VRAM this beta eats up within minutes of booting up it makes me think they are quite literally bruteforcing PC port to run atm by throwing power and resources at it. 90% CPU usage, 5GB of RAM used etc. are quite insane numbers for game of this scale and looks.
 

wbEMX

Member
Apr 7, 2014
1,174
0
355
Straubing, Germany
i5 6600K @ 4.4GHz
16GB DDR4
980Ti
W10 Pro

Game maxed out on 1080p runs at around ~110FPS with major dips in certain areas of maps, when close to large explosions etc. and game has constant micro stuttery feel to it making it feel unresponsive and inaccurate. Trying to downsample from e.g. 1440p caused insane drop in FPS, for comparison e.g. BF4 doesn't take such major nosedive when downscaling.

Going to play with settings today and see if I can get better performance out of this.


Seeing how much CPU, RAM and VRAM this beta eats up within minutes of booting up it makes me think they are quite literally bruteforcing PC port to run atm by throwing power and resources at it. 90% CPU usage, 5GB of RAM used etc. are quite insane numbers for game of this scale and looks.
Did you turn down the texture quality from extra to high? Extra seems to be buggy and the reason for stuttering at the moment.
 

Kezen

Banned
Jul 28, 2014
8,919
0
0
France
I have not tested it myself but from the various reports I'm reading the beta seems to run really well.
 

Pjsprojects

Member
Feb 6, 2013
2,613
12
470
Did you turn down the texture quality from extra to high? Extra seems to be buggy and the reason for stuttering at the moment.
Not sure about Extra setting being buggy because I'm running it fine.
Agree with the above about brute force for the pc version,this build is clearly designed for consoles.
 

Mahnmut

Member
Apr 10, 2013
177
0
440
Seems best to do a cold boot before you load the game. Mine black screened on the very first start up but a reboot sorted it.
Pretty sure the Beta has a memory leak because if you exit out the game and then reload it stutters. A reboot sorts it completely.
I tried but still the same. If I disable the sound in the windows sound manager it works.
But when I try to re enable it once the game is launched it crashes.
The GTX is hooked to my Yamaha AV Receiver.
 

Pjsprojects

Member
Feb 6, 2013
2,613
12
470
Extra caused micro-stutter for me and for others. FPS are fine but you notice stuttering. Huh.
No micro stutter at all and I was playing using Raptor video capture on.

Really looking like they need to optimise for all the system combo's.