Does Resident Evil HD Remaster on Steam work for anyone else?

I just downloaded the game on a freshly formatted and updated PC.. and all I get is a black window for about 2 seconds then it closes again.

I've tried multiple things in the Nvidia control panel (resolution, refreshrate, scaling options) and nothing works. There's was a comment about an old exe in the forums, so I tried that and it doesn't work either.

So either it's the latest Windows Insider Build that I'm on with has broken it, or maybe it's Nvidia's drivers?

Anyone else able to run it with no issues?
 

brian0057

Member
Literally tried everything there.
I've played it with Intel integrated graphics on Windows 10 so I don't know if that helps.
It runs like shit even with the fixes. But it runs nonetheless.
That being said, I've replayed it most both on original hardware and on Dolphin. And the latter runs so much better than the HD Remaster.
 
I've played it with Intel integrated graphics on Windows 10 so I don't know if that helps.
It runs like shit even with the fixes. But it runs nonetheless.
That being said, I've replayed it most both on original hardware and on Dolphin. And the latter runs so much better than the HD Remaster.
Yea. Well, I know it worked in the past.. I've played it many times without issue.. but now suddenly, neither RE1 nor RE0 work. They both do the same thing. Black window for 2 seconds, then close.

Nothing seems to work.. so I'm guessing it's either a new Nvidia driver thing that broke the game, or the Windows Insider Build that I'm on which has broken them.

Hell, they work fine on my Steam Deck.. but I want to play on my PC lol.
 

brian0057

Member
Yea. Well, I know it worked in the past.. I've played it many times without issue.. but now suddenly, neither RE1 nor RE0 work. They both do the same thing. Black window for 2 seconds, then close.

Nothing seems to work.. so I'm guessing it's either a new Nvidia driver thing that broke the game, or the Windows Insider Build that I'm on which has broken them.

Hell, they work fine on my Steam Deck.. but I want to play on my PC lol.
You said you have a fresh install of Windows.
Can you try it without the dedicated GPU and maybe you can start rulling out variables?
As in, uninstalling the drivers and running from the iGPU.
 
Last edited:

PSlayer

Member
I finished the game over and over again on steam and worked fine. I do remember the game crashing a few times at the intro but it was very rare.

GPU: 1650 Super
CPU: Ryzen 1600AF
RAM: 16GB
 
Top Bottom