Middle-earth: Shadow of Mordor PC Performance Thread

Haden

Banned
Nov 28, 2007
460
0
0
I have an i7 processor, 8gb ram and a GTX 765m laptop any chance I can run this game reasonably? I am not really sure what my system equates to, I am happy to run most games medium settings at a low resolution, any advice would be most welcome.
 

Lime

Member
Apr 27, 2008
26,894
0
0
Anyone have an R9 290 and 2500k playing in 1440p?

I'd like to get an idea of what I'm in for
I'm on a i7 4790k with a 290. With Vsync on, I get like 62 fps with everything set to ultra, except textures and motion blur.
 
Dec 24, 2011
251
0
505
UK
www.twitch.tv
Well I've been playing about with various settings all day on my setup with an i7 3770K (OC) and a GTX780 (OC 3GB) and there seems to be a ton of 'situations' in the game which can suddenly bring the frame crashing down - weather, some fires, certain locales with the fly baits, large enemy numbers etc.

The only way I have been able to reliably 100% get 60fps without a hiccup is setting everything to high and using borderless mode with Vsync enabled. I've also ditched DoF and Motion Blur because I simply don't like them.

This gives a guaranteed 60fps for me and to be quite honest using the Boulotaur 64 bit injector to clean up the whole image I am not seeing any significant difference from using some of the Ultra options.

I swear sometimes as a PC gamer the desire to set everything to max ruins my enjoyment of these games. High is high and good enough in this case (for me).
 
Jul 22, 2007
20,049
0
0
So, anyone using max settings with ultra textures on a 4 gb gtx 770? I saw the chart earlier for the 2 gb version but i was curious if the 4 gb 770 was fairing any better. Just aiming for 1080p/60 but im ok with dips.
 
May 25, 2014
102
0
0
I was looking forward to playing this game all day but instead the game keeps stuttering and I've spend all evening trying to get it to work.

Specs:
CPU: i5 2500k @4,6
GPU: R9 290
RAM: 8gb
OS: W8.1

The game keeps stuttering. It doesn't matter if I put the game on low or high, vsync is disabled, I tried AMD 14.4, 14,7 & 14,9 drivers, installed it on my SSD instead of my normal hd... Nothing seems to fix my problem. Even when I go through the menu everything goes slow/stutters.

I did a benchmark on low and high and got these results:

Low: Max: 808/Average: 90/Min: 7
High: Max 400/Average: 80/Min: 7

Both times the drop to 7fps happend at the beginning.
Perhaps you're paging memory to hard disk? I suggest using Process Explorer to check the memory load (run the program and press ctrl+i) over something like Windows' built-in Resource Monitor. I mentioned in a previous thread how Watch Dogs would start paging to disk and crash if I had too many browsers open. I don't have the game yet but I'm curious how much memory size matters.

Also, if you have a hard limit set to how large the page file is allowed to grow then that might also be an issue. One of the reasons I had crashes in Watch Dogs was because I thought that I wouldn't need more than a gigabyte of SSD space for the pagefile because I have 12GB of system RAM. Even at that memory size, I would get stutters as the OS started paging my browser sessions to disk.

The graph to pay attention to is System Commit rather than Physical Memory. Below the graphs is Commit Charge which has Limit/Peak which become important if they ever go over your 8GB of system RAM.
 

Chakan

Member
May 10, 2009
1,787
13
750
Got 1080P@60fps with an i5 4670 and a gtx 770 2GB. Everything on Ultra, except textures.

Not a single issue so far. Game is running great. Good job Monolith.
 

Salaadin

Member
Apr 5, 2009
11,718
0
705
34
Pennsylvania
So has anyone actually booted the game up with Ultra everything, textures included and checked to see how much VRAM is was taking up on average? Im really curious.
 

matics

Member
Jul 3, 2010
2,970
30
580
Thank you based durante!

How to skip the annoying intro videos:

1. Text screens and middleware:

goto:
Steam\SteamApps\common\ShadowOfMordor\game\interface\videos\legal

there, rename:
legaltext.vib -> legaltext_.vib
legaltext_fr.vib -> legaltext_fr_.vib
middleware.vib -> middleware_.vib

2. Nvidia and Shadow of Mordor title plate

goto:
Steam\SteamApps\common\ShadowOfMordor\game\interface\videos

there, rename:
intro.vib -> intro_.vib (plus your game language)
nvidia_splash.vib -> nvidia_splash_.vib

Boom!
title menue in 3 seconds
Thanks for this!
 

Coolbgdog12

Member
Oct 10, 2011
4,676
0
0
This Intel Pentium G3258 still running strong.

Intel Pentium G3258 oc'd to 4.4GHZ
8GB DDR3
3GB Radeon HD 7970
Win 8.1

Max settings(except textures)
Benchmark looks nice.
 

JackHerer

Member
May 29, 2012
2,003
0
0
So this game does not utilize SLI? I have 4 Titans (6GB) and the game is only running at 55-60 fps (settings maxed at 2560x1440)
 

Smokey

Member
Nov 15, 2005
41,212
1
1,205
www.twitch.tv
Update for me.

Yesterdays results at 4k - ultra settings + hd textures

28 fps. No SLI Profile was applied.


Todays results 4k ultra settings + hd textures using FEAR 3 SLI Bits:

About 47 fps

A little better but not really where it should be.


So this game does not utilize SLI? I have 4 Titans (6GB) and the game is only running at 55-60 fps (settings maxed at 2560x1440)
Try using the FEAR 3 SLI bits in Nvidia Inspector.
 

x3sphere

Member
Sep 24, 2006
4,897
0
1,020
AZ
gamercards.exophase.com
Been playing a bit at 4K with 980 SLI... Ultra settings are a no go at this res, lots of stuttering, kind of expected that though. High textures work fine.

I settled on setting the resolution slider to 70% to get a locked 60. Hopefully newer drivers will improve performance. Oh and I am using the FEAR 3 SLI bits.
 

stanleyc415

Neo Member
Jan 9, 2014
56
0
0
The Internet
I installed the HD TEXTURE PACK but my VRAM usage on ULTRA still only says around 3.5 GBS @ 1080p While on HIGH it says around 2.5ish anyone else see this?

This is under the benchmark.
My GPU is Gtx 970
 

RankFTW

Unconfirmed Member
Sep 4, 2013
802
0
0
Scotland
That is not representative of Ultra Texture at all. You need to play single player, your game will start to chug (based on reports).



Weird, I'm confused then, why are some people with 980's reporting chugging with ultra textures and some not?

Not to mention the game uses 5.8GB of VRAM on my Titan. Now I'm confused, something is not adding up, either you are wrong or other people are insane.
Right got that video made now. Game is silky smooth while playing.
 

Nokterian

Member
Jul 20, 2012
18,404
1
0
twitter.com
Played this morning and tonight and i have to say this is a good port it just works monolith did a very good job with this. Even though i don't have the ultra textures enabled this game looks beautiful. Constant 60-70fps also forced AA through nvidia inspector and looks so nice now.
 

ohohdave

Member
Dec 19, 2012
59
0
0
CPU - i7-4770 3.4GHz
GPU - NVIDIA GeForce GTX 770 4GB DDR5 (dxdiag shows as 12153MB)
RAM - 16GB

Ultra errting

Benchmark gives a 47fps score.
During the bench it was locked to 30fps until it switched to 60. (selected locked 60 and v sinc.)

Hope it helped, diving in... NOW.
 

scitek

Member
Aug 23, 2005
17,119
10
1,230
El Paso, TX
twitch.tv
Well I've been playing about with various settings all day on my setup with an i7 3770K (OC) and a GTX780 (OC 3GB) and there seems to be a ton of 'situations' in the game which can suddenly bring the frame crashing down - weather, some fires, certain locales with the fly baits, large enemy numbers etc.

The only way I have been able to reliably 100% get 60fps without a hiccup is setting everything to high and using borderless mode with Vsync enabled. I've also ditched DoF and Motion Blur because I simply don't like them.

This gives a guaranteed 60fps for me and to be quite honest using the Boulotaur 64 bit injector to clean up the whole image I am not seeing any significant difference from using some of the Ultra options.

I swear sometimes as a PC gamer the desire to set everything to max ruins my enjoyment of these games. High is high and good enough in this case (for me).
As a PC gamer unwilling to go sli, I've gotten used to locking games to 30fps and maxing the graphics out if I can't maintain a relatively solid 60fps. That is, unless the console equivalent runs at 60fps, then I'll drop settings because the developer clearly prioritized framerate and intended for the game to be played that way.
 

StalkerUKCG

Member
Jun 4, 2011
17,138
0
645
I didn't download the HD texture pack if that thing is optional but

I7 3.5ghz Stock
780ti 3GB
16GB DDR3

Benchmark with everything on Ultra said Average FPS was 81fps and everything felt smooth.

Res = 1080p
 

Coolbgdog12

Member
Oct 10, 2011
4,676
0
0
How do I download the HD textures if I'm playing the game through Steam family share?? My cousin's PC which is downstairs from me has it downloading but when I go on mines upstairs the download button on the steam page goes to an error screen that says:
An error was encountered while processing your request:

There was a problem adding this product to your Steam account.
 

Kezen

Banned
Jul 28, 2014
8,919
0
0
France
How do I download the HD textures if I'm playing the game through Steam family share?? My cousin's PC which is downstairs from me has it downloading but when I go on mines upstairs the download button on the steam page goes to an error screen that says:
You cannot.
 

-tetsuo-

Unlimited Capacity
Aug 19, 2007
19,303
1
1,020
Neo-Tokyo
Wow using shadowplay spikes the hell out of my cpu usage. Game hovers around 50% cpu usage without. Then i turn it on and it spikes to 100% every time no matter what
 

bcl0328

Member
Mar 26, 2012
2,293
0
0
i have an i7-3770k with a gtx 680 SC and i have everything on ultra, even downloaded ultra textures and i run the game flawless.

did i do something wrong?
 

Seanspeed

Banned
Sep 10, 2009
29,419
0
0
i have an i7-3770k with a gtx 680 SC and i have everything on ultra, even downloaded ultra textures and i run the game flawless.

did i do something wrong?
Yea, you were supposed to buy the PS4 version, cuz you don't have 6GB of vRAM.
 

SaberEdge

Member
Mar 5, 2014
833
3
0
Yes I can I played it last week and it is above 30 with dips from 60.

Played it tonight on my machine as I was let down with shortages on the 970 I wanted I now have to wait to end of October or even November before in stock again to fur fill my order so still sporting a 7870 and performance is woeful indeed. Had to dip textures to medium (and pretty much everything else) and then I get no where near a locked 60 but the stuttering of texture load is gone.

At high it can drop to single digit a lot and is unplayable. A simple case of the new consoles memory layout simply having the entire ram in one go and swapping from system ram to VRAM causing massive judder.

That said love the game and story and voice acting, some ropey scene loading and why in the hell do we still have fmv cutscenes this gen?!?
Ok, cool, thanks. I have a PS4 and a good PC, but I haven't got the game yet for either. It looks like a great game though. I'm looking forward to it.
 

Kevyt

Member
Oct 27, 2012
9,582
1
390
That was my question. :lol
Oh sorry, I thought you meant that as if you had a 970 and ran it in ultra while maintaining 60 fps in a form of a question.

I installed the HD TEXTURE PACK but my VRAM usage on ULTRA still only says around 3.5 GBS @ 1080p While on HIGH it says around 2.5ish anyone else see this?

This is under the benchmark.
My GPU is Gtx 970
Do you have a screenshot for this? what frames are you getting and under what settings?
 

Artchur

Member
Sep 2, 2007
100
0
0
Victoria, BC
That's good news, do you have 2GB or 4GB?
2GB. After playing for a bit longer I do notice some slow down mostly related to when things get, for lack of a better term, "wraithy". I will play around with the settings and see what I get. I don't think the benchmark does a very accurate job of depicting in game scenarios.