• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • Hey Guest. Check out the NeoGAF 2.2 Update Thread for details on our new Giphy integration and other new features.

Modder 'fix' Tales of Zestiria on PC, it's now running at 60fps

Lutherian

Member
Sep 9, 2014
1,316
0
0
37
France
Thanks a lot for this mod, it's great !

I'm really scared about the PC version of Symphonia, since it's based on the PS2 version witch resulted in the terrible port on PS3 : terrible framerate on the world map, terrible textures, 30 FPS in battles and exploration (while the GameCube version was at 60 FPS everywhere but not on the world map), mini freezes on the world map (did I already said that there's problems on the world map ?).
 

Vazra

irresponsible vagina leak
Sep 12, 2010
44,197
1
140
Nah
Thanks a lot for this mod, it's great !

I'm really scared about the PC version of Symphonia, since it's based on the PS2 version witch resulted in the terrible port on PS3 : terrible framerate on the world map, terrible textures, 30 FPS in battles and exploration (while it was 60 FPS everywhere but not on the world map), mini freezes on the world map (did I already said that there's problems on the world map ?).

We shall see what happens with Symphonia. I believe it might be doable to mod it to 60fps but gotta see the way it the port is done.
 

Falk

that puzzling face
Aug 26, 2013
20,818
0
0
www.vgo-online.com
I'd be less worried about Symphonia, since that's a game that was originally 60fps, which means it'd be more of undoing whatever changes were made to get it to run at 30fps (Symphonia), rather than bumping the framerate and then dealing with unforeseen issues running at a rate the game wasn't made to run at (Zestiria).

You're right though, ultimately no one knows till the game is out and it can be looked at.
 

Lagamorph

Member
Aug 6, 2013
5,975
0
485
35
UK
Been using this fix for a little while now and I'm happy to say I've had almost zero problems.
The only issue I have is that whenever I exit the game, I get a message that the .exe has stopped working. If I remove the fix, that error goes away. Odd, but I can certainly live with it since it only happens when I actually quit the game manually anyway.


I'd be less worried about Symphonia, since that's a game that was originally 60fps, which means it'd be more of undoing whatever changes were made to get it to run at 30fps (Symphonia), rather than bumping the framerate and then dealing with unforeseen issues running at a rate the game wasn't made to run at (Zestiria).

You're right though, ultimately no one knows till the game is out and it can be looked at.
Boy, this post turned out to be incredibly wishful thinking.....
 

Easy_D

never left the stone age
Jan 5, 2008
23,623
2
0
I'd be less worried about Symphonia, since that's a game that was originally 60fps, which means it'd be more of undoing whatever changes were made to get it to run at 30fps (Symphonia), rather than bumping the framerate and then dealing with unforeseen issues running at a rate the game wasn't made to run at (Zestiria).

You're right though, ultimately no one knows till the game is out and it can be looked at.

Been using this fix for a little while now and I'm happy to say I've had almost zero problems.
The only issue I have is that whenever I exit the game, I get a message that the .exe has stopped working. If I remove the fix, that error goes away. Odd, but I can certainly live with it since it only happens when I actually quit the game manually anyway.



Boy, this post turned out to be incredibly wishful thinking.....

Not exactly. Kaldaien said his frame unlimiter would be able to get the game running at 60 FPS since it uses the same frame limiter as Zestiria. But it's impossible until the poopy DRM used is cracked. So yeah, paying customers get fucked over again.
 

Skyfireblaze

Member
Dec 19, 2011
4,639
1
0
Germany
Can someone help me? I'm a bit stumped here, I just double-dipped on Zestiria for cheap on Steam and the game works great normally but I can't get TZFix to work :/ No matter what I do the game either won't start at all or hang on black-screen with the cursor visible.

My system:

GTX 1070
i5 3570k
8gb RAM
Windows 7
 

Kaldaien

Neo Member
Dec 16, 2015
50
0
0
Cape Coral, FL
Are we supposed to change anything? I still can't get the game to start with TZFix at all :/

I can't really diagnose a problem like that by guessing. This is why the mod outputs 6 different log files :)

The guide's not as well organized as my later work, but the way I prefer to handle troubleshooting is if you paste the logs to pastebin and then post in the thread on the Steam forums. I get notifications for any comments or posts to that thread and guide. I do not monitor reddit, Neogaf, etc. Heck, I frequently miss problem reports on GitHub; Steam will always be the best place to get support for my projects.
 

Corpekata

Banned
Jun 7, 2013
20,280
1
0
I actually had a problem with ToZ early on around launch, it would crash because I had some third party audio software running. It happened to a lot of people, it either didn't like the software or surround sound period and people had to disable software, update it/ drivers, or switch to stereo as fixes.

Try to disable some programs. Can't remember the name of the one that did it for me, was related to my motherboard. It actually happened with a few other games like Darkest Dungeon so I eventually just uninstalled it.

Edit: Nahamic was the name.
 

Skyfireblaze

Member
Dec 19, 2011
4,639
1
0
Germany
I can't really diagnose a problem like that by guessing. This is why the mod outputs 6 different log files :)

The guide's not as well organized as my later work, but the way I prefer to handle troubleshooting is if you paste the logs to pastebin and then post in the thread on the Steam forums. I get notifications for any comments or posts to that thread and guide. I do not monitor reddit, Neogaf, etc. Heck, I frequently miss problem reports on GitHub; Steam will always be the best place to get support for my projects.

Oh I had no idea the developer actually was posting/reading here, that's nice but yeah I understand that. I managed to get it to work now simply by using version 1.4.2 instead of 1.4.4 now it runs perfectly at 1440p 60fps with 2048 shadows. Thanks for the great work! :D

Would it help you still if I try it with 1.4.4 again and send you the logs?
 

Falk

that puzzling face
Aug 26, 2013
20,818
0
0
www.vgo-online.com
Boy, this post turned out to be incredibly wishful thinking.....

Not exactly. Kaldaien said his frame unlimiter would be able to get the game running at 60 FPS since it uses the same frame limiter as Zestiria. But it's impossible until the poopy DRM used is cracked. So yeah, paying customers get fucked over again.

Half a year later no 60fps

RIP the dream
 

Easy_D

never left the stone age
Jan 5, 2008
23,623
2
0
Half a year later no 60fps

RIP the dream

Eh! 60 FPS is possible, they just have to hex-edit the game scene for scene. It'll take a decade or two, don't worry! It's true though, I forgot who, but they managed to get some 60 FPS action going but it required too much manual work to be a feasbile project :(
 

Skyfireblaze

Member
Dec 19, 2011
4,639
1
0
Germany
Okay I found the solution to all my troubles and 1.4.4 works too now. It was the fault of the MSI Afterburner OSD. The settings of TZF.exe didn't apply for Afterburner for whatever reason. After manually setting Stealth Mode to ON for Tales of Zestiria.exe in RTSS everything works like a charm problem free with 1.4.4 :)
 

Hoover1979

Neo Member
Oct 29, 2014
12
0
0
I can't get the fix to work.

Just like the Tales of Symphonia fix when I run the game nothing happenes and the .exe is sitting in processes under Task manager, but can't be switched to. If I try again it says an instance is already running. So for me the only way to get the game to start at all is by deleting the fix or renaming the d3d9.dll to something like d3d9.old.

Is this because I removed Data Execution Prevention (D.E.P.) from my Windows 7 with a script in elevated command prompt, because I am sick of it blocking my games and refusing to add 64bit games to an exception list?