• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

NeoGAF PC Gaming General Performance Tweaking Thread

rallyart

Neo Member
Sep 28, 2009
117
0
0
Any trick for improve Assassin Creed Revelation performance??

I'm having some massive fps drops randomly, at the great bazar, views from sky, etc.

What I´ve tried, disable Hyperthreading, set compatibility to win xp, turn down some setting (like AA from 4 to 8, apparently there is no difference at all).

i7 920@ 3.8ghz
GTX580
6 gb ram
nvidia 290.53
win 7 x64 ultimate.

thanks
 
Sep 15, 2010
4,252
0
0
Any trick for improve Assassin Creed Revelation performance??

I'm having some massive fps drops randomly, at the great bazar, views from sky, etc.

What I´ve tried, disable Hyperthreading, set compatibility to win xp, turn down some setting (like AA from 4 to 8, apparently there is no difference at all).

i7 920@ 3.8ghz
GTX580
6 gb ram
nvidia 290.53
win 7 x64 ultimate.

thanks

The game is CPU limited. Nothing you can do about it other than upgrade your CPU to something higher end. I get drops even with a 4.7 Ghz 2500k.
 

Felix Lighter

Member
Oct 2, 2007
20,750
1
0
The game is CPU limited. Nothing you can do about it other than upgrade your CPU to something higher end. I get drops even with a 4.7 Ghz 2500k.

That's good to know. I never ended up finishing Brotherhood because I could never get vsync to work properly and i can't stand tearing. Knowing that Revalations performs poorly, gives me no incentive to go back to it.
 

dr_rus

Member
May 3, 2007
10,983
0
1,350
Moscow, Russia
The frame limiter is missing?

Screw that, I'm not upgrading then. That was an awesome feature.
You can use MSI Afterburner's frame limiter. I haven't tried it myself but it's supposedly better and works with all driver versions.

Beta FXAA? how do i look up more info about this and what drivers/cards support it and how to use it?
All cards, 290.53 drivers, it can be turned on via NVIDIA Inspector but it is very buggy at the moment -- guess that's why they've removed it in 295.51.
 

Felix Lighter

Member
Oct 2, 2007
20,750
1
0
I'm having a weird issue with Batman Arkham City. When ever I close the maps/menus the framerate falls dramatically for a few seconds and then quick returns to normal. Is this something that everyone experiences? Is there anyway to fix?
 
Sep 15, 2010
4,252
0
0
I'm having a weird issue with Batman Arkham City. When ever I close the maps/menus the framerate falls dramatically for a few seconds and then quick returns to normal. Is this something that everyone experiences? Is there anyway to fix?

That's very strange. What GPU and drivers are you using?
 

Felix Lighter

Member
Oct 2, 2007
20,750
1
0
That's very strange. What GPU and drivers are you using?
7970 with the latest drivers. The frame rate drops to 30 fps for a couple seconds (a very choppy 30 fps) and then it ramps back up to 60 and runs smoothly until I bring the map or menus back up. I'm force triple buffered vsync with d3doverrider. It's 100% consistent. It's a minor annoyance but it does make me not want to view the map.
 
Sep 15, 2010
4,252
0
0
7970 with the latest drivers. The frame rate drops to 30 fps for a couple seconds (a very choppy 30 fps) and then it ramps back up to 60 and runs smoothly until I bring the map or menus back up. I'm force triple buffered vsync with d3doverrider. It's 100% consistent. It's a minor annoyance but it does make me not want to view the map.

Use Vsync + triple buffering from the game's ini files and disable D3D Overrider.
 
Sep 15, 2010
4,252
0
0
Also, I found Nvidia Inspector settings for antialiasing for Warhammer 40k Space Marine on Guru3D, figured since I & others may have picked it up yesterday for $5 from the THQ store that we'd want some antialiasing.

Warhammer 40k: Space Marine

0x00001241 - For MSAA/TrSSAA
0x000012С1 - For SGSSAA; OGSSAA
0x000112C1 - For OGSSAA+MSAA
 

Felix Lighter

Member
Oct 2, 2007
20,750
1
0
Use Vsync + triple buffering from the game's ini files and disable D3D Overrider.

I see the UseVsync option but I don't know how to enable triple buffering in the bmengine.ini.

Edit: Nevermind, I disabled D3D Overrider and used RadeonPro to force vsync and triple buffering and the problem is solved. I wish I would have figure it out earlier. Thanks for pointing me in the right direction.
 
Apr 17, 2008
2,442
0
985
New York
Not sure if there's a better thread to go to for help, but I just had a problem trying to continue a game of Quake IV that I started last year. Just posted this in the Steam forums:

I just tried to load a saved game I had from the last time I played (12/4/11). The save is: mapstart Strogg Medical Facilities. The loading bar fills up and says to click to continue. When I do, the screen goes black and the audio plays. Not really sure why this is happening. When I load the previous quicksave file the game loads fine. Unfortunately when I get to the same loading screen mentioned above (Strogg Medical Facility), the same thing happens with the screen going black and the audio playing. Guess I shoulda beat it when I was playing back in December.

I have disabled FRAPS and Radeon Pro, restarted, verified game cache and removed the autoexec.cfg file to no avail. Any help would be awesome.
 

TronLight

Everybody is Mikkelsexual
Oct 2, 2011
3,317
0
775
Well, I'll try to ask here.
I bought Deus Ex: Human Revolution from Gamersgate, I took the key, I put it on steam, I installed the game, and I played.
The games runs smooth (70 fps fixed with all on Max) but... In the cutscene it's like having an fps drop, but fraps show always 400fps!
I don't know if I explained myself, it's like a bad streaming, it snaps a lot, with every cutscene... This make the game unplayable.
Also, its the only game with this problems...
I have a Gigabyte GTX570 with a little OC pre-applied and a i5-2500k stock. Someone can help me?
 

Ledsen

Member
Mar 25, 2007
12,259
2
0
Sweden
I don't know about your particular problem, but DE:HR has tons of weird performance issues like stuttering when near light sources etc.
 

TheExodu5

Banned
Nov 27, 2007
38,093
3
0
Ottawa, Canada
The game is CPU limited. Nothing you can do about it other than upgrade your CPU to something higher end. I get drops even with a 4.7 Ghz 2500k.

Seriously? Brotherhood ran fantastically on my stock 2500K and 2x GTX 570 no stutters and a perfect 60fps lock. When I sold one of my GTX 570 mid playtrough, I started getting the occasional drop below 60 fps.
 
Sep 15, 2010
4,252
0
0
Seriously? Brotherhood ran fantastically on my stock 2500K and 2x GTX 570 no stutters and a perfect 60fps lock. When I sold one of my GTX 570 mid playtrough, I started getting the occasional drop below 60 fps.

Brotherhood is different than Revelations, though. Revelations has weird FPS drops in certain places with lots of NPC's. It's so odd to be going around the city and then just randomly drop to a locked 30 FPS for 2-3 seconds and then back up to 60.
 

TheExodu5

Banned
Nov 27, 2007
38,093
3
0
Ottawa, Canada
Brotherhood is different than Revelations, though. Revelations has weird FPS drops in certain places with lots of NPC's. It's so odd to be going around the city and then just randomly drop to a locked 30 FPS for 2-3 seconds and then back up to 60.

So you're saying it's not triple buffered either? Brotherhood was definitely triple buffered. =\

Still haven't gotten around to playing Rev.
 
Sep 15, 2010
4,252
0
0
So you're saying it's not triple buffered either? Brotherhood was definitely triple buffered. =\

Still haven't gotten around to playing Rev.

I have no idea what's wrong with it, tbh. It drops to 30 FPS at random spots (usually on roofs when overlooking NPC's)... but ONLY 30. Then goes back up to 60. If the game is already triple buffered, I wonder if it could be doing that because I'm using D3dOverrider to force triple buffering as well? Hm
 
Oct 19, 2009
589
0
840
Does anyone have any idea of how to show CPU temperature in game? (OSD)

I've tried using Rivatuner and HWinfo as recommended elsewhere but Rivatuner doesn't even have an OSD option under the settings for me.

In case it matters, I'm using an AMD Phenom II.
 

n0n44m

Member
Mar 4, 2009
2,207
0
0
Netherlands
Does anyone have any idea of how to show CPU temperature in game? (OSD)

I've tried using Rivatuner and HWinfo as recommended elsewhere but Rivatuner doesn't even have an OSD option under the settings for me.

In case it matters, I'm using an AMD Phenom II.

I remember doing it when I had a Core2Duo as there was some plugin for Rivatuner

MSI Afterburner is the modern version of Rivatuner btw (with the same OSD options), but I can't find any CPU temp plugin other than the Rivatuner Core2Duo one ...

then again the only game that comes close to stressing my CPU is Civilization 5
 
Sep 15, 2010
4,252
0
0
Does anyone have any idea of how to show CPU temperature in game? (OSD)

I've tried using Rivatuner and HWinfo as recommended elsewhere but Rivatuner doesn't even have an OSD option under the settings for me.

In case it matters, I'm using an AMD Phenom II.

Here:

http://forum.techinferno.com/hwinfo...splaying-hwinfo32-64-sensor-values-games.html

http://forum.notebookreview.com/gam...lay-cpu-gpu-usage-temp-etc-2.html#post7681007

Those two links will show you how to do it.
 
Oct 19, 2009
589
0
840
I remember doing it when I had a Core2Duo as there was some plugin for Rivatuner

MSI Afterburner is the modern version of Rivatuner btw (with the same OSD options), but I can't find any CPU temp plugin other than the Rivatuner Core2Duo one ...

then again the only game that comes close to stressing my CPU is Civilization 5


Thanks a million, helpful as always guys.
 

Stallion Free

Cock Encumbered
Jan 21, 2009
29,933
0
0
Connecticut, U.S.
steamcommunity.com
I have no idea what's wrong with it, tbh. It drops to 30 FPS at random spots (usually on roofs when overlooking NPC's)... but ONLY 30. Then goes back up to 60. If the game is already triple buffered, I wonder if it could be doing that because I'm using D3dOverrider to force triple buffering as well? Hm

Yeah, I get that with the in-game v-sync and when I use triple buffer it doesn't drop to 30 anytime a scene goes below 60.
 
Sep 15, 2010
4,252
0
0
Yeah, I get that with the in-game v-sync and when I use triple buffer it doesn't drop to 30 anytime a scene goes below 60.

I guess I'll screw around with it and see if disabling triple buffering fixes it, thanks! I figured it was some retarded CPU optimization issue like AC2 and Brotherhood had.
 
Sep 15, 2010
4,252
0
0
Syndicate Bloom Fix + Enhanced Quality

BLOOM FIX:
press ctrl+alt+~
enter xr_effectmodels 0
ENHANCED QUALITY:
pressctrl+alt+~
enter xr_adaptivequalitymode 3
enter xr_fxaa 3
enter xr_postaa 3
enter xr_ssao 2
enter xr_ssaogain 0.5
KNOWN ISSUES:
although the heavy bloom will be fixed, the screen will darken when running. I’m trying to resolve this issue and will incorportae it into the upcoming Syndicate CFG maker on release. Enjoy!

You can also enter those variables into environment.cfg in My Documents/Syndicate.

So add these lines to the end of environment.cfg.

Code:
xr_adaptivequalitymode 3
xr_fxaa 3
xr_postaa 3
xr_ssao 2
xr_ssaogain 0.5

SOURCE: http://donotargue.com/note/syndicate-cfg-maker-on-its-way-bloom-fix-and-enhanced-quality/
 

TronLight

Everybody is Mikkelsexual
Oct 2, 2011
3,317
0
775
One way to enable the Anisotropic filterin The Witcher 2? With the ubersampling I can't achieve a good framerate. :(

Edit: I used nVidia Inspector and I adeed 8x anisotropic, lol
Works great.

Anyway a friends of mine said to me that Inspector could overheat the vga, is that real? For now is everything ok. :)
 

Jtrizzy

Member
Jun 20, 2007
8,667
0
0
North Carolina
Was hoping for a little bit of a tutorial/help on AA. I've tried the stuff from the op in Nvidia inspector but feel like I'm doing it wrong.

Inspector has a feature that will upload a shot of the global or specific game settings. I was hoping someone would upload the proper settings for Chaos Theory. When I enable shader model 3.0, AA is automatically disabled.

We could even keep a collection of the inspector uploads for future pc gamers. If we have a couple to go off of, it will make it easier for people to do the tweaks on their own.
 

Rice-Eater

Member
Aug 10, 2006
13,969
0
1,180
I know this isn't really the thread for question but I didn't want to ask a new one just for small problem.

I just got STEAM and bought LA Noire. I have a 5.1 surround sound system, and everything seems to be working fine except I don't have voices coming from my center channel. Music and background noises sound fine on every satellite, voices also come out from the side and rear speakers. It's only the center channel where I'm not getting sound when the characters are speaking to each other.

Does anybody know what's wrong and what I can do to fix it. I've been all over Google the past hour and I can't find anything. Someone please help.
 
Sep 15, 2010
4,252
0
0
Was hoping for a little bit of a tutorial/help on AA. I've tried the stuff from the op in Nvidia inspector but feel like I'm doing it wrong.

Inspector has a feature that will upload a shot of the global or specific game settings. I was hoping someone would upload the proper settings for Chaos Theory. When I enable shader model 3.0, AA is automatically disabled.

We could even keep a collection of the inspector uploads for future pc gamers. If we have a couple to go off of, it will make it easier for people to do the tweaks on their own.

Use this AA compatibility bit for Chaos Theory: 0x080100c.

I used 32x CSAA on that game with no problem.
 
Sep 15, 2010
4,252
0
0
http://img.techpowerup.org/120305/nvidia_20120305_030732.png



If you have a sec, could you take a look at this...I am wondering about gamma correction. Also, don't I change some of the filtering options for the global setup to 16 somehow?

Another question, does everything from Inspector just automatically override settings in the Nvidia control panel?

Keep gamma correction on. Force 16x anisotropic (user defined). And yes, Inspector overrides Nv Control Panel.
 
Sep 15, 2010
4,252
0
0
RAGE Custom Config for High End Machines
I have been playing RAGE lately and it is truly one of the most stunning games around. I made a custom config for those of us with high-end rigs.

Recommended hardware:
Midrange or above GPU with 1.5-2GB+ of VRAM
Quad-core CPU
4 GB of RAM
Optionally, a fast HDD or SSD will make a good difference as well

I am playing with 8x MSAA + 4x Transparency Supersampling AA, 2560x1440... and with this config I am averaging 2 GB of VRAM usage, sometimes up to 2.3 GB. HOWEVER I have 99% eliminated the texture pop-in thanks to forcing almost everything to load up into VRAM and the game looks gorgeous and runs like a dream. It never drops below 60 FPS, even with Vsync + triple buffering.

Go to Rage/base and make a file called 'Rageconfig.cfg'. Then paste these settings into it.

Code:
vt_pageimagesizeuniquediffuseonly2 8192 
vt_pageimagesizeuniquediffuseonly 8192 
vt_pageimagesizeunique 8192 
vt_pageimagesizevmtr 8192
vt_restart 
vt_maxaniso 4
image_anisotropy 4
vt_maxPPF 64
cvaradd g_fov 12
image_usecompression 0
vt_useCudaTranscode 2
image_preload 1
image_lodbias -1
image_useCache 1
image_cacheMegs 1536
image_cacheMinK 50
r_useHighQualityPostProcess 1
r_shadowsHighQuality 1
r_useHBAO 1
r_useMotionBlur 1
r_skipBump 0
r_skipSpecular 0
r_cgFragmentProfile best
r_skipNewAmbient 0
vt_lodBias -2
r_cgVertexProfile best
AllowConsole 1
SkipIntroVideo 1
vt_uncompressedvmtr 1
vt_uncompressedphysicalimages 1
vt_vmtrcompression none
vt_preload 1
vt_qualityhdplossless "1"
vt_qualityhdppower "1"
vt_qualityhdpspecular "1"
vt_qualityhdpnormal "0"
vt_qualityhdpdiffuse "1"
vt_qualitydctpower "100"
vt_qualitydctspecular "100"
vt_qualitydctnormal "100"
vt_qualitydctchroma "100"
vt_qualitydctluma "100"
vt_maxlockedpages "2048"
g_showPlayerShadow "1"
r_showGlobalShadows "1"
r_showDimShadows "1"
r_showAmbientLighting "1"
r_showDynamic "1"
r_showEdges "1"
r_showEnvs "1"
r_showShadows "1"
r_showBlendedLights "1"
r_showBlendedSurfOverdraw "1"
r_showBuffers "1"
r_showCommits "1"
r_showCracks "1"
r_showDepth "1"
r_showDestinationAlpha "1"
r_showDetailNodeBounds "1"
jobs_numthreads 2
vt_feedbackLodBias -1

After that, start up the game. It will look glorious and shouldn't have any texture loading problems + runs like a dream.
 

subversus

I've done nothing with my life except eat and fap
Oct 26, 2009
24,268
0
0
Thanks, my 7950 has 3 gigs of RAM, it will be enough.
 

JVIDICAN

Member
Aug 24, 2010
1,373
0
655
Started Bullet storm last night. I'm not sure if it's the config modifications or a known issue, but the first actual chapter consists of me falling through the geometry and into an unending void. Skybox looks nice, I guess. :/
 
Sep 15, 2010
4,252
0
0
Thanks, my 7950 has 3 gigs of RAM, it will be enough.
Yup. I tried to get 16k textures to work but kept running out of VRAM, even at 1080p with 4x MSAA. Oh well, they don't look any better. You could try them though. Just replace '8192' in the first 4 lines with '16384'.

Started Bullet storm last night. I'm not sure if it's the config modifications or a known issue, but the first actual chapter consists of me falling through the geometry and into an unending void. Skybox looks nice, I guess. :/

I don't think it's the config, sounds like a game bug. Try restarting the game.

If we're only running at 1080p a 1.5 gb 580 would still work with this right?

Yup, sure would. You may need to turn down MSAA to 4x though, check your VRAM usage with MSI Afterburner. I think the reason I'm hitting 2GB+ is because I'm using 1440p downsampled to 1080p.
 

Jtrizzy

Member
Jun 20, 2007
8,667
0
0
North Carolina
Just for a little more clarification...So the last two AA settings in inspector don't really effect the others? Transparency Multi and Transparency super? Those are if you are doing the AA solution you outlined in the OP?

I want to tinker with the AA in NBA 2k12 as well, and I think I understand how it's working somewhat better now. Thanks as always. Now that I look there isn't even a profile for NBA 2k12 in inspector. That seems odd. No Fifa 12 either.


Also noticed that when I enter that AA flag you gave me, it adds a 0 in when I copy/paste to inspector:

http://img.techpowerup.org/120305/nvidia_20120305_030732.png
 
Sep 15, 2010
4,252
0
0
Just for a little more clarification...So the last two AA settings in inspector don't really effect the others? Transparency Multi and Transparency super? Those are if you are doing the AA solution you outlined in the OP?

I want to tinker with the AA in NBA 2k12 as well, and I think I understand how it's working somewhat better now. Thanks as always. Now that I look there isn't even a profile for NBA 2k12 in inspector. That seems odd. No Fifa 12 either.


Also noticed that when I enter that AA flag you gave me, it adds a 0 in when I copy/paste to inspector:

http://img.techpowerup.org/120305/nvidia_20120305_030732.png

The last two AA settings in Inspector are for transparencies. Multisampling is for DX9 and is less effective than Transparency Supersampling. Supersampling works on most everything, whereas Sparse Grid Supersampling is made to be used with specific MSAA settings + compatibility bits.

Transparencies can be edge of certain objects, foliage, grass, trees etc. Transparency AA eliminates that annoying shimmering in grass, fences, trees, etc.