• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

No Mans Sky | PC Performance Thread

madmook

Member
May 17, 2006
4,145
1
0
SoCal
how did you get the 369.09 drivers? windows update isn't showing it and i can't get seem to get it from nvidia. says that 368.81 is still the latest.
I USB clean installed Windows 10 build 1607 (downloaded direct from MS through their media creation tool). After booting into Windows it automatically downloaded and installed 369.09 after a little bit. I do not know of another way to get this version. I believe it is tied to the anniversary update of Windows 10.
 

VAD

Member
Jul 23, 2009
1,167
0
0
Thanks for the tips about vsync, it looks like my game runs fine now. (i5 750 and 970)
Also, disconnect all other controllers if you plan to play with a xbone one, it won't register otherwise.
 

billyxci

13 year old console warrior. Put me on ignore.
Aug 3, 2014
13,847
8,805
1,040
I USB clean installed Windows 10 build 1607 (downloaded direct from MS through their media creation tool). After booting into Windows it automatically downloaded and installed 369.09 after a little bit. I do not know of another way to get this version. I believe it is tied to the anniversary update of Windows 10.

i went into device manager and right clicked my gpu and checked for updates. that did it. strange why nvidia haven't got it on their site or it doesn't download through windows update.
 
Oct 27, 2012
2,538
3,285
975
39
i5 3570 nonK, 8GB ram and MSI 970 here, the game works mostly well in mid-high, with noticeable FPS dips, but I get heavy stuttering on transitions (from ground to ship, etc.). Using the newest drivers. Disabling the FPS lock and the Vsync and enabling Triple buffering in the control panel helped but I get tearing. I'll try installing in my SSD and installing GeForce experience later today
 

Stoze

Member
Feb 20, 2013
4,202
0
415
I do not know of another way to get this version. I believe it is tied to the anniversary update of Windows 10.

You can just go into Device Manager and update the graphics card from there to 369.09, but yeah I think it came with the latest Windows update.

So I kinda liked what I played from those 2 hours so I caved in and bought it, and as I played more...the performance issues I was having cleared up. Like I have 4 hours played and don't remember having a hitch within the last hour. I didn't disable shader caching because it cleared itself up, but I'm betting that's it (can be turned off in the Nvidia control panel). Now I'm hoping for fixes to take off the vignetting, CA, scanlines...etc.
 
Dec 9, 2012
761
0
0
England
It's not even been out 24 hours. Perhaps they were trying to, you know, sleep? It's 9am in the UK right now.

There was this update 7 hours ago, http://steamcommunity.com/app/275850/discussions/7/360672137536640057/

"We are going to create an experimental branch with hot fixes for these most common known issues:
• Shader Cache issue – means that framerate is initially stuttering on some cards. Whilst it resolves itself over time (~1 hour of play), we will fix this issue in a patch.
• SSE 4 – for CPUs that do not support SSE 4, it is causing the game to crash on boot (some of these area technically below min spec, but we don’t want it to crash!)
• Mouse controls jitter on foot – this caused by a combination of certain resolution and GFX card. A fix is in progress.
"

The shader cache issue is definitely affecting me, if I play for a while the game starts performing a lot better, hopefully the hot fix is out soon.
 

Diggler

Member
May 25, 2006
187
0
1,380
It looks like the game is internally rendering at 720p to my eyes, anyone else agree? No matter what resolution I run at, it looks very blurry and jaggy.
 

Stoze

Member
Feb 20, 2013
4,202
0
415
It looks like the game is internally rendering at 720p to my eyes, anyone else agree? No matter what resolution I run at, it looks very blurry and jaggy.

Yeah that's my biggest issue with the game currently. It looks crap no matter the framerate or AA solution. I may just turn AA off just because it helps a tad, that and sitting further away from my monitor than usual.
 

Tankshell

Member
Apr 24, 2012
1,245
0
0
UK
So this is completely unplayable over Steam Link for me. Hitches and stutters constantly. Runs a lot better on my actual PC (but still the occasional stutter). I've already followed all the tips in the OP.

I have been running some very hardware intensive games over Steam Link without any issues previously including Witcher 3 and GTAV, so hope it isn't my hardware specs.

Anyone found a solution?

Rig:
2500k @4.5
780Ti SC
16GB ddr3
SSD
 

madmook

Member
May 17, 2006
4,145
1
0
SoCal
i went into device manager and right clicked my gpu and checked for updates. that did it. strange why nvidia haven't got it on their site or it doesn't download through windows update.
They're supposed to release a new "game-ready" driver next week, wonder if that'll be 369.09 or an even newer version with additional optimizations for NMS.

Also, chromatic aberration is a stupid thing.
 

Last_colossi

Member
Feb 1, 2014
1,051
0
0
Australia
Ok, so I just finished playing a stupidly long 5 hour and 44 min No Man's Sky gaming session and here are my results:

Specs:
Intel 6700K (stock clocks)
16GB RAM (@ 2400Mhz)
Nvidia GTX 1070 FE (again at stock clocks)

I purchased my copy from GOG.com for 2 reasons, the price is way lower than steam in Australia ($60 USD on steam and $47 USD on GOG) and of course it's DRM free.

I've been playing the game on my TV in my lounge room with an Xbone Controller for my entire playthrough, The in game graphics settings are set to the following:

Window Mode - Fullscreen
Monitor - Primary
Resolution - 1920 x 1080
V-Sync - On
Anti Aliasing - FXAA
On-Foot & Flight FOV - 100
Gamma - 120

Anisotropic Filtering - 16
Texture Detail - High
Shadow Detail - Medium
Generation Detail - High
Reflection Quality - Medium
Show HUD - On
Max FPS - Max

Performance wise the frame rate was above 60fps 99% of the time.

I did get stuttering but it was only very minor. It does stutter during the games boot up (flying through the solar systems) and it occasionally stutters when loading new areas, but this doesn't happen very often and I can fly across a planets surface in my ship with it's boosters fully engaged with no FPS drops and almost no stuttering at all.

As far as draw distances are concerned I seem to be lucky as I can stand on top of a mountain and zoom all the way in, in any direction with my analysis tool and still see detail for miles.

The game is far from perfect and it has its fair share of issues but I really don't think the game's anywhere near as bad as some people are saying.

I think this is a case of a good game with bad launch optimisation akin to Arkham Knight.
 

venomenon

Member
Jul 6, 2013
685
0
0
Germany
youtube.venomenon.de
Damn, this game has a massive CPU usage, to the point it's hardly possible to have a stream running simultaneously.

Some settings that were posted here helped a lot in getting it to run properly, though. Fps fluctuate between 60 and 85, hitching does hardly happen at all anymore. No crashes as of now (played for 8 hours). i5-3450, GTX 970, 8 GB RAM.

I set it to all max 1920x1080 at locked 30FPS
Maybe try setting FPS to 60 or max and decrease shadows and/or reflections a notch.
Never really used Big Picture mode, but isn't that a bit of a resource hog as well?
 

Patrick Young

Member
Apr 17, 2016
866
0
240
i5 2500K (pretty sure I overclocked, might be at 4.2 something)
GTX 970 4GB
8GB RAM
Windows 10 (no anniversary update)
Samsung 850 EVO

Launched from Steam Big Picture mode, I set it to all max 1920x1080 at locked 30FPS, FOV left at 75. Runs pretty crappy! I forgot to put up a counter, but it feels like it averages around 25FPS. Big hitches when I take off and do the warp speed thing in the ship.
 

kami_sama

Member
May 30, 2011
4,915
0
0
www.steamcommunity.com
OK, so I was having the same performance issues as many of you.
Here's what I did to fix it:

in Nvidia Control Panel, set Vsync to Adaptive and set Shader Cache to OFF.

That smoothed everything out for me. Hope it works for others.

(Fullscreen, max settings)
Ok, I did the shader cache thing, and the stuttering is almost gone.
 

LiQuid!

I proudly and openly admit to wishing death upon the mothers of people I don't like
Sep 25, 2006
11,528
0
1,560
40
Crashing after Hello Games logo. I can't find any information to confirm if my card is capable of running OpenGL 4.5. Can someone help me? It's an R9 280
 

Kenzodielocke

Banned
Dec 24, 2014
22,161
4
0
Do we have any low/medium/high comparisons? It seems like all loot the same to me.

Restarting the game everytime is a pain in the arse.
 

Cannon Goose

Member
Nov 28, 2011
4,093
0
660
Australia
Disabling g-sync is definitely not a fix.

What a fucking shit show this game is.

Numerous people in that thread stated that they saw no difference in performance on their G-sync setups, so this fix might only apply to AMD users.

I've got a G-sync monitor and that setting does nothing on my end.
 

Joe Spangle

Member
Jan 12, 2016
260
0
0
Would anyone know why my FPS counter isnt showing in this game? Is it something to do with the display mode? Ive tried fullscreen and boarderless window but no counter shows. There are a couple of other games i have that it never shows on - Dragons dogma was one.

Its annoying having to restart this game to apply changes to graphics settings.
 

sfried

Member
Apr 25, 2009
5,896
0
815
Anyone here with an AMD card to compare performance?

I have:
i7-6700k@4.0GHz
Asus R9 Nano 4GB HBM
32GB DDR4 RAM
Samsung 1TB SSD + 4TB Toshiba HDD (+ 256GB M.2)

Game ran pretty janky at first, but when I turned framerate (and every other setting) to Max, everything felt fluid minus a few stutters and some screen tearing, but otherwise everything was playable to the point I forgot there were any issues and just got immersed in the exploring.

I'm running on the latest AMD Crimson Drivers (16.8.2). Dunno if it could be optimized further.
Disabling g-sync is definitely not a fix.
It is when you have an AMD card :p
 

gossi

Member
Feb 18, 2013
4,690
1
0
Would anyone know why my FPS counter isnt showing in this game? Is it something to do with the display mode? Ive tried fullscreen and boarderless window but no counter shows. There are a couple of other games i have that it never shows on - Dragons dogma was one.

Its annoying having to restart this game to apply changes to graphics settings.

Game uses OpenGL (which PS4 uses) rather than DirectX. Your fps counter likely hooks DirectX.
 
Feb 24, 2008
9,648
1
920
I can say it seems some of the graphical options are BROKEN.

Possibly that's why TB noticed a change when he put everything in low, restarted the game, put it on high again, and restarted once more.

In specific, the SSAAx4 option in AA doesn't seem to work, at least with my amd card.
And more importantly, the fps limit option isn't working properly.
60 fps limit was giving me a very strange 30-50 fps performance. 90fps limit seems to limit it to 65 fps, and of course off it's giving me around 85 fps. So that's why the game is having a strangely bad performance for lots of people, and others were saying it was ok, some people were limiting the fps and others not.

Because with the theoretical (actually broken) 60 fps cap I was having a variable inferior framerate, I didn't think it had anything to do, but I was wrong.
 

Rox598

Member
Apr 22, 2013
4,230
226
620
Does anyone know how to delete the save game and restart?

Not sure if I want too but I feel like I've screwed up and should restart
 

Santar

Member
Aug 19, 2010
2,410
2
0
Norway
Do w know what setting affects the horrible pop in?
I have everything on medium except generation detail, which is on high and the pop in is just extreme.
 

EVO

Member
Sep 22, 2012
999
0
0
970/6700k/16GB/W10/GOG.

Performance hasn't been great for me so far. No crashes so far, but the frame drops are nasty and game the game doesn't look all the good. Feeling like a bit of an idiot for preordering this on GOG only a few hours before release, especially since I've got an unopened copy of the PS4 LE too.
 

billyxci

13 year old console warrior. Put me on ignore.
Aug 3, 2014
13,847
8,805
1,040
updating to nvidia 390.91 driver on my 1070 seems to have made the game run way worse. keeps freezing for like half a second every 5 seconds or something.

also the game it self i find way too confusing and it's getting really repetitive already so i'm done with it. just not worth it. maybe if performance is fixed and they improve the gameplay with future patches i'll come back to it. i'll check back in a few months.
 

saveweyard

Banned
May 19, 2012
4,076
0
0
Virginia Beach
I disabled gsync last night when I was messing around with the fov settings in that file since I have an amd card and it did seem to reduce the stuttering a bit.

I don't see any shader cache options for my amd card, though.

Edit: Nevermind, found it, I'm not awake enough this morning.
 

FunkyDealer

Banned
Mar 9, 2015
4,723
0
0
I disabled gsync last night when I was messing around with the fov settings in that file since I have an amd card and it did seem to reduce the stuttering a bit.

I don't see any shader cache options for my amd card, though.

I believe it's in the Catalyst Control Centre, under gaming. You'll need to select No Man's Sky and then there's a Shader Cache option. Don't know if you can turn it off, or if it's just on/optimized.
 

saveweyard

Banned
May 19, 2012
4,076
0
0
Virginia Beach
I believe it's in the Catalyst Control Centre, under gaming. You'll need to select No Man's Sky and then there's a Shader Cache option. Don't know if you can turn it off, or if it's just on/optimized.

Yeah, thanks! Found it after I decided to start having my morning coffee. I'm not awake, yet, apparently.
 

FunkyDealer

Banned
Mar 9, 2015
4,723
0
0
Yeah, thanks! Found it after I decided to start having my morning coffee. I'm not awake, yet, apparently.

Could you turn it off? Any difference in the game for you?

I'm interested because, as you can guess, I've got AMD as well. But I've not got the game yet. Most of the discussion so far has been on Nvidia cards.
 

sfried

Member
Apr 25, 2009
5,896
0
815
Could you turn it off? Any difference in the game for you?

I'm interested because, as you can guess, I've got AMD as well. But I've not got the game yet. Most of the discussion so far has been on Nvidia cards.

Yes, it can be turned off.
Under the Profile Settings for No Man's Sky, there should be a pull down tab for Shader Cache. It now has Off, AMD Optimized, and On.
 

Hasney

Member
Dec 6, 2012
46,467
2
0
I did all the things that were causing stutters last night, like quickly flying above hills and flying at terrain level. Perfectly smooth now. So goddamn happy.