• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.

PS4's Automatic RGB setting is unreliable, so double check your TV / PS4

Jan 27, 2011
7,638
25
660
Nevada, USA
***The problem*** :

The PS4's RGB [Automatic] setting is unreliable with certain TV's/PC Monitors. Or it's the TV/PC monitor that's improperly sending it's EDID settings. Same bad end result either way. For example, I verified this with my own BenQ monitor. My display is clearly set to full, and the ps4 is set to automatic, but apparently the PS4's 'automatic' setting is assuming limited. So I'm getting a washed out image (where blacks are dark greys and true whites are dirtied) The problem only fixes itself when I have to manually put the PS4 to output at full. Update : Tried it with multiple monitors, from BenQ, ASUS, Samsung - they are all set at RGB Full yet the PS4 on automatic is assuming limited.

Ether way, Sony should look into this, and you - should just assume the worst and set it up specifically and don't trust the automatic setting. Especially if you're using a PC monitor since those seem to favor RGB full.
*** How to Fix This ***

- Under settings -> sound and screen -> your ps4 RGB output is at automatic by default. You want to either change it to limited or full, to match whatever your TV or PC monitor is set at. Check your TV's picture menu to see what it's RGB levels are, under the options the tv may have it listed as black level, or RGB range, or color space, different tv companies call it different things but it refers to the same thing. Whatever it is, it's going to be some kind of option in the picture menu that has a choice between two settings. The higher choice on your TV, is referring to PS4 Full. The lower choice on your TV, is referring to PS4 Limited. Choose a setting on your TV and make the necessary adjustments to your PS4.
- If your TV only has a LIMITED or LOW setting, or if it doesn't even have an option for this at all (probably an older TV) then assume limited, and set the PS4 to limited.

The above steps are for ideal conditions. Some TV's call the RGB color range different things, like black level, so if you need help post it in here and I'm sure others with similar model TV's can help.
*****Important, since all TV's label it differently, but all these terms mean the same thing, observe:
Full : High/Normal : Wide : RGB 0-255 = all equate to Full RGB setting on PS4
Limited : Low : Narrow : RGB 16-235 = all equate to Limited RGB setting on PS4
In summary: Your TV/PC Monitor and PS4 need to match. Full to Full. Or Limited to Limited. As others have said, it's not like one is necessarily 'better' than the other. They just have to be the same between devices. And don't trust the PS4's Automatic setting, depending on the type of display, the PS4 and TV/PC Monitor do not necessarily communicate proper RGB color ranges properly. Check your TV and PS4 and make sure they match up and SET IT UP MANUALLY.

PS4 Limited + TV Limited = You're Good
PS4 Full + TV Full = You're Good
PS4 Full + TV Limited = Not Good. Crushed Blacks. You'll get a more vibrant image, but don't be fooled, this is not good since games will start being overly dark, especially in darker areas, it'll be impossible to see.
PS4 Limited + TV Full = Not Good. Washed out, dull, flat image. Everything seems too over-exposed, and blacks appear "greyish"
Know that essentially all (99.999%) of PC Monitors default to RGB Full. So you need to set the PS4 to RGB Full to match. And know that most HDTV (televisions) default to RGB limited. So set your PS4 to limited. If your TV has an auto setting, you might as well set it specifically to either limited or full, and then match it up with the PS4. Really, there is no need to trust these auto settings, especially now that you know what limited/full means and that matching it up is important.

EDIT: BTW* Just so we're clear the PS4's color gamut is fine, it's just that the automatic setting doesn't work on certain TV's, particularly PC monitors and needs to be set manually/specifically.

PS: The Xbox One works the same way. Except Xbox calls RGB Limited (TV) and RGB Full (PC). You can find this under it's settings menu.
 

Turbowaffles

Member
Jun 1, 2013
1,402
0
525
Hmm, I did feel like I had to set the brightness way lower than I thought it should be in The Last of Us. I will give this a shot when I get home.

Thanks for the heads up, TC!
 

GribbleGrunger

Dreams in Digital
Oct 12, 2012
15,183
6,574
1,075
I just have my Philips set to PC and it's perfect. I couldn't believe the difference it made for both my PS4 and my PS3.
 

Harp

Member
Feb 27, 2013
644
0
0
Most Tv's should be set to limited. I think the issue is your using a computer monitor which when used on a pc should be set to full. The reality is most computer monitors don't really communicate at all.
 

RedRooster

Member
Apr 7, 2013
1,340
0
485
Saskatoon, SK
I highly recommend calibrating your tv correctly before doing anything else though. Factory defaults and presets really are way off the majority of the time, you'll see it right away when doing a calibration. Usually their brightness/contrasts are WAY too high, and then everything is a gray mess that no setting on the console can fix.
If you find you have to always adjust the in game brightness settings for various games, calibrate now.

But that is a good point about full RGB. I wondered why it looked no different between auto and off, so I left it off. Will go manual tonight!
 

luffeN

Member
Sep 13, 2006
5,025
0
1,030
I just have my Philips set to PC and it's perfect. I couldn't believe the difference it made for both my PS4 and my PS3.
I will test out what OP said but this is also good advice! Connected my PC to my LG 3D TV and the mouse was lagging. Changed the HDMI input to PC and boom, perfect everything.
 

Trace

Banned
Feb 15, 2014
9,027
1
0
Vancouver, BC
I did this awhile ago with my BenQ monitor. Night and day difference between setting it to full and limited, make sure you're getting all your colors!
 

SLOSifl

Member
Dec 9, 2013
70
0
360
PIttsburgh, PA
twitch.tv
It's more accurate to say that your monitor/television isn't properly communicating with the PS4. My Panasonic plasma and the PS4 decided on Full by themselves. The PS4 is set to automatic. I verified this by switching them both to Full, both to Limited, Automatic/Full and comparing to Automatic on both.
 

Jomjom

Banned
Nov 26, 2009
11,734
2
0
Los Angeles
Yup the automatic setting has been like this forever.

Here's a easy way to check if your TV supports full and if your setting on the PS4 is correct.

View the below image in the PS4 browser. If your TV supports RGB full you'll be able to see the upper left most square very faintly. If it doesn't support it or if your settings are wrong, you likely won't see most of the top row. Toggle the RGB setting from limited and full and you'll see the difference in the image. If your TV doesn't support Full RGB, you just won't be able to see the top row of squares because the blacks used are blacker than the range RGB Limited can support.

 
Feb 27, 2014
8,414
0
0
also worth noting, Full isn't necessarily better or anything. just make sure the settings on your TV and your PS4 are the same
Perhaps not but if your TV is set to full and your PS4 to automatic you will be getting a worse picture quality, yet you probably are expecting to PS4 to output at full. Helpful tip from the OP, will have to swap this over when I log back on in a bit.

Yup the automatic setting has been like this forever.

Here's a easy way to check if your TV supports full and if your setting on the PS4 is correct.

View the below image in the PS4 browser. If your TV supports RGB full you'll be able to see the upper left most square very faintly. If it doesn't support it or if your settings are wrong, you likely won't see most of the top row.
Thanks a million! Been wanting to check this for a long time and trying something like this never occurred to me.

If you have a Samsung LED, go to settings, then change the input label of the HDMI input you're using to "PC", you'll see the screen flicker for a second, and when it comes back, prepare to see the purest, rawest, bestest, perfectest image, crystal clear HD. I can't go back to normal TV now.

You're welcome!
Ok how do I do that? I've never found an option to change input labels but I've been wanting to use PC mode for a long time since I've heard about this a lot of times now.
 

thatJohann

Member
Jun 26, 2007
1,930
6
1,175
Brooklyn, NY
If you have a Samsung LED, go to settings, then change the input label of the HDMI input you're using to "PC", you'll see the screen flicker for a second, and when it comes back, prepare to see the purest, rawest, bestest, perfectest image, crystal clear HD. I can't go back to normal TV now.

You're welcome!
 

Killthee

helped a brotha out on multiple separate occasions!
Jun 6, 2004
17,268
0
0
Weird, Automatic works fine on my 2013 Sony TV. Auto & Full both output using Full while switching the PS4 to limited changes the output to limited.
 
Jun 7, 2004
21,704
2
0
47
NM USA
Could've sworn that this was revealed by another poster here in another thread months ago. In any case, I already had mine set to 'full' as, yes, 'automatic' does revert to limited range.
 

10k

Banned
Mar 20, 2012
15,859
1
0
32
Toronto, Ontario, Canada
I noticed this before. Automatic is useless. Either go limited or full. Wii U only does limited so I just set all my consoles and tv to limited. Less hassle, barely a difference. Plus most games offer brightness sliders.
 

DUFFMCWALIN

Member
Mar 6, 2010
11,115
0
600
Chico, CA
Thanks for the post OP I'll give it a look when I get home.

I'm not sure if this is the place to post it but are people still getting the audio bug where no sound comes from the PS4 until you restart it? I got this again the other day. Surprised it hasn't been fixed via patch (unless its faulty hardware or something on my end).
 

Jomjom

Banned
Nov 26, 2009
11,734
2
0
Los Angeles
I noticed this before. Automatic is useless. Either go limited or full. Wii U only does limited so I just set all my consoles and tv to limited. Less hassle, barely a difference. Plus most games offer brightness sliders.
If your TV has the capability of having different settings for each input, that would be the best way. I have every input calibrated differently and with limited/full depending on what console or device is connected.
 

opticalmace

Member
Dec 8, 2008
14,633
0
0
Bay Area
Thanks for the post OP I'll give it a look when I get home.

I'm not sure if this is the place to post it but are people still getting the audio bug where no sound comes from the PS4 until you restart it? I got this again the other day. Surprised it hasn't been fixed via patch (unless its faulty hardware or something on my end).
That happens to me once in a while. I just change the TV input and then put it back to the PS4 and it seems to fix itself. Don't know why.
 

Sword Of Doom

Member
Aug 18, 2013
11,594
2
0
I noticed this issue with Hohokum. After playing on the PS4 I played on my Vita and noticed there were certain white objects in the game I was not seeing on my TV. Turns out the issue was exactly as you stated OP. Changed settings to full and problem was fixed
 

Guymelef

Member
Sep 19, 2007
12,900
3
1,125
Spain
Yeah, I noticed that with RGB Range set on automatic my console choose limited range.
You can see it clearly when turn on with black screen and PS logo, on limited blacks had bright.
It's better choose full range manually.
 
Sep 6, 2007
4,443
0
0
I wonder if this is a bug introduced in a recent update, because I just recently noticed washed out blacks while playing TLOUR and I didn't have that problem before. I have the RGB setting on my Kuro set to auto and it works fine when I manually force either full or limited RGB in the PS4 but not auto. Or if I set the PS4 to auto then I have to manually force the settings in the Kuro to match the PS4's output. It just doesn't work having both set to auto.
 

Jomjom

Banned
Nov 26, 2009
11,734
2
0
Los Angeles
Does the Y Pb/Cb Pr/Cr range setting matter much for anything? What about Deep Color Output?
On the PS4 the setting is a bit weird. On PS3, it was either automatic, on, or off, but on the PS4 it only offers automatic or off.

The setting should be the same as "Superwhite" on the PS3 and you should turn it on if your tv doesn't support Full RGB. There was a lengthy thread on AVS Forum that basically stated that all TVs benefit from Superwhite/Limited if Full RGB is not an option.
 

Reallink

Member
Jan 7, 2008
6,177
906
1,105
FYI, DON'T use Ground Zero's as a reference. Its video levels are completely broken unless they've pushed out a patch since I played. My guess is they "Mastered" the game on a RGB mismatched set up and internally corrected for it--resulting in a completely fucked output.
 

Korezo

Member
Jan 9, 2013
3,511
0
0
Are you saying the automatic setting doesn't work? I've always just put limited for my tv and full when I switch to a monitor and it always worked.
 

The Lamp

Member
Nov 6, 2010
17,181
5
0
Found out my TV supports full. Turned it on on my TV settings and ps4 settings and holy shit... Night and day difference.
 

Aces&Eights

Member
Nov 13, 2013
3,946
53
475
Spokane, WA
Ok how do I do that? I've never found an option to change input labels but I've been wanting to use PC mode for a long time since I've heard about this a lot of times now.
Hit your AV/Imput button on remote. Go to the one where your ps4 is at. Hit the tools button on remote. Hit "edit name". Scroll down to PC. Push Enter.
 

TheAznOne

Member
Apr 10, 2012
910
0
390
My Sony Bravia from 2010 should have this setting right? I don't see anything on the settings menus.
 

Jomjom

Banned
Nov 26, 2009
11,734
2
0
Los Angeles
Are you saying the automatic setting doesn't work? I've always just put limited for my tv and full when I switch to a monitor and it always worked.
Ideally "automatic" should set the PS4 to whatever your TV is set at. What OP is saying is that the automatic is not detecting what your TV supports and simply defaulting to "Limited" no matter what.
 

haikira

Member
Nov 17, 2005
3,991
0
0
UK
FYI, DON'T use Ground Zero's as a reference. Its video levels are completely broken unless they've pushed out a patch since I played. My guess is they "Mastered" the game on a RGB mismatched set up and internally corrected for it--resulting in a completely fucked output.
I can back this up too. Played Ground Zeroes on more than one screen, one of which is calibrated, and Ground Zeroes is definitely fucked up.
 

cjp

Junior Member
Dec 1, 2013
1,895
6
480
I'm using my sister's old KDL-32EX403 at the minute. If someone can find the correct setting for that, feel free to tell me. It's not in the manual and, while there is a metric shit ton of different picture settings, there doesn't seem to be one relating to Full or Limited RBG Range.

I've tried both Full and Limited and I can't seem to tell the difference in all honesty.

Possibly related, I have noticed some minor colour banding in some games. There's definitely a little in Don't Starve and I saw some again in the P.T demo surrounding the clock. Is that my set up or the game itself? Like I said, changing RGB doesn't fix it and neither does selecting between different levels of contrast or black enhancement or whatever settings there are available.
 

Withnail

Member
Dec 16, 2009
3,781
2
775
Good points OP. I would only add that if you ever watch Blu-ray movies on your PS4 then you should stick to Limited.
 

Ferr986

Member
Oct 6, 2012
13,086
0
0
Yup the automatic setting has been like this forever.

Here's a easy way to check if your TV supports full and if your setting on the PS4 is correct.

View the below image in the PS4 browser. If your TV supports RGB full you'll be able to see the upper left most square very faintly. If it doesn't support it or if your settings are wrong, you likely won't see most of the top row. Toggle the RGB setting from limited and full and you'll see the difference in the image. If your TV doesn't support Full RGB, you just won't be able to see the top row of squares because the blacks used are blacker than the range RGB Limited can support.

Cant see the first square, the rest of the first row show up well though. Im good to go?
 

Team Top Hat

Banned
Mar 31, 2014
1,532
0
0
If you have a Samsung LED, go to settings, then change the input label of the HDMI input you're using to "PC", you'll see the screen flicker for a second, and when it comes back, prepare to see the purest, rawest, bestest, perfectest image, crystal clear HD. I can't go back to normal TV now.

You're welcome!
You are my hero. Thanks!