• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.

Rage PC perfomance thread

luka

Loves Robotech S1
Jan 15, 2009
9,990
2
0
Samiad said:
This thread has me feeling like Quake/2/3 config editing never left us :( I thought we were past this.
You should try editing autoexec.bat. Or you could borrow my boot disk, I swear there are no viruses. :p
 

Grayman

Member
Feb 7, 2005
15,125
0
0
34
Surrey, BC
I gotta get on that raw mouse. With my 20 mins of play 8k texture res works on a gtx260 with only 876 or so video ram and 4gb system ram. Without the game was way too slow to load in the opening that I immediately quit. The environment is too big for 4k or it needs to "warm up".

don't know how id fucked up the console, cvaradd instead of just changing values. I can't get r_swapinterval to save through regular use, cvaradd, or cfg's, have not tried launch properties yet. Normally I don't use vsync on id games but Rage is the worst I have ever seen. Maybe if I crank this shit up to 120 fps(also seems to need swapinterval working) it can have the decency to tear at the bottom of the screen.
pa22word said:
The weird thing is, now the game is doing it regardless of the settings in rageconfig.cfg. I renamed it to something irrelevant to "turn it off", and now I'm still getting the lock-ups. Only difference is, now I'm getting them with pop-up and unfiltered textures! :lol:

In fact, I was just in game (with the fixes in the op "off") before I locked up again and then proceeded to completely crash right after you get the sniper rifle. Maybe the 8k texture fix had nothing to do with the lockups, but we just started playing the game more with the fix enabled so the lock-ups started rearing their head. Correlation =/= causation or something like that.





K, so that confirms it not just an issue with the guys with less than (or equal to) 1GB VRAM. I guess it's a problem with the ATI drivers that were just put out. *sigh*


Can't win for losing with this game can we, fellow ATI brothers? v_V
try changing the value to the 4k amount and typing exec <filename> in the console and seeing if that gets you back to 4k textures permenantly. since the game never made rageconfig on its own it is probably saving elsewhere (steamcloud, appdata, default?). If you tab after exec you get a listing of files in base.
 

Grayman

Member
Feb 7, 2005
15,125
0
0
34
Surrey, BC
Samiad said:
This thread has me feeling like Quake/2/3 config editing never left us :( I thought we were past this.
grrrr

a choice is awesome. b the ten minute impression is that tweaking is more convoluted for the worst
 

JaseC

gave away the keys to the kingdom.
Jul 30, 2009
73,803
6
1,030
Western Australia
I've noticed these settings have all but eradicated texture pop-in for me. The small amount that is still present isn't particularly bothersome, much unlike before.

Rewmac said:
Thanks I just used total commander it's pretty easy there :)
Cool. :)
 

Kong Fisso

Banned
Nov 10, 2009
1,207
0
0
I NEED to play RAGE. I do nothing but sit and read about people's performance, trying to deduce whether it will run properly on my machine.

So I'm hoping someone can answer my question.

I have the newish 27" imac with radeon mobility 6770. Will it run RAGE properly? Will the RAGE driver work, seeing as this is a mobility card?

Plz, answers. This is killing me!
 

Grayman

Member
Feb 7, 2005
15,125
0
0
34
Surrey, BC
Kong Fisso said:
I NEED to play RAGE. I do nothing but sit and read about people's performance, trying to deduce whether it will run properly on my machine.

So I'm hoping someone can answer my question.

I have the newish 27" imac with radeon mobility 6770. Will it run RAGE properly? Will the RAGE driver work, seeing as this is a mobility card?

Plz, answers. This is killing me!
if you wait long enough it will. You will need someone with your specific card to help as far as right now goes.
 

Alex Connolly

Member
May 12, 2008
8,965
0
0
Kagoshima, Japan
twitter.com
Kong Fisso said:
I NEED to play RAGE. I do nothing but sit and read about people's performance, trying to deduce whether it will run properly on my machine.

So I'm hoping someone can answer my question.

I have the newish 27" imac with radeon mobility 6770. Will it run RAGE properly? Will the RAGE driver work, seeing as this is a mobility card?

Plz, answers. This is killing me!
The ATI Rage package installs on my laptop no problem. It's a waiting game for PAL territory laptop owners, though...longest couple of days if no one in the US is in the same boat as us. I'm running a 5650 HD Mobility. One of the lucky ones when it came to Brink, ran that like butter with no issues, glitches or fuss. We'll see with this one.
 

Sinatar

Official GAF Bottom Feeder
Jun 7, 2004
36,860
0
1,745
Edmonton
Hmm the game is trying to create cache files in users\username\id software\rage but the folder doesn't exist. I just made the folder manually and it's putting a 1GB cache file in there. Didn't seem to help with anything, but interesting nonetheless.

I've got all the issues sorted except this constant freezing. Every minute or so it'll freeze for about 3 - 4 seconds and then resume as per normal. Seems tied to certain areas of the maps as well. It's *incredibly* annoying. This is on a Radeon 5870 with todays Rage specific driver.
 

Melhisedek

Member
Mar 5, 2007
1,860
0
1,040
scitek said:
I'm getting the freezing, moving, freezing, moving, issue except it's every damn second, not every few minutes. I'm running a 2GB Radeon 6950 with the AMD Rage performance driver, and I did the 8k texture fix, and that fixed my pop-in issue for the most part, but now it's unplayable.
Exactly the same problem... 5850 with latest drivers and no fixes in cfg (somehow my game wont read it as I enabled console in the file but nothing happens when I press § in game)
 

Sutton Dagger

Member
Feb 22, 2010
6,037
0
0
Australia
Kong Fisso said:
I NEED to play RAGE. I do nothing but sit and read about people's performance, trying to deduce whether it will run properly on my machine.

So I'm hoping someone can answer my question.

I have the newish 27" imac with radeon mobility 6770. Will it run RAGE properly? Will the RAGE driver work, seeing as this is a mobility card?

Plz, answers. This is killing me!
It seems like your biggest limiting factor will actually be V-ram, those 6770m's only have 512mb. You're pushing a massive display with the iMac, your best bet will be to lower the res. I don't have this iMac myself so what I say is only speculation based on the apparent V-ram requirements, but you won't be able to do these texture fixes I think.
 

trudderham

Member
Jun 14, 2009
527
0
0
Kong Fisso said:
I NEED to play RAGE. I do nothing but sit and read about people's performance, trying to deduce whether it will run properly on my machine.

So I'm hoping someone can answer my question.

I have the newish 27" imac with radeon mobility 6770. Will it run RAGE properly? Will the RAGE driver work, seeing as this is a mobility card?

Plz, answers. This is killing me!
I have the 27" iMac with the Radeon 6950 and RAGE plays perfectly at 2560x1440. Getting more than 60FPS without V-Sync on. Only trouble is the game crashes whenever a load screen appears, so I'm stuck in the opening area. Hopefully it gets patched soon :/
 

PetriP-TNT

Member
Jul 13, 2007
21,470
0
0
Finland
Samiad said:
This thread has me feeling like Quake/2/3 config editing never left us :( I thought we were past this.
Editing Q123 config files was the best, I undoubtedly have the best (as in most optimized for most older setups) ET config around for example.

"BUT I WANT SLIDERS WAAH". I laugh in your puny little face so called PC Master Race
 

dr_rus

Member
May 3, 2007
10,983
0
1,080
Moscow, Russia
OK, after reading all the screamings yesterday I wasn't really expecting it but Rage runs prefect on my GXT470 - constant 60 fps in 1920x1200 with AA 8x. Texture pop-ins are there but can't say that they're very noticable.

What I would like to know now is how to change the 60 fps limit to something like 61 or 122. That should probably remove most of the frame tearing without the need for VSync.
 
May 17, 2011
524
0
0
PetriP-TNT said:
Editing Q123 config files was the best, I undoubtedly have the best (as in most optimized for most older setups) ET config around for example.

"BUT I WANT SLIDERS WAAH". I laugh in your puny little face so called PC Master Race
I'm with this guy.
 

Solo

Member
Apr 21, 2005
68,175
1
0
Canada
Good thread. I tweaked a lot yesterday but will try a lot more of this stuff today when I get back to the game.
 

plagiarize

Banned
May 24, 2006
41,139
1
0
chinner, while it does make a difference to LOD in some scenes, it's more about how much it reduces pop up in actual gameplay.

i am still getting inconsistant performance though. sometimes i get wellspring (and everything else) locked at 60 fps. sometimes it drops quite regularly. if it's running at 60 fps it stays there through different levels and missions. if it isn't locked at 60 when i load it, it won't get to running locked at 60 even if i go in and kill other processes etc.

it seems to have nothing to do with the size of my textures either. there's probably something i'm missing, but i haven't spotted it yet... and i've seen others complain of the same inconsistant performance.
 

Stahsky

A passionate embrace, a beautiful memory lingers.
May 6, 2006
7,352
0
1,280
31
Finally got it running at 60FPS constant and zero pop in on AMD, but it crashes on loads. Booo.


I will say, that this game looks fucking beautiful. Can't wait to play more than an hour of it!
 

Volcynika

Member
Dec 17, 2007
21,317
0
0
Anyone have an issue where the game runs fine, but whenever there's dialogue the game just freezes in parts for a few seconds, then runs fine (after freezing 3 or 4 times during dialogue)?
 

Jubbly

Member
Nov 21, 2007
1,149
0
0
i7-2600K
8GB RAM
NVIDIA GeForce GTX 580 1.5GB VRAM
AA 16x
GPU Transcode Enabled
FOV 95

vt_pageimagesizeuniquediffuseonly2 4096
vt_pageimagesizeuniquediffuseonly 4096
vt_pageimagesizeunique 4096
vt_pageimagesizevmtr 4096
vt_restart
vt_maxaniso 4
image_anisotropy 4


i7-2600K
8GB RAM
NVIDIA GeForce GTX 580 1.5GB VRAM
AA 16x
GPU Transcode Enabled
FOV 95

vt_pageimagesizeuniquediffuseonly2 8192
vt_pageimagesizeuniquediffuseonly 8192
vt_pageimagesizeunique 8192
vt_pageimagesizevmtr 8192
vt_restart
vt_maxaniso 4
image_anisotropy 4


1.5GB of VRAM was insufficient for 16384 (likely requires 3GB).

Here's a .gif version showing my crap positioning: http://www.abload.de/image.php?img=rage40968192zu3d.gif
 

D6AMIA6N

Member
Sep 30, 2009
1,231
0
0
Atlanta, GA
subversus said:
It has become impossible to gather any information about the actual game from OT because 80% of posts there are PC tech talk. The port seems to be rushed and shitty, it's a shame that it comes from people who defined PC gaming. Well, times change and we need this thread.

I'll update OT with tweaks as you post them.


If you have solutions to your problems post them there, I'll update OT.
I just want to give a shout out to subversus. I had been whining in the OT thread about all the PC config issues being posted, made a snide remark, and for that, I apologize.

subversus, nice work on this thread. I genuinely think this will make it easier for all the PC users to find answers to their questions, and free up the OT to talk about the game itself.
 

Arcipello

Member
Aug 15, 2008
2,648
1
0
UK
so what does 16384 look like compared to the default setting? anyone got a card capable of running it?
 

Corky

Nine out of ten orphans can't tell the difference.
Jul 1, 2009
18,776
0
0
Jubbly said:
http://i.imgur.com/T7knK.jpg[/IMG



[IMG]http://i.imgur.com/QwuME.jpg[/IMG

1.5GB of VRAM was insufficient for 16384. Also, is there an image upload service that retains the original format now? Imgur converted to .jpg :/[/QUOTE]

Hey mate I don't suppose you could upload a version with 16384? Even though you said you don't have enough vram it would be nice to see the difference.

Also abload.de is a good site for uploading pics.
 

Jubbly

Member
Nov 21, 2007
1,149
0
0
Corky said:
Hey mate I don't suppose you could upload a version with 16384? Even though you said you don't have enough vram it would be nice to see the difference.
It makes my game insta-crash, so that's a no go. As it is literally double the res again you'll probably need a GPU with 3GB of VRAM.
 

Corky

Nine out of ten orphans can't tell the difference.
Jul 1, 2009
18,776
0
0
Jubbly said:
It makes my game insta-crash, so that's a no go. As it is literally double the res again you'll probably need a GPU with 3GB of VRAM.
Gotcha, thanks.
 

JaseC

gave away the keys to the kingdom.
Jul 30, 2009
73,803
6
1,030
Western Australia
LiquidMetal14 said:
Can't believe you have to to an ini alteration to get the textures to where they should be. I don't have the game yet so I'm definitely out of the loop but the game looks great overall but screens don't do it favors.
The game doesn't better in motion due to the world being static. Does the engine even support motion blur? I certainly haven't noticed any if it does.

Rage looks fantastic for a 60fps console game, and that's it.
 

zlatko

Banned
Dec 17, 2009
17,687
0
0
I own a 5870 and was planning on picking this up next week. How does it fair on it? I have the latest drivers ready. I'm also curious if id has said when they plan on a patch to fix these issues?
 

Derrick01

Banned
May 9, 2011
34,663
0
0
WrikaWrek said:
I have a GTX 470 and have been hearing the game stutters like crazy. Anybody has some hands on?
I'm using a 470 with a 3ghz quad and the game runs perfectly. I get about .1 seconds of pop in but when you get into the game it's unnoticeable.
 

Jubbly

Member
Nov 21, 2007
1,149
0
0
I've just done some more testing:

  • If you lock the game to 4096 it will look like ass. If you cannot run 8192 smoothly do not use it as the dynamic detail levels will give you a much better experience.
  • 8192 looks consistently better than the auto-detail level on my GPU.

I'm trying to take some shots now that show auto vs. 4096 vs. 8192.

Edit: Here they are.

4096



Auto (no config in /base)



8192



Clear progression in quality. Auto also seems to work based on your distance to objects and the amount of objects in a scene, so if this were the Mayor's office, for example, I'd expect to see far less difference between Auto and 8192.
 

LiquidMetal14

hide your water-based mammals
Jan 18, 2007
46,583
1
1,215
The Confederate United States of America
JaseC said:
The game doesn't better in motion due to the world being static. Does the engine even support motion blur? I certainly haven't noticed any if it does.

Rage looks fantastic for a 60fps console game, and that's it.
I will probably get it in PC still due to mods but your words pretty much told me what kind of looker this is (or not :p)

Probably really fun game play wise but I've stayed out of the thread so not to spoil anything.
 

garath

Member
May 8, 2007
13,515
0
0
Jubbly said:
I've just done some more testing:

  • If you lock the game to 4096 it will look like ass. If you cannot run 8192 smoothly do not use it as the dynamic detail levels will give you a much better experience.
  • 8192 looks consistently better than the auto-detail level on my GPU.

I'm trying to take some shots now that show auto vs. 4096 vs. 8192.

Edit: Here they are.



Clear progression in quality. Auto also seems to work based on your distance to objects and the amount of objects in a scene, so if this were the Mayor's office, for example, I'd expect to see far less difference between Auto and 8192.
That REALLY shows the difference. Thanks for posting that.

I'm going to try the 8192 on my system over lunch and see what the results are. I had already nearly eliminated the pop-in with a previous set of cfg tweaks but I love those sharper textures.

i5 2500k @ 4.2ghz
8gig DDR3
GTX 460 1gig

We'll see how the 8192 runs with 1gig of VRAM.