• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • Hey Guest. Check out the NeoGAF 2.2 Update Thread for details on our new Giphy integration and other new features.

So my PC display is at 144hz but for some reason games are horrible because of the Intel UHD graphics it runs on to. Can anyone help?

Derktron

Member
Dec 27, 2019
1,334
1,549
510
I don't know if this is the right place to ask this sort of question, but I'm having issues with my PC not running programs the right way it's meant to run at. Including games. For some reason, my PC is using the display/GPU of Intel UHD Graphics for basically everything including games and the performance is horrible.

Before I continue I want to add my specs of my PC.

CPU - Intel i7 10 gen

GPU - Nvidia GTX 2070

Ram - 16 GB

GPU 2 - Intel UHD Graphics

So again for some reason, I'm getting horrible performances with some programs and games. Is there a way to fix this along with my display running at 144hz where it still feels like 60hz.

I did try and go into my bios, change the Nvidia settings but nothing has changed and the performances are still the same. Any help would be greatly appreciated.

Edit: I have a gaming laptop.
 
Last edited:

Pagusas

Elden Member
Jun 9, 2006
12,664
4,282
1,685
Prosper, Tx
in your nvidia settings make sure you are forcing the 2070 as the gpu. And yeah as another said, make sure you are plugging into your gpu, not the motherboard hdmi out.
 
Last edited:

ethomaz

is mad because DF didn't do a video on a video of a video of a video on PS5
Mar 19, 2013
38,824
37,454
1,310
38
Brazil
How do I do that, I tried looking for it but maybe I'm blind and could not find that in the bios.
Depend the model/bios of your notebook... you need to post the brand model.

BTW I had the same issue with a old notebook in the past.
 
Last edited:

Codiox

Member
Aug 11, 2013
2,019
101
610
Germany
you can just rightclick on the shortcut of the game and set the standard gpu for every game. or you can set it globally
 

ethomaz

is mad because DF didn't do a video on a video of a video of a video on PS5
Mar 19, 2013
38,824
37,454
1,310
38
Brazil
I found that random solution... you can try.



This happens when these services are stopped :
NVIDIA Driver Helper Service
NVIDIA Update Service Daemon.
Start Task Manager. Click the tab "Services
".Click on a button named "Services." Find them, their names. Right click on them. Then, Properties. Then, Click on "Start " and then select Start-up time :
for the first ->Automatic
for the second -service > Automatic(Delayed Start)

After doing that , it should run.
 
Last edited:

Krappadizzle

Member
Oct 4, 2011
14,804
5,548
1,255
Is this a laptop? Ah. It is. Make sure that only your actual GPU is being used in the control panel and be sure that you have g-sync turned on and running at 144hz. Laptops tend to resort to the igpu to save battery power. I hate gaming laptops. Two of my buddies have them and they are constantly complaining about this type of shit. I told them too, get a cheap laptop for browsing/work/social media and just dedicate a space for a desktop. Both are committed to getting a desk for 2021.
 
Last edited:

Derktron

Member
Dec 27, 2019
1,334
1,549
510
You have it running in "maximum gpu/power mode" in settings? Disabled the igpu? Have G-sync selected in Nvidia control panel?
I have attempted to disable the IGPU in the bios but for some reason, the bios menu I have does not let me do that which I find odd. I will check the Nvidia settings for the G-Sync and the "maximum gpu/power mode" option.
 

Krappadizzle

Member
Oct 4, 2011
14,804
5,548
1,255
I have attempted to disable the IGPU in the bios but for some reason, the bios menu I have does not let me do that which I find odd. I will check the Nvidia settings for the G-Sync and the "maximum gpu/power mode" option.
I'm just kind of guessing as I've seen people with your problem before across different websites and that seems to be the general solution. I don't have a "gaming" laptop so I couldn't really tell you too much other than general things I've seen, just wanted to help a bit if I could.
 

diffusionx

Member
Feb 25, 2006
14,565
14,676
1,800
I don't think you want to disable the integrated GPU because you don't want the discrete one running nonstop, especially if you are using it on battery.

I have an Alienware laptop and this stuff is all seamless. Hell if I accidentally load up a game on battery the game will run at 5fps until I plug it in and it switches. This shouldn't be happening. The Nvidia control panel should let you set preference for "3D applications" and even on a per-app basis.
 

AV

We ain't outta here in ten minutes, we won't need no rocket to fly through space
May 31, 2018
6,308
13,897
785
Leeds, UK
Is it plugged in? According to this, "Asus made sure that the screen automatically switches over to 60 Hz when unplugging the laptop".
 
Jul 26, 2009
3,143
5,562
1,230
My Windows 10 uses the Graphics panel in Windows Settings to handle the graphics processor output

It was previously Nvidia Control Panel but that is not the case anymore

 
Last edited:

Derktron

Member
Dec 27, 2019
1,334
1,549
510
I'm just kind of guessing as I've seen people with your problem before across different websites and that seems to be the general solution. I don't have a "gaming" laptop so I couldn't really tell you too much other than general things I've seen, just wanted to help a bit if I could.
So I can't disable the IGPU from the bios settings but I did do it on the Device Manager and it went all crazy so I restarted my laptop and now it's using the "Microsoft Basic Display Driver" as a replacement of the Intel UHD driver it had. Is this good or bad so I reconnect the Intel UHD display driver back on?
 

Patrick S.

Amiga Forever
May 4, 2013
4,908
1,792
945
Germany
That stuff is called Intel Optimus. Check the settings for GPU selection in both the nvidia and Intel control panels.
 

Patrick S.

Amiga Forever
May 4, 2013
4,908
1,792
945
Germany
So I can't disable the IGPU from the bios settings but I did do it on the Device Manager and it went all crazy so I restarted my laptop and now it's using the "Microsoft Basic Display Driver" as a replacement of the Intel UHD driver it had. Is this good or bad so I reconnect the Intel UHD display driver back on?
Did you install an nvidia driver? If yes uninstall it with DDU and do a fresh driver install.
 
Last edited:

Patrick S.

Amiga Forever
May 4, 2013
4,908
1,792
945
Germany
Weird, I'd have guessed the nvidia driver isn't installed. Yeah, I'd completely uninstall the driver and install it again.
 

Derktron

Member
Dec 27, 2019
1,334
1,549
510
Weird, I'd have guessed the nvidia driver isn't installed. Yeah, I'd completely uninstall the driver and install it again.
It still is installed, even after I disabled the Intel UHD drive on the device manager setting. It made it much worse so honestly I'm still lost.
 

Patrick S.

Amiga Forever
May 4, 2013
4,908
1,792
945
Germany
It still is installed, even after I disabled the Intel UHD drive on the device manager setting. It made it much worse so honestly I'm still lost.
You shouldn't really disable the Intel IGPU. And disabling the Intel IGPU won't make your nvidia driver disappear. Did you uninstall the nvidia driver with DDU? If not, do that, and then do a fresh install of the current version of the nvidia driver. But enable the Intel IGPU again, there's really no need to disable it.
 

Patrick S.

Amiga Forever
May 4, 2013
4,908
1,792
945
Germany
If you have a gaming laptop w/ a discrete card, you often have to set 'preferred' GPU to the Nvidia card, else it always defaults to the Intel garbage.

Shouldn't be needed to do it manually, Windows 10 normally sets it up correctly. The windows power settings don't change the display device, they adjust the CPU boosting behaviour and define after how much time your monitor and HDDs turn off and your PC hybernates.
 
Last edited:

K.S v2.0

Banned
Dec 3, 2020
525
857
335
Shouldn't be needed to do it manually, Windows 10 normally sets it up correctly. The windows power settings don't change the display device, they adjust the CPU boosting behaviour and defines after how much time your monitor and HDDs turn off and your PC hybernates.

Shouldn't do but I see this question all the time on Steam forums for just about any major game, and generally its coz the game defaults to the onboard GPU.
 

Patrick S.

Amiga Forever
May 4, 2013
4,908
1,792
945
Germany
Shouldn't do but I see this question all the time on Steam forums for just about any major game, and generally its coz the game defaults to the onboard GPU.
Well, some notebooks have some sort of "eco modes" in which the discrete GPU isn't used. I think my MSI does, too, now that I think of it. Yeah, OP, check the Asus stuff you have running in your system tray, if you are in some kind of power saving mode.
 
Last edited:
  • Like
Reactions: K.S v2.0

Zefah

Gold Member
Jan 7, 2007
44,522
25,493
1,805
Already been mentioned, but a gaming laptop I had earlier last year needed to be plugged in to run off the GPU. I also needed to go into the Nvidia control panel and sometimes force specific games to run on the discrete GPU. I remember this happening with The Witcher 3 specifically.
 
  • Thoughtful
Reactions: AV

K.S v2.0

Banned
Dec 3, 2020
525
857
335
Already been mentioned, but a gaming laptop I had earlier last year needed to be plugged in to run off the GPU. I also needed to go into the Nvidia control panel and sometimes force specific games to run on the discrete GPU. I remember this happening with The Witcher 3 specifically.
Ah yep this too, forgot. Some laptops can ONLY run the onboard GPU on battery, it just does not have enough juice to power discrete.
 

Derktron

Member
Dec 27, 2019
1,334
1,549
510

ProLogY

Member
Jul 3, 2020
82
120
210
Loads of other people have posted this already but I'll pile on.

First make sure you have the geforce experience installed and update your drivers.

For some games, especially those not explicitly optimized by nvidia, the pc will default to your integrated GPU. You can add games via the nvidia control panel then force them to use the dedicated rtx2070 instead.

This is one of the most annoying parts about owning a gaming laptop.
 
Last edited:

Derktron

Member
Dec 27, 2019
1,334
1,549
510
Loads of other people have posted this already but I'll pile on.

First make sure you have the geforce experience installed and update your drivers.

For some games, especially those not explicitly optimized by nvidia, the pc will default to your integrated GPU. You can add games via the nvidia control panel then force them to use the dedicated rtx2070 instead.

This is one of the most annoying parts about owning a gaming laptop.
I tried doing that, is there a way to make a profile on the games or programs so that Nvidia can recognize the games that need to use the GPU?
 

diffusionx

Member
Feb 25, 2006
14,565
14,676
1,800
I tried doing that, is there a way to make a profile on the games or programs so that Nvidia can recognize the games that need to use the GPU?
Nvidia control panel lets you choose the GPU on a game by game basis
 
Feb 10, 2010
934
301
1,080
www.rajdhatt.com
Double check your power settings are set to performance and not battery saving, this is in the bottom right. Single click the little battery icon and you'll see the slider.

Sorry not assuming you're stupid but this small setting gets so many people some times!
 
  • Like
Reactions: Croga

MCplayer

Member
Jun 10, 2019
594
783
490
I don't know if this is the right place to ask this sort of question, but I'm having issues with my PC not running programs the right way it's meant to run at. Including games. For some reason, my PC is using the display/GPU of Intel UHD Graphics for basically everything including games and the performance is horrible.

Before I continue I want to add my specs of my PC.

CPU - Intel i7 10 gen

GPU - Nvidia GTX 2070

Ram - 16 GB

GPU 2 - Intel UHD Graphics

So again for some reason, I'm getting horrible performances with some programs and games. Is there a way to fix this along with my display running at 144hz where it still feels like 60hz.

I did try and go into my bios, change the Nvidia settings but nothing has changed and the performances are still the same. Any help would be greatly appreciated.

Edit: I have a gaming laptop.
I know why, your gpu passes through the intel then to the screen. You probably are losing about 10 to 20fps because of that, to bypass the intel you need to connect an external monitor because the connection are directly from nvidia card, I got a lenovo legion y740 with a rtx 2070 and thankfully, lenovo laptops allow me to disable the intel gpu and fully use the nvidia.

Here
 
Last edited:

Derktron

Member
Dec 27, 2019
1,334
1,549
510
I know why, your gpu passes through the intel then to the screen. You probably are losing about 10 to 20fps because of that, to bypass the intel you need to connect an external monitor because the connection are directly from nvidia card, I got a lenovo legion y740 with a rtx 2070 and thankfully, lenovo laptops allow me to disable the intel gpu and fully use the nvidia.

Here
But that would mean I would have to either buy an external monitor or open up my laptop to see if I can do just that.