TERA News, Information, & Beta Thread

Ugh, I registered at work, so now I can't log into my Enmasse account.

It has Account Armor, which will send a code to my e-mail address for authentication, and that's great, except I get no e-mail. When you troubleshoot on their support site for log-in problems, it tells you to use a ticket. But in order to use a ticket, you need to log-in first... which is impossible. Wtf.
 
Huh, weird. Keeps crashing when I have it Alt-Tab'd for too long.


Ugh, I registered at work, so now I can't log into my Enmasse account.

It has Account Armor, which will send a code to my e-mail address for authentication, and that's great, except I get no e-mail. When you troubleshoot on their support site for log-in problems, it tells you to use a ticket. But in order to use a ticket, you need to log-in first... which is impossible. Wtf.
I had that problem. I just closed out the launcher, reopened it and logged in from there. Worked after that
 
I sent invites to everyone that requested on Valley of Titans. Let me know if you need me to resend. I also checked for Pai, Sylphanii, and some other characters mentioned a page back but none were online. Just let me know...
 
My second character is a priest named Shae on the PvE server, whenever someone in the guild gets on, can you toss me an invite into the guild? Thanks! The guild is actually pretty quiet right now, I guess everyone decided to roll on the PvP server. Is it pretty packed over there? What level does open FFA begin?

Definitely enjoying the game. Hooked already. :p
 
FML. Just got home at 6PM, and the download must have stalled at some point. It's only 20% done and keeps reducing how fast the download is constantly.

What can I do so it isn't crawling at 300KB or less.
 
FML. Just got home at 6PM, and the download must have stalled at some point. It's only 20% done and keeps reducing how fast the download is constantly.

What can I do so it isn't crawling at 300KB or less.
Have you turned off the P2P option under launcher settings? Increased my speed
 
Ugh, I registered at work, so now I can't log into my Enmasse account.

It has Account Armor, which will send a code to my e-mail address for authentication, and that's great, except I get no e-mail. When you troubleshoot on their support site for log-in problems, it tells you to use a ticket. But in order to use a ticket, you need to log-in first... which is impossible. Wtf.
Sounds like Account Armor is Working As Intended(tm). Sucks but that's their method for preventing account hacking. It's exactly the same way Steam Guard and Facebook work, actually.
 
Have you turned off the P2P option under launcher settings? Increased my speed
Turned it off, but only getting 85kb/sec. When I start it, it starts at 1.5MB/s, then slowly revs itself down bit by bit until it's only going around 100kb/sec. I checked other things running, and my internet speed overall, so not sure what is causing this.

Edit: Checked here after I posted and the turning off P2P option did in fact boost it. It's now going at 1.4MB/sec. Thanks for the tip Vivin.

Should put this in OP if it isn't already in case others run into the issue as well.
 
I'm on the Serpentis Isle PvE server as Wallach if anyone wants to play in a bit. I tried a Human for a little while, but switched to a Baraka; I'm impressed by the fact that gear looks totally different for every race.

Game is quite gorgeous, but the framerate seems to be hurt during loading a lot, similar to SWTOR. It often dips down into the 40s when first running into locations and loading everything. Kind of annoying, but still feels responsive at least.
 
Account Registration is not sending me the e-mail confirmation,been 2 hours now...I wanted to download the client overnight,anyone else having problems or took a while before you got the email?
 
Sounds like Account Armor is Working As Intended(tm). Sucks but that's their method for preventing account hacking. It's exactly the same way Steam Guard and Facebook work, actually.
Well, the problem is that it's only half working. I don't get an e-mail with a verification code at all to confirm who I am. I've checked spam, and added enmasse to my contact list. And the way of contacting customer service is impossible if you can't log-in.


Account Registration is not sending me the e-mail confirmation,been 2 hours now...I wanted to download the client overnight,anyone else having problems or took a while before you got the email?
I'm not getting e-mails in general either. I already verified my account earlier today, but I can't access it at all now.


I had that problem. I just closed out the launcher, reopened it and logged in from there. Worked after that
Unfortunately, I can't download the launcher without logging in now... at least, I don't think unless I'm missing something.
 
I'm in a weird place. I don't have any significant or even moderate complaints about the game so far. Runs well, combat is enjoyable though not as different as I was expecting and hoping, and the game looks great. However I still don't know if I'll be going through with my preorder.

Will continue to play during the beta. Maybe I'll be able to make up my mind this weekend.
 
I seriously doubt my download, if it ever finishes, will even work. Tons of Reliable source checksum errors as it's been trying to download itself tonight.

78% done, but I have a sneaking suspicion it'll either want a complete redownload or just be glitchy as shit.

Edit: I'm now at 87%, and have had over 10 stalls from 78%. My hope is they iron out the kinks with this patcher for the future of this game, because for whatever reason for me it is pure dog shit.
 
I can't for the life of me assign my controller buttons this time, it's registering the presses but when I'm in the button mapping menu and select the command to add a button to.. it acts as if nothing is being pressed (though the controller UI display shows it is being pressed).
 
I seriously doubt my download, if it ever finishes, will even work. Tons of Reliable source checksum errors as it's been trying to download itself tonight.

78% done, but I have a sneaking suspicion it'll either want a complete redownload or just be glitchy as shit.

Edit: I'm now at 87%, and have had over 10 stalls from 78%. My hope is they iron out the kinks with this patcher for the future of this game, because for whatever reason for me it is pure dog shit.
I had the same thing, Luckily i downloaded in time. I Hope you finish it so you can try the beta.