• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

The Witcher 2: Performance Thread [Enhanced Edition Patch - New content & 100+ fixes]

D

Deleted member 81567

Unconfirmed Member
So does gaf prefer Witcher with xbox controller or with m&k?
 

Kyaw

Member
Jun 5, 2010
5,558
0
590
Solihull, UK
Dr Eggman said:
So does gaf prefer Witcher with xbox controller or with m&k?

I have only played with m+kb, i got used to it and found it rather enjoyable.

Gully State said:
GAF prefers both at the same time..

Probably with the exclusion of the problems in the UI with the gamepad after patch.
 

Gully State

Member
Nov 11, 2007
14,888
0
1,185
California
I don't mind cutscene DOF since it's only active during non gameplay sections (or am I wrong?)

I'm currently playing with the gamepad (haven't updated to patch 1.1) and it feels nice but things like aiming and switching b/t magic signs would probably be better with M&K..
 

Kyaw

Member
Jun 5, 2010
5,558
0
590
Solihull, UK
Yeah CutsceneDOF only plays in cutscenes hence the name. [duh :p]

But it does cut some frames and ruins the image quality in some scenes, so i turned it off but depends on your preference really.
 
Mar 4, 2007
3,126
0
0
Atlanta
Dr Eggman said:
So does gaf prefer Witcher with xbox controller or with m&k?

Gaf prefers both, but I prefer M&KB. I absolutely ADORE those hectic moments when you're killed because your left hand has accidentally shifted over one key and your movement and blocking failed. Seriously. Love it.

While that is a pain in the ass, I LOVE the ability to change swords and spells without bringing up any sort of menu (even one as intuitive and unintrusive as the quick menu.
 

scorpscarx

Member
Feb 16, 2011
3,698
1
0
I praised 360pad originally, but m/kb has won me back.

Also I just dramatically improved my performance by raising the vc texture memory size, now I have everything maxed without uber.

Adoring this game :)
 

Domcorleone

Member
Feb 4, 2009
2,188
1
0
New York, NY
Hey guys, can one of you kindly assist me?

I am playing witcher and it says my FPS is 30 but the when running everything looks choppy, but the FPS counter remains at 29,30. I used the global settings in my radeon pro and turned off AA and VSync and motion blur in the game launcher. My specs

iMac i5 2.8ghz quad core
4gb ram
Radeon HD 5870

It says the recommended settings are high but if I leave everything as is, I barely can get 25 FPS. What the heck??? Please someone help me. Thanks in advance
 

Darklord

Banned
Oct 30, 2007
22,615
0
0
Australia
Domcorleone said:
Hey guys, can one of you kindly assist me?

I am playing witcher and it says my FPS is 30 but the when running everything looks choppy, but the FPS counter remains at 29,30. I used the global settings in my radeon pro and turned off AA and VSync and motion blur in the game launcher. My specs

iMac i5 2.8ghz quad core
4gb ram
Radeon HD 5870

It says the recommended settings are high but if I leave everything as is, I barely can get 25 FPS. What the heck??? Please someone help me. Thanks in advance

Did you turn off ubersampling?
 

Echoplx

Member
Dec 31, 2010
5,840
0
0
If that's an iMac wouldn't that be a 5870m not a 5870? If so it won't be able to run high very well.
 

Domcorleone

Member
Feb 4, 2009
2,188
1
0
New York, NY
Anyone have any suggestions? I looked at the OP and nothing seemed to help me get smoothess, the hot fix and patch helped withe the FPS but it is still overall very choppy. What could this be due to?
 

TheExodu5

Banned
Nov 27, 2007
38,093
3
0
Ottawa, Canada
Kyaw said:
Nope, just one 480. I was getting like sub 40 in places and with V-sync on i get sub 50s.
Plus it killed those micro stutters.

Microstutters are just a dual GPU artifact.

Getting extra performance with vsync alone...doesn't make sense. Something else is at play.
 

Kyaw

Member
Jun 5, 2010
5,558
0
590
Solihull, UK
Domcorleone said:
Anyone have any suggestions? I looked at the OP and nothing seemed to help me get smoothess, the hot fix and patch helped withe the FPS but it is still overall very choppy. What could this be due to?

Incapable graphics card?

TheExodu5 said:
Microstutters are just a dual GPU artifact.

Getting extra performance with vsync alone...doesn't make sense. Something else is at play.

Hmmm, i will see if it's just a placebo effect or a real difference.
 
Sep 15, 2010
4,252
0
0
Ok, there seems to be a lot of confusion about custom user.ini settings so I'm going to do my best to help clear it all up.

The problem with the Witcher 2 custom user.ini's is twofold: first, the configurator is bugged so that it doesn't always set custom settings correctly, retaining old settings (like the max shadow size etc) or even forgetting to completely put in whole variables (it loves to leave the FoliageDistance variable out, which means your grass/foliage distance is at some unknown level.)

When editing your user.ini, it needs to have ALL of these variables in it. If your user.ini doesn't have these in it, you're not adjusting all of the settings!

EXAMPLE:Ultra Config said:
[Rendering]
TextureDownscale=0
AtlasTextureDownscale=0
DetailTextureDownscale=0
MaxTextureSize=2048
MaxAtlasTextureSize=4096
TextureMemoryBudget=400
TextureTimeBudget=10
MaxCubeShadowSize=2048
MaxCubeShadowCount=3
MaxSpotShadowSize=2048
MaxSpotShadowCount=3
FoliageDistanceScale=1.0
MeshDistanceScale=1.0
CharacterLodGameplayDownscale=0
AllowBloom=1
AllowShafts=1
AllowAntialias=1
AllowBlur=1
AllowDOF=1
AllowDecals=1.0
AllowVignette=1
AllowSharpen=1
AllowRain=1
AllowSSAO=1
AllowMotionBlur=1
AllowScatterDOF=1
AllowCutsceneDOF=1
DanglesLimiter=0
ShadowQuality=3
ShadowedLights=3
Fullscreen=1
VSync=1
UberSampling=2

The premade configs have all of these, but the idiotic configurator loves to leave them out. Keep all of this in mind and make sure your User.ini has all of those variables in it!

Next, if you want to make sure the Configurator doesn't rape your custom made settings, you MUST right click on your user.ini, go to Properties, and set it to Read-Only. Otherwise the game will muck everything up.

Here's some of my suggested configs for different PC's: Medium/High (Performance Focused), High Settings with Balanced IQ/Performance, and Ultra+ for those of you who max out Ultra and want more detail.

GTS 250/9800 GT/GTS 450/Radeon 4850 recommended, 1 GB VRAM recommended
Medium-High Performance Focused said:
[Rendering]
TextureDownscale=0
AtlasTextureDownscale=0
DetailTextureDownscale=0
MaxTextureSize=1024
MaxAtlasTextureSize=2048
TextureMemoryBudget=500
TextureTimeBudget=10
MaxCubeShadowSize=512
MaxCubeShadowCount=2
MaxSpotShadowSize=512
MaxSpotShadowCount=2
FoliageDistanceScale=0.9
MeshDistanceScale=0.9
CharacterLodGameplayDownscale=0
AllowBloom=0
AllowShafts=1
AllowAntialias=0
AllowBlur=0
AllowDOF=0
AllowDecals=1.0
AllowVignette=1
AllowSharpen=0
AllowRain=1
AllowSSAO=0
AllowMotionBlur=0
AllowScatterDOF=0
AllowCutsceneDOF=0
DanglesLimiter=0
ShadowQuality=2
ShadowedLights=2
Fullscreen=1
VSync=0
UberSampling=0

Radeon 4870/5770, GTX 260/270/280 etc Recommended, 1 GB VRAM required
High Settings for Balanced Image Quality and Performance said:
[Rendering]
TextureDownscale=0
AtlasTextureDownscale=0
DetailTextureDownscale=0
MaxTextureSize=2048
MaxAtlasTextureSize=4096
TextureMemoryBudget=700
TextureTimeBudget=10
MaxCubeShadowSize=1024
MaxCubeShadowCount=2
MaxSpotShadowSize=1024
MaxSpotShadowCount=2
FoliageDistanceScale=1.0
MeshDistanceScale=1.0
CharacterLodGameplayDownscale=0
AllowBloom=0
AllowShafts=1
AllowAntialias=0
AllowBlur=1
AllowDOF=0
AllowDecals=1.0
AllowVignette=1
AllowSharpen=0
AllowRain=1
AllowSSAO=0
AllowMotionBlur=0
AllowScatterDOF=0
AllowCutsceneDOF=0
DanglesLimiter=0
ShadowQuality=2
ShadowedLights=3
Fullscreen=1
VSync=0
UberSampling=0

GeForce GTX 560,570/580, Radeon 5870/6870/6950/6970 Recommended
For those of you with beefier GPU's and that have at least 1.5GB of VRAM, try this:
Ultra+ Config said:
[Rendering]
TextureDownscale=0
AtlasTextureDownscale=0
DetailTextureDownscale=0
MaxTextureSize=2048
MaxAtlasTextureSize=4096
TextureMemoryBudget=1000
TextureTimeBudget=10
MaxCubeShadowSize=2048
MaxCubeShadowCount=4
MaxSpotShadowSize=2048
MaxSpotShadowCount=4
FoliageDistanceScale=1.6
MeshDistanceScale=2.2
CharacterLodGameplayDownscale=0
AllowBloom=0
AllowShafts=1
AllowAntialias=1
AllowBlur=1
AllowDOF=1
AllowDecals=1.0
AllowVignette=1
AllowSharpen=1
AllowRain=1
AllowSSAO=1
AllowMotionBlur=1
AllowScatterDOF=1
AllowCutsceneDOF=0
DanglesLimiter=0
ShadowQuality=3
ShadowedLights=3
Fullscreen=1
VSync=0
UberSampling=0

Feel free to play with MeshDistanceScale and FoliageDistanceScale to acquire your ideal image quality/performance balance on object LOD and foliage LOD/pop-in.

YMMV with these configs, but a couple of users with higher end PC's have reported increased image quality, FPS, and smoothness with the first config I posted (which was a more tame Ultra+ config). I personally believe CDProjekt Red erred on the side of caution with the stock Ultra config; other than the boneheaded move of enabling Ubersampling, everything is set too low to really take advantage of the increased horsepower the higher end GPU's offer.
 

Domcorleone

Member
Feb 4, 2009
2,188
1
0
New York, NY
BoobPhysics101 said:
Ok, there seems to be a lot of confusion about custom user.ini settings so I'm going to do my best to help clear it all up.

The problem with the Witcher 2 custom user.ini's is twofold: first, the configurator is bugged so that it doesn't always set custom settings correctly, retaining old settings (like the max shadow size etc) or even forgetting to completely put in whole variables (it loves to leave the FoliageDistance variable out, which means your grass/foliage distance is at some unknown level.)

When editing your user.ini, it needs to have ALL of these variables in it. If your user.ini doesn't have these in it, you're not adjusting all of the settings!



The premade configs have all of these, but the idiotic configurator loves to leae them out. Keep all of this in mind and make sure your User.ini has all of those variables in it!

Next, if you want to make sure the Configurator doesn't rape your custom made settings, you MUST right click on your user.ini, go to Properties, and set it to Read-Only. Otherwise the game will muck everything up.

Here's some of my suggested configs for different PC's: Medium/High (Performance Focused), High Settings with Balanced IQ/Performance, and Ultra+ for those of you who max out Ultra and want more detail.





For those of you with beefier GPU's and that have at least 1.5GB of VRAM, try this:


Feel free to play with MeshDistanceScale and FoliageDistanceScale to acquire your ideal image quality/performance balance on object LOD and foliage LOD/pop-in.

YMMV with these configs, but a couple of users with higher end PC's have reported increased image quality, FPS, and smoothness with the first config I posted (which was a more tame Ultra+ config). I personally believe CDProjekt Red erred on the side of caution with the stock Ultra config; other than the boneheaded move of enabling Ubersampling, everything is set too low to really take advantage of the increased horsepower the higher end GPU's offer.

Where do I find the user.ini if I purchased through steam?
 

mileS

Member
Mar 15, 2005
5,915
0
0
36
Canada
thats what I was waiting for! I knew you'd come through with a post like that. TY TY BoobPhysics101

I had no idea FoliageDistanceScale was even a setting. How did you figure that one out? Honestly thats one of my biggest problems with the game is how much the foliage pops in.

Couple of quick questions. This is the user.ini file thats under My Documents right? (I've heard people say both so thats why I'm confused). also I noticed you have TextureMemoryBudget set to 650 for 1gb cards. I assume Its also fine to use 800 for that?
 

Aurarian

Member
Jan 26, 2009
778
0
900
Still get the same framerate with the high settings config from BoobPhysics. It really bothers me that my 460 can't even get a solid 60 FPS on high without anything "taxing" turned on.
 

FlyinJ

Douchebag. Yes, me.
Sep 22, 2005
12,696
1
0
Since I installed the patch, I'm getting "screendoor" artifacts on certain shadows. Is this common?

How to describe it better... the edges of some shadows don't alpha out nicely... instead they appear as one pixel transparent, one pixel not, etc.
 

Aeana

Member
Jul 10, 2006
42,062
4
0
FlyinJ said:
Since I installed the patch, I'm getting "screendoor" artifacts on certain shadows. Is this common?

How to describe it better... the edges of some shadows don't alpha out nicely... instead they appear as one pixel transparent, one pixel not, etc.
It's dithering, and it's in 1.0 as well.
 

Wallach

Member
Jun 26, 2008
29,844
1
0
FlyinJ said:
Since I installed the patch, I'm getting "screendoor" artifacts on certain shadows. Is this common?

How to describe it better... the edges of some shadows don't alpha out nicely... instead they appear as one pixel transparent, one pixel not, etc.

Shadows are always like that, they're dithered in TW2. Not a patch thing.
 

scy

Member
Jul 20, 2007
24,493
0
900
College Station, Tx
BoobPhysics101 said:
For those of you with beefier GPU's and that have at least 1.5GB of VRAM, try this:

Got my FPS in Chapter 3 up from ~50-60 to a near constant 60 (57-60) with just the settings posted straight and without the patch but with the GOG.exe.

Specs are:
i5 2500k OC'd to 4.3 Ghz
Radeon HD 6950 2GB, not unlocked
4 GB RAM

Might play around with the settings or I may just beat the game and then worry about tweaking for my 2nd time around.
 
Sep 15, 2010
4,252
0
0
Domcorleone said:
Where do I find the user.ini if I purchased through steam?

My Documents ---> Witcher 2 ---> Config


mileS said:
thats what I was waiting for! I knew you'd come through with a post like that. TY TY BoobPhysics101

I had no idea FoliageDistanceScale was even a setting. How did you figure that one out? Honestly thats one of my biggest problems with the game is how much the foliage pops in.

Couple of quick questions. This is the user.ini file thats under My Documents right? (I've heard people say both so thats why I'm confused). also I noticed you have TextureMemoryBudget set to 650 for 1gb cards. I assume Its also fine to use 800 for that?

User.ini in My Documents, yeah.


elseanio said:
I can't seem to get the game to read from the user.ini settings.

Setting AllowMotionBlur=0 to test, yet I still get motionblur in-game

Make sure you're editing the user.ini in My Documents, not in your Witcher 2 install directory located in Program Files. Also, make sure the top of the User.ini looks like this:

[Engine]
CustomRenderingSettings=1
PerformancePlatform=1


scy said:
Got my FPS in Chapter 3 up from ~50-60 to a near constant 60 (57-60) with just the settings posted straight and without the patch but with the GOG.exe.

Specs are:
i5 2500k OC'd to 4.3 Ghz
Radeon HD 6950 2GB, not unlocked
4 GB RAM

Might play around with the settings or I may just beat the game and then worry about tweaking for my 2nd time around.

So they worked well for you?
 

Kyaw

Member
Jun 5, 2010
5,558
0
590
Solihull, UK
I can definitely see the improved LOD over distance. Getting 30-50 around outside of Henselt's camp in Chapter 2 and around 40-60 inside the camp.
 

The Bookerman

Member
Jun 7, 2004
6,838
0
0
Wait a minute I just paid for this game(New to this thread)

Here's my specs:

Core i5 2500k Stock
MSi Geforce 560 ti
8 gb of RAM...

And you're telling me I will have a hard time playing this game @ 1080p 60 fps with max settings?


Wow, now i get why I quit upgrading my cpu every year.
 

leng jai

Member
Jan 20, 2009
13,846
16
990
The CPU isn't the problem, its the mid-tier videocard. You can't expect to play one of the top PC games at 1080p/max/60fps on a $250 videocard.
 

scorpscarx

Member
Feb 16, 2011
3,698
1
0
The Bookerman said:
Wait a minute I just paid for this game(New to this thread)

Here's my specs:

Core i5 2500k Stock
MSi Geforce 560 ti
8 gb of RAM...

And you're telling me I will have a hard time playing this game @ 1080p 60 fps with max settings?


Wow, now i get why I quit upgrading my cpu every year.

Yeah we wouldn't want to advance technology forward any now would we. /sarcasm

You say that as if it was a bad thing.

Besides no one told you that, you'll be able to max the game absolutely fine.
 
Sep 15, 2010
4,252
0
0
The Bookerman said:
Wait a minute I just paid for this game(New to this thread)

Here's my specs:

Core i5 2500k Stock
MSi Geforce 560 ti
8 gb of RAM...

And you're telling me I will have a hard time playing this game @ 1080p 60 fps with max settings?


Wow, now i get why I quit upgrading my cpu every year.

Wait for more drivers and patches. Performance is going to keep improving. The game, like Crysis, is definitely made with high-end/future hardware in mind.
 

The Bookerman

Member
Jun 7, 2004
6,838
0
0
leng jai said:
The CPU isn't the problem, its the mid-tier videocard. You can't expect to play one of the top PC games at 1080p/max/60fps on a $250 videocard.

.... mid tier. Right. Lemme remind you, this GPU isn't even 4 months old.
 

ColonelColon

Member
Dec 8, 2009
2,683
0
0
Kyaw said:
BoobPhysics to the rescue!

I shall try the last config out now.

damn. when I read that right after a post full of config settings, I thought for sure that I would find BoobPhysics=1 as one of the config settings. :(
 

scorpscarx

Member
Feb 16, 2011
3,698
1
0
The Bookerman said:
.... mid tier. Right. Lemme remind you, this GPU isn't even 4 months old.
Why are you complaining?

Most of us are dying for a real game to test our hardware on, and your set up will run this game exactly as you described sub ubersampling.

Have you even booted it yet?
 

Wallach

Member
Jun 26, 2008
29,844
1
0
Max settings for this game are pretty demanding. Not like other stuff where "max" isn't really that impressive for PC. Your system will still run the game great on Ultra sans supersampling.
 

Echoplx

Member
Dec 31, 2010
5,840
0
0
The Bookerman said:
.... mid tier. Right. Lemme remind you, this GPU isn't even 4 months old.

How is that relevant? Every gen of GPU's has low/mid/high end and the 560 is mid.
 

Revolutionary

Member
Sep 13, 2007
20,956
4,463
1,565
Brooklyn, NY
ColonelColon said:
damn. when I read that right after a post full of config settings, I thought for sure that I would find BoobPhysics=1 as one of the config settings. :(
Oh, but it is! It uses the patented Dead or Alive age = boob size algorithm, so set it to BoobPhysics=99 for maximum boobage.