• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

UH OH, new PSP exploit for all firmware versions (requires Lumines)

Lain

Member
Jul 24, 2004
18,141
0
1,470
PjotrStroganov said:
Hmm, I thought you lived in The Netherlands. Figured you were the same Lain from a Dutch forum.

I live in Italy.

quetz67 said:
Do you realize that playing the games without load times makes them much more enjoyable (and increases battery life) than just running them at 333mhz (which obviously im many cases doesnt make any difference at all)

I realize that, but to me 333mhz mode is more important than lesser load times or longer battery life (this especially because I mainly play with the PSP around my home, so battery life really isn't a concern). It's not the load times that annoy me with the PSP games I have, it's the slowdowns.

EDIT: Woah, Valhalla Knights battles play alot smoother now. No slowdowns when entering battles with 6vs6 and special abilities used. 333mhz mode <3.
 

NekoFever

Member
Feb 21, 2007
13,309
1
1,385
UK
Verboten said:
WHOO HOO! I think I did it! I just need to know if after downgrading to 1.50, can I format my memory card or do I have to keep all those downgrading files on it? Anyone know?
Format away. The firmware is stored in the PSP's internal flash so it doesn't matter what's on the Memory Stick. As long as you're now on 1.5 you can go ahead and install 3.40 OE.
 

Regret Truth

Member
Jan 17, 2006
1,936
0
0
Just to let you guys know the price of Lumines USED went up at Gamestop. From 12.99 t o17.99. Same price as Lumines II used.
 

burnfout

Member
Sep 18, 2006
1,949
0
0
Netherlands
Great, after spending 6 hours of downgrading, upgrading, ripping, converting, popstationing, PBPing and what not, I get a eboot file of my FF7 disc 1, my emulator shows up on my PSP, but nothing happens, just a black screen :( Im depressed.
 

Mejilan

Running off of Custom Firmware
Jun 9, 2004
38,484
0
0
42
NJ, USA
Buddy of mine had the same problem. Most likely a bad ISO rip. Rerip the disc. Also, if you're customizing the EBOOT with images, icons, and sounds, make sure the TOTAL file size of all of the custom images/sounds don't surpass 500kbs.

SNUG REVOL said:
Just to let you guys know the price of Lumines USED went up at Gamestop. From 12.99 t o17.99. Same price as Lumines II used.

Not a bad idea to format the mem stick after installing 3.40 OE-A as well, since the tweaked format routine populates your mem stick with the homebrew-ready folders, for your convenience! :)
 

burnfout

Member
Sep 18, 2006
1,949
0
0
Netherlands
Mejilan said:
Buddy of mine had the same problem. Most likely a bad ISO rip. Rerip the disc. Also, if you're customizing the EBOOT with images, icons, and sounds, make sure the TOTAL file size of all of the custom images/sounds don't surpass 500kbs.



Not a bad idea to format the mem stick after installing 3.40 OE-A as well, since the tweaked format routine populates your mem stick with the homebrew-ready folders, for your convenience! :)


Yeah I did format my MS after 3.40 EO-A, to get the game150 folders, they weren't there after the update.


Anyway it seems my black screen problem happens ALOT with PAL games, which sucks cause
I own 50 + PAL games.

I just tried RE3 Nememis NTSC, and that worked like a charm. But I really want to rip my own games instead of downloading :(
 

seb

Banned
Jan 13, 2007
809
0
0
Toulouse, France
Homebrew noob question:

So, it seems with 3.50 HEN I can run homebrew just fine. If I'm only interested in running prx done by myself or others, it's enough to use 03.50 HEN right ? what do I gain by downgrading ? (I know what I'm loosing !)
 

Schrade

Member
Apr 12, 2007
7,055
102
1,405
Carl2282 said:
ok right now i have 3.40oe on my psp can anyone tell me what app i need to install to rip my umd's to my memory stick?
You need to download USB Special System Storage (USBSSS): http://www.psp-hacks.com/file/1008

Copy the two folders in this archive to ms0:/PSP/GAME150

%__SCE__USBSSS --> ms0:/PSP/GAME150/%__SCE__USBSSS
__SCE__USBSSS --> ms0:/PSP/GAME150/__SCE__USBSSS

Then, put the UMD in that you want to copy and make sure your USB cable remains hooked up.

Go to your Games section in the PSP XMB and run USB Special System Storage.

Highlight "Virtual FAT16 . UMD ISO-9660" and press X

You should now hear your USB device being recognized by your system and you can just double click on the drive letter and copy the UMD9660.ISO file from that to your PC's hard drive.

Once it's on your hard drive you can rename it and you might need to right click it and select properties then remove the read only flag on the file.

If you press X again it should unmount the UMD drive and you can insert another one.
 

DustinC

Member
Oct 26, 2005
848
0
0
40
Ohio
So when I run the 3.50 downgrader, if I have a TA-082 motherboard, it'll just ask me if I want to patch it, which I do, right?

Edit: Nevermind. I just read the how to txt. Reading is for winners.
 

StorablePrawn

Banned
Sep 2, 2004
1,051
0
0
www.worthplaying.com
I'm so behind on all this. I haven't used homebrew since near launch period.

SOMEBODY POST A LIST OF THE BEST PSP SOFTWARE.

Links not even necessary. I'm just so overwhelmed, I need a good place to start.
 

YYZ

Junior Member
Mar 5, 2007
8,275
0
0
I'm getting a 2.80 PSP, should I be ok? Can I do everything on it like run custom firmware, play PSX games and run UMD games off a memory stick? It would help with the load times, especially the FF remake.
 

Schrade

Member
Apr 12, 2007
7,055
102
1,405
YYZ said:
I'm getting a 2.80 PSP, should I be ok? Can I do everything on it like run custom firmware, play PSX games and run UMD games off a memory stick? It would help with the load times, especially the FF remake.
Yes you'll be ok. You don't need to buy Lumines to downgrade but if you find a copy BUY it. It will allow you to downgrade PSPs with 3.50 firmware and lower using the Illuminati exploit downgrader. Sony just released a 3.51 firmware that fixes the exploit so make DAMN sure you do not update your firmware using the network update feature of the PSP.

If you have a TA-082 or TA-086 motherboard, get Chilly Willy's Corruption Free Downgrader to downgrade it. You need to find out what type of motherboard you have first.

http://forums.maxconsole.net/showthread.php?t=53933

(It shows you how to tell what motherboard you have)
 

MadFuzzy

Member
Jun 8, 2004
1,445
7
1,425
Looks like Sony are making a quick move to patch this exploit, since firmware 3.51 has just been released and the only new feature is "security tightened up".
 
Schrade said:
The brightness problem is due to a new LCD module on your PSP. Not too many PSPs have this new module.. It's mentioned that this is only on TA-086 motherboards. The fix can be found here:

***WARNING***: This is a somewhat advanced level hack you CAN brick your PSP if you do something incorrectly.

How to Repair your backwards brightness problem: http://lan.st/forums/showthread.php?p=4640#post4640

Again, this is pretty advanced so proceed with caution! If you feel you're not up to the challenge maybe get someone else who has done it before to walk you through it or get a friend who is adept with this stuff to help you in person.
This brightness thing happens to me, but only when I run the SNES emulator. I just entered the scene and I want to know what are some good homebrew games/apps?
 

Futurevoid

Member
Dec 7, 2005
24,351
0
0
www.lcvg.com
Just a question, after the downgrade is completed...should I remove any of the files I copied over to the PSP? By that I mean the files from the MS_ROOT folder I copied over from the downgrader and the UPDATE.PBP I used to get 1.50 installed? Just curious as I dont want to have Lumines boot up each time into the exploit and I'd imagine that would happen. Or should I leave everything as is and move on to the Dark Alex custom firmware install?
 

kenta

Has no PEINS
Jan 27, 2005
8,490
0
0
Apparently 3.51 is out, just a heads up to not update with the PSP's official checker
 

Pimpwerx

Member
Jun 7, 2004
26,261
1
0
305 'til I die
iapetus said:
Got my downgrade done yesterday - remarkably smooth process. Now it's just a case of finding out what software's worth getting for it and waiting for my 2GB memory card to arrive. :D
2GB? What is this, 2006? Get with the time, iapetus. The 4GB Sandisk sticks can be found for $60-70US at reputable e-tailers. I'm actually waiting for the 8GB to drop in price. I moved the 4GB stick to my PSP and put my gf's old 512MB in my phone, and it's just not enough space for music. But if I get a 4GB stick, I found I filled that pretty quickly too. So I'm waiting for an 8GB for my PSP and moving the 4GB back to my phone. 2GB just seems so last-gen now. :p PEACE.
 

Eric P

Member
Nov 23, 2004
4,779
0
1,500
NoVa
hey, wow. it worked.

that was really easy too.

time to go buy a larger memstick. i still have the 32 meg that was in my launch unit's packaging
 

slidewinder

Banned
Nov 5, 2004
5,245
0
0
Futurevoid said:
Just a question, after the downgrade is completed...should I remove any of the files I copied over to the PSP? By that I mean the files from the MS_ROOT folder I copied over from the downgrader and the UPDATE.PBP I used to get 1.50 installed? Just curious as I dont want to have Lumines boot up each time into the exploit and I'd imagine that would happen. Or should I leave everything as is and move on to the Dark Alex custom firmware install?
You can get rid of the downgrader stuff for sure. You will need the 1.50 firmware file as part of the OE install, though you'll have to rename it and move it to a particular folder (detailed in the OE instructions).
 

Eric P

Member
Nov 23, 2004
4,779
0
1,500
NoVa
so i followed the instructions that were included with dark alex, but i'm a little unclear on the final step


- Copy 340oeflasher and 340oeflasher% to /PSP/GAME if you are in 1.50, or to /PSP/GAME150 if you
are in any SE/OE version. Move the DATA.DXAR to 340oeflasher directory.

this leaves me with 3.40 oe-a update maker and with 3.40 oe-a firmware install. it doesn't state which of these to run, so i ran firmware install, which did a bunch of stuff then dumped me back to the game section of my psp. i check the system info and it says 1.5. I turn off, I turn on and it says the same version.

i run the other program and i get the same thing.

is my system now on the dark alex firmware?

edit: nvm. i had lumines in the drive. i removed and formated the mem stick and am going through the upgrade process again

edit2: that was it. so if you're upgrading to 3.40, don't have anything in the umd drive.
 

Bartman3010

Banned
Apr 1, 2005
1,113
0
0
Looks like Sony is already up to the plate, they have Version 3.51 up for grabs.

I just got a PSP and, kind of need help how to get it working. Any ideas? Right now, my system's firmware is at 3.30.
 

n8NMONSTER

Member
Jul 20, 2006
666
0
0
Bartman3010 said:
Looks like Sony is already up to the plate, they have Version 3.51 up for grabs.

I just got a PSP and, kind of need help how to get it working. Any ideas? Right now, my system's firmware is at 3.30.

you can follow this guide:
http://forums.qj.net/f-guides-hacks...ide-310-350-to-15-downgrade-guide-112252.html

- upgrade to 3.50, then downgrade to 1.50.

then follow this guide:
http://forums.qj.net/f-guides-hacks...nd-303-oe-c-installation-guide-faq-90741.html

- upgrade from 1.50 to 3.40 oe-a.

when a future oe firmware you can upgrade directly from 3.40 oe-a.

- ie, upgrade from 3.40 oe-a to 3.51 oe (whenever it comes out).
 

neptunes

Member
Jun 6, 2004
15,611
1
1,740
I don't think the hackers have a copy of the japanese Lumines yet.

They said they'd work on one as soon as they get a hold of one.
 

Eric P

Member
Nov 23, 2004
4,779
0
1,500
NoVa
kind of a noob question but how do i get my psp to run in 333?

i have 3.4 oe-a but don't see that option
 

Ikuu

Had his dog run over by Blizzard's CEO
Mar 7, 2007
14,998
1
1,255
Eric P said:
kind of a noob question but how do i get my psp to run in 333?

i have 3.4 oe-a but don't see that option

Turn your PSP off, and restart it holding R down and it's in the menu somewhere. Give me a sec and I'll check.

Edit: Under CPU Speed.

Also go to Configuration and change Game folder homebrew, and change it to 1.50 Kernel pretty sure it's needed for emulators to run.
 

Eric P

Member
Nov 23, 2004
4,779
0
1,500
NoVa
Ikuu said:
Turn your PSP off, and restart it holding R down and it's in the menu somewhere. Give me a sec and I'll check.

Edit: Under CPU Speed.

Also go to Configuration and change Game folder homebrew, and change it to 1.50 Kernel pretty sure it's needed for emulators to run.

thanks a lot.

hopefully Ys will run a lot better now and become almost playable.
 

Aeana

Member
Jul 10, 2006
42,062
4
0
I'd really like to try this... but I'm not sure exactly what I should be doing.

I have a TA-082 PSP, with 2.82 firmware. Should I follow this guide, upgrading to 3.50 before downgrading to 1.5? I don't want to mess anything up!
 

n8NMONSTER

Member
Jul 20, 2006
666
0
0
thats the guide i followed.

in the 3.50 downgrader, there will be a part that asks you to patch it before continuing (only shows if you have a TA-082 psp):

You have a TA082+ PSP, which needs to be patched
before it can be downgraded.

Press X to start the patch. By doing it, you accept the
risk and ALL the responsibility of what happens.
If you don't agree press R-trigger button.

just press x to continue, and everything else goes normal. but yea, upgrade to 3.50 first.
 

NintendoGal

Member
Oct 3, 2005
4,347
0
0
38
Belmont, CA
www.thegreedyant.com
I believe this thread deserves a bump in light of DAX leaving the scene:

Bye, scene.

I've decided to cease OE development, and leave PSP scene.
The reasons are various.
One of them is the time it consumes, which i'm losing from other things.
The other is related to my security. I didn't like Sony menaces to PS3 hackers.
I think it is better to leave now rather than end paying the consequences.

http://dark-alex.org/
 

B.K.

Member
Jun 8, 2004
25,494
0
1,575
I wonder if this exploit will work on the firmware in the new PSPs or if Sony fixed it.
 

travisbickle

Member
Mar 26, 2006
14,928
0
0
Bumping an old thread, but can the US 3.5 update be used on a UK/Euro PSP? I not where do I find the 3.5 update?