• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

Battlefield 3 PC Performance thread

Emily Chu

Banned
May 14, 2010
3,544
0
0
Ogs said:
So i swap out my 4870 1GB for an 8800GT 512MB, and what do you know, nVidia drivers win again -



Running around areas like that are significantly smoother than the way more powerful 4870. Why the hell did i even think of going back to ATI in the first place i dont know. Yeah im sure they will get upto speed in driver updates, but they come so bloody slowly i aint waiting.


lol I get 60 FPS on my 8800GT 512mb + PH II X4 955 AMD everything low @ 720p

it looks not bad to be honest, 16x AF, Post AA Set to high.
 
Aug 30, 2007
28,293
0
0
Ca
man, this game does not like an OC'd GTX.
finally have my 580 stabled at.
1150 voltage
866 core clock
2462 memory

but im getting major flickering, weird geometric artefacts, and funny colored backgrounds
 

Varna

Member
Dec 6, 2008
5,978
0
0
So this is what my PC will look like after a few upgrades...

ASUS P8Z68-V PRO
i5-2500k (will OC to 4GHZ at least)
EVGA 580GTX SC
G.SKILL Sniper 8GB
Corsair Force Series 120GB SSD

What kind of settings should I be aiming for to hit 60FPS at 1080p? Any form of SSAO will be turned off right away (did not like the look in the beta).
 

MikeE21286

Member
Jun 15, 2007
23,767
0
1,110
Varna said:
So this is what my PC will look like after a few upgrades...

ASUS P8Z68-V PRO
i5-2500k (will OC to 4GHZ at least)
EVGA 580GTX SC
G.SKILL Sniper 8GB
Corsair Force Series 120GB SSD

What kind of settings should I be aiming for to hit 60FPS at 1080p? Any form of SSAO will be turned off right away (did not like the look in the beta).

I'm guessing close.

I have the same step with a stock 2500k and a 570 and I'm around 40 fps constantly it seems
 

TheBear

Member
Aug 16, 2008
4,568
0
0
Looking to upgrade my card before I buy this. My stats:
AMD 955
HD4890
4GB Ram

What current Nvidia card would I need to run this game on Ultra @ 60fps? And would it be worth waiting for the next gen of cards?
 

Team Klimt

Member
Mar 26, 2007
1,298
1
0
twitter.com
dgud said:
I have to downclock my factory overclocked 560ti to get the game stable.

So people with 560ti and problems downclock it to 820-1640.

I've done exactly this and I'm still crashing/ freezing after a few minutes of play every time I join a game. 560 ti with 3gb ram, only a 2.4 quad-core cpu.

Are there other precautions I should take? I upgraded my power supply to 750w and got the 560ti for BF3. Needless to say, I'm fucking pissed that I've dropped $400+ and I haven't been able to finish ONE game yet. (sorry for the rant, but goddamn...)

Any help would be appreciated.

Running on recommended settings (High) at 1280x768.
 

K.Jack

Knowledge is power, guard it well
Mar 10, 2007
24,183
0
1,410
Team Klimt said:
I've done exactly this and I'm still crashing/ freezing after a few minutes of play every time I join a game. 560 ti with 3gb ram, only a 2.4 quad-core cpu.

Are there other precautions I should take? I upgraded my power supply to 750w and got the 560ti for BF3. Needless to say, I'm fucking pissed that I've dropped $400+ and I haven't been able to finish ONE game yet. (sorry for the rant, but goddamn...)

Any help would be appreciated.

Running on recommended settings (High) at 1280x768.
Maybe try raising the voltage.
 

Varna

Member
Dec 6, 2008
5,978
0
0
MikeE21286 said:
I'm guessing close.

I have the same step with a stock 2500k and a 570 and I'm around 40 fps constantly it seems

Close? What are your settings like?

In the beta I had to turn down everything but texture to high (whatever the second highest was) and I got 50-60 (and some low 40s in heavy smoke areas). That was with a stock i5-760 and the same gpu. I know the retail version is more intensive and many of the maps are much larger... I just want to get an idea... maybe a new cpu/ram/ssd aren't even worth it.
 

Hawk269

Member
Aug 22, 2005
8,762
416
1,615
K.Jack said:
Maybe try raising the voltage.

Why would he add voltage if he is downclocking the GPU???

You add voltage when you overclock, not when you underclock.
 

MikeE21286

Member
Jun 15, 2007
23,767
0
1,110
Varna said:
Close? What are your settings like?

In the beta I had to turn down everything but texture to high (whatever the second highest was) and I got 50-60 (and some low 40s in heavy smoke areas). That was with a stock i5-760 and the same gpu. I know the retail version is more intensive and many of the maps are much larger... I just want to get an idea... maybe a new cpu/ram/ssd aren't even worth it.
I run on ultra settings at 1080p
 

Niblet

Member
Jan 4, 2009
1,086
0
0
Right now I have my 2600k running at 4.5GHz and my 6950 running at 940/1350 with unlocked shaders. Running at 2560x1440 I'm getting high 50s to 60 fps in campaign right now with the following settings:



AA is putting me in the 40s and the difference is not worth the performance loss. I'm going to try to squeeze some more OC juice out of my gfx.

Here is an screenshot taken with 4x AA (this ran in mid 40s)

 

specialguy

Banned
Feb 17, 2011
4,527
0
730
Ogs said:
So i swap out my 4870 1GB for an 8800GT 512MB, and what do you know, nVidia drivers win again -



Running around areas like that are significantly smoother than the way more powerful 4870. Why the hell did i even think of going back to ATI in the first place i dont know. Yeah im sure they will get upto speed in driver updates, but they come so bloody slowly i aint waiting.

Ogs, you must have something very wrong cause my 4890 (basically overclocked 4870) runs the game mostly ultra 1080p at 30 FPS+.

Very, very wrong.

Make sure you're not using MSAA I guess. Kills AMD in this game. Not enough to cause what you're experiencing though.

Personally I'm scared to buy an Nvidia card cause, look at this thread. Most of the problems are with Nvidia cards, especially stuttering, running out of vram (known issue with Nvidia cards in all games AFAIK).

The problems on the AMD side all seem to be crossfire related, which I dont give a crap about that, and xfire/sli isn't something you expect to be reliable anyway. The nvidia problems seem much more fundamental to me. They say even factory overclocked Nvidia cards are having issues for example, what kind of crap is that? If my card is factory overclocked it better work at that clock.
 

Team Klimt

Member
Mar 26, 2007
1,298
1
0
twitter.com
Hawk269 said:
Why would he add voltage if he is downclocking the GPU???

You add voltage when you overclock, not when you underclock.

It's not that crazy actually. I guess it makes sense to give it more power than it needs. Better that than not having enough and it dropping suddenly.

My Memory Freq is set at 2000 mhz. On a 1gb card with 3gb of system ram, should i knock that down? I'm not sure exactly what that setting means - seems like it could be high.

On my 560 ti, I'm currently running 820 (core freq)/1640 and I boosted the voltage from 1020 to 1150 (I'm assuming that's a max voltage and that it won't be running that hot at all times. Is that right?)
 
Sep 15, 2010
4,252
0
0
BoobPhysics101 said:
High looks about the same as Ultra textures. I run high on my GTX 570 cause the fucking thing only has 1.28GB of VRAM lol. Makes me want to sell it and buy a 6950 2 GB, but whatever.

I'll test out Ultra textures and see if I can get the game to over-use VRAM and cause problems... I'll report back with my results. I'll measure VRAM usage.

Update

I ran the game @ 1080p, Ultra everything, Post AA @ Low (I don't like the blur that the higher Post AA adds), Deferred MSAA set to off.

The game maxes out at 1.2~ GB VRAM usage on Ultra textures on my system. If someone with a 1.5 GB or 2 GB VRAM card could measure their VRAM usage, that'd be swell.

Ultra textures plays just as smoothly as High. Didn't stutter or anything. Game plays perfectly smooth.


Varna said:
So this is what my PC will look like after a few upgrades...

ASUS P8Z68-V PRO
i5-2500k (will OC to 4GHZ at least)
EVGA 580GTX SC
G.SKILL Sniper 8GB
Corsair Force Series 120GB SSD

What kind of settings should I be aiming for to hit 60FPS at 1080p? Any form of SSAO will be turned off right away (did not like the look in the beta).

Why does anyone bother with the GTX 580? It's only a bit faster than a GTX 570 or 6950 but so much more expensive. Just overclock, damn.
 
Dec 20, 2005
2,205
0
0
I'm playing on a laptop with a mobility 5650, finding it just a fraaaction too slow. SP is around 30 - 50 fps, MP 25 - 40 fps. If i could find a way to bump it up a tiny bit more i would be happy, i think a miracle patch is my only hope.
 
Sep 15, 2010
4,252
0
0
Fix The Scientist said:
I'm playing on a laptop with a mobility 5650, finding it just a fraaaction too slow. SP is around 30 - 50 fps, MP 25 - 40 fps. If i could find a way to bump it up a tiny bit more i would be happy, i think a miracle patch is my only hope.

Overclock that 5650. Set everything to Low, except Textures (set to High if you have 1 GB VRAM).
 

EatChildren

Currently polling second in Australia's federal election (first in the Gold Coast), this feral may one day be your Bogan King.
Jan 29, 2008
36,140
8
0
Australia
So I've noticed that once every blue moon the screen will do a bit of green flickering. Any known reason to this. VRAM related?
 
Dec 20, 2005
2,205
0
0
BoobPhysics101 said:
Overclock that 5650. Set everything to Low, except Textures (set to High if you have 1 GB VRAM).
I already have it overclocked to 700 engine, 1000 memory, all settings on low, plus other tips from the Witcher 2 thread. I am pushing this bitch for all it's worth... temp gets to 90 C also...

I tried running driver sweeper and that seemed to screw up the laptop pretty bad, am i meant to remove everything in that giant ATI Display list?
 
Sep 15, 2010
4,252
0
0
EatChildren said:
So I've noticed that once every blue moon the screen will do a bit of green flickering. Any known reason to this. VRAM related?

Read last page. Apparently it happens on AMD, Nvidia, AND the consoles as well. DICE voodoo shit, basically. :\


Fix The Scientist said:
I already have it overclocked to 700 engine, 1000 memory, all settings on low, plus other tips from the Witcher 2 thread. I am pushing this bitch for all it's worth... temp gets to 90 C also...

I tried running driver sweeper and that seemed to screw up the laptop pretty bad, am i meant to remove everything in that giant ATI Display list?

I don't think you can do much more. I was in a similar boat: Had an Asus K53TA with 6650m and 6520m, used them in Crossfire... overclocked the Llano CPU to 2.5 Ghz for BF3... maxed that bitch out. Only got 25-40 FPS on Low @ 1366x768.

Sold that shit for the same amount I paid for it, spent $300 and built a rig that runs BF3 @ 1080p Ultra @ 60+ FPS.

My advice would be to do the same. It's so worth it.
 

EatChildren

Currently polling second in Australia's federal election (first in the Gold Coast), this feral may one day be your Bogan King.
Jan 29, 2008
36,140
8
0
Australia
BoobPhysics101 said:
Read last page. Apparently it happens on AMD, Nvidia, AND the consoles as well. DICE voodoo shit, basically. :\

Hahaha oh wow. Fix that shit DICE!
 
Dec 20, 2005
2,205
0
0
BoobPhysics101 said:
I don't think you can do much more. I was in a similar boat: Had an Asus K53TA with 6650m and 6520m, used them in Crossfire... overclocked the Llano CPU to 2.5 Ghz for BF3... maxed that bitch out. Only got 25-40 FPS on Low @ 1366x768.

Sold that shit for the same amount I paid for it, spent $300 and built a rig that runs BF3 @ 1080p Ultra @ 60+ FPS.

My advice would be to do the same. It's so worth it.
Yep recently i've been thinking i should do something like that, thanks for the advice.
 

.nimrod

Member
Jul 8, 2007
1,297
0
0
I'm getting weird stuttering where the screen sometimes freezes for half a second when i try to record gameplay with fraps.

It's especially noticable in the second part of this video i recorded 2 days ago: www.youtube.com/watch?v=YI6fWPgJIEs&hd=1

Is there anything i can do about it?
I'm on a GTX580 and i tried to record at 1080p/half resolution, maybe someone else on a similar setup doesn't have that problem and could share his settings. I really need my locked 60fps when i'm flying.
 
Dec 28, 2008
19,767
0
0
UK.
I record half resolution (native 2048x1152) and I maintain 60fps fine with a 6950 2gb, 8gb RAM, 955 @ 3.8ghz and most of the settings on high.

How's your CPU? Stuttering like that could be caused by it overheating due to the strain of recording after a while.
 

.nimrod

Member
Jul 8, 2007
1,297
0
0
Foliorum Viridum said:
I record half resolution (native 2048x1152) and I maintain 60fps fine with a 6950 2gb, 8gb RAM, 955 @ 3.8ghz and most of the settings on high.

How's your CPU? Stuttering like that could be caused by it overheating due to the strain of recording after a while.
I have an i7 870 that runs at 3,4GHz while playing and usually never goes above 50°C, but i'll have to monitor that while frapsing later today.
I hope it's not my harddrive, they got really expensive lately. It's a 7200rpm 1TB samsung spinpoint with about 100GB free space that i recently defragmented.
 

Kusuri

Neo Member
Oct 31, 2010
28
0
0
Portugal
Jtrizzy said:
This sounds similar to what I'm seeing. Mouse movement makes everything jittery but when I move w/o moving the mouse it looks right.

Yes, exactly the same I'm experiencing. I remember noticing this years ago in other older games like CoD 2 while strafing and looking around at the same time. What made it smoothen out then was a dual core fix for my old AMD 4400+.

Right now I'm on a i7 920 @ 3.75 and a GTX 480 @ stock. Settings: 1680x1050, Ultra except shadows (Low). AA 2x, AF 8x. Ambient occlusion off.
 

Naeblish

Member
May 19, 2007
885
0
0
Is there any good guide out there that explains all the settings and how each one effects the graphics and performance?
I've upgraded from a E8400 dual core to a Q8200 quad core and a 4850 to a 6870, and the game runs butter smooth now, but i would like to optimize the settings.
 

spk

Member
May 9, 2010
1,232
0
560
.nimrod said:
I'm getting weird stuttering where the screen sometimes freezes for half a second when i try to record gameplay with fraps.

It's especially noticable in the second part of this video i recorded 2 days ago: www.youtube.com/watch?v=YI6fWPgJIEs&hd=1

Is there anything i can do about it?
I'm on a GTX580 and i tried to record at 1080p/half resolution, maybe someone else on a similar setup doesn't have that problem and could share his settings. I really need my locked 60fps when i'm flying.
Make sure to record to another drive if you're not already doing that
 
Nov 22, 2010
913
2
940
South Africa
Hey guys, I got kicked out to a blue screen saying something about memory management?then the PC rebooted.I built a new PC for the game ,got 8 gigs of new ram so I doubt its the ram, but maybe I,m wrong.Anyone else having these issues?
 

IonicSnake

Banned
Nov 6, 2009
4,233
0
0
Here are my settings.



I get around 40-55 sometimes 60fps depending on map.

My PC:

CPU: i5 2500k
GPU: HD6950 2gb
RAM: 12gb

Here's a video I recorded using fraps from one of the campaign levels (Going Hunting). I don't recommend watching it if you haven't played the campaign because it's a level you would want to see for the first time in the game.

http://youtu.be/RuayRgO_-dk?hd=1
 

bizatch

Member
Aug 24, 2007
410
0
0
So, like some other people on here, im getting a frozen screen and sound looping, which requires a reboot, after 10-30min of mp gameplay. I tested my CPU, RAM and Video Card, so its definitely not that. The only solution I've read is replacing the sound card, which I am not about to do. This is the only game that gives me this problem, and I didnt get it in beta. WTF DICE?!
 

Gareth Bale

Member
Nov 5, 2009
20,339
0
620
Last time I played I was getting artifacting (I think that's what it's called) quite badly around the reticle. I checked the temp (560ti) and it wasn't going above 80. Is this a known issue?
 

Manager

Member
Jul 9, 2006
10,792
0
0
Sweden
.nimrod said:
I'm getting weird stuttering where the screen sometimes freezes for half a second when i try to record gameplay with fraps.

It's especially noticable in the second part of this video i recorded 2 days ago: www.youtube.com/watch?v=YI6fWPgJIEs&hd=1

Is there anything i can do about it?
I'm on a GTX580 and i tried to record at 1080p/half resolution, maybe someone else on a similar setup doesn't have that problem and could share his settings. I really need my locked 60fps when i'm flying.

Maybe it's the harddrive? Tried defrag? A lot of information being saved. Otherwise you could just try, to test, 720p and record at lower res and see if it fix it.

Bungieware said:
Last time I played I was getting artifacting (I think that's what it's called) quite badly around the reticle. I checked the temp (560ti) and it wasn't going above 80. Is this a known issue?

http://www.neogaf.com/forum/showpost.php?p=32261267&postcount=1223
 

MNC

Member
Mar 4, 2008
14,139
0
0
Any more 540m impressions? I keep watching youtube videos, be satisfied, I've played the Beta, was satisfied, I KNOW IT WILL RUN DECENT ENOUGH FOR MY TASTES. But I still want to read more. Fucking exam week.
 

Detox

Member
Nov 9, 2010
5,321
0
0
Bungieware said:
Not just me then. It was happening on Firestorm. I'm running a MSI 1GB GeForce GTX 560 Ti Twin Frozer II by the way, so it's factory overclocked.
If you're getting the problem I posted a pic of then someone mentioned turning off MSAA and just using Post AA. I believe MSAA causes it to exceed the VRAM, my friend has done this and so far he hasn't had the problem repeat.
 
Sep 15, 2010
4,252
0
0
Naeblish said:
Is there any good guide out there that explains all the settings and how each one effects the graphics and performance?
I've upgraded from a E8400 dual core to a Q8200 quad core and a 4850 to a 6870, and the game runs butter smooth now, but i would like to optimize the settings.

I can give you some quick tips:

Set Ambient Occlusion to SSAO instead of HBAO. Looks about the same but gives a nice performance boost. Turn off deferred antialiasing, it'll kill your FPS especially on AMD hardware. Turn shadows to medium or high for a decent boost with little image quality loss.
 

HollovVpo1nt

Banned
Apr 17, 2010
3,183
0
0
EatChildren said:
So I've noticed that once every blue moon the screen will do a bit of green flickering. Any known reason to this. VRAM related?

I was just lurking this thread since I don't own the PC version of BF3, but that green flickering happens in the 360 version too. I've only noticed it on Caspian Border MP so far.
 

Metalmurphy

Member
Jan 17, 2007
32,670
1
0
Portugal
steamcommunity.com
BoobPhysics101 said:
Read last page. Apparently it happens on AMD, Nvidia, AND the consoles as well. DICE voodoo shit, basically. :\


This started to happen to a friend of mine AFTER he updated to 11.10 that got released today.


Probably not a good idea to update.



Funnily enough, I did update and it's not happening to me.
 

belvedere

Junior Butler
Jun 2, 2006
9,148
1
0
Metalmurphy said:
I did, now the game crashes everytime i try to join a server

Just out of curiosity, did you set min threads to 0 and max to 4 (or whatever your core count is)?
 

Slackbladder

Member
Mar 13, 2007
4,141
1
880
51
Why does the game freeze when I go to the Video options? Why does it take 2 minutes to launch the game? Why did the game download and not install from the disc? Why is Origin and EA such a shower of shit?
So far I have yet to play it (that's after having it for 4 hours). I'm sure the game will be great but really, an absolute fucking joke.