• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

Nier: Automata PC performance thread

Momentary

Banned
Jan 22, 2011
10,453
74
830
So what is the current state of this game with official patches vs unofficial hacks?

edit; so it seems like FAR is the only thing needed right now for both FS and AO fixes?

Once there is an official patch we will be able to compare.
 

skLaFarebear

Member
May 18, 2014
29,666
0
0
J-Block, NJ
I downloaded the fix and turned down GI to low and disabled the nvidia stuff since it didn't work anyway (and turned down AA). Gonna test it out now, but anyone know how to turn off the Green FAR ui on the top left though?

nvm im dumb i should read all the instructions lol
 

Zafir

Member
May 11, 2011
13,529
0
0
United Kingdom
So the other day someone mentioned that setting the GI to Low was bugged in places. I had a look into this today in basically the same place since I'm now up to where I imagine they were (Start of Route B). I turned it up to medium and I noticed even that causes some weird issues in places which seemingly don't appear on Low.

<Spoiler Alert don't click if you haven't finished the game at least once and got ending A>

http://screenshotcomparison.com/comparison/204588

Edit: It's worth noting I am using reshade for some things, but I don't see how that would affect the medium setting.

Also, interestingly, medium seems to render the lighting in some places lighter than that of the high/default setting. For example Low will show shadows excessively dark, Medium shows them quite light, High/Default shows them somewhere in between.
 

longdi

Banned
Jun 7, 2004
8,933
6,714
1,890
Since turning off AA, i having good performance, mostly 60fps at 1440p max settings. I did not apply any fix. 980Ti at 1480mhz.
 

SapphiCine

Member
Jan 16, 2016
1,287
0
305
So the other day someone mentioned that setting the GI to Low was bugged in places. I had a look into this today in basically the same place since I'm now up to where I imagine they were (Start of Route B). I turned it up to medium and I noticed even that causes some weird issues in places which seemingly don't appear on Low.

<Spoiler Alert don't click if you haven't finished the game at least once and got ending A>

http://screenshotcomparison.com/comparison/204588

Edit: It's worth noting I am using reshade for some things, but I don't see how that would affect the medium setting.

Also, interestingly, medium seems to render the lighting in some places lighter than that of the high/default setting. For example Low will show shadows excessively dark, Medium shows them quite light, High/Default shows them somewhere in between.
Hearing stuff like that makes me hesitant to try this out. :<
 

Renesis

Member
Aug 20, 2012
74
0
0
Anyone else having this issue, im pretty sure the light shafts didnt look this bad before.
 

Crevox

Member
Aug 24, 2012
127
0
0
Anyone else having this issue, im pretty sure the light shafts didnt look this bad before.

I always had this issue in these areas.

Hearing stuff like that makes me hesitant to try this out. :<

There's obviously going to be some quality loss... it's just that the performance gain for turning this down is monumental, especially for how little changes. In most areas, very little to nothing is different, or things you wouldn't notice either way.
 

brau

Member
Sep 29, 2014
8,596
0
0
Playing the game right now.

But, in the area after the first mission. Is it normal for it to blink to black every so often?

In the menus it doesn't. But as i play it likes to blink to black for some reason.

Is this normal?
 

Ruff

Member
Jun 9, 2014
1,811
0
0
Playing the game right now.

But, in the area after the first mission. Is it normal for it to blink to black every so often?

In the menus it doesn't. But as i play it likes to blink to black for some reason.

Is this normal?

No
 

Zafir

Member
May 11, 2011
13,529
0
0
United Kingdom
Hearing stuff like that makes me hesitant to try this out. :<

I mean if you have a card which is older than a few years, I totally recommend turning down GI anyway. I think this is definitely a game that benefits from 60FPS, and if GI helps you get there, I totally think you should accept the little shadow bugs here and there for it.
 

JoeyJungle

Banned
Aug 24, 2011
4,421
0
0
So does the unofficial patch fix the crashing issues with the game? I haven't played since last weekend since it was happening so often for me.
 
Jun 19, 2014
201
0
0
So does the unofficial patch fix the crashing issues with the game? I haven't played since last weekend since it was happening so often for me.

What video card do you have? If you have a Kepler card (I have 780Ti), there is nothing that can be done, I've already tried everything (driver clean, driver rollback, GPU underclock, borderless, FAR tweaks etc.) and I still get GPU crashes.

I find playing Fullscreen with V-Sync on and RTSS locked to 60 produces the most stable results. When I get crashes at problem areas such as the Amusement Park or Old Factory, I have to set the graphics settings to Low, I still can get a crash on Low but it is much rarer. The rest of the time I'm playing with AF: x16, Effects: High, Shadows: High, AA and AO off and get good performance for the majority of the game.

For any other Kepler owners, I recommend checking out this thread on Steam which is 500 posts strong, check the OP for a link to report the issue to Nvidia:
http://steamcommunity.com/app/524220/discussions/0/135511913382921167/
 

Mailbox

Member
May 3, 2014
4,811
0
0
Canada
So does the unofficial patch fix the crashing issues with the game? I haven't played since last weekend since it was happening so often for me.

which crashing issues?
Like when the screen freezes but things still happen?
or like the white screen bug?

What graphics card are you using.
Details are important , because if its the later and you have an AMD card, you just have to revert back to an old driver.

(a Part of me wants to see if i can play this on my cheap broadwell core m, integrated graphics windows tablet :p)
 

JoeyJungle

Banned
Aug 24, 2011
4,421
0
0
What video card do you have? If you have a Kepler card (I have 780Ti), there is nothing that can be done, I've already tried everything (driver clean, driver rollback, GPU underclock, borderless, FAR tweaks etc.) and I still get GPU crashes.

I find playing Fullscreen with V-Sync on and RTSS locked to 60 produces the most stable results. When I get crashes at problem areas such as the Amusement Park or Old Factory, I have to set the graphics settings to Low, I still can get a crash on Low but it is much rarer. The rest of the time I'm playing with AF: x16, Effects: High, Shadows: High, AA and AO off and get good performance for the majority of the game.

For any other Kepler owners, I recommend checking out this thread on Steam which is 500 posts strong, check the OP for a link to report the issue to Nvidia:
http://steamcommunity.com/app/524220/discussions/0/135511913382921167/

which crashing issues?
Like when the screen freezes but things still happen?
or like the white screen bug?

What graphics card are you using.
Details are important , because if its the later and you have an AMD card, you just have to revert back to an old driver.

(a Part of me wants to see if i can play this on my cheap broadwell core m, integrated graphics windows tablet :p)

I've got a 980ti, one crash was the game freezing during a Loading Area, and had two or three CTD's.
 

Gbraga

Member
Aug 6, 2009
23,691
0
0
I'm finally starting this for good!

Finished Night in the Woods and my 1060 arrived yesterday. As soon as I'm home from work I'll get started.

I'm going with borderless, vsync on and RTSS to lock it to 60 at first, to see if I'm ok with the performance, before lowering GI.

Just reporting that I played until the first boss after the tutorial and I'm very happy with my performance using these settings. The game is gorgeous, and fantastic so far, really strong opening.

I hope they release patch soon to remove mouse cursor when using controller and few more things.

Use Borderless Gaming. It'll remove the cursor even if you're playing in fullscreen.
 

Mifec

Member
Oct 11, 2014
8,188
1
285
Just reporting that I played until the first boss after the tutorial and I'm very happy with my performance using these settings. The game is gorgeous, and fantastic so far, really strong opening.

Replay The Witcher after you're done :3

I still got 2h left on my download of nier, got home from Thailand today.

Glad Kal got a fix out already.
 

Mailbox

Member
May 3, 2014
4,811
0
0
Canada
I've got a 980ti, one crash was the game freezing during a Loading Area, and had two or three CTD's.

weird...
I'm on a 970 and only had to deal with 2 screen freezes.
never any CTD's though :/

Anyone else having this issue, im pretty sure the light shafts didnt look this bad before.

I noticed that in 2 places in the game once using the GI fix. This was at mid settings (32)
I'm gonna see if 64 makes it look okay later
 

Gbraga

Member
Aug 6, 2009
23,691
0
0
Replay The Witcher after you're done :3

I still got 2h left on my download of nier, got home from Thailand today.

Glad Kal got a fix out already.

Sounds like a good idea!

Man, Witcher 3 at 60fps will be awesome. Finally!
 

Limit

Member
Dec 8, 2012
2,275
0
0
Weird issue I'm having. 1080 (laptop version), i7 6820, 32 gigs of ram, windows 10. Installed game on thursday, ran geforce experience for recommended settings there. Everything ran great on fullscreen with expected hitching videos. Ran the game on friday and game started hitching every 4 seconds. It drops down to 4 - 6 fps for 2 seconds then everything is normal for a few seconds, then back to slowdown. Like a clockwork and doesn't matter where in the gameworld I am. Updated drivers. Everything is fine and dandy. I played for a few hours. No issues. Now I started the game again today. The random hitches are back. I haven't touched a single setting. Didn't install any other programs since playing last night. No idea what the cause is.

Any insight?
 

kewlmyc

Member
Dec 15, 2011
21,237
0
540
I think I'm going to have to give up on the game for now. Playing on a gaming laptop while on a business trip.

GeForce GTX 1060 6GB
Intel Core i7 6700HQ
12 GB RAM

Yet, while in the city ruins
after the explosion
, I am getting anywhere between 30-50 FPS when fighting enemies, and even getting ~47 FPS when standing still in the
crater.
It's beyond annoying. Upgrading drivers to see if it helps, but I doubt it. I have also turned AA, AO, and Texture support off and have GI turned to 0.

Hopefully my GTX 980Ti will be better up to the task back at home.
 

electroflame

Member
Jan 4, 2013
1,930
0
0
Looks like some work's been done on the game's built-in framerate limiter:
Kaldaien via Github said:
Added (and enabled by default) an option to turn the game's framerate limiter from sleep-based to busy-wait. This reduces artificial hitches caused by the kernel rather than the game itself, but will increase CPU load on the render thread.

I expect most people running the game have enough CPU cores to make this decision practical, but if not, you can turn the option off in the Control Panel

The update should be live in the test branch, or if you install it manually you can get it from the Github releases tab.

I haven't tried it myself (once I turned off Texture Caching in FAR everything seems to be running pretty smoothly, so I haven't felt like updating it yet). Still, if you're having hitching problems it might be worth a shot.
 
Jun 12, 2014
101
0
0
This game's performance is infuriating to me. I have a 1060, and I'm running at mostly 1080p/60fps, but I just get these completely random hitches pretty constantly. I'll be fighting a ton of guys and it'll be smooth with no drops, but it hitches sometimes for a full second in a fight with just one enemy. It seems completely interminable as to what is making it stutter and drop.
 

didamangi

Member
Dec 19, 2010
2,624
0
490
steamcommunity.com
Looks like some work's been done on the game's built-in framerate limiter:


The update should be live in the test branch, or if you install it manually you can get it from the Github releases tab.

I haven't tried it myself (once I turned off Texture Caching in FAR everything seems to be running pretty smoothly, so I haven't felt like updating it yet). Still, if you're having hitching problems it might be worth a shot.

An eventual full override of the game's framerate limiter (with possible support for framerates > 60) is planned, but for now the focus is on eliminating unnecessary sources of hitching

So > 60 fps + hd texture mod might be possible down the line then.
 

Dsyndrome

Member
Jun 12, 2014
5,096
57
475
USA
About to beat Ending D of the original Nier and get into Automata. Do folks recommend 64 or 32 for the GI setting? Is there much of a difference at all? Running with a GTX 1080 on my gaming laptop.
 

Momentary

Banned
Jan 22, 2011
10,453
74
830
Kaldaien's FAR 0.2.0 has eliminated the studdering. Just did a run across the map and it was as smooth as butter.
 

Gbraga

Member
Aug 6, 2009
23,691
0
0
I only get stutters in City Ruins, and they're most likely just framerate drops. Everything else is perfectly smooth.
 

Robobandit

Member
Aug 11, 2005
5,200
0
0
Kaldaien's FAR 0.2.0 has eliminated the studdering. Just did a run across the map and it was as smooth as butter.

I still get some stutters with it enabled.. was getting some framerate drops in the first proper boss fight, too.. Maybe if I completely disable reshade it'll help. I left the files in the directory and the stock ini loads reshade now..
 

Sinatar

Official GAF Bottom Feeder
Jun 7, 2004
36,859
0
1,745
Edmonton
I still get some stutters with it enabled.. was getting some framerate drops in the first proper boss fight, too.. Maybe if I completely disable reshade it'll help. I left the files in the directory and the stock ini loads reshade now..

Try disabling texture caching in FAR, when I turned that off it completely removed my stuttering.
 

Cetra

Member
Jan 5, 2010
1,497
0
865
I'm pretty sure FAR 2.0 just fixed my Driver Kernel crashes on my 780GTX. I'm now running the game smoother than it's ever run before and haven't gotten a crash since it 2.0 was installed.

I'm sending this guy some money on payday.
 

Robobandit

Member
Aug 11, 2005
5,200
0
0
Try disabling texture caching in FAR, when I turned that off it completely removed my stuttering.

I have it disabled.. I still get the occasional hitch when running in the open world.. maybe not full on stuttering, but definitely some hitches.
 

tuxfool

Banned
Oct 21, 2014
16,148
1
0
I have it disabled.. I still get the occasional hitch when running in the open world.. maybe not full on stuttering, but definitely some hitches.

Not sure there is much to be done there. To me that seems to be a map streaming issue, which would be a core engine feature, not something one could fiddle with using graphics APIs.
 

brau

Member
Sep 29, 2014
8,596
0
0
So have you guys found a way to help with the popin in the game. Its super distracting. I feel like i can be pretty close to a building and its LOD is LOD4 and it ends up looking like a PS1 game.
 

brau

Member
Sep 29, 2014
8,596
0
0
I've learned to just not let it bother me. xD

hahaha.

Im in the desert area, no buildings to LOD there. So its not a big deal atm. Amazing game tho. Combat is quite awesome.

Also. anyone have issues with Borderless Gaming where the game will boot, go as normal, and then on loading the image will hang, but the sounds and responses from the control are normal? disabling BG solved that issue after i booted it up with it to get a true borderless window.
 

Momentary

Banned
Jan 22, 2011
10,453
74
830
I played some ReCore today and it made me think how amazing this game is optimized compared to Nier. It made me really wonder what other things other than Global Illumination could be dragging down the performance of the game.

I feel like Nier should be able to easily break a 100FPS on top end cards at 4K such as the image down below. Recore is more detailed and has way more graphics tech running behind it, yet it is buttery smooth.

I guess that's the trade off... Medicore game, amazing performance from the engine. Awesome game, horribly optimized graphis engine.

Hopefully, if there is a sequel, they'll opt to use UE4 next go around. ReCore uses Unity I believe. So that wouldn't be bad either.
 
Feb 8, 2010
2,927
0
0
0.2.3 is working great for me. I had a sudden crash which hasn't happened in quite a while, but I'm hoping its just a fluke since it's been working fine after that. Fullscreen finally works and stuttering is almost completely eliminated. Great stuff!
 

KainXVIII

Member
Jan 16, 2014
4,902
2
510
I played some ReCore today and it made me think how amazing this game is optimized compared to Nier. It made me really wonder what other things other than Global Illumination could be dragging down the performance of the game.

I feel like Nier should be able to easily break a 100FPS on top end cards at 4K such as the image down below. Recore is more detailed and has way more graphics tech running behind it, yet it is buttery smooth.

I guess that's the trade off... Medicore game, amazing performance from the engine. Awesome game, horribly optimized graphis engine.


Hopefully, if there is a sequel, they'll opt to use UE4 next go around. ReCore uses Unity I believe. So that wouldn't be bad either.

Maybe Platinum can't make their refined combat on other engines (Scalebound says hi), so we will stick with their shitty engine for like forever &#128512;
 

Izuna

Banned
Nov 23, 2010
28,298
6
0
England
I played some ReCore today and it made me think how amazing this game is optimized compared to Nier. It made me really wonder what other things other than Global Illumination could be dragging down the performance of the game.

I feel like Nier should be able to easily break a 100FPS on top end cards at 4K such as the image down below. Recore is more detailed and has way more graphics tech running behind it, yet it is buttery smooth.

I guess that's the trade off... Medicore game, amazing performance from the engine. Awesome game, horribly optimized graphis engine.


Hopefully, if there is a sequel, they'll opt to use UE4 next go around. ReCore uses Unity I believe. So that wouldn't be bad either.

ReCore has broken TSAA and forces you to use FXAA otherwise. Horrible port.
 

Imur

Member
Apr 28, 2016
187
0
0
Edit: nvm. I tried borderless and it seems to run fine. I hope it stays that way.


I finally bought this and now I am a little bit confused.

Which fix should i use for the real resolution? Borderless Gaming or FAR? Does the cutscene fix help? All I want is 1080p 60fps at highest possible details (max?).

My System:

i5 6600K @3,50 Ghz (OC)
EVGA Nvidia GTX 1070 (no sc or oc)
16GB DDR4 2666