• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

Assassin's Creed Unity - PC Performance thread

b0bbyJ03

Member
Apr 10, 2013
2,030
37
630
sup everyone, since i just built my first PC this year there are still some things i haven't really learned to do. what is the best way to lock this game at 30fps? I know I've seen mentions of msi afterburner and Nvidia inspector in this thread. I currently have an EVGA GTX 970 and i downloaded EVGA Precision (can I use this as well?). My 3770k is currently OCed to 4.2 and I got 8 GB of ram.
 

Fedelias

Member
Jul 6, 2013
1,087
1
510
Palo Alto
sup everyone, since i just built my first PC this year there are still some things i haven't really learned to do. what is the best way to lock this game at 30fps? I know I've seen mentions of msi afterburner and Nvidia inspector in this thread. I currently have an EVGA GTX 970 and i downloaded EVGA Precision (can I use this as well?). My 3770k is currently OCed to 4.2 and I got 8 GB of ram.

You can go to NVIDIA control panel and change the vsync to adaptive (half refresh rate) which will cap it at 30.
 

Serandur

Member
May 23, 2013
1,196
0
0
Wow, I just watched a sustained cutscene with only 2 NPCs in a small room render at about 24-27 FPS. As soon as I got control of Arno back again, it nearly doubled. What's going on in cutscenes with this game?
 

HariKari

Member
Jun 28, 2013
7,298
0
0
Has anyone tried it on medium settings to see if you can get an ez 60fps like that?

Fun fact - there is no medium on some of the options, just high/low.

I had it working well last night but now it's a complete unplayable stuttering shit show this morning.

Wow, I just watched a sustained cutscene with only 2 NPCs in a small room render at about 24-27 FPS. As soon as I got control of Arno back again, it nearly doubled. What's going on in cutscenes with this game?

Plus the hair popping and clothing fluttering around randomly is really distracting.
 

Wildschwein

Member
Mar 14, 2014
663
1
0
I just gave the game a shot with my setup.

Asus Strix GTX 970
i5 2500k @ 4.3
8gb 1600mhz ram

It ran pretty decently at max settings so long as I used FXAA. TXAA was still over 30 at all times, but FXAA rarely ever dropped below 45. 50-60 at most times.

I'm just hoping that tessellation doesn't completely destroy those results when that patch hits.

What I did get was a gamebreaking bug within the first fifteen minutes. One of the first cutscenes in France didn't trigger. The game just disabled inputs and had me stand there til I gave up and shut it off.
 

elementalsin

Member
May 30, 2011
812
0
0

Zafir

Member
May 11, 2011
13,529
0
0
United Kingdom
I mentioned in the other thread... Pretty sure it releases the 13th in India.. Which is roughly 24 hours from now. Still got a bit to wait.

See my post in there for why people are unsure.

The order also said 12th, and not the 13th. Not that I can access the order to show, the page has technical difficulties.
 

Kuro

Member
Jun 12, 2013
3,538
6
405
So it is it normal for my GPU and CPU to go above 75c while playing this? Gigabyte G1 970 and 4690k both oc'd.
 

Zafir

Member
May 11, 2011
13,529
0
0
United Kingdom
So it is it normal for my GPU and CPU to go above 75c while playing this? Gigabyte G1 970 and 4690k both oc'd.
CPU shouldn't really go above 70 and that's on the hot side. GPU's are fine up to 80C(That's when they start to not boost), however, the gigabyte g1 970 should be running a lot cooler than that. You sure the airflow in your case is ok?
 

Dario ff

Banned
Sep 11, 2012
984
0
0
Mar Del Plata, Argentina
i5 2500K @ 4.3 GHZ
MSI GTX 760 2 GB with a small OC
8 GB RAM

I settled for the High preset with FXAA @ 1080p, and forced adaptive v-sync at half refresh rate. Constant 30 on the city (in Paris), but drops to 25-ish on cutscenes (only there from what I noticed). This is with latest NVIDIA drivers. I feel like this could be a bit better (PC-port wise) but I dunno what the PS4 settings are to give it an estimate of how it should perform. How demanding the game is on all platforms and what it achieves is another discussion. :p

Dunno if this is with the second patch or not since Uplay sucks at giving me useful info. Not many glitches so far other than your usual Ubisoft share, but not much technical issues either I'd say. I'd appreciate an in-game option to limit the framerate rather than having to force it on the driver tho.

BTW, the architectural design indoors is incredible.
 

Kevyt

Member
Oct 27, 2012
9,581
1
390
I got to the Paris sequence and the performance was atrocious. I was getting 30-40fps on my 270. But when I moved the camera around and run for a good distance, the game would stutter a lot and the frame rate would drop to 15 fps. This is with environment settings set to medium, high settings, FXAA, bloom off, v sync off. Running at 1920 x 1080. I switched to 1600 x 900, everything set to low and only managed to gain 10 fps. There's not a lot of difference between low and high, there should be more options. But yeah even at the lowest settings at 900p, the performance is still terrible. Too much stuttering. I did not have a chance to download the AMD beta drivers, will do this tonight and see if it makes a difference.
 

Aquanox

Junior Member
Aug 24, 2007
275
3
1,060
Lima, Perú
Tried it today on my 7990:

1. The game is badly optimized on any hardware but worse on AMD. Visuals are really nothing to write home about. They're also very unconsistent. Looks pretty decent at times, and bullshit at others. Black Flag looks better to me. I've seen videos of it running on 780ti SLI and still going as low as 30fps in stupid scenes.
2. The game runs like absolute CRAP my 7990, 14.11 Beta.
3. Crossfire (25-45fps) has a lot of stuttering and some graphical issues (known issues of these drivers). Using a Single GPU eliminates the issues but framerates go as low as 15-30fps.

Feels like Watchdogs all over again.

Rig:

Powercolor AMD 7990.
Catalyst 14.11 Beta (Supossedly optimized for AC Unity)
Core i7 3770k @4.5Ghz
Using SSD Corsair M4
16GB DDR3 RAM
Windows 8.1
 

Costia

Member
Mar 8, 2013
1,915
0
0
steamcommunity.com
Most posts i have seen here were about running unity on max settings on high end cards.
I currently have a 560Ti. Anyone tried running unity with an equivalent card? Can i expect 30 fps with medium settings and minimal AA/low shadow quality?
 

SliChillax

Member
Aug 1, 2014
4,009
221
485
Tirana, Albania

hoserx

Member
Feb 27, 2013
4,156
1
500
Cleveland, Ohio
wtf........... auto launch from Uplay? I came home from work and the game had launched after starting......... a stupid setting to be on as default!

edit: even more WTF, the game isn't even downloading after going for 10 hours..... was 3mb/s when I left for work, now downloading at 6 kb/s!!!!!
 

Wildschwein

Member
Mar 14, 2014
663
1
0
wtf........... auto launch from Uplay? I came home from work and the game had launched after starting......... a stupid setting to be on as default!

edit: even more WTF, the game isn't even downloading after going for 10 hours..... was 3mb/s when I left for work, now downloading at 6 kb/s!!!!!

Ran into this too. Apparently the game had been running for about 7 hours since I set it to download before going to sleep.
 

Zefah

Gold Member
Jan 7, 2007
44,605
25,703
1,805
wtf........... auto launch from Uplay? I came home from work and the game had launched after starting......... a stupid setting to be on as default!

edit: even more WTF, the game isn't even downloading after going for 10 hours..... was 3mb/s when I left for work, now downloading at 6 kb/s!!!!!

Going down to 6kb/s seems to be a weird quirk of UPlay. I had that happen once while downloading last night and had to restart the program to get it back to normal DL speeds.
 

-Deimos

Member
Sep 10, 2013
8,451
1
460
steamcommunity.com
I mentioned in the other thread... Pretty sure it releases the 13th in India.. Which is roughly 24 hours from now. Still got a bit to wait.

This is pretty pathetic. The client shows Nov 11, the order page says Nov 12 and the official PAL release date is the 13th. Talk about incompetence. Luckily for me I'm not in any rush to play.
 

burgerdog

Member
Apr 24, 2007
9,697
0
0
CA
This is pretty pathetic. The client shows Nov 11, the order page says Nov 12 and the official PAL release date is the 13th. Talk about incompetence. Luckily for me I'm not in any rush to play.

I'm just going to cancel my order if it's not available by 10AM tomorrow.
 

hoserx

Member
Feb 27, 2013
4,156
1
500
Cleveland, Ohio
Going down to 6kb/s seems to be a weird quirk of UPlay. I had that happen once while downloading last night and had to restart the program to get it back to normal DL speeds.

yeah........ I restarted uplay and then clicked verify install just to be safe........ so of course instead of being 60% through the download, I have just restarted......... lol. This fuckin game, I am so glad it was "Free" with my gtx 970s.
 

Fedelias

Member
Jul 6, 2013
1,087
1
510
Palo Alto
yeah........ I restarted uplay and then clicked verify install just to be safe........ so of course instead of being 60% through the download, I have just restarted......... lol. This fuckin game, I am so glad it was "Free" with my gtx 970s.

The percentage resets to 0 but the amount left to download doesn't change.
 

UnrealEck

Member
Jan 29, 2013
5,767
0
500
Curious about vram usage. Can anyone running @ 1080p with max settings and aa tell me what your gpu vram usage looks like?

It uses whatever you have. Well no one's shown it running on an 8GB card yet but it uses 6GB if you have it.
It doesn't need it though.
 

Reizo Ryuu

Member
Jan 12, 2014
9,171
1,672
765
I'm just going to leave this here as some sort of reference I guess.
i5 4670k 3.8ghz
8gb ram
r9 290 tri-x 4gb
cat 14.4

Everything on high, 2x msaa, ssao on, no vsync, borderless.
30-40 fps on the first segment, seemed playable to me, if the second part drops the fps too low I guess I can just drop the AA setting.

Also all of these settings were autodetected.
 

Zefah

Gold Member
Jan 7, 2007
44,605
25,703
1,805
yeah........ I restarted uplay and then clicked verify install just to be safe........ so of course instead of being 60% through the download, I have just restarted......... lol. This fuckin game, I am so glad it was "Free" with my gtx 970s.

No, actually... check the remaining download size.

The percentage resets to 0 but the amount left to download doesn't change.

Already covered.

I'm actually quite impressed with UPlay's download system and letting you play part of the game while it's still downloading. Seems pretty progressive for a company that, according to folks around here, has nothing but disdain for the PC platform.
 

axb2013

Member
Mar 8, 2014
527
0
0
So the performance is very rough without tessellation already, cant imagine how bad it'll be after.

I'm guessing a ~ 5%-10% hit on Nvidia cards.

The game does look good, my issue with it is that I have seen this image quality before but at 40fps, Unity does it at 15fps for me. I can't tell just how valid the argument "Ryse wasn't an open world game" is. I can see the development time, costs and file sizes going up but I don't see the frame rates coming down, if hypothetically Ryse were to attempt mimicking Unity.

Again, I don't think it's a bad PC port, rather a too demanding game to begin with.





 

Denton

Member
Mar 11, 2014
6,479
1,691
715
I'm actually quite impressed with UPlay's download system and letting you play part of the game while it's still downloading. Seems pretty progressive for a company that, according to folks around here, has nothing but disdain for the PC platform.

UPlay has terrible rep, but they have been updating it pretty heavily over the last year. Frankly I have no problems with it, as long as the servers are up. Don't mind it at all.
 

Genio88

Member
Mar 9, 2014
3,405
0
0
Italy
UPlay has terrible rep, but they have been updating it pretty heavily over the last year. Frankly I have no problems with it, as long as the servers are up. Don't mind it at all.

Everything which is not Steam will be hated on the internet
 
Nov 16, 2011
2,759
2
700
UPlay has terrible rep, but they have been updating it pretty heavily over the last year. Frankly I have no problems with it, as long as the servers are up. Don't mind it at all.

This is me right now...



My connection normally downloads at 1.59 MB/s consistently.
 

Zefah

Gold Member
Jan 7, 2007
44,605
25,703
1,805
This is me right now...



My connection normally downloads at 1.59 MB/s consistently.

Pause the download and restart UPlay and you'll probably fix the issue.

Don't freak out when the download bar says 0% when you restart. It just means 0% of the remaining download size. You won't lose your progress.