• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

Downsampling for AMD cards is now possible

psn

Member
Jun 23, 2013
1,482
55
575
Germany
Okay, booted in safe mode, DDU cleaning, reboot, driver install, reboot.

Now these settings are correct?
Opened list.bat the first time to set the display index:


This is the CR.txt:

AdapterIndex 0
DisplayIndex 5
TimingStandard 1
PossibleStandard 14
RefreshRate 144
Width 1920
Height 1081
TimingFlags 0
HTotal 0
HDisplay 0
HSyncStart 0
HSyncWidth 0
VTotal 0
VDisplay 0
VSyncStart 0
VSyncWidth 0
PixelClock 0
HOverscanRight 0
HOverscanLeft 0
VOverscanBottom 0
VOverscanTop 0

You wrote:
2. Open CR.txt and change the TimingOverride values and RefreshRate to 144. Make sure the resolution is 1920 by 1081.

Where is the TimingOverride value? Or am I confused here?
 

Irobot82

Member
Apr 21, 2012
4,230
1,675
840
South Florida
Okay, booted in safe mode, DDU cleaning, reboot, driver install, reboot.

Now these settings are correct?
AdapterIndex 0
DisplayIndex 5
TimingStandard 1
PossibleStandard 14
RefreshRate 144
Width 1920
Height 1081
TimingFlags 0
HTotal 0
HDisplay 0
HSyncStart 0
HSyncWidth 0
VTotal 0
VDisplay 0
VSyncStart 0
VSyncWidth 0
PixelClock 0
HOverscanRight 0
HOverscanLeft 0
VOverscanBottom 0
VOverscanTop 0

You wrote:
2. Open CR.txt and change the TimingOverride values and RefreshRate to 144. Make sure the resolution is 1920 by 1081.

Where is the TimingOverride value? Or am I confused here?

Sorry,
AdapterIndex 0
DisplayIndex 5

are your TimingOverride values that is generated when you ran LIST.bat


EDIT: LOOKS GOOD BEGIN PHASE 2.....FIRE!!!!!
 

psn

Member
Jun 23, 2013
1,482
55
575
Germany


This window says "hello" again :/

Edit:

found someone who said that I am not allowed to change the refresh rate here, later in the registry it should be possible. So I try again with 60.
 

Irobot82

Member
Apr 21, 2012
4,230
1,675
840
South Florida


This window says "hello" again :/

Then I think we must come to the conclusion that 144hz is not supported.

We can try one more thing. In your CR.txt change the Refresh bat to 60. Run the .bat again. Perhaps we can just simply mod it inside the regedit.
 

psn

Member
Jun 23, 2013
1,482
55
575
Germany
Then I think we must come to the conclusion that 144hz is not supported.

We can try one more thing. In your CR.txt change the Refresh bat to 60. Run the .bat again. Perhaps we can just simply mod it inside the regedit.

60 is working, I opened the registry and located the modetimingoverride and changed it to the correct values:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000\DAL2_DATA__2_0\Common\EDID_D109_7F1E]
"default"=hex:64
"All_nodes"=hex:4d,6f,64,65,54,69,6d,69,6e,67,4f,76,65,72,72,69,64,65,73,5f,44,\
56,49,5f,43,6f,6e,6e,31,32,35,34,38,00
"ModeTimingOverrides_DVI_Conn12548"=hex:00,00,00,00,00,0A,00,00,A0,05,00,00,90,\
00,00,00,03,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,10,0a,00,00,00,00,\
00,00,80,07,00,00,00,00,00,00,80,00,00,00,c8,00,00,00,61,04,00,00,00,00,00,\
00,39,04,00,00,00,00,00,00,03,00,00,00,0a,00,00,00,c2,a4,02,00,00,00,00,00,\
00,00,00,00,03,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,\
00,00,00

90 = 144 Hz

rebooting now.


EDIT:

Oh my god, it worked!
Thank you soooo much!

 

Irobot82

Member
Apr 21, 2012
4,230
1,675
840
South Florida
"ModeTimingOverrides_DVI_Conn12548"=hex:00,00,00,00,00,0A,00,00,A0,05,00,00,90,\
00,00,00,03,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,10,0a,00,00,00,00, \
00,00,80,07,00,00,00,00,00,00,80,00,00,00,c8,00,00,00,61,04,00,00,00,00,00, \
00,39,04,00,00,00,00,00,00,03,00,00,00,0a,00,00,00,c2,a4,02,00,00,00,00,00, \
00,00,00,00,03,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80, \
00,00,00

you haven't updated all of them

HTotal
10 0A to 20 08

HSyncStart
80 00 to 30 00

HSyncWidth
C8 to 20

VTotal
61 04 to 57 04

VDisplay
39 04 to 38 04

VSyncWidth
0A to 05

PixelClock
C2 A4 02 to E0 22 02

you need to do these too.
 

Syrus

Banned
Jan 26, 2014
3,683
0
0
Can I do this with a 7970? Or should I force supersampling?

How do I force steam games? Find the games app launcher?
 

psn

Member
Jun 23, 2013
1,482
55
575
Germany
"ModeTimingOverrides_DVI_Conn12548"=hex:00,00,00,00,00,0A,00,00,A0,05,00,00,90,\
00,00,00,03,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,10,0a,00,00,00,00, \
00,00,80,07,00,00,00,00,00,00,80,00,00,00,c8,00,00,00,61,04,00,00,00,00,00, \
00,39,04,00,00,00,00,00,00,03,00,00,00,0a,00,00,00,c2,a4,02,00,00,00,00,00, \
00,00,00,00,03,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80, \
00,00,00

you haven't updated all of them

HTotal
10 0A to 20 08

HSyncStart
80 00 to 30 00

HSyncWidth
C8 to 20

VTotal
61 04 to 57 04

VDisplay
39 04 to 38 04

VSyncWidth
0A to 05

PixelClock
C2 A4 02 to E0 22 02

you need to do these too.

It works like with the settings I posted. 2560x1440 with 144Hz
Thank you thank you thank you for your help :)
 

psn

Member
Jun 23, 2013
1,482
55
575
Germany
Can I do this with a 7970? Or should I force supersampling?

How do I force steam games? Find the games app launcher?

Depends on the games you play. I did this before with my 7950, so it should be no problem with a 7970.
 

Irobot82

Member
Apr 21, 2012
4,230
1,675
840
South Florida
It works like with the settings I posted. 2560x1440 with 144Hz
Thank you thank you thank you for your help :)

HELL YEAH MAN! I knew we could get this done. Enjoy that downsampling!

Can I do this with a 7970? Or should I force supersampling?

How do I force steam games? Find the games app launcher?

If you use the tool, whatever resolution you create will show up in the Resolution list for every game.
 

Syrus

Banned
Jan 26, 2014
3,683
0
0
I went to 12.11 and get an error. I cant do anything with the downsample program now.

I have all the boxes unchecked too
 

jett

D-Member
Jun 6, 2004
98,866
13
1,765
I'm disappointed there isn't an easy way to do this crap with an AMD card. Should've gone with Nvidia this time. :| I'm not about to mess around with registry keys and shit.
 

subwilde

Member
Apr 11, 2013
631
0
0
How many times have we seen a twitter comment with an ominous tone dressed over the whole thing about getting official support? :(

Told my buddy a couple months ago to get a 280x. Don't think I'm gonna make that recommendation now and will be buying an Nvidia card when it's time to upgrade my 7970 3 gb.
 

Adry9

Member
Jun 2, 2013
1,848
117
665
Not working on my 7950 Boost with 14.6 drivers, get an error message everytime I click "Ok" when changing the resolution :(
 

Lime

Member
Apr 27, 2008
26,894
1
0
Yeah if I hadn't gotten an OC 290 Windforce for $250, I would have definitely jumped over to Nvidia from my 6950.
 

LeeRoyBrown

Banned
Apr 15, 2013
1,672
0
390
Reckon anyone could do a review of this thread for me, the second step to a link doesnt work and I really want to down sample Aliens.

Can anyone help me with it?

Seems pretty complicated.

R9 290.
 

Milincho

Banned
Jun 1, 2013
24
0
0
Spain
The published settings here and in other forums didn't work for me (maybe using Hdmi via an AVR have something to do with that), but blindly changing values just out of pure frustration I managed to get 2720x1530@60 on my 290X using these settings:



Now I would like to add more options like:

2720x1530@50

2560x1440@60

...


How can I do that?
 

Milincho

Banned
Jun 1, 2013
24
0
0
Spain
I managed to get both 2560@60 and 2720@60 using:

hex:00,00,00,00,00,0a,00,00,a0,05,00,00,3c,\
00,00,00,03,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,86,08,00,00,00,00,\
00,00,80,07,00,00,00,00,00,00,98,00,00,00,30,00,00,00,57,04,00,00,00,00,00,\
00,38,04,00,00,00,00,00,00,03,00,00,00,05,00,00,00,00,38,02,00,00,00,00,00,\
00,00,00,00,03,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,\
00,00,00,a0,0a,00,00,fa,05,00,00,3c,00,00,00,03,00,00,00,02,00,00,00,00,00,\
00,00,00,00,00,00,86,08,00,00,00,00,00,00,80,07,00,00,00,00,00,00,98,00,00,\
00,30,00,00,00,57,04,00,00,00,00,00,00,38,04,00,00,00,00,00,00,03,00,00,00,\
05,00,00,00,00,38,02,00,00,00,00,00,00,00,00,00,03,00,00,00,00,00,00,00,02,\
00,00,00,01,00,00,00,00,00,00,00,80,00,00,00,


Then I tried to add same resolutions @50 just changing the hex 3c (60) to 32 (50) and although it seems to work (the 50Hz option appears on windows) my display reports a 60Hz signal so in the end it doesn't work.

Which settings could be altered to make the output signal @50, the same way it works in the standard 1080p@50? any ideas?
 

Coolbgdog12

Member
Oct 10, 2011
4,676
0
0
I can't get this to work anymore. I'm on 14.9. This used to work a while ago.

Edit:I started over fresh and simply uninstalled my drivers and reinstalled.

I searched the registry and found many keys.

This is one of them
Code:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000\DAL2_DATA__2_0\Common\EDID_6252_206]
"default"=hex:64
"All_nodes"=hex:4d,6f,64,65,54,69,6d,69,6e,67,4f,76,65,72,72,69,64,65,73,5f,44,\
  56,49,5f,43,6f,6e,6e,31,32,35,35,36,00
"ModeTimingOverrides_DVI_Conn12556"=hex:00,00,00,00,80,07,00,00,39,04,00,00,39,\
  00,00,00,03,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,00,0a,00,00,00,00,\
  00,00,80,07,00,00,00,00,00,00,78,00,00,00,c8,00,00,00,60,04,00,00,00,00,00,\
  00,39,04,00,00,00,00,00,00,03,00,00,00,0a,00,00,00,b2,7d,02,00,00,00,00,00,\
  00,00,00,00,03,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,\
  00,00,00
I'm stumped right here. I don't want to simply copy and paste someone elses settings.
 

Lime

Member
Apr 27, 2008
26,894
1
0
Yeah, all the registry edits just makes me throw up my hands.

I wish the original DSR tool worked. Why would AMD patch it out when they don't even have anything to supersede it?
 

Coolbgdog12

Member
Oct 10, 2011
4,676
0
0
Okay I got it working.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000\DAL2_DATA__2_0\Common\EDID_6252_206]
"default"=hex:64
"All_nodes"=hex:4d,6f,64,65,54,69,6d,69,6e,67,4f,76,65,72,72,69,64,65,73,5f,44,\
56,49,5f,43,6f,6e,6e,31,32,35,35,36,00
"ModeTimingOverrides_DVI_Conn12556"=hex:00,00,00,00,00,0a,00,00,a0,05,00,00,3c,\
00,00,00,03,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,20,08,00,00,00,00,\
00,00,80,07,00,00,00,00,00,00,30,00,00,00,20,00,00,00,57,04,00,00,00,00,00,\
00,38,04,00,00,00,00,00,00,03,00,00,00,05,00,00,00,e0,22,02,00,00,00,00,00,\
00,00,00,00,03,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,00,00,00,00,80,\
00,00,00
This is the edited values that I imported back into the registry.
 

Pro

Member
Feb 7, 2012
2,473
0
0
I've been running 2560x1600 on my 7970 for quite some time now. But nobody has ever been able to give me the registry settings for 4K 3840x2400 ratio.

EDIT: And it looks like guru3D has been updated since the last time I checked. Values for 1920x1200 monitors.

Source

hex:00,00,00,00,00,0a,00,00,40,06,00,00,3c,\
00,00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,20,08,00,00,00,00,\
00,00,80,07,00,00,00,00,00,00,30,00,00,00,20,00,00,00,d3,04,00,00,00,00,00,\
00,b0,04,00,00,00,00,00,00,03,00,00,00,06,00,00,00,12,5a,02,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,40,00,00,00,a0,\
0a,00,00,a4,06,00,00,3c,00,00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,\
00,00,20,08,00,00,00,00,00,00,80,07,00,00,00,00,00,00,30,00,00,00,20,00,00,\
00,d3,04,00,00,00,00,00,00,b0,04,00,00,00,00,00,00,03,00,00,00,06,00,00,00,\
12,5a,02,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,\
00,00,00,40,00,00,00,40,0b,00,00,08,07,00,00,3c,00,00,00,0f,00,00,00,02,00,\
00,00,00,00,00,00,00,00,00,00,20,08,00,00,00,00,00,00,80,07,00,00,00,00,00,\
00,30,00,00,00,20,00,00,00,d3,04,00,00,00,00,00,00,b0,04,00,00,00,00,00,00,\
03,00,00,00,06,00,00,00,12,5a,02,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,02,00,00,00,01,00,00,00,40,00,00,00,00,0f,00,00,60,09,00,00,3c,00,\
00,00,0f,00,00,00,02,00,00,00,00,00,00,00,00,00,00,00,20,08,00,00,00,00,00,\
00,80,07,00,00,00,00,00,00,30,00,00,00,20,00,00,00,d3,04,00,00,00,00,00,00,\
b0,04,00,00,00,00,00,00,03,00,00,00,06,00,00,00,12,5a,02,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,02,00,00,00,01,00,00,00,40,00,00,00
 

jett

D-Member
Jun 6, 2004
98,866
13
1,765
Why can't AMD offer official support for this? It's really the one thing that would have my next video card purchase be Nvidia.
 

Pro

Member
Feb 7, 2012
2,473
0
0
Anyone have experience downsampling on a Sony Bravia 1080p TV? I configured 1440p last night and the TV couldn't do it. What's the issue?
 

RazorbackDB

Member
Jun 29, 2012
1,661
0
0
Valdivia, Chile
This is quite... interesting. I guess AMD was software locking?

The reg keys were taken from a modified W10 driver which seems a lot more updated than the current drivers on their page, maybe the changes needed were also introduced in 15.3 and they are waiting for more testing or whatever to officially release it, I don't know if someone has tried the reg keys with 14.12 but I doubt it works.
 

Pro

Member
Feb 7, 2012
2,473
0
0
OK can someone help? I'm no stranger to this but recently I connected a Sony Bravia 1080p TV as a second monitor via HDMI. This wiped my Downsampling resolutions so I had to start over. Except now I can only configure DS resolutions on the Sony Bravia. Whenever I try to configure them on my main monitor (24" BenQ 1920x1200 connected via DVI) I get the ADL_display_modetimingoverride_set failed() ERROR. Why can't I DS on my BenQ monitor any more? Even if I completely remove the Sony Bravia I still get the ERROR.
 

RazorbackDB

Member
Jun 29, 2012
1,661
0
0
Valdivia, Chile
ddu -> 15.3 -> tahiti cmd. unless the max res is 2560x1440, nothing new popping up in games

That's weird, maybe GCN 1 is límites to 1440p? I have no idea. Anyway these reg keys are specific to GPU/connection/display so maybe you are having bad luck, just wait for official support.

Yeah I think that's the max fora DVI-D cable. Which makes me think this is software based.

I'm using a DVI to VGA adapter, I doubt that's the problem
 

Irobot82

Member
Apr 21, 2012
4,230
1,675
840
South Florida
That's weird, maybe GCN 1 is límites to 1440p? I have no idea. Anyway these reg keys are specific to GPU/connection/display so maybe you are having bad luck, just wait for official support.



I'm using a DVI to VGA adapter, I doubt that's the problem

I think it is the problem. If it's software based like the old regedit hacks, 1440p will be a hard limit on DVI.
 

Pro

Member
Feb 7, 2012
2,473
0
0
Question on VSR for the HD 7xxx series. How does it choose which max resolution you can use?

I got it working on my 7970 15.3 beta driver and it chose 2560x1600 for me (using DVI) whereas previously (albeit with an HDMI cable) I was able to achieve 2720x1700. It must be the delta between DVI and HDMI.
 

ChoklitReign

Member
Aug 15, 2008
5,807
3
0
Bumping because I need something that I lost. I found a way to use VSR with a 280x that involved Display Driver Uninstaller and a batch file or something and now I can play in 1440p on a 1080p Hanns-G monitor. The problem is I didn't bookmark or save the website that showed how to do it and now I want to install the 15.4 beta drivers to play GTAV in the future. It would probably wipe out the settings I used to have VSR (AMD can fuck right off having it for only like 4 cards and I want in on the action) and I would love to know the website. Don't recommend GeDoSaTo, I can't get it to work.
 

RazorbackDB

Member
Jun 29, 2012
1,661
0
0
Valdivia, Chile
http://forums.guru3d.com/showthread.php?t=397924

People got VSR working on all GCN cards with a registry hack and 15.3/W10 drivers, works on my 260x up to 3200x1800.

Bumping because I need something that I lost. I found a way to use VSR with a 280x that involved Display Driver Uninstaller and a batch file or something and now I can play in 1440p on a 1080p Hanns-G monitor. The problem is I didn't bookmark or save the website that showed how to do it and now I want to install the 15.4 beta drivers to play GTAV in the future. It would probably wipe out the settings I used to have VSR (AMD can fuck right off having it for only like 4 cards and I want in on the action) and I would love to know the website. Don't recommend GeDoSaTo, I can't get it to work.

Right there on the middle of the page.