• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • Hey Guest. Check out the NeoGAF 2.2 Update Thread for details on our new Giphy integration and other new features.

Far Cry 4 PC performance thread

Dec 3, 2014
672
0
0
Just wanted to post my performance here and have a question or two if they can be answered: First what is with the lack of aniso on roads again even when forced in CP or NI? Not a huge bother but still wildly distracting and the only really terrible thing in game.

I'm on OC'd 970 and 4.5 i5 and this game is now running almost 60FPS solid except for the usual harder stuff.... with normal FOV, no motion blur, and no Nvidia soft shadows. Everything else full setting including a few profile tweaks.

Obviously, I did the GPU buffered frames to 1 and it seemed to work along with reducing my wide FOV. I'm amazed the game runs so well actually. Crazy they cannot get their own game to function properly without profile tweaks though. Anyway, was wondering if anyone had a fix for the roads at all.
 

SliChillax

Member
Aug 1, 2014
3,999
188
485
Tirana, Albania
Are you guys having any issues with Windows 10 or Nvidias latest drivers? I've put 12 hours into the game so far and I've encountered occasional crashes here and there, nothing major. Now the game keeps crashing at the same spot over and over again, really irritating. I'm coming from a clean W10 install so I don't know what might be causing it.
 

Dries

Member
Dec 8, 2009
2,841
313
990
Netherlands
Ugh, I can't get Anisotropic filtering working for me at all. I turned it on via Nvidia Control Panel, but it just won't work. Whyyyyyy?
 

jrush64

Banned
May 23, 2012
4,102
2
530
So can anyone please help? I've been trying to run this game for close to 2 weeks now and it just closes the moment I open the game. The game just doesn't start at all. This has been happening non stop. This is the Uplay version.

I have a GTX 970
Intel Core i5-4690K
16GB Ram