• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

Just Cause 3 PC performance thread

Peterthumpa

Member
May 31, 2009
5,172
73
1,270
Jesus, I'm usually ok with post processing AA methods, but the SMAA implementation in this game is abysmal when things start moving, it looks like a sort of continuous dream sequence. Absolutely awful.
 

Kezen

Banned
Jul 28, 2014
8,919
0
375
France
Jesus, I'm usually ok with post processing AA methods, but the SMAA implementation in this game is abysmal when things start moving, it looks like a continuous sort of dream sequence. Absolutely awful.

SMAA 2TX produces visible artefacts but from what I've seen SMAA is fine, likewise for FXAA but both look pretty bad.
 

Cannon Goose

Member
Nov 28, 2011
4,093
0
660
Australia
I don't think that GI is worth the performance hit, things are definitely smoother with it off and the game still looks nice. It's a pity that explosions still hit the frame rate so hard even with some of the heavier settings turned down.
 

interfreak

Member
Feb 1, 2014
366
4
465
Jesus, I'm usually ok with post processing AA methods, but the SMAA implementation in this game is abysmal when things start moving, it looks like a sort of continuous dream sequence. Absolutely awful.

Bit of an explanation as to why here (translated):

Just cause 3 offers three anti-aliasing method for image smoothing: FXAA, SMAA and SMAA 2TX. The first two is pure post filter, that is, are the pictures ready calculated from the graphics card before dispensing soft drawn. In this way creates a smoothing effect at minimal performance cost, however this process can do anything against temporal aliasing such as flicker. SMAA 2TX is responsible for the latter: in addition to the anti-aliasing works here a temporal component. successive images are offset to smooth movements and aliasing related. This works well and the smoothing is inherently better than at SMAA and FXAA, however the algorithm causes partly ansfransende edges, for example, on Rico's parachute cables. Also is clear to see that individual frames are mixed together with low frame rates in the 30s range, the result is a ghost of kind of and also slight twitch. SMAA 2TX was in the trial version of Just Cause 3 incorrectly, but just in time for the release fixed reports according to which, the mode does not work, - use an old version of the game.

If SMAA 2TX is too restless to you or you play with low frame rates in the 30s, you have the choice between SMAA and FXAA as an alternative. The former is our recommendation as it achieved a mild and almost free image smoothing without destroying text detail. FXAA although ensures a generally softer image, does not differentiate in contrast to SMAA but between smoothing values of objects and textures, which is why the latter lose much of its splendour.


http://www.pcgameshardware.de/Just-Cause-3-Spiel-9784/Specials/Test-Benchmarks-1179397/

No AA:
http://www.pcgameshardware.de/screenshots/original/2015/11/Just_Cause_3_1x_AA_cr-pcgh.png

SMAA:
http://www.pcgameshardware.de/screenshots/original/2015/11/Just_Cause_3_SMAA_cr-pcgh.png

FXAA:
http://www.pcgameshardware.de/screenshots/original/2015/11/Just_Cause_3_FXAA_cr-pcgh.png
 

Ramenman

Member
Apr 4, 2007
7,136
0
0
Stuttering abound.
Begins at a nice 70fps, then stutters as you move through the world even on foot, causing audio glitches too.
Everything max.

Tried turning down Shadows, Antiostropic Filtering and Bokeh Depth of Field and no postive change to report.

Pretty much what I'm experiencing (except the starting framerate isn't 70, but I don't expect it to be on my rig :p)

But basically : framerate is ok, just some very clear stutters when moving through the world, or sometimes entering vehicles, or engaging enemies (which counts as moving through the world I'd say). It's not framerate dips, it's really stutters, the game hangs, and the audio loops.

And lowering options can have some sort of impact on the "base framerate" sure, but it does nothing for those terrible stutters that really ruin everything :/

For what it's worth, I'm trying to run it on my X51 with :

GTX 760
i7-4790 @ 3.60GHz
8G RAM
Drivers 359.06
Windows 8.1

Also, I'm playing on a small 1440x900 screen, so I usually have zero trouble running anything at that res with this computer, incl Mad Max, Witcher, etc.


Edit : also tried Offline Mode (steam offline) but didn't stop the stutter in any way.
 

Sinatar

Official GAF Bottom Feeder
Jun 7, 2004
36,859
0
1,745
Edmonton
If you're stuttering trying running it in offline mode, many people are reporting stutters when it tries to access the stupid leaderboards.
 

PHOENIXZERO

Member
Jan 7, 2007
14,183
0
1,150
We can say now it is a game issue for sure. Even Totalbiscuit experienced it.
https://www.youtube.com/watch?v=ghclK4Gd-sw
19.16 minutes you can see the flickering with GI on.
Yep I've had to keep GI off because of the flickering and I notice very little visual improvements with it on anyways, plus it keeps the framerate up a bit higher.

Yeah I plan on turning it off next time I play. Also forgot to disable the in game AF since it's broken anyway.
 

Chris R

Member
Jul 31, 2007
43,506
0
1,210
Anchorage Alaska
So apparently turning Screen Space Reflections on will solve the GPU hanging issue I was having last night.

Good to know. At least I've made it past the first mission so if I do crash/hang I won't be forced to do the intro again and again like last night.
 

FiraB

Banned
Jul 26, 2013
1,735
0
0
New Zealand
Specs:
4690k @ 4.2ghz
7970 3GB @ Slight Overclock
16GB DDR3 2333mhz

Settings and Notes:
Resolution: 1080p x Vsync
Textures: High
I noticed very little difference between high and very high unless you are super close to objects and looking at it very closely.

Shadows Medium
My personally preference, don't like super detailed shadows.

Water High
Again not much difference between high and very high, probably more noticeable on a nvidia card though because they worked with the company like last time on the water effects

Water Tess On
Very little cost for a good effect, about 3fps it cost me

Bokeh Off
Edge Fade On
Global Lum On
SSAO On
If you want performance, turn it off, it eats your fps by about 7-10fps depending on the situation

Motion Blur Off (makes me dizzy, always have this off)

LOD Factor Low
It didn't make that much of a difference for me to care, stand on the highest point you can find and look at a enemy base or village from a far will give you a idea if you want it on or not.

SSR off
I wanted this on but had to sacrifice it because it annihilates fps during explosions by 10fps and during normal gameplay by about 7fps, it also caused flicker on the textures which was even worse.

Thoughts:
Overall it runs pretty damn well, I was a bit afraid after reports but I'm sitting at 45fps most the time with dips down to 27fps when shit goes really crazy. I think drivers are a big issue with this right now and maybe a bit more optimization on avan's part otherwise its pretty damn good.
 

Ryu bogard

Member
Dec 18, 2008
871
0
0
Singapore
It was running poorly on my system. I tried turning all settings to medium and turned off global illumination, reflection and some other stuff but as soon any action happened on screen the framerate starts dropping from 60 to 30. I ended up getting a refund. I think it might be time to upgrade my pc.

I5 3570
Amd 7950
8gb ram
 

ffejeromdiks

Banned
Mar 26, 2014
2,905
2
445
It was running poorly on my system. I tried turning all settings to medium and turned off global illumination, reflection and some other stuff but as soon any action happened on screen the framerate starts dropping from 60 to 30. I ended up getting a refund. I think it might be time to upgrade my pc.

I5 3570
Amd 7950
8gb ram
Turn off vsync
 
Nov 16, 2011
2,763
6
720
Does anyone else get massive lag/slowdowns when viewing the "you've unlocked" and "x more gears" to unlock screens? I'm talking going down to 1-2 FPS
 
Oct 9, 2005
7,823
1
0
2500k@4Ghz, 8GB, 970. Installed on SSD.

The freezing/stuttering is superbad. The mission where you're protecting Mario's truck was completely fucked up. Couldn't tether the car that was driving right next to me. Game seemed to run alright in the beginning. Memory leak? I don't know how things work.

I'll install 359.06 tomorrow and hopefully that''ll do a thing. For now, this is the wost performing and buggiest game in a while. I think the stuttering might have gotten less bad when I turned everything off and down to low, but things were still herky jerking.
 

Woo-Fu

Banned
Jan 2, 2007
18,685
9,824
1,695
Does anyone else get massive lag/slowdowns when viewing the "you've unlocked" and "x more gears" to unlock screens? I'm talking going down to 1-2 FPS

I get a shitload of disk activity during this part even though I've verified the game and my save directory are on SSD. Something is fishy.
 

~Kinggi~

Banned
Oct 22, 2006
23,454
1
0
Can someone tell me what was the deal with all the folk with 770s getting total shit performance? Still a thing and has anyone recognized this?
 

Peachpies

Member
Sep 3, 2011
643
0
0
Can someone tell me what was the deal with all the folk with 770s getting total shit performance? Still a thing and has anyone recognized this?
I have a 4gb 770 and am running everything on the highest except shadows and AA without any problems
 
Oct 9, 2005
7,823
1
0
I wish I could get a refund, but silly me bought it from GMG.
This is pretty bad.
They have a bad refund policy, but their support might still come through. Doesn't hurt to try. Which is what I'll be doing if this situation doesn't fix itself within this week or so.

For now, I'll leave a negative review on Steam, with the hope that Square Enix will pull a Warner Bros. Or you know, ideally hurry up and fix their shit.
 

LCGeek

formerly sane
It was running poorly on my system. I tried turning all settings to medium and turned off global illumination, reflection and some other stuff but as soon any action happened on screen the framerate starts dropping from 60 to 30. I ended up getting a refund. I think it might be time to upgrade my pc.

I5 3570
Amd 7950
8gb ram

Is your 3570 oced, this makes a huge diference?

The 7950 is little old at this point unless you like playing newer games on high or medium. I have one left that works but have replaced 3 of the 4 I have. Even oc'ed the 7950 doesn't have the grunt like 290/X or 970 and higher would.

Cards sales are awesome right now 970s were as low as 200 this past week. They are hovering in between 230-290 at other places when they are on sale.
 

Blizzard

Banned
Jan 23, 2008
36,025
0
0
Yeah, between the non-functioning AF (how can you mess this up in 2015?), the non support of SLI/CF and this:



Which is appearing each time I open the menu at the moment even if I'm in the "offline mode" this game will need a patch or two before it will be in a playable state on PC.
Even in offline mode? This almost pushed me over the edge to refund before the install even finished. :( I guess I'll at least try to play an hour, and then leave a review (pointing out the third-party DRM the store page doesn't mention, plus the social connection issues, plus the performance) and refund it.
 

pulsemyne

Member
Sep 6, 2004
3,864
0
0
Thankfully I'm having no such problems. Not even one crash. I'm on windows 10 so maybe that helps along with the latest Nvidia driver.

System spec is an i5-3350p, 8gigs, standard 970GTX and the game is installed on an SSD. Everything is on full except shadows to high and using FXAA. I am going to turn the bloody motion blur off.
Also the res is 3440x1440 and it seems to stick around 30fps except during crazy explosions.
 

SlaughterX

Banned
Jan 12, 2007
6,735
259
1,415
Alsip, IL
SlaughterX.1up.com
Ahh, my rig doesn't even meet the min requirements... still rocking that GTX 660! Luckily I don't really want this game but boy am I ready to upgrade, still regret not getting the GTX 970 when it came with 2 free games. :( I am gonna be strong and wait until the next gen GPUs come out though, it's gotta be soon.....






























I hope :(
 

CaLe

Member
Jan 23, 2009
2,232
0
0
So I'm assuming I shouldn't be purchasing this right now... I have a GTX 970, so I don't have much hope if I base myself off the impression of some users here.
 

Rizzi

Member
Jan 23, 2009
8,922
1
900
Newcastle Australia
They have a bad refund policy, but their support might still come through. Doesn't hurt to try. Which is what I'll be doing if this situation doesn't fix itself within this week or so.

For now, I'll leave a negative review on Steam, with the hope that Square Enix will pull a Warner Bros. Or you know, ideally hurry up and fix their shit.

I sent them a support request. Worth a try I guess.
 
Feb 27, 2014
8,414
0
0
Ahh, my rig doesn't even meet the min requirements... still rocking that GTX 660! Luckily I don't really want this game but boy am I ready to upgrade, still regret not getting the GTX 970 when it came with 2 free games. :( I am gonna be strong and wait until the next gen GPUs come out though, it's gotta be soon.....

I hope :(

That isn't looking like the case unfortunately and it's now looking likely that the HBM2 may only be in the x80 and x80 ti versions. Personally I got sick of waiting and made the jump to a 970 from a 580 ti and it feels like at least double the performance. I haven't properly crunched out numbers but I'd hazard a guess somewhere around 220% and that's only testing on a few poorly optimized games. On the ones that run better which I have downloaded right now I was hitting my display rate limit of 60hz whilst maxing out everything so it was hard to get a feel for what boost other than a nice one. Got more taxing stuff downloading now that my old card couldn't do well enough to bother playing so that should help get a feel for it.

Plus I dunno about you, but I was getting real sick of not having driver support anymore. Felt like my old card aged more in those few months than it did between then and when I got it in may 12 I think. I'm not one to typically have a lot of budget available for my PC but for what I paid I'm super happy even if I only keep it for a year or 2 and I usually hold onto parts for 4 years or so.
 

possiblyphil

Member
Aug 17, 2011
274
0
0
This game is running horribly on my i5 4670k/770gtx/8gigs of ram... hoping moving it to another hard drive will help like it did for fallout 4 but right now its literally unplayable.
 

Qwell

Member
Dec 5, 2008
1,726
110
1,055
Little update now that I have played a bit longer.

2700k
16gb ram
7950 boost

I was putting a little oc on the card but had 2 hard full pc locks that required full reboots. Turned off the oc and things have actually run pretty decent now. Have a lot of the advances stuff off like ssao gi, aa etc but I am running textures and stuff at high at 1080p

Usual running around is holding close to 60fps,parachute and wingsuit it drops to around 45 or so and fighting gets into the 30.not the best at all but playable for me. Stuttering stopped and so for about 3 hours without another lock
 

Samus4145

Member
May 21, 2010
3,115
0
0
NY
www.selectbutton.com
Bit of an explanation as to why here (translated):

Just cause 3 offers three anti-aliasing method for image smoothing: FXAA, SMAA and SMAA 2TX. The first two is pure post filter, that is, are the pictures ready calculated from the graphics card before dispensing soft drawn. In this way creates a smoothing effect at minimal performance cost, however this process can do anything against temporal aliasing such as flicker. SMAA 2TX is responsible for the latter: in addition to the anti-aliasing works here a temporal component. successive images are offset to smooth movements and aliasing related. This works well and the smoothing is inherently better than at SMAA and FXAA, however the algorithm causes partly ansfransende edges, for example, on Rico's parachute cables. Also is clear to see that individual frames are mixed together with low frame rates in the 30s range, the result is a ghost of kind of and also slight twitch. SMAA 2TX was in the trial version of Just Cause 3 incorrectly, but just in time for the release fixed reports according to which, the mode does not work, - use an old version of the game.

If SMAA 2TX is too restless to you or you play with low frame rates in the 30s, you have the choice between SMAA and FXAA as an alternative. The former is our recommendation as it achieved a mild and almost free image smoothing without destroying text detail. FXAA although ensures a generally softer image, does not differentiate in contrast to SMAA but between smoothing values of objects and textures, which is why the latter lose much of its splendour.


http://www.pcgameshardware.de/Just-Cause-3-Spiel-9784/Specials/Test-Benchmarks-1179397/

No AA:
http://www.pcgameshardware.de/screenshots/original/2015/11/Just_Cause_3_1x_AA_cr-pcgh.png

SMAA:
http://www.pcgameshardware.de/screenshots/original/2015/11/Just_Cause_3_SMAA_cr-pcgh.png

FXAA:
http://www.pcgameshardware.de/screenshots/original/2015/11/Just_Cause_3_FXAA_cr-pcgh.png

So 2TX is what causes the ghosting in cutscenes?
 

TheSpoiler

Member
May 2, 2011
19,504
0
865
So when I try to boot up the game, it doesn't do anything despite it sitting in my Task Manager. What in the fuck Steam?
 

interfreak

Member
Feb 1, 2014
366
4
465
So I'm assuming I shouldn't be purchasing this right now... I have a GTX 970, so I don't have much hope if I base myself off the impression of some users here.

Runs fine on my 970, 60fps 90% of the time with only shadow detail and LOD turned down one notch.
 

possiblyphil

Member
Aug 17, 2011
274
0
0
How much memory is being utilized while playing?

shows me between 4-6 gig total usage on win 10. gpu usage is at 98% though in gpu tweak.

this is a rig that ran witcher 3, fallout 4 with no issues, after moving the hard drive im still getting dips to 20 fps on the ground sections of the first mission.
 
Mar 17, 2006
6,830
0
0
38
I used the GeForce experience to set things, turned off global illumination, and switched the AA. I get a steady 60 to 70fps, with drops to 50fps during the action. The worst parts are actually the cutscenes. Im really surprised for a gaming laptop.

970M 6GB
16GB RAM
i7-4710MQ
 

Wastwood

Neo Member
Jan 2, 2014
47
0
0
the game is not recognizing any input on my controllers, tried with the wired 360, wireless and even the DS4, weird thing is im having the exact same problem on JC2

Any help?
 

DarkoMaledictus

Tier Whore
Oct 9, 2009
4,447
8
680
Indeed, you said no difference though, so I wanted to address that.

Is there even a crossfire profile out? What res are you playing at? Try disabling one of the cards and see what happens.


I think that's pretty normal v-sync behaviour. Try turning off v-sync and instead capping the global fps at 60 with rivatuner statistics server.

No profile yet, its working with single still until the drivers get updated. Hopefully it gets better!!
 

matrix-cat

Member
Jan 9, 2009
10,072
1
0
the game is not recognizing any input on my controllers, tried with the wired 360, wireless and even the DS4, weird thing is im having the exact same problem on JC2

Any help?

It's been doing that on startup for me recently. I get to the main menu and nothing works, not even my keyboard and mouse. Alt-tabbing out and in again fixes it, though.

Is anyone else unable to get any outside programs working with this? RTSS doesn't work, forcing Adaptive V-Sync in the Nvidia CP doesn't work, and I can't even get the Steam Overlay to show up.
 

ClaptoVaughn

Member
Apr 24, 2014
1,157
0
470
It's been doing that on startup for me recently. I get to the main menu and nothing works, not even my keyboard and mouse. Alt-tabbing out and in again fixes it, though.

Is anyone else unable to get any outside programs working with this? RTSS doesn't work, forcing Adaptive V-Sync in the Nvidia CP doesn't work, and I can't even get the Steam Overlay to show up.

If you want to get RTSS working, go to the folder for RTSS profiles:

C:\Program Files (x86)\RivaTuner Statistics Server\ProfileTemplates

And create a new one called "JustCause3.exe.cfg"

Then type this into it:

[RendererDirect3D10]
Enable = 0