• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

Just Cause 3 PC performance thread

johnnydrama

Banned
Jan 29, 2015
3,483
0
0
Explosions hit the framerate super hard. I'm on a 980Ti and the framerate dipped all the way down to 30 at one point.
 

Crisium

Member
Feb 8, 2009
2,111
6
990
SMAAT2X looks very bad to me. It's less noticeable in screenshots but in motion it looks atrocious. Here's some pics I took. For all comparisons Global Illumination and Bokeh (ex1 ex2) are Off with LOD set to High.

For the first comparison, pay no attention to the tiny bit of a tree you can see peaking out from behind the rock in the top left. It was in between LOD rendering.

FXAA: http://abload.de/img/testfxaa9npuz.png

SMAA: http://abload.de/img/testsmaafgq3x.png

SMAAT2X: http://abload.de/img/testsmaa22poia.png

Here's a comparison just between SMAA2TX and FXAA. This really shows the strange, ugly effect SMAAT2X has, very noticeable in the leaves in the top right.

FXAA: http://abload.de/img/fxaaandgioff2vsssy.png

SMAAT2X: http://abload.de/img/smaa2bdskp.png

Three-way comparison with a town.

FXAA: http://abload.de/img/cityfxaaxqpp5.png

SMAA: http://abload.de/img/citysmaa5eqzx.png

SMAAT2X: http://abload.de/img/citysmaa2i2rlc.png

I originally went FXAA, but I have switched to SMAA. FXAA makes the textures awfully soft for me.
 

TheSpoiler

Member
May 2, 2011
19,504
0
865
There was a trick to get games that don't start up to run on Steam. Anyone remember what that was? Like bypassing the error where you hit the Play button and nothing pops up at all.
 

plumpblumpkin

Member
Nov 30, 2012
429
0
0
Gtx 970 3570k here...

Some weird ass stuttering and freezes happening. It's like the GPU hangs..I get 60fps most of the time but the stuttering kills it.

Also the explosions really hit the framerate...

Really disappointed considering how amazing the port for JC2 and Mad Max was....
 

Blizzard

Banned
Jan 23, 2008
36,025
0
0
Gtx 970 3570k here...

Some weird ass stuttering and freezes happening. It's like the GPU hangs..I get 60fps most of the time but the stuttering kills it.

Also the explosions really hit the framerate...

Really disappointed considering how amazing the port for JC2 and Mad Max was....
For science, try running in offline mode. That stuttering might be due to it trying to talk to servers occasionally.
 

Mutagenic

Permanent Junior Member
Aug 18, 2007
6,750
0
0
Since I didn't see it in the OP, is there a tweak to adjust FoV? It's way too small for me by default.
 

DarkLordMalik

Member
Aug 15, 2010
12,060
3
0
twitter.com
No it's not a mess by any means, just needs a patch or two to sort out some minor bugs.

The latest Nvidia driver seemed to help a fair bit.
I mean the engine lacks SLI support and people are reporting stuttering + fps drops even on a beefy rig. It is obviously not the same engine as Mad Max, which ran like a dream on PC.
 

Mutagenic

Permanent Junior Member
Aug 18, 2007
6,750
0
0
I mean the engine lacks SLI support and people are reporting stuttering + fps drops even on a beefy rig. It is obviously not the same engine as Mad Max, which ran like a dream on PC.
Mad Max wasn't performing nearly as many calculations. Really not comparable.
 
Feb 27, 2014
8,414
0
0
So this is a bad port on PC? The conclusion is that the engine is a mess, no?

Thing is it's probably the same engine just the b team managed to really screw it up. Some of it is probably poor decisions. Thinking back to a Dev diary they were talking about how they were dialing up explosions until the computer couldn't take it anymore and then dial it back to just where it worked. At the time it sounded exciting but with the game out it's looking more like poor use of the resources.

If that was the mentality the team had with everything then it's possible some of it could be cleaned up. Typically I'd assume it was rushed but the game appears to have been in the works for a long time going by mentions of it we've heard in the years gone by.
 

SapientWolf

Trucker Sexologist
Jul 4, 2004
35,710
0
0
Thing is it's probably the same engine just the b team managed to really screw it up. Some of it is probably poor decisions. Thinking back to a Dev diary they were talking about how they were dialing up explosions until the computer couldn't take it anymore and then dial it back to just where it worked. At the time it sounded exciting but with the game out it's looking more like poor use of the resources.

If that was the mentality the team had with everything then it's possible some of it could be cleaned up. Typically I'd assume it was rushed but the game appears to have been in the works for a long time going by mentions of it we've heard in the years gone by.
They should have left that dial in the PC port.
 

gafneo

Banned
Jun 2, 2013
3,998
1
0
I'm playing with everything turned up except aa. Seems to have crazy amounts of pop in no matter what. It's more noticeable when driving for long distances. Not a miraculous difference from a console setting. Loading is like 10 seconds though.
 
Dec 20, 2012
7,013
0
0
29
Ogden, Utah
steamcommunity.com
Turning off GI helped with the random framedrops I was getting. Although I still get them.

Laying waste to a huge base in a helicopter, explosions everywhere: 50-60fps

Look from the base to the ocean with nothing going on? 30-40fps. Looking in the same direction, lower to sea level? 60fps again.

Like, I can look at an entire town from far enough away that it's at a lower LOD and my framerate will (only sometimes) tank, but do the same with it up close and in full detail and I'll get 60.
 

Chris R

Member
Jul 31, 2007
43,506
0
1,210
Anchorage Alaska
Newest nVidia driver and other fixes people suggested to fix the hanging did nothing.

Getting a refund now I think, if Steam will still let me do it.
 

Mutagenic

Permanent Junior Member
Aug 18, 2007
6,750
0
0
I cannot believe the FoV on this game. It's making me nauseous. I'll have to wait for a tweak to be discovered. =/
 

Qwell

Member
Dec 5, 2008
1,726
110
1,055
I just don't get it, earlier I played for 4 hours straight and didn't have any issues. Now that I'm back home every time I try to play the game crashes within 10-15 minutes. Can't even finish clearing this one town I'm at. I've rebooted twice, and the game has crashed at least 10 times on me.
 

Codeacious

Banned
Mar 26, 2014
861
1
0
San Diego, CA
Okay, so I just played for ~4h and had no issues (except for flickering, which toggling Global Illumination fixed without having to restart); 50-60FPS all the time, and explosions didn't cause any noticeable FPS drops. Everything maxed except Edge Fade off, only using SMAA, VSync off. Forcing 16x AF and Adaptive VSync via NVIDIA control panel. Also playing in offline mode with the new NVIDIA driver.

Specs: GTX 970 @ 1480MHz, i5-4690k @ 4.5GHz, 16GB RAM @ 2400MHz, 1080p @ 60Hz monitor.

Took a bit to get everything working, but man is this game fun once you don't have to worry about FPS drops.
 

AwesomeMeat

PossumMeat
Mar 25, 2015
1,032
0
0
I played for a while after work and I wasn't expecting much after reading through the thread at work... but... I didn't have any real issues.

GTX 970 OC
16GB RAM
i7 2700K

Put everything on max (except shadows), disabled GI, and didn't notice any major issues. FPS dips here and there based on explosions but I wasn't bothered.
 

Cannon Goose

Member
Nov 28, 2011
4,093
0
660
Australia
The textures in the distance look awful, that poor mountain.

 

slash3584

Member
Sep 12, 2013
1,419
3
490
Well this runs considerably worse than I expected.

When nothing is happening it's mostly 60 fps, but even if there is one explosion or I'm close to a town the FPS drops inmediately to something like 35-40 fps. When things get hectic it drops to the lower 20s.

I5 2500K @ 4.2
GTX 970
8GB DDR3

Most of the settings are high with the exception of shadows that are on medium. But I really think that lowering settings doesn't change much. I can ramp up some stuff to very high and get the same performance.

Any tips?
 

omonimo

Banned
Jun 6, 2012
7,572
2
0
Well this runs considerably worse than I expected.

When nothing is happening it's mostly 60 fps, but even if there is one explosion or I'm close to a town the FPS drops inmediately to something like 35-40 fps. When things get hectic it drops to the lower 20s.

I5 2500K @ 4.2
GTX 970
8GB DDR3

Most of the settings are high with the exception of shadows that are on medium. But I really think that lowering settings doesn't change much. I can ramp up some stuff to very high and get the same performance.

Any tips?
Wait for a patch.
 

A Serious Man

Member
May 22, 2013
6,851
1
0
Game runs well for me... except sometimes the sound doesn't work. And other times it only plays out of one speaker. It requires a relaunch to fix.
 

plumpblumpkin

Member
Nov 30, 2012
429
0
0
Why did they change the controls so much compared to JC2?? The grappling hook/parachute bindings feel weird now. I liked it when it was F to grapple.
 

Rosur

Member
Nov 15, 2013
3,036
0
0
UK
Getting mostly 60fps except during explosions (drops to 30-40fps) everything max except shadows at high (only played around 2hrs).

Specs:

I5-5690k
32GB DDR3 RAM
GTX 970
 

PHOENIXZERO

Member
Jan 7, 2007
14,183
0
1,150
I can't use KB/Mouse with this game for anything but shooting though I need to turn down the sensitivity. Anyway I think I'm going to be waiting for a patch after playing for a bit tonight, I don't like falling through the ground or seeing things do it, especially when I need to destroy them. The most notable one was while doing some random kidnap/assassinate mini-encounter/mission thing where I had to dive out of a vehicle just before it'd be destroyed so I found a cliff and dove out but went through the ground and the car disappeared. >_>

Oh and seeing KB/M controls while using a controller is annoying. But tonight was the first time I've launched the game without having to Alt-Tab out and back in to get the controls to work so I guess there's that. At least my performance seems okay, I didn't notice any significant drops even when I did a place with a lot of big shit blowing up. I really need to disable the steam frame counter, my eyes are drawn to it way too much.
 

matrix-cat

Member
Jan 9, 2009
10,072
1
0
Something needs to be done about that interminable intro of Rico on the beach in the deckchair. I don't know if it's actually loading the game world in the background, but given that it leads into a loading screen after it logs you in I can only imagine it's just... I don't know, some unskippable bullshit. Shit's gotta go.
 

Sevenfold

Member
Mar 4, 2014
1,829
212
540
Running this maxed with a 6700k/980ti/16 GB of RAM not a single issue so far, runs far better than I've managed to get Fallout to.

Same set up. No problems here either. What are your F4 troubles? Silky with about 30 mods here.

So this is a bad port on PC? The conclusion is that the engine is a mess, no?

Not at all.

DF's comparison between the consoles and a GTX 750ti/i3 4130 PC:

https://www.youtube.com/watch?v=FKmfWg_rERk

In the helicopter (flight) bit about halfway through, you can really see the broken GI in effect next to the consoles. The budget PC is such a soldier! That 750ti punching well above its weight here. I fear its days are numbered but damn.
 

MaLDo

Member
Jun 4, 2009
3,613
1
780
Barcelona
maldotex.blogspot.com
Something needs to be done about that interminable intro of Rico on the beach in the deckchair. I don't know if it's actually loading the game world in the background, but given that it leads into a loading screen after it logs you in I can only imagine it's just... I don't know, some unskippable bullshit. Shit's gotta go.

It loads nothing, there is a connecting screen after it, and then a loading screen. The unskippable (and not 1080p) intro is the icing in the cake.


is it sufficiently clear that I am really disappointed with the decisions they have taken in this game? I really love JC2 and this is sad.
 

Cannon Goose

Member
Nov 28, 2011
4,093
0
660
Australia
I don't see that on mine. Maybe you need to launch it with an app called geforce experience. That's what I use. It automatically updates nvidia drivers too.

I thought I might be running out of VRAM or something but my game hasn't stuttered once in several hours of play so I'm not sure if it's that. Also, the same poor distance textures are visible in some of the Nvidia performance guide screenshots.



 

gafneo

Banned
Jun 2, 2013
3,998
1
0
I thought I might be running out of VRAM or something but my game hasn't stuttered once in several hours of play so I'm not sure if it's that. Also, the same poor distance textures are visible in some of the Nvidia performance guide screenshots.




hmm, I will start the game again and check those mountains and take a pic.
 

TheSpoiler

Member
May 2, 2011
19,504
0
865
Ah, I figured it out. You have to change the resolution of your desktop.

But man, this game runs like ass. My FX4300 is struggling, but it shouldn't be this bad with everything on low. Maybe I'll throw the resolution to 800.

I think it's because of the drivers. Even with the new ones, my damn game is still showing missing textures.

AMD users are and always will be fucked.
 

interfreak

Member
Feb 1, 2014
366
4
465
Seems to be a bit of a theme that those with at least 16GB RAM are getting the smoother results.

I noticed my page file creeping towards 10GB after a few hours of play today...

With my set up (gtx 970/i5 4590/16GB RAM) I'm getting a reasonably constant lock at 60 fps, with drops during heavy alpha effects with the worse being on the open ocean oddly enough.

Very happy with performance, but it could be better.
 

gafneo

Banned
Jun 2, 2013
3,998
1
0
There's kind of a sky fog off a distance from the mountain. There's no blurry smudge on the mountains. Sorry for the crap res shot. I don't have a normal keyboard that has a print thing to copy and paste caps. I just use a tablet cam. I would suggest going into nvidia control panel, by right clicking mouse. My computer is set to use my preference emphasizing performance. Maybe yours is set to quality. Also under pysX Config I have my geforce graphics card selected where there is an option to use cpu as default.
 

polychron

Member
May 1, 2013
192
0
0
Yeah so I had horrible stuttering issues initially, and I realised it was when I writing to the pagefile on my old mechanical harddrive that the game chugged. Seems like 8 gigs of ram just isn't enough for this game, I've had to move the pagefile to my SSD to smooth things out.
 

Kezen

Banned
Jul 28, 2014
8,919
0
375
France
Ah, I figured it out. You have to change the resolution of your desktop.

But man, this game runs like ass. My FX4300 is struggling, but it shouldn't be this bad with everything on low. Maybe I'll throw the resolution to 800.

I think it's because of the drivers. Even with the new ones, my damn game is still showing missing textures.

AMD users are and always will be fucked.

Lowering your rendering resolution will probably not yied the results you are hoping for. Your CPU is really slow and Just Cause 3 is a CPU heavy game.
How does it run with LOD factor and shadows on low ? The FX4300 is below minimum specs.