Recore PC performance thread

Caayn

Member
Mar 10, 2013
12,378
370
700
The Netherlands
i7 4790k @4.4Ghz
GTX1070 @ 2000mhz core + 9Ghz memory
16GB 1866Mhz DDR3

No matter what settings I choose I can't escape common dips to <30fps when using 3840x2160. 60fps, look to the right framerate drops to 30...

I've settled on these settings:
2560x1440
Texture Quality: Very High
AF: Force On
AA: TAA 16X
Shadow type: Hard and Soft
Shadow resolution: very high
Bloom: Enabled
AO: Enabled
AO Quality: Very high
Motion Blur: Off

These settings result in 60fps with a few dips to mid 50s.

Also one thing that annoys me a bit is that unlike other UWP games I can't drag and drop the game to another display and have it detect that displays resolution. I can drag and drop FM6 Apex from my main display (2560x1080) to my secundary display(3840x2160) and it'll allow me to select 3840x2160, Recore doesn't support that sadly. The max resolution I can choose is the max supported by my main display.
 

Dark-VIII

Member
May 25, 2012
501
0
0
Hmm maybe it's GSYNC that is screwing stuff up for me since this is a UWP game. I'll turn it off. Frame rates shouldn't be this wonky with the hardware I'm using
i don't think GSYNC has to do anything with it, my hardware is also capable of running this with max setting at least on 1080P but for some reason i am getting some frame drop
 

FunkyDealer

Banned
Mar 9, 2015
4,723
0
0
Are shadow resolutions really low even at "very high" for the rest of you as well?

Also, none of the anti-aliasing options seem to do anything.
 

Dark-VIII

Member
May 25, 2012
501
0
0
OK turn out i am playing mostly in 60 FPS in 4K resolution but i am having weird texture and shadow issue that happen from time to time
 

Rayge

Member
Jan 22, 2011
10,429
1
610
North Carolina
Turned off GSYNC and now I'm getting 144fps @ 1440p maxed out without any weird ass drops. Also seemed to have a little trouble with ULMB activated.

4K maxed is also stable at around 110-120fps without drops and the same with 5K at around 60-70fps in the overworld and 70-80 in dungeons. This is awesome.
 

Izuna

Banned
Nov 23, 2010
28,334
1
0
England
Very strange...

Surface Book i5/dGPU

Tweaks:
"High Performance" CPU (hack)
dGPU Core Clock +135MHz
dGPU Memory Clock +700MHz

Settings:
Everything Max
1600x1066 (3:2)

Runs at 30fps (lock)

~~

For some reason, even if I lower to 1200x800 and turn all the settings to their lowest, I can only get about 14fps gain (44fps).

I don't understand... I really think something is wrong. Turning the settings off should make it much better. I literally cannot do anything to get close to 60 and yet I can keep increasing the settings and stay at 30. Oh well. 30 will do, I guess.
 

Rayge

Member
Jan 22, 2011
10,429
1
610
North Carolina
Very strange...

Surface Book i5/dGPU

Tweaks:
"High Performance" CPU (hack)
dGPU Core Clock +135MHz
dGPU Memory Clock +700MHz

Settings:
Everything Max
1600x1066 (3:2)

Runs at 30fps (lock)

~~



For some reason, even if I lower to 1200x800 and turn all the settings to their lowest, I can only get about 14fps gain (44fps).

I don't understand... I really think something is wrong. Turning the settings off should make it much better. I literally cannot do anything to get close to 60 and yet I can keep increasing the settings and stay at 30. Oh well. 30 will do, I guess.
The same thing is happening to me. There is some wonky stuff going on with the graphics settings.
 

Izuna

Banned
Nov 23, 2010
28,334
1
0
England
The same thing is happening to me. There is some wonky stuff going on with the graphics settings.
I'm not sure what kind of AA is being forced on, but I don't like it. It might be what this Book is struggling to deal with. In the meantime I'm happy to play it on here as opposed to Xbone. But yeah, I hope this is addressed/fixed.
 

Mohasus

Member
Jul 23, 2012
5,120
1
420
I don't understand... I really think something is wrong. Turning the settings off should make it much better. I literally cannot do anything to get close to 60 and yet I can keep increasing the settings and stay at 30. Oh well. 30 will do, I guess.
That happens when the bottleneck isn't the GPU.
 

Rayge

Member
Jan 22, 2011
10,429
1
610
North Carolina
After finally fixing the issues I decided to run some benchmarks in both the overworked and dungeon and during combat with max settings.

1440p @ 144 fps (capped)
4K DSR @ 121 fps
5K DSR @ 75 fps
 

Izuna

Banned
Nov 23, 2010
28,334
1
0
England
That happens when the bottleneck isn't the GPU.
What could it be then? It isn't the CPU, for sure.

After finally fixing the issues I decided to run some benchmarks in both the overworked and dungeon and during combat with max settings.

1440p @ 144 fps (capped)
4K DSR @ 121 fps
5K DSR @ 75 fps
What did you fix? Oh nvm.

Yeah I feel like AA settings don't do anything and something is forced. Hmm
 

Super Rookie

Member
Dec 16, 2013
546
0
0
London
steamcommunity.com
I get the audio cut outs every now and then - only on PC version not Xbox One
Yeah it is weird. The originaal pauses I had were longer before I updated my HDD (FRom a 5400RPM, to a 7200RPM) That has helped shorten the pauses but they are still there,

Turned off GSYNC and now I'm getting 144fps @ 1440p maxed out without any weird ass drops. Also seemed to have a little trouble with ULMB activated.

4K maxed is also stable at around 110-120fps without drops and the same with 5K at around 60-70fps in the overworld and 70-80 in dungeons. This is awesome.
Cheers Rayge! Disabling G-Sync helped a ton.

Edit: Weird, re-enabled G-sync and it is fine still?
 

Rayge

Member
Jan 22, 2011
10,429
1
610
North Carolina
Yeah it is weird. The originaal pauses I had were longer before I updated my HDD (FRom a 5400RPM, to a 7200RPM) That has helped shorten the pauses but they are still there,



Cheers Rayge! Disabling G-Sync helped a ton.

Edit: Weird, re-enabled G-sync and it is fine still?
I'll try turning it back on to see what happens
 

Rayge

Member
Jan 22, 2011
10,429
1
610
North Carolina
Turned G-Sync back on and my frame rate at 1440p went from 144fps to around 80/90 in the same static room. Yeah, this game doesn't like GSYNC if you're running a super high end rig. I'm sure people incapable of reaching over 100fps won't see this issue pop up for them when using GSYNC.

No big deal. I'll just keep it off.

At the same time I'm still curios as to why when I set the game to 4K the fps shoots back up into the 110~120s
 

shanafan

Member
Oct 27, 2013
7,906
69
535
Is it possible to add ReCore to the GeForce Experience program? Or, is it depended on the program itself to support the game?
 

UltraJay

Member
May 8, 2015
723
0
0
33
Australia
ReCore will unexpectedly drop to 30 FPS from a locked 60 while I'm playing, especially if I'm leaving a menu. At first I thought it was only happening in the outside, but I've gotten it to happen inside the crawler (after I did some upgrading). Pointing the camera at a wall for a bit allows to go back up to 60 and stay there so I'm pretty sure it isn't a case of my computer not being able to handle it.

OS
Windows 10 Pro 64-bit
CPU
Intel Core i7 4790K @ 4.00GHz
Haswell 22nm Technology
RAM
16.0GB Dual-Channel DDR3 @ 666MHz (9-9-9-24)
Motherboard
MSI Z97 GAMING 7 (MS-7916) (SOCKET 0)
Graphics
Acer G24 (1920x1200@59Hz)
3071MB NVIDIA GeForce GTX 780 Ti (NVIDIA)

Something strange is also going on, sometimes particles get "stuck" on the screen and walking through sand leaves an after image that sticks around. I couldn't find anyone having this problem.


You can see Mack's tracks from where he walked.

This blob just follows the player around.

Here it is again in a different area for comparision.
 

Izuna

Banned
Nov 23, 2010
28,334
1
0
England
Decided to run with these settings for my Surface Book :S

Everything Maxed Out (since performance is literally the same)
Locked 30
1368x912 (900p equivalent)



~~

Basically, I cannot turn off the AA, and the setting is making no difference. I have no idea what's going but I'm sure there's some bullshit effect going on that's stopping me from hitting 60. I also feel like AO etc. is always secretly running even if you turn it off.

The game looks blurry and I can't tell the difference between 1368x912 to 1800x1200 like I can in other games.

We really need a fix for this. But rn, it's like playing the Xbone but with SSD attached.

UWP am cry
 

Robobandit

Member
Aug 11, 2005
5,200
0
0
you're not going to hit 60 on a surface book. it's a ULV slow dual core cpu and a modified 940m gpu. It's very weak. (assuming you have the dGPU model)
 

Izuna

Banned
Nov 23, 2010
28,334
1
0
England
you're not going to hit 60 on a surface book. it's a ULV slow dual core cpu and a modified 940m gpu. It's very weak. (assuming you have the dGPU model)
This is not exactly my concern. I concern is hitting 30-45 at 1800x1200 and having no performance increase by turning all the settings off and lowering the resolution to like 1200x800.

More so, I want to turn off the AA...

side note: the i5 in this machine is dope, and the dGPU performs like a 950m just with 1GB VRAM ~
 

Robobandit

Member
Aug 11, 2005
5,200
0
0
This is not exactly my concern. I concern is hitting 30-45 at 1800x1200 and having no performance increase by turning all the settings off and lowering the resolution to like 1200x800.

More so, I want to turn off the AA...

side note: the i5 in this machine is dope, and the dGPU performs like a 950m just with 1GB VRAM ~
probably cpu limited if dropping settings and resolution isn't helping you.
 

Dark-VIII

Member
May 25, 2012
501
0
0
Ok guess i had enough
Can't believe that i am having problems running this game at fill strength on even 1080p with my PC
Core i7 6700
Gtx 1080 FTW
16 gb of DDR4 RAM

If anyone know a fix for the performance of this game please let me know
 

Synth

Member
Dec 4, 2005
14,082
3
1,140
36
London, UK
Ok guess i had enough
Can't believe that i am having problems running this game at fill strength on even 1080p with my PC
Core i7 6700
Gtx 1080 FTW
16 gb of DDR4 RAM

If anyone know a fix for the performance of this game please let me know
Something is very wrong here. That's pretty much the same as my PC (I have a 6700K tho), and I'm getting perfectly smooth performance whilst downsampling from 4K. When you say performance issues, what framerates are you targeting. I have it locked to 60fps, so I'm not sure if you're playing on a 144hz monitor and attempting significantly higher than that?
 

Dark-VIII

Member
May 25, 2012
501
0
0
Something is very wrong here. That's pretty much the same as my PC (I have a 6700K tho), and I'm getting perfectly smooth performance whilst downsampling from 4K. When you say performance issues, what framerates are you targeting. I have it locked to 60fps, so I'm not sure if you're playing on a 144hz monitor and attempting significantly higher than that?
I also have 6700K
Targetting 60fbs
I'll try resetting my windows and see if it fixes the problem
 

scitek

Member
Aug 23, 2005
17,119
12
1,230
El Paso, TX
twitch.tv
just small question ... can it be played offline ??? I read that encrypted appx requires online to be able to play and seen reports of game not working offline https://www.reddit.com/r/recore/comments/52iyku/pc_specs_and_how_well_it_runs/d7lcknt
I was not able to play offline. The game will start, and you will get as far as the menu, but as soon as it tries to sync your save and can't find a connection, the game immediately closes. It seems like a bug to me given how it happens.
 

prudislav

Member
Mar 15, 2012
2,762
0
445
ok hope they will fix it soon if its a bug ... i its now thats asshole move and kinda worrying for Forza
 
I was not able to play offline. The game will start, and you will get as far as the menu, but as soon as it tries to sync your save and can't find a connection, the game immediately closes. It seems like a bug to me given how it happens.
This and other Windows 10 Xbox games need to be launched with an online connection before playing on an offline connection. An offline connection only lasts for 24 hours. I think Microsoft Studios games are the only titles that do this, exception of Minecraft I believe.

Its exactly like the 24 hour check-in DRM the Xbox One was gonna utilise back in 2013. In fact it probably is.

Unless your on the latest Windows 10 Insider build; which is 14931. Then it's a bug caused by this Windows build.
 

Dark-VIII

Member
May 25, 2012
501
0
0
Last thing happened with me with this game is a crush and force close.
Weird that Forza Horizon 3 is working perfectly fine
 

Theorry

Member
Dec 4, 2014
15,857
3
0
Weird. They said october 5th.

Its this btw.

Hello Far Eden Explorers!



We’ve continued to get great feedback as you play ReCore, and we have more good news to share. On October 5th, we’ll be releasing a significant update to ReCore for Xbox One, Xbox One S, and Windows 10.



In this update, you will experience decreased loading times, see audio and visual improvements, and notice improvements to issues you may have experienced with waypoints, achievement tracking, collision locations, checkpoints and respawn points."
 

Zedox

Member
Oct 16, 2013
4,092
0
380
I wonder if the update is up on xbox as well. I'll be checking at lunch so we'll see.
 

malcher

Member
Dec 4, 2013
151
0
0


Large update just went live. No idea what the fixes are.
I actually wonder if 8,7GB is the correct size of the update or is it a bug and Windows 10 re downloads a whole game. Their blog post http://www.recoregame.com/oct-5th-recore-update/ says that latest Win10 update should prevent such a bug. Did anyone have a different (smaller) update or is everyone forced to download 8,7GB? Hopefully it's not a general bug - I don't care about ReCore anymore, but I don't want to re-download 40GB for upcoming FH3 patch if the bug really exists.
 

luffeN

Member
Sep 13, 2006
5,025
0
1,030
I actually wonder if 8,7GB is the correct size of the update or is it a bug and Windows 10 re downloads a whole game. Their blog post http://www.recoregame.com/oct-5th-recore-update/ says that latest Win10 update should prevent such a bug. Did anyone have a different (smaller) update or is everyone forced to download 8,7GB? Hopefully it's not a general bug - I don't care about ReCore anymore, but I don't want to re-download 40GB for upcoming FH3 patch if the bug really exists.
I started the update and it also says 8.7GB ... IIRC I have the WIN10 update installed that Major Nelson mentioned some time ago.
 

SkyTurnsRed

Banned
Sep 4, 2012
2,063
0
0
www.youtube.com
Just wanted to come in here and say that disabling G-Sync worked for me at 1440p. I was getting 20-25 FPS. Now I'm maxing out again. I know there will be a lot of new players with the sale, so hopefully this helps. :)
 
May 8, 2011
543
3
560
Australia
Just wanted to come in here and say that disabling G-Sync worked for me at 1440p. I was getting 20-25 FPS. Now I'm maxing out again. I know there will be a lot of new players with the sale, so hopefully this helps. :)
I was looking at picking this up due to the sale, and was wondering if they fixed the Gsync issue :/ If you play in borderless window mode (which should disable it) does that also work - without having to totally disable it via Nvidia control panel? Or even using Nvidia inspector, to adjust the profile?
 

Shpeshal Ed

aka Collingwood
Mar 16, 2007
15,434
133
1,220
i7 6700
16GB DDR4
6GB 1060

At 1920 x 1080 everything is maxed and it runs at 60 without a hitch. I turned off motion blur though. It looked weird.