• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.

Tomb Raider PC Performance Thread

isamu

OMFG HOLY MOTHER OF MARY IN HEAVEN I CANT BELIEVE IT WTF WHERE ARE MY SEDATIVES AAAAHHH
Jun 7, 2004
10,784
6
1,850
Try the Hitman Absolution trick. It works perfect for me. Even with the latest patch and drivers I got two successive hard crashes within minutes, after a simple fix in Nvidia Inspector I am now playing the game without a single crash. Fourteen hours and counting.
Link to fix?
 

Mudo

Member
Feb 8, 2006
831
0
0
43
Columbia, TN
Bought Tomb Raider PC last night and played about 2 hours but my computer hard locked suddenly during a rain storm in the game. I figured maybe it was because I had settings too high, but I had disabled tessellation and exclusive fullscreen and tressfx before starting. I see the fix for Nvidia users using Inspector and I just opened it and *tried* to do what it said but I've not used inspector before.

I found and deleted the Tomb Raider profile then I selected Hitman Absolution and clicked "add application to current profile", and then found the Tomb Raider exe and selected it. Is that it? I didn't get any kind of confirmation so I'm not sure that it even worked. Also, I see tons of options here for AA / AF and millions of other things but really have no idea what to select. Anyone have any standard/safe things for me to try? My computer is Intel Core i7-3960X and I have 2 GTX 580s and 32GB RAM. I don't want to explode the game so I"m cool lowering whatever I need to in order to run it ok.....
 

Ce-Lin

Member
Mar 16, 2012
1,314
0
0
Europe
I got this results with a GTX 660 Ti 3GB

1920 x 1080 FXAA, Everything else at max settings except Tress FX which was disabled

min 61
max 111
average 78

same settings with Tress FX enabled...

min 35
max 71
average 51

so many frames lost ! please tell me it's my old CPU (doubt it since the game is GPU-bound for the most part)... if the future wave of games go with computing-accelerated effects the likes of Tress FX then my (admittedly cheap) 660 Ti will be useless...

any news on Nvida optimising Direct Compute on the 6XX cards or are these cards forever crippled ? synthetic benchmarks such as Compute Mark which uses Direct Compute put the 6XX cards in a pretty good position, seems like real word performance is a different story :(
 

BadTaste

Member
Jul 13, 2007
1,748
0
995
93.4 MB patch just downloaded on Steam. wut is it?

edit:

- Fixed an issue in ”Chasm Monastery” where the player cannot progress after fighting the Oni.
- New community requested graphics option ‘Screen Effects’ to disable camera-based full screen effects like water and blood drops.
- Fixed last campsite save not always updating when expected.
- Various small optimizations.
- Various minor UI fixes.
- Minor graphics fixes.

While we expect this patch to be an improvement for everyone, if you do have trouble with this patch and prefer to stay on the old version we made a Beta available on Steam, Build730.0, that can be used to switch back to the previous version. Please note however that you can only play multiplayer with people that share your version.

Unfortunately we do not yet have a resolution for the players that are experiencing crashes and major graphical corruption on NVIDIA hardware. We are still working on this with NVIDIA and hope to have an update soon.

We are planning further patches beyond this one to address various issues. We always welcome your feedback!
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
Is TressFX meant for dual GPUs only or something?

I have an 7970 with the latest drivers clean installed and the game crashes on start up if that's enabled.

I only see people mention crashes on Nvidia hardware though... Disabling exclusive fullscreen does nothing for me...
 

rallyart

Neo Member
Sep 28, 2009
117
0
0
when it´s raining, performance drops considerably, is this normal?

Texture: Ultra
AA: FXAA
Shadow: Normal
Shadow res: High
LOD: Normal
Hair: Normal
Reflection: high
DOF: Normal
SSAO: Normal

Post Processing, Tessellation and High precision, turn on.

Playing @ 1080p.

Lastest driver, and game update.

I7 920 @ 3.8
GTX580 Oced.
 
May 22, 2011
7,255
0
0
Hi guys,

Just to be clear again, all I was saying is that you are hitting a CPU bottleneck, and specifically a CPU bottleneck regarding the speed of each individual core. More cores (and especially) hyper threads will not help with this. Because the CPU is the bottleneck the GPU usage will drop, and the GPU usage dropping will be especially apparent on fast GPU configurations like SLI or Titans. And more so at lower resolutions. (At higher resolutions the GPU will have plenty of work to do...)

I'm not sure what you are trying to convince me off. That these spots are specifically CPU heavy, much more so then some other spots? I am not disagreeing with that at all. This is fact. The main contributor to this performance drop is the LOD setting, and you can obviously set this to a lower setting to improve your performance. Also note that both the game and the driver contribute to CPU time spend, so it is quite difficult to compare with so many variables in play.

One thing you can do with the game right now, on the latest patched build, is that you can set the game registry setting Graphics\MultiCoreFlushMode (you will have to add this registry key) to 1. With this set to one it enables new functionality in the game engine that can increase framerate in these spots by up to 50%. You may want to try it out to see how it works for you.

Note that there are reasons this has not yet been enabled by default, testing has been limited, and the well known severe corruption and crash issues on NVIDIA hardware have been seen to occur more frequently and on more machines with this enabled, so please use with caution.
.
 

JaseC

gave away the keys to the kingdom.
Jul 30, 2009
73,802
6
1,030
Western Australia

ambientmystic

Member
Dec 4, 2012
3,986
16
525
Malaysia
http://forums.eidosgames.com/showthread.php?p=1900809#post1900809

Start -> regedit -> HKEY_CURRENT_USER -> Software -> Crystal Dynamics -> Graphics -> right-click in the empty space of the right-hand window -> New -> DWORD (32-bit) Value -> Enter MultiCoreFlushMode and hit enter -> right-click on it and select Modify -> Change the value to 1

Edit: I've added this to the OP.
Thanks JaseC! Just had to know whether the entry was a DWORD or a BINARY value entry.

Does it work well? I'm about to find out on my old ass laptop lol.
 

ymmv

Banned
Mar 17, 2007
6,485
0
0
Amsterdam, NL
The update that went live a few hours ago improves general GPU performance:
Plus this:

Unfortunately we do not yet have a resolution for the players that are experiencing crashes and major graphical corruption on NVIDIA hardware. Some progress has been made though, and we expect hope to have an update soon.
Nvidia's ManuelG wrote on Guru3d:

In our upcoming driver, we have provided workarounds for the TDR in Tomb Raider and corruption in Tomb Raider in NVIDIA Surround. Hair flicker with TressFX in SLI mode is an application bug and we are still trying to find a workaround.
He also said the new beta won't be out this week ... You could try the new Quadro drivers though. There are tricks to make those drivers run on regular Geforce cards.
 

JaseC

gave away the keys to the kingdom.
Jul 30, 2009
73,802
6
1,030
Western Australia
The Hitman trick fixed all crashes and visual corruptions for me, bar one -- just after Shanty Town's closing bridge sequence, where Roth is covering you via sniper fire, there's a small cave you have to push through, and my entire screen would become a kaleidoscope of artefacts. At first I thought my GPUs were overheating, but I quickly realised the issue only occurred when going through that particular cave -- everything else before and after it rendered just fine. Odd that Nvidia is having trouble when a simple profile switch fixes most of the problems.

Also, the hair flickering was rather annoying. Nothing took me out of the experience more than seeing Lara's hair dancing.
 

Gangxxter

Member
Aug 26, 2012
2,031
11
510
30
Austria
steamcommunity.com
I ran the benchmark with my old Radeon HD 4870 with all settings set to maximum (as far as my card is capable of since it's only DX10 compatible, incl. FXAA) and I was really surprised how well the benchmark ran @1080p.

Min: 26 fps
Max: 36 fps
Avg: 33 fps

This benchmark was done without the latest patch, so I'm really kinda surprised :D I was totally expecting a slide show on my old card. (Luckily my brand new 7970 Ghz Edit has just arrived, time to install this baby!)

I haven't played the game yet, just tried the benchmark because I want to play the game in full glory with my new graphics card. But as far as I can tell from the benchmark I'm not really impressed by the graphics. Is there really such a huge gap between DX10 and DX11 graphics? Because it seems everyone is praising TR's graphics but so far I really can't understand that.
 

ambientmystic

Member
Dec 4, 2012
3,986
16
525
Malaysia
Is there really such a huge gap between DX10 and DX11 graphics? Because it seems everyone is praising TR's graphics but so far I really can't understand that.
Kinda.

DX11 Tesselation + DX11 TressFX makes Lara's curves more rounded out and her hair pretty damn awesome. High and Ultra Shadows, Ultra Reflections, High DOF, and High SSAO are also only DX11.

Also SSAA 2x/4x is not available for DX 10 cards in this game, only on DX11. As you've noted above, only FXAA is available, which blurs out the image/textures, making it look worse.

It's the combination all of the above factors that make TR look really, really good, almost CG like in some scenes and shots.
 

Gangxxter

Member
Aug 26, 2012
2,031
11
510
30
Austria
steamcommunity.com
Thanks for your reply. I'd never have guessed that those mostly subtle improvements will make such a big deal at the end of the day.

Really looking forward to finally play this game with my new 7970 now!
 

moop1167

Member
Mar 6, 2011
1,446
0
0
So weird... I am getting weird artifacting using 2xSSAA. It doesn't happen with FXAA or 4xSSAA, but of course my machine cannot run 4xSSAA at a good framerate and FXAA isn't the best.

I get a constant 60 fps with 2xSSAA for about 20 seconds then this weird artifacting occurs. It only happens with exclusive fullscreen turned on, but turning off exclusive fullscreen even with Vsync + triple buffer, there is mad screen tearing.

What the hell is the best option then? Just downsample with FXAA? I am on dual GTX 670s (4GB)
 

ymmv

Banned
Mar 17, 2007
6,485
0
0
Amsterdam, NL
New Nvidia beta drivers: http://www.guru3d.com/files_details/geforce_320_00_beta_driver_download.html

Release Summary
This is the GeForce Game Ready driver for Dead Island: Riptide, Neverwinter, and Star Trek.

Get optimal game settings and automatically stay up to date with the latest drivers with GeForce Experience.

New in GeForce R319 Drivers

Performance Boost – Increases performance by up to 20% for GeForce 400/500/600 series GPUs in several PC games vs. GeForce 314.22 WHQL-certified drivers. Results will vary depending on your GPU and system configuration. Here is one example of measured gains:

GeForce GTX 660:

Up to 20% in Dirt: Showdown
Up to 18% in Tomb Raider
Up to 8% in StarCraft II
Up to 6% in Sniper Elite V2
Up to 6% in Metro 2033
Up to 6% in Far Cry 3
Up to 6% in Deus Ex: Human Revolution
Up to 5% in F1 2012


GeForce GTX 660 SLI:

Up to 17% in Dirt: Showdown
Up to 18% in Tomb Raider
Up to 9% in Assassin's Creed III
Up to 7% in StarCraft II
Up to 6% in Far Cry 3
Up to 6% in Deus Ex: Human Revolution
Up to 6% in Battlefield 3
Up to 5% in BioShock: Infinite
Up to 5% in F1 2012


SLI Technology

Added SLI profile for Alien Fear
Added SLI profile for Call of Juarez: Gunslinger
Added SLI profile for Dead Island: Riptide
Added SLI profile for Dragon Sword
Added SLI profile for Neverwinter
Added SLI profile for Far Cry 3: Blood Dragon
Added SLI profile for GRID 2
Added SLI profile for Human Head 2
Added SLI profile for Remember Me
Added SLI profile for The Walking Dead: Survival Instinct
Updated SLI profile for Natural Selection 2
Updated SLI profile for Resident Evil 6
Updated SLI profile for Trackmania 2: Canyon

Fixes:
...
[SLI][Surround][GeForce GTX Titan][Tomb Raider]: There is corruption in the game and the system hangs when played at high resolution and Ultra or Ultimate settings. [1254359]
[SLI][GeForce GTX 680][Tomb Raider (2013)]: The game crashes and TDR occurs while running the game at Ultra settings. [1251578]
BTW Already an SLI profile for Remember Me?. Nice. Looking forward to that game.
 

Smokey

Member
Nov 15, 2005
41,211
1
1,365
www.twitch.tv
Just got the game via GMG.

Some bad performance for my setup, SLI Titans. Terrible GPU scaling. Put up CPU-Z while playing and have noticed that my CPU will not run at it's OC speed of 4.7ghz with this game. It will fluctuate between 1.6ghz and 3ghz, but will not run at 4.7ghz. I tried the registry trick in the OP and it still does it.

Is this a known issue? Tried some other games just to make sure it wasn't a bigger issue and everything else runs at 4.7ghz as expect. So this points to a TR specific issue. Already feeling like I wasted $20 if this is the case.
 

nomis

Member
May 15, 2011
5,034
1
0
Just got the game via GMG.

Some bad performance for my setup, SLI Titans. Put up CPU-Z while playing and have noticed that my CPU will not run at it's OC speed of 4.7ghz with this game. It will fluctuate between 1.6ghz and 3ghz, but will not run at 4.7ghz. I tried the registry trick in the OP and it still does it.
 

JaseC

gave away the keys to the kingdom.
Jul 30, 2009
73,802
6
1,030
Western Australia
Just got the game via GMG.

Some bad performance for my setup, SLI Titans. Put up CPU-Z while playing and have noticed that my CPU will not run at it's OC speed of 4.7ghz with this game. It will fluctuate between 1.6ghz and 3ghz, but will not run at 4.7ghz. I tried the registry trick in the OP and it still does it.

Is this a known issue? Tried some other games just to make sure it wasn't a bigger issue and everything else runs at 4.7ghz as expect. So this points to a TR specific issue. Already feeling like I wasted $20 if this is the case.
Disabling SpeedStep and all C-states in the BIOS should do the trick, however doing so will cause your CPU to run at 4.7GHz at all times. I didn't think to keep an eye on CPU usage while playing the game but the CPU not being asked to run at its maximum speed would certainly explain why performance takes a dive in Shantytown.
 

Smokey

Member
Nov 15, 2005
41,211
1
1,365
www.twitch.tv
Disabling SpeedStep and all C-states in the BIOS should do the trick, however doing so will cause your CPU to run at 4.7GHz at all times. I didn't think to keep an eye on CPU usage while playing the game but the CPU not being asked to run at its maximum speed would certainly explain why performance takes a dive in Shantytown.
Yeah I did the C-state deal before on my old setup. I'll try it again and see if that helps. I just tried the new beta drivers and I got a bit of a bump in fps, but my GPU scaling is terrible. I suspect it's because of the core speed not sticking at 4.7ghz. As I mentioned it goes all over the place from 1.6 -> 4.7. It's really odd.
 

Smokey

Member
Nov 15, 2005
41,211
1
1,365
www.twitch.tv
Got it running at 4.7ghz by turning off C-states and Speedstep. Tried it again and still getting some bad GPU scaling. One Titan runs in the 70% range, the other in the 90% range. SLI gives me an avg of 71fps. Single Titan gives me avg 53fps. On the newest Nvidia beta drivers 320.00.

This is on the Ultimate setting, 2560x1600, TressFX enabled etc. Going by the release notes Andy put up on Geforce.com, I'm pretty much sitting in the 680 SLI range. Something is definitely up with a difference of only 18 fps when adding a second Titan!
 

MaLDo

Member
Jun 4, 2009
3,613
1
780
Barcelona
maldotex.blogspot.com
http://forums.eidosgames.com/showthread.php?p=1900809#post1900809

Start -> regedit -> HKEY_CURRENT_USER -> Software -> Crystal Dynamics -> Graphics -> right-click in the empty space of the right-hand window -> New -> DWORD (32-bit) Value -> Enter MultiCoreFlushMode and hit enter -> right-click on it and select Modify -> Change the value to 1

Edit: I've added this to the OP.
A.WE.SOME!!

Ultra LOD in most cpu bounded scene goes from 47 fps to 65 fps using multicoreflush.
 

Zimbardo

Member
Jan 21, 2011
2,157
2
470
canada
http://forums.eidosgames.com/showthread.php?p=1900809#post1900809

Start -> regedit -> HKEY_CURRENT_USER -> Software -> Crystal Dynamics -> Graphics -> right-click in the empty space of the right-hand window -> New -> DWORD (32-bit) Value -> Enter MultiCoreFlushMode and hit enter -> right-click on it and select Modify -> Change the value to 1

Edit: I've added this to the OP.
this tweak worked well through ShantyTown, but the section of the game after Shanty, in the caves, i started getting graphics corruption ...which of course sucks.

worked well for a while anyway, but had to remove it from the registry.

using a gtx680 btw.
 

luca_29_bg

Member
Aug 30, 2006
1,976
143
1,215
italy
multi core flush mode doesn't works for me, i have an i7 860 oc at 3.7 ghz, always 46 fps with maximum detail in some scene :(
 

Coldsnap

Member
Dec 11, 2008
5,263
0
0
Florida
Some reason I can't get above 24fps on my system. Playing on Normal, my computer is a i5 2500k GTX 560. Seems like I should be able to run it better..

Edit: I don't think MSI Afterburner is showing the right FPS because it doesn't change from 24 fps when I swap to low and normal.
 

Terbinator

Member
Dec 9, 2011
7,975
0
585
Some reason I can't get above 24fps on my system. Playing on Normal, my computer is a i5 2500k GTX 560. Seems like I should be able to run it better..
Get spongy performance myself.

320.00 drivers, the multicoreflush and i barely hit over 30FPS on highest settings @ 1440p with a 2500K and Titan - both at stock. Most reviews have the Titan as better than this on highest settings @ 1600p.
 

Mr. Robot

Member
Apr 22, 2011
1,456
0
0
Mexico
Core I3 2120 3.3GHz
Radeon HD 6870 1GB
8GB Ram

i get stable 60fps on most areas at High to Ultra settings at 1080p, and stable 30fps with TressFX enabled...
 

Van Owen

Banned
Aug 2, 2009
5,416
0
0
Picked this up during the GOG the other day.

Using a AMD 6970 the game will be running fine for 5 minutes or so in the 50-60fps range and then will suddenly drop to like 10fps and sort of hiccups. This all happens in the opening area. Tried messing with all the settings but it still keeps happening. When I switch something it runs ok again then five minutes later the framerate goes to shit.

Any suggestions?
 

Demon Ice

Banned
Aug 3, 2008
6,581
0
0
How's this game (and Bio Infinite) run with the bundled AMD card (7850 1 or 2GB, I believe)? I would assume it maxes out?
7850 probably can't run with TressFX and the contact hardening shadows at 1080p but everything else will be maxed or near max, plus FXAA.

A.WE.SOME!!

Ultra LOD in most cpu bounded scene goes from 47 fps to 65 fps using multicoreflush.
Did you notice any instability or corruption using that registry tweak? Do you have an Nvidia GPU?
 

scitek

Member
Aug 23, 2005
17,119
13
1,400
El Paso, TX
twitch.tv
lol, i turn off motion blur and screen effects and now im at 90fps from 24.
Turning off post-processing gets rid of AO, which can be a big performance hog, but makes a sizable difference visually, I think. I was going to say if you were stuck exactly at 24fps all the time, then it sounds like vsync is on with your refresh rate at 24Hz. Since you got it fixed, though, that must not have been it.
 

frontieruk

Member
Jul 18, 2007
4,211
7
1,030
7850 probably can't run with TressFX and the contact hardening shadows at 1080p but everything else will be maxed or near max, plus FXAA.
My 6950 must be magic then, as it managed just that, ok was only at ~30fps but coming from console gaming it made no difference to me being at that fps but the step up in IQ...
 

Anony

Member
Feb 5, 2008
3,499
0
0
I cant seem to launch the game

I start it, and a options windows opens
when i actually start to play, all i get is a black screen
I've tried multiple settings in the options (fullscreen, diff screen res, buffers, etc) nothing happens
tried to force dx9 (via regedit), nothing happens

checked task manager i can see it stops loading at 20mb with dx11, 42mb with dx9
also checked the integrity of the files on steam already, it's fine

i5-2500k, 6870, win7 64b with latest ati drivers (13.4)
 

Coolbgdog12

Member
Oct 10, 2011
4,676
0
0
Upgraded to a 7870 from a GtX 550 TI and man I can play the game almost maxed out at 2560x1440 around 40fps with Sweetfx and Tressfx!