Dark Souls internal rendering resolution fix (DSfix)

Mar 24, 2012
8,873
0
0
Seoul, ROK
Alright, I still can't get Dark Souls to play nice with my setup.

i5 2500K @ 4.5GHz
8GB 1600MHz RAM
R9 290X 1100MHz 4GB GDDR5 1350MHz

LG 29UM67-P 21:9 2560X1080@75Hz IPS monitor

I'm just getting a black screen even with DSfix. I uninstalled DS, deleted DSfix. Reinstalled the game and reinstalled DSfix and still nothing.

Does anyone have a similar set-up? If so, what settings do you use to get the game to work?
 

Alo81

Low Poly Gynecologist
Jun 24, 2012
13,143
0
640
steamcommunity.com
Alright, I still can't get Dark Souls to play nice with my setup.

i5 2500K @ 4.5GHz
8GB 1600MHz RAM
R9 290X 1100MHz 4GB GDDR5 1350MHz

LG 29UM67-P 21:9 2560X1080@75Hz IPS monitor

I'm just getting a black screen even with DSfix. I uninstalled DS, deleted DSfix. Reinstalled the game and reinstalled DSfix and still nothing.

Does anyone have a similar set-up? If so, what settings do you use to get the game to work?
Might have something to do with your ultra wide monitor. Make sure in game AA is turned off, perhaps try render and present resolution at a 16:9 res. I know the game doesn't natively support ultrawide res's.
 
Feb 5, 2013
2,159
1
0
So this is a bit odd...

Last year I played the GFWL version of Dark Souls for about 50 hours and during that time I was seeing 28-30fps.

I have recently installed Dark Souls again on the same pc, no hardware changes, but I am getting a consistent 15fps. I went into the dsfix.ini file and enabled the 60fps option. Now I am getting the regular 28-30fps.

I don't understand why this would happen, the only thing different on my end is that Dark Souls has been updated from GFWL to Steam and updated my display drivers. I also don't understand how enabling 60fps mode in an ini file could give me the performance I had a year ago lol.

(Extra info: Dark Souls 2 has stayed 30fps the whole time for me since release)
 
Feb 5, 2010
9,228
0
0
Finland
So this is a bit odd...

Last year I played the GFWL version of Dark Souls for about 50 hours and during that time I was seeing 28-30fps.

I have recently installed Dark Souls again on the same pc, no hardware changes, but I am getting a consistent 15fps. I went into the dsfix.ini file and enabled the 60fps option. Now I am getting the regular 28-30fps.

I don't understand why this would happen, the only thing different on my end is that Dark Souls has been updated from GFWL to Steam and updated my display drivers. I also don't understand how enabling 60fps mode in an ini file could give me the performance I had a year ago lol.

(Extra info: Dark Souls 2 has stayed 30fps the whole time for me since release)
You had probably unlocked the framerate in the GFWL version as well.
The way Dark Souls handles framerate by default is that if you for any reason can't maintain rock solid 30, it will drop straight to 15, nothing in between.
When you unlock it and cap it to 60 (or 30 or 45, or whatever, as long as it's unlocked), you can see variable framerates like 28.

So unlocking and capping through dsfix is always recommended, even if your rig can't run the game at 60.
 
Feb 5, 2013
2,159
1
0
You had probably unlocked the framerate in the GFWL version as well.
The way Dark Souls handles framerate by default is that if you for any reason can't maintain rock solid 30, it will drop straight to 15, nothing in between.
When you unlock it and cap it to 60 (or 30 or 45, or whatever, as long as it's unlocked), you can see variable framerates like 28.

So unlocking and capping through dsfix is always recommended, even if your rig can't run the game at 60.
I saw the note about possibly getting banned from GFWL by unlocking the framerate so I left it off. So I am thinking that my system is just not performing as well as it was a year ago. I know I need to upgrade but I have been lazy\not interested in spending the money.

I thought, "upgrade the pc or buy a ps4", so I bought a ps4. Now I still want to upgrade my pc lol.
 
Feb 5, 2010
9,228
0
0
Finland
I saw the note about possibly getting banned from GFWL by unlocking the framerate so I left it off. So I am thinking that my system is just not performing as well as it was a year ago. I know I need to upgrade but I have been lazy\not interested in spending the money.

I thought, "upgrade the pc or buy a ps4", so I bought a ps4. Now I still want to upgrade my pc lol.
If you left it off, then it's literally impossible for you to have gotten 28-30fps. Like I said, if you can't maintain solid 30fps, it drops like a rock straight to 15fps by default.
 
Jul 7, 2010
3,142
5
645
Just wondering if anyone has tried SGSSAA with this?

I have a GTX 970, and at 1080p if I enabled 4xSGSSAA I can barely hold 30fps. Is the game just that demanding? As a compromise, I have been able to enable 2xMSAA w/transparency MS. That plus DSfix's AA is certainly good enough, but was just wondering why supersampling is so demanding for such an old game.

I'm using this compatibility bit: 0x004000C0
 
Jan 19, 2015
15,314
2
0
Scotland
Got Dark Souls for PC yesterday (dropped it on PS3 years ago when I hit Blighttown... ugh)

> Copied the DSfix files into the main Dark Souls directory, but the game didn't even start (crashed)
> realised I hadn't moved the DSfix folder over, did this
> set res to 1080p just for testing
> game booted up
> clicked 'Load game'
> crashed

Just removed it and played vanilla for a bit. (Still fucking amazing, way better than I remember on PS3 years back, Bloodborne helped I think.)

I realised afterwards that I had in-game AA turned on. Tonight I might try turning that off. But would in-game AA be enough to prevent the game from loading at all beyond the frontend menu?

FYI
i5 4460k / 16GB RAM/ GTX 960
 
Mar 24, 2012
8,873
0
0
Seoul, ROK
Got Dark Souls for PC yesterday (dropped it on PS3 years ago when I hit Blighttown... ugh)

> Copied the DSfix files into the main Dark Souls directory, but the game didn't even start (crashed)
> realised I hadn't moved the DSfix folder over, did this
> set res to 1080p just for testing
> game booted up
> clicked 'Load game'
> crashed

Just removed it and played vanilla for a bit. (Still fucking amazing, way better than I remember on PS3 years back, Bloodborne helped I think.)

I realised afterwards that I had in-game AA turned on. Tonight I might try turning that off. But would in-game AA be enough to prevent the game from loading at all beyond the frontend menu?

FYI
i5 4460k / 16GB RAM/ GTX 960
In game AA makes mine crash every time.
 
Jan 19, 2015
15,314
2
0
Scotland
In game AA makes mine crash every time.
Yep, disabled AA, DSfix works perfectly

Dafuq

Game looks great

Now to keep bashing my head off Havel.

Anybody else get a diagonal deadzone with x360e and a DS4? Tempted to try InputMapper again but it didn't seem to work ideally for me.

Basically, Havel has killed me 3-4 times because I tap O to dodge front and diagonally and the game just doesn't register it. I can dodge ahead and horizontally, but it seems dodgy picking up forward-diagonal rolls. Maybe it's just I'm too used to Bloodborne.
 
Apr 27, 2007
5,169
0
0
So I thought I'd be adventurous and try the 60 FPS mode, even though I'm not sure I like the idea of it affecting animations etc. I'm getting crazy tearing though, do I have to enable V-sync or is there some workaround? Tried forcing fullscreen in the ini file but didn't help.
 
Apr 27, 2007
5,169
0
0
Instead of fullscreen, try borderless fullscreen.
Well, that's the default, no? Same thing there, thanks though. I actually have a problem in general with Windows 8 in that borderless window results in dropped frames (ingame counter is steady, but obvious 30 FPS at regular intervals) so maybe again this is due to some sync issue between game and Windows window compositing.

Gonna try forcing vsync in Nvidia panel later, see if the latency is acceptable.
 
Feb 5, 2010
9,228
0
0
Finland
Well, that's the default, no? Same thing there, thanks though. I actually have a problem in general with Windows 8 in that borderless window results in dropped frames (ingame counter is steady, but obvious 30 FPS at regular intervals) so maybe again this is due to some sync issue between game and Windows window compositing.

Gonna try forcing vsync in Nvidia panel later, see if the latency is acceptable.
Default? I don't remember. I've been carrying my dsfix.ini with me for so long that I have no idea what's the default.

Did you also turn the in-game setting from Fullscreen to Windowed?
Dsfix's borderless needs the in-game setting to be windowed.
 
Nov 10, 2011
6,321
0
0
Can't get it to work at all, I'm afraid. The game just crashes back to desktop without even fully starting so long as DSfix is active. In-game AA is off, all that jazz. It worked during a previous install, with an earlier version of DSfix, the only difference now is the Steamworks version of the game, and I'm running Win10 now. Not sure if there's anything else I should try.

Framerate aside, the game doesn't actually look as horrible as it could. I've got a 1440p monitor now, which is almost exactly double the game's own rendering resolution, so it's basically just doubling pixels. Jaggy, but actually pretty sharp, not as soft-looking as it was on my 1080p monitor.
 
Feb 7, 2012
2,148
0
0
I've used this wonderful fix for years, and have a quick question about optimizing for downsampling. I have a 780M (770GTX I guess?) and a decent amount of ram, but my fps is honestly pretty bad above 1080p. I do run with a myriad of texture mods and sweetfx etc., which I have tweaked before but don't seem to get very good results even turning AA down/off and turning dof down to below average. Should I just bag it until I get a better system?
 
Jul 7, 2010
3,142
5
645
I've used this wonderful fix for years, and have a quick question about optimizing for downsampling. I have a 780M (770GTX I guess?) and a decent amount of ram, but my fps is honestly pretty bad above 1080p. I do run with a myriad of texture mods and sweetfx etc., which I have tweaked before but don't seem to get very good results even turning AA down/off and turning dof down to below average. Should I just bag it until I get a better system?
I have a GTX970 and get frame drops even at 1080p, notably in Blighttown, Demon Ruins and Chasm of the Abyss. When I downsampled from 4K I couldn't even maintain 30fps, let alone 60. It's a game that will have to be brute-forced by future hardware.
 
Feb 5, 2010
9,228
0
0
Finland
I've used this wonderful fix for years, and have a quick question about optimizing for downsampling. I have a 780M (770GTX I guess?) and a decent amount of ram, but my fps is honestly pretty bad above 1080p. I do run with a myriad of texture mods and sweetfx etc., which I have tweaked before but don't seem to get very good results even turning AA down/off and turning dof down to below average. Should I just bag it until I get a better system?
What is a decent amount of ram? Is system ram shared with the gpu in the setup?
I don't know much about laptop configurations, but whenever I hear someone playing on laptop and is having a sub optimal experience, ram/vram is the first thing I think about. Second thing is the cpu.

You could install something like msi afterburner to monitor your system and see which ceiling you are pushing against.
 

TronLight

Everybody is Mikkelsexual
Oct 2, 2011
3,320
0
0
I have a GTX970 and get frame drops even at 1080p, notably in Blighttown, Demon Ruins and Chasm of the Abyss. When I downsampled from 4K I couldn't even maintain 30fps, let alone 60. It's a game that will have to be brute-forced by future hardware.
Oh so it's not just me... 970+2500k and At 1440p with VSSAO2, DOF resolution at 810 I'm getting some drops in the Undead Burg.
 
Oct 15, 2013
1,170
0
0
Toronto
Oh so it's not just me... 970+2500k and At 1440p with VSSAO2, DOF resolution at 810 I'm getting some drops in the Undead Burg.
Well, at least I'm not the only one. Playing with a 780 and a non-OC 4770 and the framedrops are pretty bad even at 1080p... Thinking about letting go of 60 FPS, at least the game will look amazing. Also, it will be a great game to replay after a GPU upgrade in the next few years.
 

Ogs

Member
Feb 9, 2009
4,809
0
695
UK
Bout time I sang Durante's praises, you the man man ! It changed a game from unplayable to totally playable, with icing on top. I've been playing this on a a bit of a banger PC (X4 640, AMD 5770), and it was basically unplayable, thanks to their V-Sync implementation. Turned it off thanks to this mod, totally playable, with gravy on top thanks to resolution boost and removing the stupid cursor from the screen.

Durante, I salute you.

 
Mar 25, 2013
5,385
1
0
IDK what happened, but when I updated DSFix and PVP Watchdog, now my Menu audio and Music is Mono and only comes out on right side. Actual gameplay audio is still in surround, but music and menu beeps being Mono is really going to be distracting. Anyone got this before and know how to fix?
 
Jun 1, 2013
1,334
0
0
So, I'm trying to play DS1 on my laptop. I had completed the game some years ago on my desktop with DSFix that worked wonders, but now I am having some problems, despite the laptop being arguably better than the desktop (desktop was Phenom II X4, 4GB RAM, 4870):

Laptop:
i7 4710 hq
8 GB RAM
860m Maxwell

I am having quite bad performance for the specs, even after lowering AA and AO quality. I am rendering at native res (1920x1080), and use normal settings in the DSFix cfg, without ecaggerations. Even when I lower them, I get bad performance at Firelink and Undead Burg. I would expect to get almost constant 60FPS but that is definitely not the case. I suspect that somehow the NVidia GPU is not being used, and the game uses the on-board Intel one. The NVidia GPU is the default adapter globally.

I have noticed that the cfg has an option for adapter use, but I am not sure if it's what I need, and I don't exactly understand the syntax:
# D3D adapter override
# -1 = no override
# N = use adapter N
# this setting is for multiple (non-SLI/crossfire) GPUs
# everyone else should leave it at -1
d3dAdapterOverride -1

Should I instead of -1 type the name of the adapter that I want to use (the 860m)? How should I type it?

Edit: Nevermind, it was a power setting of the laptop... Sorry!
 
Feb 6, 2011
2,686
0
0
I haven't played DS in a long while now, but I updated DSFix and have some questions.

I have enabled borderless fullscreen, but I still get a window with a border when I play. Is there any way to solve this?

Last time I played DS, I used a 360 pad. Now I use a DS4, but the game doesn't recognise it or respond to button presses. Any way to fix this?
 
Jan 18, 2015
510
0
0
I tried playing dark souls on my old laptop and I get around 10-15fps. Laptop is core i7, 6gb ram and nvidia 520m and intel hd 3000. Is there anything I can do to make it run faster?
 
Jan 13, 2015
1,927
0
255
I tried playing dark souls on my old laptop and I get around 10-15fps. Laptop is core i7, 6gb ram and nvidia 520m and intel hd 3000. Is there anything I can do to make it run faster?

I have a similar laptop and no matter what i tried the game dropped to 15 fps after 3 seconds.

In the end i just gave up. I hope someone finds a solution for you
 
Feb 5, 2010
9,228
0
0
Finland
You can decrease the rendering resolution from the dsfix ini and then upsample to whatever your laptops native res is. Obviously it will not look as good as native res, but hey. Also make sure you disable any extra stuff dsfix might have enabled by default.

Then just unlock the fps and use the borderless fullscreen option from dsfix, and that's probably the best you can do.
 
Aug 17, 2011
22,258
0
0
can't run this with any of the dsfix changes so i just wanna delete it entirely, but how do I do that?

I deleted the DSfix folder and the two configuration things and uninstalled and re-installed the game but it's still giving me errors cause i guess i don't have dsfix anymore or am missing a part or something


it says in steam the game is running when it's not
 
Dec 7, 2010
1,350
0
0
I need help with Dsfix, want to replay Dark souls and this time I'm going to troubleshoot.

Dsfix 2.4 (placed contents in Data folder)
dspte 2.0
Added darksouls.exe to DEP (Data execution prevention)
AA is off in Dark souls
Checked file integrity

Changing settings in the dsfix.ini has no effect in game, not the resolution, skip intro, mouse etc except the frame unlocker but the game runs in double speed *insert Benny Hill theme. Anyone got any ideas?
 
Jul 18, 2004
1,124
0
0
Orlando|FL
I need help with Dsfix, want to replay Dark souls and this time I'm going to troubleshoot.

Dsfix 2.4 (placed contents in Data folder)
dspte 2.0
Added darksouls.exe to DEP (Data execution prevention)
AA is off in Dark souls
Checked file integrity

Changing settings in the dsfix.ini has no effect in game, not the resolution, skip intro, mouse etc except the frame unlocker but the game runs in double speed *insert Benny Hill theme. Anyone got any ideas?
You using the beta (non-GFWL) version of Souls?
 
Feb 5, 2010
9,228
0
0
Finland
I need help with Dsfix, want to replay Dark souls and this time I'm going to troubleshoot.

Dsfix 2.4 (placed contents in Data folder)
dspte 2.0
Added darksouls.exe to DEP (Data execution prevention)
AA is off in Dark souls
Checked file integrity

Changing settings in the dsfix.ini has no effect in game, not the resolution, skip intro, mouse etc except the frame unlocker but the game runs in double speed *insert Benny Hill theme. Anyone got any ideas?
I don't know if it matters for your specific problem, but are you saying you are on the dspte 2.0 branch on Steam? That's an old branch that they put up during steamworks migration, the actual public branch is newer.
 
Apr 11, 2013
9,816
0
400
West Virginia
I need help with Dsfix, want to replay Dark souls and this time I'm going to troubleshoot.

Dsfix 2.4 (placed contents in Data folder)
dspte 2.0
Added darksouls.exe to DEP (Data execution prevention)
AA is off in Dark souls
Checked file integrity

Changing settings in the dsfix.ini has no effect in game, not the resolution, skip intro, mouse etc except the frame unlocker but the game runs in double speed *insert Benny Hill theme. Anyone got any ideas?
Hmm. You should replay at double speed. Would make for a funny Twitch stream or YouTube series.
 
Dec 7, 2010
1,350
0
0
I don't know if it matters for your specific problem, but are you saying you are on the dspte 2.0 branch on Steam? That's an old branch that they put up during steamworks migration, the actual public branch is newer.
What I did was go into Properties -> Beta -> dspte 2.0

I remember I left it there when they migrated.
 
Dec 7, 2010
1,350
0
0
That's an old branch now, you should probably opt out of the beta.
Though again, I don't know if it's actually the cause for your problems.
Found this
CASE 3: For users who purchase Dark Souls™ Prepare To Die Edition on or after February 16th (this will be the steam only version):

1) Launch Dark Souls™ Prepare To Die Edition from Steam

Ok launched (opted out of the beta) and I encounter the same problem ... maybe I should do a twitch run with double speed :p
 
Feb 5, 2010
9,228
0
0
Finland
Opt out? How do you do that? Does it now just automatically default to what it's supposed to?
The public, normal branch has been Steamworks since February 2015, the beta branch was only necessary during the migration.

If you are installing the game normally, it will just be the normal public branch by default.
Ok launched (opted out of the beta) and I encounter the same problem ... maybe I should do a twitch run with double speed :p
Sorry to hear it didn't help. Afraid I haven't heard anyone else with this problem.
Could be some kind of weird OS or even bios related issue, hard to say.
 

Unai

Member
Jan 30, 2011
4,872
1
0
Unaí/MG
So the beta is older? Outside of the beta my games crashes when I try to load a save or even when I try to start a new game.

Do people in the Beta can play with people that are not on it?
 
Dec 8, 2008
14,633
0
0
Bay Area
Brand new here. It is still locked at 30fps in-game, though the menu was 60fps for some reason?

This is what I've done:
- installed DS
- set it to use the beta version in Steam
- installed DSfix, set resolution to 2560x1440. framerate to unlocked, default at 60fps.
- turned off AA in-game

Any suggestions? Thanks.

edit: if it matters, I'm using a 2500k @ 4.3ghz and a 970.