• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.

Metro: Last Light PC performance thread

Smokey

Member
Nov 15, 2005
41,212
1
1,205
www.twitch.tv
What about an SLI-setup with a pair of 680s. For example.
How does the card hold up against that? Out of curiosity. Used in a multi monitor setup that is.
I dunno, there are tons of articles out there. 2 680s are faster than a single Titan but I'm sure you already knew that.

Some people don't want to mess with sli. Some people dont want the extra heat or extra power requirements. Some people want a good compute card in addition to the fastest single GPU. There's nothing wrong with that.
 

AndyBNV

Nvidia
Sep 26, 2012
1,232
0
0
The game has been Re-Benchmarked with the AMD Patch. Resulting in a quite Massive improvement.
Gold star for content theft, sure the author loves people ripping off his/her work without any kind of source or accreditation.
 

Mad Max

Member
Sep 3, 2006
1,339
0
0
I get 46fps @very high,1920x1200 with my OC'ed 7950 and old ass 955BE, so that's definitely a big improvement compared to when the game came out.
 

haikira

Member
Nov 17, 2005
3,991
0
0
UK
I've started having crashes, post patch. Not a system crash, just the game locks up and i have to close it in task manager. Played many hours before the patch, without any problems. Now i can't go more than 20 minutes.
 

timcsavage

Member
Mar 26, 2011
312
0
0
UK
I'm not sure if it's just placebo effect but I'm pretty sure my game smoothed out after uninstalling Classic Shell (on Windows 8 x64).

I did this after the latest patch which did help with performance but it seems so much better now. I should note I've not done another big outdoors section but I got stutter everywhere.
 

d00d3n

Member
Apr 27, 2011
5,814
0
595
Sweden
My i5 3570k, 8 gig ram, geforce 580 (asus directcu II) sli system just crashed in metro last light. I have experienced the green squares freeze before with obvious visible squares in black ops 2, and this was the same thing. The crash occurred during the stage performance. I am using the latest nvidia drivers that were released today.

So ... I guess voltage hacking with msi afterburner is back. The geforce 500 series is as useless as ever.
 
May 22, 2011
7,255
0
0

RoKKeR

Member
Oct 17, 2012
23,406
1
0
I'm amazed at this game's performance, especially after just playing Metro 2033 with, well, shitty optimization. Everything maxed out, SSAO off (I honestly don't see the need for it, I have a hard time spotting bad jaggies) at 1200p and things are running smoothly. 50-60fps average, dips in combat.

570
i52500k
 

Smash88

Banned
Dec 6, 2008
5,867
0
0
Canada
Just got my new computer and I wanted to test it.

CPU: i7 4770k @ 4.1Ghz
GPU: GTX Titan
RAM: 16GB DDR3 2133Mhz

SSAA OFF:



SSAA ON:

 

Demon Ice

Banned
Aug 3, 2008
6,581
0
0
Performance wise the game runs beautifully for me, very pleasantly surprised given that I have an extremely old processor.

Core2Quad Q8200 (I think) @ 2.4 Ghz
4 GB DDR2
GTX 660 Ti 2GB

Running it at very high at 1680x1050 with High Tessellation and PhysX on.


However I have had a pair of CTDs where I got a popup saying my graphics driver had crashed and had to be recovered. I'm using the latest 320.18 drivers. I also have random minor shadow flickering with the flashlight. Nothing major.

I was having massive artifacting with the 320.14 beta drivers for some reason but going up to the official release fixed that.
 

CaptainZombie

Member
Oct 3, 2010
1,167
0
575
I got to Venice and now I keep getting all kinds of different crashes. This game ran flawlessly till Saturday night with almost max settings @ 1080p. Not sure what happened here.

I had the most updated NVIDIA drivers and then went to beta 320.49 which haven't helped either on my EVGA 770.

I even uninstalled the game and reinstalled. I even did the repair in Steam.

One of the error messages that I am getting is

"Previous Launch was unsuccessful. Would You like to start in safe mode."
 

Cannon Goose

Member
Nov 28, 2011
4,093
0
0
Australia
This game's performance is kind of strange, it seems to perform flawlessly during certain parts that look like they should be taxing but then it chugs during parts that aren't so complex. I even have Advanced Physx and Tesselation turned off and I still get these odd dips.

Luckily for the most part it's really smooth, certainly better than Metro 2033, but I still find the dips to be a bit random.
 

CaptainZombie

Member
Oct 3, 2010
1,167
0
575
This game's performance is kind of strange, it seems to perform flawlessly during certain parts that look like they should be taxing but then it chugs during parts that aren't so complex. I even have Advanced Physx and Tesselation turned off and I still get these odd dips.

Luckily for the most part it's really smooth, certainly better than Metro 2033, but I still find the dips to be a bit random.
I turned everything off for now to see if it does anything, but with the 770, there should be no issues.
 

FuzzyNorman

Member
Jun 9, 2009
2,235
0
0
I just started this game. I'm using a 680m gpu, and whenever I started the first hour I was getting a steady 45fps with the settings I had. I then decided to upgrade my drivers to the current ones because I have upgraded in awhile. Now whenever I play, there are some spots that drop down to a steady 13fps. It is pretty much unplayable and annoying. It is really this unoptimized?
 

knitoe

Member
Feb 22, 2006
8,117
0
1,145
I just started this game. I'm using a 680m gpu, and whenever I started the first hour I was getting a steady 45fps with the settings I had. I then decided to upgrade my drivers to the current ones because I have upgraded in awhile. Now whenever I play, there are some spots that drop down to a steady 13fps. It is pretty much unplayable and annoying. It is really this unoptimized?
Try reinstalling the drivers with the custom > clean option.
 

Damian.

Banned
Jun 19, 2012
2,137
0
0
Anyone with an Nvidia GPU experiencing lighting flicker? It seems similar to the bug that AMD users were seeing when the game first launched, only with lights and not shadows.

Video here.
Not to that extreme, but definitely some spots that distracted me with a 680 and the latest driverset throughout my playtime.
 

Gvaz

Banned
Apr 7, 2010
11,619
0
0
USA
gvaz.notsleepytime.org
I think most people expect some kind of visual anomalies with larger fov's, especially with player models/guns so it's not such a big deal. I'm just happy knowing we can eventually change it so it makes the game less vomit inducing.

I do wish these devs would learn that 90 is a much better fixed FOV than 60/70 though. The line about performance is very telling and it's obvious they designed the narrow FOV with console limitations in mind.
The reason they put it so low is because they develop for consoles, and consoles you generally don't play at arm's length like PC games.
 

Starviper

Member
Mar 26, 2013
2,760
0
0
Minneapolis, Minnesota
So i've been getting a really stupid problem. Tried reinstalling/cleaning out all my drivers too. I have a GTX 770 and if I turn on PhysX in this game after a few seconds of the game running it seems like something loads up in the game engine and causes it to lag for no obvious reason. It was running fine for awhile, so not sure what the cause is but I'd really like to be able to make use of the card I have. This PhysX shit should be cake for it.
 

Gvaz

Banned
Apr 7, 2010
11,619
0
0
USA
gvaz.notsleepytime.org
I just ran the benchmark for shits and giggles:

Options: Resolution: 1920 x 1200; DirectX: DirectX 10; Quality: Very High; Texture filtering: AF 16X; Advanced PhysX: Disabled; Tesselation: Not supported; Motion Blur: Low; SSAA: OFF;
Physx because I'm running an HD4890 (also DDR3 and an i5 3570k @ 4.2), and I only have a 10.1 card and will have one for the foreseeable future (at least till the end of the year most likely), and motion blur low because motion blur sucks. SSAA also for the same reason I'm running an HD4890

Total Frames: 6541, Total Time: 171.2408 sec
Average Framerate: 38.23
Max. Framerate: 73.12 (Frame: 25)
Min. Framerate: 7.29 (Frame: 150)
What isn't shown here, in most cases I was getting 35-45fps and some cases a consistent 50+ fps. With my aging hardware, this is very very impressive.
 

Sullichin

Member
Sep 11, 2004
11,860
0
0
Apologies for the bump. Posted in the Steam thread before I saw this one:

Getting horrible performance no matter what I do - even low settings on 720p with no AA - the game eventually goes to about 15-20fps and stays there. Same thing on very high settings/1080p. I'll get nearly 60fps and it's great but after a few minutes it locks at a really low framerate. HD7950, i52500k, using the latest Catalyst beta because it's supposed to improve LL performance... anyone have any ideas? :(
 

Dries

Member
Dec 8, 2009
2,617
2
685
Netherlands
Hey guys, I was wondering if I could get the most ultra settings and get around 45 fps with my rig. 60 fps is no requirement, everything between 40-45 will be golden. Will I get that with a:

i5 2500k 3.3 ghz (NOT overclocked)
8 GB ram
GTX 770 2 gig
Playing at 1920 x 1080

Thanks!
 

Corpekata

Banned
Jun 7, 2013
20,288
0
0
Hey guys, I was wondering if I could get the most ultra settings and get around 45 fps with my rig. 60 fps is no requirement, everything between 40-45 will be golden. Will I get that with a:

i5 2500k 3.3 ghz (NOT overclocked)
8 GB ram
GTX 770 2 gig
Playing at 1920 x 1080

Thanks!
I have the same card. I can run everything at max save for Supersampling, which is one of those "Fuck your rig" type of settings that I'd wager most people will not be enabling, let alone maxing. I can enable it and get 45-50 most of the time at 2x but can't really go any higher.
 

Dries

Member
Dec 8, 2009
2,617
2
685
Netherlands
I have the same card. I can run everything at max save for Supersampling, which is one of those "Fuck your rig" type of settings that I'd wager most people will not be enabling, let alone maxing. I can enable it and get 45-50 most of the time at 2x but can't really go any higher.
Sounds sweet. Are you also using the same CPU as me?
 

diggmcbadass

Member
Jan 17, 2013
3,065
0
425
No, if offers other types as well. I can't remember which ones specifically, but at least all the standard options.
 

Mohonky

Member
Jan 19, 2007
11,302
816
1,285
i7 4770
16gb ram
GTX670

This game runs like ass. The original did too. Changing settings didnt seem to fix much. Initially out in the field I was getting 60fps there abouts, as soon as I am indoors, less than 30fps, at times I reckon I would be lucky to hold 20fps.