• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • Hey Guest. Check out the NeoGAF 2.2 Update Thread for details on our new Giphy integration and other new features.

Metro: Last Light PC performance thread

Zefah

Gold Member
Jan 7, 2007
44,425
25,236
1,805
New update: AMD fixes and FOV
A patch has been released on Steam to fix issues with AMD hardware, and improve performance for these cards. It's live now, but might take a few minutes to reach everyone. Restart your client or verify local files if it doesn't download automatically.

It also fixes a shadow visual corruption bug on AMD 7xxx cards, and fixes an issue with the game starting only in 3:1 resolution on some TVs.

In addition, you can now customize the FOV this way:

After starting the game up, the user.cfg will be updated with the r_base_fox attribute. You can find this in %LOCALAPPDATA%\4A Games\Metro LL\. Tweak it at your leisure!

http://steamcommunity.com/app/43160/discussions/0/810924774395015649/

---------

r_base_fov 69 = 95 HOR FOV I believe. It's the setting I'm using and looks great.

Yay! I really hope this fixes my issues with the shadows. I've been waiting for that to start playing the game.
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
Are you getting spikes and stutters during gameplay?
The benchmark is meant to stress cards like hell... and is not indicative of in game performance.
I'm pretty sure it's an in game scene we'll encounter in the game. And yes they remain in game, even just sitting in the main menu. Are you saying you have them in the benchmark but not in game?
 
May 22, 2011
7,255
0
0
PCGamesHardware tested a up to ~60(!!)% higher framerate on AMD after downloading the patch:



No difference for nvidia. To me it looks like they accidentally shipped it with some bug affecting AMD cards, which they quickly fixed.
 

Aklamarth

Member
Jan 2, 2010
865
16
540
angular graphics said:
To me it looks like they accidentally shipped it with some bug affecting AMD cards, which they quickly fixed.

<conspiracy>

Or nVidia paid to have the game broken at launch on AMD hardware.

</conspiracy>
 

Smokey

Member
Nov 15, 2005
41,213
1
1,515
www.twitch.tv
I am testing my 580s that I have up for sale..ran the Metro benchmark on High settings, Phsyx On, Very High Tesselation and got an average frame rate of 31fps in NV Surround (5760x1080). The benchmark is more intensive than the game. That's not bad at all..

Still had the issue where the 2nd GPU was being used more than the first so it's definitely not a card issue (had the same issue on the Titans).
 

Futurevoid

Member
Dec 7, 2005
24,351
0
0
www.lcvg.com
Nothing here for me and that's with 2 GTX 670s.

Not touching this game 'til 4A or NVIDIA get their crap together.

I'm gonna try dumping back to the previous official driver and see what I get. I just played 2033 prior to Last Light shipping to me and it ran flawlessly at 30fps locked with max settings and no AA outside of the default AAA algorithm they use. It's technically the same engine though likely with some substantial modifications?

I should try 2033 and see how that runs for me on the beta drivers.
 

plumpblumpkin

Member
Nov 30, 2012
429
0
0
Anyone getting stuttering with a gtx 680? It's quite irritating. I'm using the latest drivers and new game update 3570k @ 4.4ghz.

 

Xyber

Member
Aug 24, 2011
5,278
0
0
Sweden
Went from running like shit on Normal/High with no SSAA for me to now running decent on Very High with X2 SSAA

Resolution and fps is more important to tell than just saying it's "decent".

Something running decent to me is ~45-50fps and I really doubt you get that in most areas with very high and 2xSSAA. Heck, my 680 (OC'd to 1260MHz) have to work like crazy in this place I'm in now with those settings to maintain 50+. My guess is that you would get maybe 20fps or lower here and that is faaar from playable to many on PC. :p

Anyone getting stuttering with a gtx 680? It's quite irritating. I'm using the latest drivers and new game update 3570k @ 4.4ghz.

http://img15.imageshack.us/img15/8152/capturecxv.png[IMG][/QUOTE]

Yes, some stuttering here as well.
 

Jubbly

Member
Nov 21, 2007
1,149
0
0
I have a 7970 GHz Edition and SLI 680s. Both stutter, so I'm thinking it's a game issue instead of a Nvidia one, though the stuttering was far worse on the 680s.
 

Futurevoid

Member
Dec 7, 2005
24,351
0
0
www.lcvg.com
Ok, this is fucking weird. For those that installed the beta drivers, do you have a listing for PhysX in your installed programs?

I don't. I even downgraded to the previous official drivers and I still have zero listing for PhysX despite knowing it's been there before!
 

Mr. Plankton

Neo Member
Mar 26, 2012
41
0
0
Ok, this is fucking weird. For those that installed the beta drivers, do you have a listing for PhysX in your installed programs?

I don't. I even downgraded to the previous official drivers and I still have zero listing for PhysX despite knowing it's been there before!

That's happened to me before. It's still "there", I believe, but I couldn't launch Metro 2033 at first because it said the PhysX .dll was missing. You can to where you extracted the driver package, locate the PhysX folder, then uninstall and re-install it using the executable.
 

Futurevoid

Member
Dec 7, 2005
24,351
0
0
www.lcvg.com
That's happened to me before. It's still "there", I believe, but I couldn't launch Metro 2033 at first because it said the PhysX .dll was missing. You can to where you extracted the driver package, locate the PhysX folder, then uninstall and re-install it using the executable.

I ended up uninstalling the driver and using Driver Fusion to clean out all of the Nvidia and PhysX files. I reinstalled the driver and everything was back to normal.

Still get stuttering and hitches on Very High like crazy. Setting to High now seems to make the game a bit more playable as it removes the stuttering for the most part but it still hitches like mad. Very much like it's trying to load something and 5 or so frames are dropped. It's fucking annoying.:(

I've been meaning to clean out the desktop for awhile so I may go ahead and do a clean install of Windows this weekend anyway (and contemplate whether I care to jump to Windows 8 or not) but I'll see what happens after the clean install.
 

plumpblumpkin

Member
Nov 30, 2012
429
0
0
I ended up uninstalling the driver and using Driver Fusion to clean out all of the Nvidia and PhysX files. I reinstalled the driver and everything was back to normal.

Still get stuttering and hitches on Very High like crazy. Setting to High now seems to make the game a bit more playable as it removes the stuttering for the most part but it still hitches like made. Very much like it's trying to load something and 5 or so frames are dropped. It's fucking annoying.:(

I've been meaning to clean out the desktop for awhile so I may go ahead and do a clean install of Windows this weekend anyway (and contemplate whether I care to jump to Windows 8 or not) but I'll see what happens after the clean install.

Same here man...same here...
 

Zefah

Gold Member
Jan 7, 2007
44,425
25,236
1,805
Game runs well now without any of that crazy shadow flickering on my 7970. Very happy to finally be able to play it.

I read there was supposed to be a r_base_fov line in the user.cfg, but I see nothing of the sort in my file. Would adding it manually allow me to adjust the fov?
 

kitanii

Banned
Mar 2, 2008
113
0
0
Game runs well now without any of that crazy shadow flickering on my 7970. Very happy to finally be able to play it.

I read there was supposed to be a r_base_fov line in the user.cfg, but I see nothing of the sort in my file. Would adding it manually allow me to adjust the fov?

After the update that variable is added to the "user.cfg" located in "C:\Users\username\AppData\Local\4A Games\Metro LL\1100001005bfb04" and it's created when you run the game the first time after the patch.
 

Damian.

Banned
Jun 19, 2012
2,137
0
0
I ended up uninstalling the driver and using Driver Fusion to clean out all of the Nvidia and PhysX files. I reinstalled the driver and everything was back to normal.

Still get stuttering and hitches on Very High like crazy. Setting to High now seems to make the game a bit more playable as it removes the stuttering for the most part but it still hitches like made. Very much like it's trying to load something and 5 or so frames are dropped. It's fucking annoying.:(

I've been meaning to clean out the desktop for awhile so I may go ahead and do a clean install of Windows this weekend anyway (and contemplate whether I care to jump to Windows 8 or not) but I'll see what happens after the clean install.

I get that too. I notice it for example when I turn a corner, and the game will freeze for a split second and I miss several frames and I jerk around the corner instead of making a smooth transition. Gets annoying after a while, because instead of playing the game, you start to wait for the hitch. GPU water torture!
 

Aquanox

Junior Member
Aug 24, 2007
275
3
1,060
Lima, Perú
After the Patch, Benchmarks results are fairly similar, but In-Game performance has massively improved, and now CrossfireX does work (Still room to improve)

After a bit of work I think AMD hardware will match nVidia's in this game without much hazzle.
 

kitanii

Banned
Mar 2, 2008
113
0
0
So whats a good fov value to use?

I play at 1920x1080

Well, the default when using that resolution is 50.625 which I personally think works very well since it was designed with this in mind. It's a hell of a lot better than in Metro 2033 at least. Tried using 70 which is low for most modern games, but that made it look extremely fishy so to speak. So perhaps 55 or 60?
It's all a matter of preferences.
 

Xdrive05

Member
Nov 1, 2005
7,368
396
1,675
36
What's the core utilization like in this game? (for the 8-core AMD users and i7 users)

Crysis 3 was pretty good at using more than four threads/cores. Same thing here? Are we dipping into the post-4-core world yet?
 

TheVampire

Banned
Dec 14, 2009
8,693
0
0
Australia
www.youtube.com
Well, the default when using that resolution is 50.625 which I personally think works very well since it was designed with this in mind. It's a hell of a lot better than in Metro 2033 at least. Tried using 70 which is low for most modern games, but that made it look extremely fishy so to speak. So perhaps 55 or 60?
It's all a matter of preferences.

I think 60 looks pretty good.
 

Dragon1893

Member
Feb 20, 2013
12,388
0
0
would I be better off buying the 360 version or running this game at maybe a combination of medium and high on a 560ti?

If you take a look at the face off I posted above the 360 version has a pretty bad frame-rate. PS3 version runs better but I'd say definitely go with PC.
 

bob_arctor

Tough_Smooth
Jun 7, 2004
18,636
2
0
48
Has anyone posted the best possible FOV? By this I mean, the highest you can get before you start creeping outside visual borders on-screen. For example, using a 70 FOV, I can see the "box" of the blood filter when Artyom is getting smacked around in cut-scenes.

Great game, btw. Playing on Ranger, its still too easy but at least hints are gone.
 

timcsavage

Member
Mar 26, 2011
312
0
0
UK
Don't laugh

CPU: Phenom X4 @ 3.2Ghz
GPU: HD7850 2GB
RAM: 6GB DDR3
Resolution: 1920x1080
Settings: Normal tesselation, no SSAA.
Framerate: avg: 26.7 max: 66.12, min: 7.21

It stutters like crazy. I have cat 13.5 beta 2, disabled my Logitech drivers. Vsync doesn't do much, it's horrible. Same at lowers resolutions on lower presets.
 

kitanii

Banned
Mar 2, 2008
113
0
0
Using a GTX 660 Ti I had flickering lighting at a couple of areas when I looked at certain angles. Turning down tesselation to normal instead of high or very high removed the flickering. Sure. Now only the characters are being tesselated, but it's better than faulty lights. Thought I'd share and spare someone a headache.

EDIT:
Sorry. False alarm. Still persists at some points while it did in fact remove the issue at others.
 

Elsolar

Member
Jan 16, 2012
411
0
0
would I be better off buying the 360 version or running this game at maybe a combination of medium and high on a 560ti?

I'm playing the game on a 560Ti and it runs great on high quality, advanced physx, no SSAA or tessellation at 1080p. 50 - 60 hz in most indoor scenes, 40 - 50 outdoors. Drops into the low/mid 30s during intense combat. And man does it look gorgeous.

Has anyone posted the best possible FOV? By this I mean, the highest you can get before you start creeping outside visual borders on-screen. For example, using a 70 FOV, I can see the "box" of the blood filter when Artyom is getting smacked around in cut-scenes.

I've been playing with r_base_fov=59 (equivalent to 90 degrees horizontal) at 16:9 and I haven't noticed any weird near-FOV glitches or shrunken post processing.
 

Hypron

Member
May 9, 2012
11,839
0
520
If You dont have integrated GPU (before Haswell) its always better to run game on PC. With this GPU? Its not even a question.

This. It blows my mind that someone would even ask a question like that this late into the gen.
 

Futurevoid

Member
Dec 7, 2005
24,351
0
0
www.lcvg.com
So you want to fix the stuttering and hitches? Well, the solution is to do a complete clean installation of Windows.

I backed up everything this afternoon and did a clean install of Windows 7 Pro. Installed the latest beta drivers along with all of the available Windows Updates. Metro is the only game installed on the rig at the moment and the only thing I'm running alongside it is D3DOverrider.

Using Very High Settings, Tessellation set to Normal, no SSAA and no PhysX and the games runs completely smooth as butter and an almost flawless 60fps. No stuttering, no hitching...nothing on my 680 with an i5 2500k running at 4.5ghz.

I do get a very, very slight hitch every now and again when the game loads but in comparison to how this was playing for me previously? It's freaking night and day. Obviously something on the computer was causing the stutter/hitch but I can't for the life of me tell you what.

I'm going to count my blessings and play...
 

kitanii

Banned
Mar 2, 2008
113
0
0
So you want to fix the stuttering and hitches? Well, the solution is to do a complete clean installation of Windows.

I backed up everything this afternoon and did a clean install of Windows 7 Pro. Installed the latest beta drivers along with all of the available Windows Updates. Metro is the only game installed on the rig at the moment and the only thing I'm running alongside it is D3DOverrider.

Using Very High Settings, Tessellation set to Normal, no SSAA and no PhysX and the games runs completely smooth as butter and an almost flawless 60fps. No stuttering, no hitching...nothing on my 680 with an i5 2500k running at 4.5ghz.

I do get a very, very slight hitch every now and again when the game loads but in comparison to how this was playing for me previously? It's freaking night and day. Obviously something on the computer was causing the stutter/hitch but I can't for the life of me tell you what.

I'm going to count my blessings and play...

Try turning on advanced physx. Just to see if it makes it any different.
 

The Janitor

Member
Jun 29, 2011
2,595
809
855
Not a fan of the AA solution.. blurry as hell and SSAA is way too demanding. Would have rather had 4xMSAA like in Metro 2033.
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
I also just reached this one area where the framerate dropped like a rock for absolutely no reason, it was still just tunnels and things, nothing really fancy. It didn't last long though, just a couple corridors. But it was BAD.
 

plumpblumpkin

Member
Nov 30, 2012
429
0
0
So you want to fix the stuttering and hitches? Well, the solution is to do a complete clean installation of Windows.

I backed up everything this afternoon and did a clean install of Windows 7 Pro. Installed the latest beta drivers along with all of the available Windows Updates. Metro is the only game installed on the rig at the moment and the only thing I'm running alongside it is D3DOverrider.

Using Very High Settings, Tessellation set to Normal, no SSAA and no PhysX and the games runs completely smooth as butter and an almost flawless 60fps. No stuttering, no hitching...nothing on my 680 with an i5 2500k running at 4.5ghz.

I do get a very, very slight hitch every now and again when the game loads but in comparison to how this was playing for me previously? It's freaking night and day. Obviously something on the computer was causing the stutter/hitch but I can't for the life of me tell you what.

I'm going to count my blessings and play...

Hey, do you have V Sync forced in Overrider?? or in the game?