• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • Hey Guest. Check out the NeoGAF 2.2 Update Thread for details on our new Giphy integration and other new features.

Metro: Last Light PC performance thread

Thrakier

Member
Jun 9, 2006
11,339
0
1,275
steamcommunity.com
as soon as next gen games hit the market and the PC gets some multiplats/ it would be wise to upgrade.

I will, of course. But the new Metro really doesn't look THAT great and in comparison to the console power it's also running on, 60FPS on a 660ti (if you get rid of some of the bells and whistles) should be just a standard.
 

plumpblumpkin

Member
Nov 30, 2012
429
0
0
I have to say, the FOV is terrible. I'm already feeling sick just within the first 15mins...

Come on 4A.. Do you even WANT me to play your game? At this rate, I'm just gonna put it aside just as I did 2033 because of something so simple can't be fixed..

Jesus.
 

SLV

Member
Feb 18, 2011
1,862
0
0
Latvia
BTW guys, the most stupid possible problem, if you are getting like only 50 % at max GPU usage, and if you have a logitech gaming keyboard, close down the logitech series display app. Seriously ! Shot up from 20 Fps at max to silky smooth 60 !
 

Smokey

Member
Nov 15, 2005
41,213
1
1,515
www.twitch.tv
Just a heads up. Apparently if you use a logitech g19 keyboard the software that is running kills performance in this game. You need to disable it. Lcore. Exe

Multiple users at ocn have disabled it and ha e reported huge gains in performance.
 

Zefah

Gold Member
Jan 7, 2007
44,461
25,342
1,805
Has there been any official recognition of the shadow flickering/corruption issue from either the developer or AMD?
 

SLV

Member
Feb 18, 2011
1,862
0
0
Latvia
Just a heads up. Apparently if you use a logitech g19 keyboard the software that is running kills performance in this game. You need to disable it. Lcore. Exe

Multiple users at ocn have disabled it and ha e reported huge gains in performance.

Yes, what i just said :D I dont know why it affects it, but it is true !
 

kitanii

Banned
Mar 2, 2008
113
0
0
Well, is there a way to do that?
I'd much rather disable it's own aa-solution and use SMAA via sweetfx since I discovered it
gives the same effect as 4xMSAA (at least in Hitman Absolution and BF3 that is), but with an overall sharper image. @1080p.
 

jim2point0

Banned
Jan 23, 2013
10,744
0
0
Here
www.flickr.com
Well, is there a way to do that?
I'd much rather disable it's own aa-solution and use SMAA via sweetfx since I discovered it
gives the same effect as 4xMSAA (at least in Hitman Absolution and BF3 that is), but with an overall sharper image. @1080p.

No way at all to disable it. You can still use SMAA. You might want to enable a small amount of LumaSharpen to counter FXAA blur.
 

Zefah

Gold Member
Jan 7, 2007
44,461
25,342
1,805
Has there been any official recognition of the shadow flickering/corruption issue from either the developer or AMD?

Replying to myself, but I found a statement from AMD.

http://www.overclock.net/t/1391248/metro-last-light-lag-on-ati-cards/10#post_19970228

AMD said:
The shadow flickering/artifacting in MLL is an application issue, not a driver issue. The developer has committed to working with us to fix it.

Hopefully they get this sorted out fast so I can actually play the game without having to switch to DX9 or whatever.
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
Just a heads up. Apparently if you use a logitech g19 keyboard the software that is running kills performance in this game. You need to disable it. Lcore. Exe

Multiple users at ocn have disabled it and ha e reported huge gains in performance.
Not seeing a difference, though my lcore is from my mouse gaming driver (g400), not keyboard. Guess the AMD issues override the lcore issues for me.
 

Zefah

Gold Member
Jan 7, 2007
44,461
25,342
1,805
Something interesting I'm seeing in the benchmark:

Options: Resolution: 1920 x 1200; DirectX: DirectX 11; Quality: Very High; Texture filtering: AF 4X; Advanced PhysX: Disabled; Tesselation: Not supported; Motion Blur: Normal; SSAA: OFF;

I have Tesselation set to very high in the benchmark setup program before running the benchmark. My GPU is a 7970, so it definitely supports tesselation. Maybe this is why the shadows and lighting look all messed up in the actual game?
 

Xyber

Member
Aug 24, 2011
5,278
0
0
Sweden
Something interesting I'm seeing in the benchmark:



I have Tesselation set to very high in the benchmark setup program before running the benchmark. My GPU is a 7970, so it definitely supports tesselation. Maybe this is why the shadows and lighting look all messed up in the actual game?

That's just a glitch in the benchmark. You are using it.
 

Zefah

Gold Member
Jan 7, 2007
44,461
25,342
1,805
That's just a glitch in the benchmark. You are using it.

Oh, OK.

In that case, I really don't know what's up. I got 38 average FPS with those settings and experienced no shadow/lighting glitches in the actual benchmark. Wonder why they are present in the actual game. Very frustrating.
 
May 22, 2011
7,255
0
0
Replying to myself, but I found a statement from AMD.

http://www.overclock.net/t/1391248/metro-last-light-lag-on-ati-cards/10#post_19970228



Hopefully they get this sorted out fast so I can actually play the game without having to switch to DX9 or whatever.

It seems they released it.

http://steamcommunity.com/app/43160/discussions/0/810924774395015649/

New update: ATI patch in distribution
A patch has been released on Steam to fix issues with ATI cards. It's live now, but might take a few minutes to reach everyone. Restart your client or verify local files if it doesn't download automatically.
 
May 22, 2011
7,255
0
0
BTW: includes FOV fix!!

yes that patch does include configuration for FOV. look for r_base_fov in user.cfg

edit

A patch has been released on Steam to fix issues with AMD hardware, and improve performance for these cards. It's live now, but might take a few minutes to reach everyone. Restart your client or verify local files if it doesn't download automatically.

It also fixes a shadow visual corruption bug on AMD 7xxx cards, and fixes an issue with the game starting only in 3:1 resolution on some TVs.

In addition, you can now customize the FOV this way:

After starting the game up, the user.cfg will be updated with the r_base_fox attribute. You can find this in %LOCALAPPDATA%\4A Games\Metro LL\. Tweak it at your leisure!
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
Another benchmark run with the new patch on i7 3770K, 16GB DDR3, 7970 OC got 48.91 Average Framerate.



Last night's pre-patch run gave me 41.43 Average Framerate.



It should again be a little smoother if I had it run twice in a row thanks to the loading hitches in the beginning.

Also note it should be frame limited to 59fps with Afterburner despite the Max. Framerate there shown to be a little higher.

I think it seemed overall a lot smoother, like the part that shows the burning area from the side as people run through it didn't momentarily go down to 20fps.

But at the same time there could be a bigger improvement I think, and the stuttering spikes are still there, even when in the game's main menu and in DX9 as before.

Edit: letting it run twice it almost got the exact same results, just a higher Min. Framerate probably because of missing some stutter in the beginning as I speculated before.

Total Frames: 8367, Total Time: 171.1418 sec
Average Framerate: 48.92
Max. Framerate: 61.56 (Frame: 4196)
Min. Framerate: 13.56 (Frame: 1217)

But wtf at all that spiking, that's what they should prioritize.
 

puzl

Banned
Sep 8, 2012
279
0
0
New update: AMD fixes and FOV
A patch has been released on Steam to fix issues with AMD hardware, and improve performance for these cards. It's live now, but might take a few minutes to reach everyone. Restart your client or verify local files if it doesn't download automatically.

It also fixes a shadow visual corruption bug on AMD 7xxx cards, and fixes an issue with the game starting only in 3:1 resolution on some TVs.

In addition, you can now customize the FOV this way:

After starting the game up, the user.cfg will be updated with the r_base_fox attribute. You can find this in %LOCALAPPDATA%\4A Games\Metro LL\. Tweak it at your leisure!

http://steamcommunity.com/app/43160/discussions/0/810924774395015649/

---------

r_base_fov 69 = 95 HOR FOV I believe. It's the setting I'm using and looks great.
 

daxter01

8/8/2010 Blackace was here
Nov 2, 2009
2,430
0
0
how can I cap frame rate? is there a command or just through nvidia Control panel?
 

dark10x

Digital Foundry pixel pusher
Jun 9, 2004
51,621
2,196
2,035
www.eurogamer.net
Hmm, so when I first played the game, I had a tessellation option available but now it has disappeared. In addition, performance has tanked. I was initially seeing a near perfect 60 fps but now I'm not able to hold it at all. Any ideas? What's going on here?
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
Hmm, so when I first played the game, I had a tessellation option available but now it has disappeared. In addition, performance has tanked. I was initially seeing a near perfect 60 fps but now I'm not able to hold it at all. Any ideas? What's going on here?
If you changed it to DX9 or DX10 api then tessellation won't work and that option is disabled. Check your config file and change the api line to 2 if it's 0 or 1.
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
You can use MSI Afterburner. The OSD Server has a framerate limit option and it works perfectly well in my experience.
Yep, MSI Afterburner is great for that, I dunno why so few recommend it, when I was googling for that I only found suggestions for stuff like DXTory and Frame Limiter and whatever else. Afterburner works great.
 

-bakalhau-

Member
Sep 16, 2009
1,612
0
860
Hmm, so when I first played the game, I had a tessellation option available but now it has disappeared. In addition, performance has tanked. I was initially seeing a near perfect 60 fps but now I'm not able to hold it at all. Any ideas? What's going on here?

This can happen if you started your game in safe mode - I did that once and had to switch to DX11 via the .cfg file, in the api line. Just switch it from a 0 or 1 to 2.

Anyone finding the Physx implementation sub-par? In visual terms at least. I find it has no performance impact so that is good. But particles are not that much and cloth simulation is turned on whether or not you have Physx turned on.
 

scitek

Member
Aug 23, 2005
17,119
13
1,400
El Paso, TX
twitch.tv
This can happen if you started your game in safe mode - I did that once and had to switch to DX11 via the .cfg file, in the api line. Just switch it from a 0 or 1 to 2.

Anyone finding the Physx implementation sub-par? In visual terms at least. I find it has no performance impact so that is good. But particles are not that much and cloth simulation is turned on whether or not you have Physx turned on.

I had a firefight yesterday that benefited greatly from PhysX IMO.
 

nOoblet16

Member
Feb 1, 2010
15,340
0
915
Liverpool
I have seen some really bad textures, I am going to assume it has to do with PS360 versions?

Artistic limitations, Metro 2033 had crap textures too (and the outdoors had awful textures). They are technically sound and high res but they don't look good because not much time is spent on them. Compare that to a game like Castlevania or Uncharted, which appears to have much superior texture quality and consistency, even though they are made for consoles and the actual resolution of textures are lower than Metro.
 

Linch

Neo Member
Jul 21, 2011
56
0
0
28
Newcastle Upon Tyne, UK
After reading the Kotaku review (hur hur) it said people are having issues with framerates when using HDMI HD TVs.

Reading through this thread, it seems like some people are running on TVs and not monitors.

Any one had this issue?

I mean on a HDTV for the PC using HDMI instead of monitor. But if using a monitor or a VGA connection its fine. Just in the Kotaku review it stated:

That said, I couldn't get either machine to run the game well on my TV through HDMI; both games seemed stuck at 24-30 frames per second, no matter which settings or resolutions I chose. The only way to get them to run at a high framerate was to plug them into my PC monitor via DVI.

I suppose if worse comes to worse I can swap from HDMI to VGA for the game.

This should run ok on my PC, this PC of mine when running at 720p on HDTV can manage no problem on that res.

Q6600 2.4GHZ
4GB RAM
6870 1GB AMD card.
 

JaseC

gave away the keys to the kingdom.
Jul 30, 2009
73,802
7
1,030
Western Australia
thanks downloaded it but I cant find where is fps limiting section :)) is it in setting>monitoring or somewhere else?

Look in your Start Menu for MSI Afterburner -> MSI Afterburner On-Screen Display Server. (If clicking it seemingly does nothing, then it's already open and you'll need to click the system tray icon that has a pink "60" in the upper-left corner.) Click the spanner icon and then set your desired framerate limit.
 

daxter01

8/8/2010 Blackace was here
Nov 2, 2009
2,430
0
0
Look in your Start Menu for MSI Afterburner -> MSI Afterburner On-Screen Display Server. (If clicking it seemingly does nothing, then it's already open and you'll need to click the system tray icon that has a pink "60" in the upper-left corner.) Click the spanner icon and then set your desired framerate limit.
found it thanks a lot mate
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
found it thanks a lot mate
You can also enable single tray icon mode, I have it like that so I only have the GPU temperature showing in my tray rather than that, the afterburner icon and the osd server icon. Plus it has replaced fraps for me, since it has frame rate display and screenshot taking too (in .png for free!). It's such a great utility even if you don't use its fan control and overclocking functions, which I don't with this card yet, unlike the GTX285 I had.
 

AndyBNV

Nvidia
Sep 26, 2012
1,232
0
0
File for me was in C:\Users\Administrator\AppData\Local\4A Games\Metro LL\110000100005a67 Had to run the game once to generate the option in the config. Default was r_base_fov 50.625

Used http://www.rjdown.co.uk/projects/bfbc2/fovcalculator.php to calculate a new FOV of 64 (95 horizontal).

Default FOV:



64 FOV:



With a gun:



In that in-game intro I noticed some banding at the bottom of the screen where the game wasn't meant to be visible, so you may experience similar issues in other cutscenes.
 

Dictator93

Member
Jun 29, 2011
23,812
4
660
File for me was in C:\Users\Administrator\AppData\Local\4A Games\Metro LL\110000100005a67 Had to run the game once to generate the option in the config file. Default was r_base_fov 50.625

Used http://www.rjdown.co.uk/projects/bfbc2/fovcalculator.php to calculate a new FOV of 64 (95 horizontal).

Default FOV:



64 FOV:



With a gun:



In that in-game intro I noticed some banding at the bottom of the screen where the game wasn't meant to be visible, so you may experience similar issues in other cutscenes.

I am debating whether or not I want to up my FOV... is the performance difference quite large?
 

Nekrono

Member
Feb 23, 2010
2,103
0
760
HUGE boost in performance after patch!!! Game is actually playable now!

Ran some benchmark of the (most likely) configurations people with my card or similar setups might be running.

Specs: 2500k (stock), 8GB RAM, 7970 (No OC, 13.5 Beta drivers).

Maxed out, no AA, Tesselation Very High, no Physx:
Pre patch:

Resolution: 1920 x 1080; DX 11; Quality: Very High; AF 16X; PhysX: Disabled; Tesselation: Very High; Motion Blur: Normal; SSAA: OFF;



Post patch:
Resolution: 1920 x 1080; DX 11; Quality: Very High; AF 16X; PhysX: Disabled; Tesselation: Very High; Motion Blur: Normal; SSAA: OFF;



Maxed out, no AA, Tesselation Normal, no Physx:
Pre patch:

Resolution: 1920 x 1080; DX 11; Quality: Very High; AF 16X; PhysX: Disabled; Tesselation: Normal; Motion Blur: Normal; SSAA: OFF;



Maxed out, no AA, Tesselation Normal, no Physx:
Post patch:

Resolution: 1920 x 1080; DX 11; Quality: Very High; AF 16X; PhysX: Disabled; Tesselation: Normal; Motion Blur: Normal; SSAA: OFF



In the actual game I can safely say performance has doubled! Granted I have not progressed too much and just got outside for the first time but in the beginning scene where there's a bunch of dudes working out I used to get 14 FPS looking that way and when I turned around the opposite way I got 60 FPS, now I get almost 60 FPS locked everywhere I look.

When you go out the first time I got around 45ish and during combat 30ish, now I get 60ish and in combat around 45ish if not more.

No more shadow flickering anymore.

Great patch, I will actually start playing this today now that is fixed.
 

Alextended

Banned
Jan 30, 2010
9,943
0
0
That's a dramatic difference in your case, it's improved for me but it wasn't that bad previously except in some areas, I posted my results earlier. It's definitely smoother overall though. But the stuttering spikes are still there all over the place. And there's the occasional flickering visual glitch still, probably not because of GPU brand in this case however. I took screenshots of a few but I won't post because I didn't catch them...

Why's the colonel the only one with decent hair anyway? Everyone else looks to have some Bioshock style waxy hair stylization, or just textures on a head, or is bald, but his hair is proper good.
 

SniperHunter

Banned
Mar 18, 2012
18,021
0
0
Caledon, Ontario
New update: AMD fixes and FOV
A patch has been released on Steam to fix issues with AMD hardware, and improve performance for these cards. It's live now, but might take a few minutes to reach everyone. Restart your client or verify local files if it doesn't download automatically.

It also fixes a shadow visual corruption bug on AMD 7xxx cards, and fixes an issue with the game starting only in 3:1 resolution on some TVs.

In addition, you can now customize the FOV this way:

After starting the game up, the user.cfg will be updated with the r_base_fox attribute. You can find this in %LOCALAPPDATA%\4A Games\Metro LL\. Tweak it at your leisure!

http://steamcommunity.com/app/43160/discussions/0/810924774395015649/

---------

r_base_fov 69 = 95 HOR FOV I believe. It's the setting I'm using and looks great.

Awesome!