Metro: Last Light PC performance thread

Alextended

Banned
Jan 30, 2010
9,943
0
0
Running great on my 3570k and 670. Full 60 so far at Very high. I'm playing at 2048x1152, and downsampling to 1600x900, though. So I dont really need AA at this point.
Weird, that image on the last page shows that card at 45fps average at only 1080p/no AA/no physx with a crazy CPU in the system, SSD, tons of RAM, etc.

Hope they can get the 7970 to perform on par with your 670 sans physx, that'd be sweet.

Also, the hitches can't all be loading based cos they happen in the main menu, or if I, for example, just move around while staring at the crashed rail cart, etc...

By the way if you alt tab out and back in the intro is skipped.
 

Smokey

Member
Nov 15, 2005
41,212
1
1,205
www.twitch.tv
I ran Metro LL in 3D Surround...

Performance not as bad as I expected! The frame rate ranged from 30-35. There were a few firefights involved as well so I wasn't just standing around doing nothing. Max settings, Physx, no SSAA. I wish I had 3D Vision 2 in this case as the picture is a bit dark on my OG setup. Overall though a very cool experience. Pretty much the type of experience my setup is geared towards, and it held up well. Will probably continue playing the game in this mode.
 

kamspy

Member
Dec 16, 2008
11,579
0
0
Cincinnati, OH
AMD 1100t
Gtx 680
Gtx 640 (physx, dunno iv it's being used)

Running maxed without any ssaa.

Feels like mostly 60 with smooth dips to what I'd estimate to be 40s.

Anyone know if this game makes use of a dedicated phyx card?
 

Smokey

Member
Nov 15, 2005
41,212
1
1,205
www.twitch.tv
AMD 1100t
Gtx 680
Gtx 640 (physx, dunno iv it's being used)

Running maxed without any ssaa.

Feels like mostly 60 with smooth dips to what I'd estimate to be 40s.

Anyone know if this game makes use of a dedicated phyx card?
You could set the 640 to be the dedicated card in NVCP and watch Afterburner/Precision X GPU usage and see if it's getting worked.
 

kamspy

Member
Dec 16, 2008
11,579
0
0
Cincinnati, OH
I know. GF got home stop I'm probably off the game for the night. I was too busy playing to check earlier, and I never had any perf issues to investigate.

I'm getting mostly 60 fpz though so I'm happy. I would never have dreamed of running ssaa on that rig in a Metro game, so not having that up isn't a beef for me.
 

Megasoum

Banned
Aug 27, 2009
20,141
0
0
Montréal
Hmmm

i5-2400
8gb Ram
GTX 570

Options: Resolution: 1920 x 1080; DirectX: DirectX 11; Quality: High; Texture filtering: AF 16X; Advanced PhysX: Enabled; Tesselation: Not supported; Motion Blur: Low; SSAA: OFF;

Average Framerate: 43.00
Max. Framerate: 76.38
Min. Framerate: 12.84
All right I guess
 

jacksepticeye

Member
Feb 15, 2013
7,197
0
0
You can skip the intro by alt-tabbing out of and back into the game. Removing the video file causes the game to hang for me.
I knew there had to be some way. I was gonna delete the videos when I saw them in the directory and I'm glad I didn't now, thanks for the tips :) The intro logos are super annoying
 

DSmalls84

Member
May 28, 2010
2,415
0
0
Savannah, Ga
I-5 2320 3.0 ghz
6 gb ram
660 ti 2gb

At 1080p very high with no ssaa or tesselation I get 45-60 frames indoors and outdoors.

Thought some people might appreciate some non titan benchmarks.

Edit: also not using advanced PhysX.
 

Dictator93

Member
Jun 29, 2011
23,813
4
570
I-5 2320 3.0 ghz
6 gb ram
660 ti 2gb

At 1080p very high with no ssaa or tesselation I get 45-60 frames indoors and outdoors.

Thought some people might appreciate some non titan benchmarks.

Edit: also not using advanced PhysX.
you could pretty easily put the tesselation on normal (or higher). It does not effect performance really much at all on Fermi or Kepler.
 

Futurevoid

Member
Dec 7, 2005
24,351
0
0
www.lcvg.com
Ugh. Game is just a big hitchy, stuttering mess on my computer for some reason.:(. Even lowering the settings to Low makes no difference. Still just hitches like crazy despite FRAPS showing 60fps.
 

legacyzero

Banned
Feb 20, 2011
27,805
1
0
Wisconsin
www.youtube.com
Weird, that image on the last page shows that card at 45fps average at only 1080p/no AA/no physx with a crazy CPU in the system, SSD, tons of RAM, etc.

Hope they can get the 7970 to perform on par with your 670 sans physx, that'd be sweet.

Also, the hitches can't all be loading based cos they happen in the main menu, or if I, for example, just move around while staring at the crashed rail cart, etc...

By the way if you alt tab out and back in the intro is skipped.
And I have physics on high. She dips from time to time when shit gets crazy. But overall, WAY more optimized than 2033.
 

zainetor

Banned
Dec 26, 2012
2,007
0
0
Any way to mitigate the stuttering? It gets worse when outdoors.
It's bioshock Inf. bad or better? I wonder why the fuck all these stuttering problems recently.
Curious to see if it will run better on my fx8350 rig or 3570k rig. just have to wait for new amd drivers.
 

Mr. Plankton

Neo Member
Mar 26, 2012
41
0
0
It's bioshock Inf. bad or better? I wonder why the fuck all these stuttering problems recently.
Curious to see if it will run better on my fx8350 rig or 3570k rig. just have to wait for new amd drivers.
It's pretty bad, IMO. I'm running 2 GTX 670s and an i5 2500K.
 
Apr 10, 2012
78
0
360
Vancouver
Strong Nvidia presence here. Particularly the Titan team. We probably need more complaint posts from AMD users to even things out.

How long would it take for AMD to throw out a beta driver?
 

Mr. Plankton

Neo Member
Mar 26, 2012
41
0
0

Aquanox

Junior Member
Aug 24, 2007
274
3
0
Lima, Perú
CPU: 3770K @ 4.6Ghz
GPU: AMD 7990
8GB 2400Mhz RAM



Not bad for an "Nvidia Game".

GPU usage fluctuates between 70-80% (CrossfireX)

Things should only get better with proper drivers and CAPs.

PS. Tessellation is set at Max, though it says not supported. (Bug I guess)
 

cobragt4001

Banned
Sep 23, 2009
1,542
1
0
CPU: 3770K @ 4.6Ghz
GPU: AMD 7990
8GB 2400Mhz RAM



Not bad for an "Nvidia Game".

GPU usage fluctuates between 70-80% (CrossfireX)

Things should only get better with proper drivers and CAPs.

PS. Tessellation is set at Max, though it says not supported. (Bug I guess)
You running a single 7990 or a two? Reason I ask is your 7990 is equal to my 670's. That's great performance.
 

Aquanox

Junior Member
Aug 24, 2007
274
3
0
Lima, Perú
Update:

In-Game, performance goes to hell.

Usage drops to 30%, 1 GPU only (Ignores second card) and framerates around 20fps.

I guess I'll leave it alone until proper drivers arrive. Hope it doesn't take as long as it took nVidia to fix Tomb Raider.
 

rallyart

Neo Member
Sep 28, 2009
117
0
0

Futurevoid

Member
Dec 7, 2005
24,351
0
0
www.lcvg.com

kamspy

Member
Dec 16, 2008
11,579
0
0
Cincinnati, OH
It will run a dedicated physx card. Just confirmed it.

No stutter here. No clue if it's related. Maybe people with SLI setups can try making one Physx and setting if it helps.
 

Deputy Dangle

Member
Feb 12, 2012
2,626
0
495
I played a session the morning the game unlocked and a short session just now for a couple hours. Both were ended abruptly by random crashes that locked up my PC and kept me from using my mouse temporarily. Then whenever I try to boot up the game again after the crash it gives me the option to go into safe mode or not. When I choose not to, I get a black screen and have to press the Esc key to go back to desktop. When I choose to run in safe mode, I get an annoying stuttering issue.

The only solution that I have found to boot up the game successfully with no stuttering after a crash is to restart my PC. Logging out and logging back in to steam might fix it as well, but I haven't tried.

Anyone else having issues like this?

I have:
I5 3570k @3.4Ghz
8GB RAM
GTX 660 ti

with the 320.14 Beta driver.
 

Brerlappin

Member
Jan 1, 2013
3,400
1
0
Benchmark is pretty crippling on my PC but in game seems fine, using the exact settings as the benchmark. (very high, tessellation on, physx on)

560ti 2GB
8GB ram
Q6600

Benchmark: min fps 4, max 48, avg 22.
In game is fine tho, at least in the prologue section i had a solid 50-60fps

anyone with a similar setup wondering how it runs, here the benchmark from my pc

http://www.youtube.com/watch?v=L4kUM9Yj85Q
 

pa22word

Member
Oct 24, 2010
11,062
0
0
Heard it was bad on AMD?

Anyone have a 5850 or similar. How is it?

Thanks in advance.


5870 here, and while the game is generally fine (50/60 fps) on high @ 1920x1080 the game is virtually unplayable due to the stuttering. This is coming from someone who tolerates it in BSI. The game drops 3-5 frames constantly and bumps right back up, and it makes precision aiming a game of chance. Skip this one until someone gets their shit together on either the driver end or whatever.
 

MotionBlue

Member
Apr 12, 2011
2,590
0
580
5870 here, and while the game is generally fine (50/60 fps) on high @ 1920x1080 the game is virtually unplayable due to the stuttering. This is coming from someone who tolerates it in BSI. The game drops 3-5 frames constantly and bumps right back up, and it makes precision aiming a game of chance. Skip this one until someone gets their shit together on either the driver end or whatever.
I had a similar problem during the bridge levels, using the same card.
 

daxter01

8/8/2010 Blackace was here
Nov 2, 2009
2,430
0
0
do you guys thing I can get more than 30 fps at 1280x800 resolution with these?

i5-2400
8gb Ram
560 ti