• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • Hey Guest. Check out the NeoGAF 2.2 Update Thread for details on our new Giphy integration and other new features.

Far Cry 4 PC performance thread

Feb 13, 2011
3,132
4
540
Just started playing this and I gotta say, it looks fucking gorgeous. It runs very well for me too. I play at 1440p and even at max settings it runs in 40-mid/late 50s with some deeps to mid/early 30s. Very impressed.

 

Aztechnology

Member
Jun 1, 2013
15,209
3
550
Where is the cheapest place I can buy this for PC? I know Steam Autumn sale starts soon, but I'd like to play it over this weekend

Check the Buy/Sell/Trade thread here on GAF. A few people got a game voucher with their new GPU's and are selling your choice of AC3/Unity/FC4 for 30-35
 

Cannon Goose

Member
Nov 28, 2011
4,093
0
660
Australia
After playing this for three hours and getting away from that starting village I've found that this actually runs decently (above 30fps) like 95% of the time. There's some micro-stuttering but not a whole lot, even while driving. When I had only completed the prologue I thought this would be a hot mess but I'm actually enjoying it quite a lot now.
 

Phinor

Member
Aug 17, 2011
2,556
0
0
I wonder when they'll finally release the 1.4.0. patch on Uplay. Because that's not even the patch I'm looking forward to, but they have to get that out of the way first.
 

Damian.

Banned
Jun 19, 2012
2,137
0
0
Has it been released and pulled multiple times? I am currently at 1.4 with my uPlay copy. It's not any different than 1.3 though, all the same problems remain. Getting rid of the vast majority of the stuttering means living with shitty textures. Have they made an official statement detailing how they knew of this "bug" from the start of development and never felt the need to deal with it?
 

Aztechnology

Member
Jun 1, 2013
15,209
3
550
So before i decide to buy does sli works (2x770)?

I have the same setup, with 2 4gb 770's. I either have to deal with unbelievably dark shadows/nights or flickering textures. Other than that, there's a bit of stuttering, but the game runs well enough (Over 60 fps, just with aforementioned issues, stuttering makes it feel sub 60).

Basically after my disappointment with my 770 compatibility and issues for a lot of games both new and old. I decided to sell off my 770's and buy a 970 until the 980TI or new AMD cards come out.
 

riflen

Member
Feb 12, 2013
2,402
0
0
So before i decide to buy does the sli works (2x770)?

Works is such an absolute term. =)

The Far Cry 4 SLI profile has 80-90% scaling, but it has bugs. Shadows are too black, making the game hard to enjoy. A fix is being worked on, no ETA.

I'm playing with the Far Cry 3 profile which doesn't scale as well, but doesn't have the bugs, as far as I can tell. I've not played very long though, so others might be able to tell you more.
The game does have problems with stutter, but it can be mostly worked around.
 

pestul

Member
Jun 13, 2004
10,516
0
0
Just started playing this and I gotta say, it looks fucking gorgeous. It runs very well for me too. I play at 1440p and even at max settings it runs in 40-mid/late 50s with some deeps to mid/early 30s. Very impressed.

Yeah, it looks amazing depending on the time of day. I'll post some of mine later.
 

Skyzard

Banned
Jun 3, 2012
20,772
0
0
As I unlock more of the map...my RAM usage is going up...used to play at around 6GB total ram usage (looked at my old recordings with the stats), now it goes up to 9/10 GB from a fresh reboot.

Is it possible the RAM stuff has an effect on smoothness? Sometimes I feel like there is a link in this.
 

Q8D3vil

Member
Jul 16, 2009
9,166
0
0
I have the same setup, with 2 4gb 770's. I either have to deal with unbelievably dark shadows/nights or flickering textures. Other than that, there's a bit of stuttering, but the game runs well enough (Over 60 fps, just with aforementioned issues, stuttering makes it feel sub 60).

Basically after my disappointment with my 770 compatibility and issues for a lot of games both new and old. I decided to sell off my 770's and buy a 970 until the 980TI or new AMD cards come out.
I have the 4gb edition as well, SLI support was so bad this year, I'm really considering ditching it and go solo if it doesn't get proper support next year (my third sli setup).
 

JRW

Member
Nov 29, 2006
2,488
110
1,305
Clovis, California
Don't try running this on a GTX 480, It has finally met its match (Runs absolutely awful even on the Low graphic preset).

Nice, replying to my own comment.. anyhow just wanted to clarify the issue isn't 100% GTX 480, because even if I lock the framerate to 30fps and never see the fps drop below 30, it just doesnt *feel* like a proper 30fps, its more like 25fps.

I noticed others in this thread mentioning the same thing so guess the game needs optimization on PC. I can tell you PS4 FC4's 30fps runs proper which made me notice the issue even more when coming home to my PC (Been playing it at a friends last few days).
 

laxu

Member
Jan 10, 2013
2,174
0
345
Finland
So before i decide to buy does sli works (2x770)?

With Batman Arkham Origins SLI bits there are no visual defects but it doesn't run as fast as with Far Cry 3 Blood Dragon bits (which can sometimes cause a flickering environment or can work fine, I don't know what causes this). That said, even a single 770 is enough to play this at 2560x1440 at around 30 fps.

For me aside from Nvidia not providing a SLI profile at launch for some recent games, SLI has worked fine for me and even then 2 GB VRAM on my cards hasn't become an issue at all.
 

Stallion Free

Cock Encumbered
Jan 21, 2009
29,933
0
0
Connecticut, U.S.
steamcommunity.com
Did the most recent patch fuck up the shadows/lighting or something? They are flashing like crazy and clearly broken every time I go to the Himalayas/indoor areas and now in the North it's overly bright and the shadows are all fucked up.

I tried messing with the shadow settings/post-process/godrays and everything else that seemed like it might affect it and none of them did anything to help. I have a 970/5820k both performing perfectly and I'm on 344.75/vers 1.4.0 of the game (it autoupdated). It's honestly bad enough I'm stopping playing the game until another patch hits.I had none of these issues in the first zone on release.
 

opticalmace

Member
Dec 8, 2008
14,633
0
0
Bay Area
Any idea if I should get this for PC or PS4? Little worried about performance.

PC:
2500k @ 4.3GHz
AMD 6950 2GB (oc'd to ~6970 specs)
enough ram

Thanks.
 

hoserx

Member
Feb 27, 2013
4,157
1
500
Cleveland, Ohio
Any idea if I should get this for PC or PS4? Little worried about performance.

PC:
2500k @ 4.3GHz
AMD 6950 2GB (oc'd to ~6970 specs)
enough ram

Thanks.

"enough ram", yet you don't know if your specs are good enough to run the game? How do you know it's enough? If it is, why not just state the amount you have?
 

opticalmace

Member
Dec 8, 2008
14,633
0
0
Bay Area
"enough ram", yet you don't know if your specs are good enough to run the game? How do you know it's enough? If it is, why not just state the amount you have?

16GB. I don't know, didn't seem super relevant.

I know I can run the game, I just don't know if it'll be worse than playing it on PS4.
 

Aztechnology

Member
Jun 1, 2013
15,209
3
550
I have the 4gb edition as well, SLI support was so bad this year, I'm really considering ditching it and go solo if it doesn't get proper support next year (my third sli setup).

You're more patient than I. I sold off my 770's on amazon. Picked up a reference model 970 from bestbuy

(got them to price match a $350 different model from newegg :D) easily clocked it up to almost 1500 mhz running really cool still and I'm not looking back. I made out like a bandit, so I may sell my 970 when the 980ti comes out and grab that. Regardless it's performing well on farcry 4 now, but Ubi-Soft games are just a nightmare right now in general.
 

SaberEdge

Member
Mar 5, 2014
833
3
405
I don't mind it dipping into the 45ish range, AC Unity does the same, but AC Unity doesn't hitch the way FC4 does. It's the hitching that is annoying. Can't make it go away on pretty much all the tweaks I've tried.

Same for me. I'm also getting some stuttering in Dragon Age Inquisition. It's strange that ACU got most of the hate, but in my experience all of these games are similarly demanding but ACU runs the best of all of them. I'm not able to achieve a stable 60fps at max settings on my GTX 970 in any of them, but at least when I cap ACU at 50fps or 30fps the frame pacing is even and smooth.
 

LordOfChaos

Member
Mar 31, 2014
11,626
7,001
915
Has there been any word on an OSX release for FC4? There's one for 3, but I can't find any mention of it for 4.
 

SaberEdge

Member
Mar 5, 2014
833
3
405
They look like fucking shit. I don't understand how anyone can think adding a ridiculous amount of haze over the entire scene is a desirable visual effect.

I don't see any haze. Just more realistic lighting. I guess if you want it to look flat and videogamey that's your prerogative, but the god rays are absolutely vital to the look of this game. I would turn down most other settings before I would turn those off.
 

b0uncyfr0

Member
Dec 1, 2012
650
176
645
So any news on the how to fix the pitch black shadows yet? Its really messing with me.

EDIT: Turns out its SSBC that's causing the pitch black shadows everywhere on single GPU systems at least. If you're on SLI, it could be another matter though. You can check by forcing these bits in NV inspector - SLI Compatibility bits (DX1x) - 0x080020F5.
 

BrassDragon

Member
Nov 28, 2013
2,837
0
0
After much get tinkering, I still get extreme stuttering and frame locks in the arena while most of the open world runs smoothly... any ideas what's causing this?

It just confuses me that the game can perform perfectly when showing a vista for miles around, including traffic and wildlife, but becomes a creaky mess when rendering a contained room with 15 enemies.
 

PuppetSlave

Member
May 11, 2006
5,142
0
0
Sweden
So any news on the how to fix the pitch black shadows yet? Its really messing with me.

I had them but after I used geforce experience optimize they disappeared. I don't have SLI either. Other then that check the OP and the net for crushed blacks for some other possible solutions.
 

Manac0r

Member
Dec 8, 2009
527
0
855
UK
Anyone else experiencing the game pad issue? If I try boots g the game with a pad plugged in I get a black screen. As soon as I disconnect the pad it loads up fine. When I get in game and try reconnecting the pad, areas fail to load or button prompts don't show and checkpoint won't load. Disconnect the pad and it works fine.

I know I could just use k/b + mouse, but seems like a great game for couch play. I have tried using different USB ports but still get the same behaviour. I surely can't be the only one?
 

pestul

Member
Jun 13, 2004
10,516
0
0
After much get tinkering, I still get extreme stuttering and frame locks in the arena while most of the open world runs smoothly... any ideas what's causing this?

It just confuses me that the game can perform perfectly when showing a vista for miles around, including traffic and wildlife, but becomes a creaky mess when rendering a contained room with 15 enemies.

It's really got to be CPU core utilization issues. Try logging your core usage in both scenarios to see what the difference is. It could also be the proposed memory leak.

I really hope they fix the stuttering, because the game looks breathtaking on the highest settings.
 

pestul

Member
Jun 13, 2004
10,516
0
0
Does anyone else experience weird artifacting with fires/smoke at times? It doesn't seem to happen all the time, but once I set a huge blaze and the game went straight janky. I lowered my clocks to see if it was a gpu stabilization issue, but it didn't seem to be.
 

Skyzard

Banned
Jun 3, 2012
20,772
0
0
I have to restart my PC each time I play the game otherwise I lose like 6GB of RAM lol. Really feel that it's tied to the save file as well.

Anyone else experiencing the game pad issue? If I try boots g the game with a pad plugged in I get a black screen. As soon as I disconnect the pad it loads up fine. When I get in game and try reconnecting the pad, areas fail to load or button prompts don't show and checkpoint won't load. Disconnect the pad and it works fine.

I know I could just use k/b + mouse, but seems like a great game for couch play. I have tried using different USB ports but still get the same behaviour. I surely can't be the only one?

I'm not experiencing this but I read that Ubisoft were working on a patch for that as others have.
 

Ogimachi

Member
Mar 28, 2013
1,990
0
0
OP should add the AF tweak with nvidia CP/inspector as well. The difference is night and day, and it makes the game look much better with DisableLoadingMip.
 

Ruff

Member
Jun 9, 2014
1,811
0
0
My GPU has started artifacting slightly after completing this game. I read that other people have had a problem with this game "frying" their card too. Hope it's just a coincidence since mine has certainly got it's uses worth by now.
 

pestul

Member
Jun 13, 2004
10,516
0
0
OP should add the AF tweak with nvidia CP/inspector as well. The difference is night and day, and it makes the game look much better with DisableLoadingMip.
I can't get that to work on mine now. Any ideas? I have 16x Aniso forced in both Global and the FC4 profile, yet I'm clearly not getting 16x. Maybe I'll try backing up my gamerprofile.xml.. deleting the orginal and let FC4 rebuilt it. There's something fishy going on.

I can't do the DisableMip thing. Too many textures look like 'Low' settings for me. The performance is wonderful with that setting however.

Oh, anymore opinions on having GPUMaxBufferedFrames on 3 vs. 1? I've yet to try it, but I think I'll give it a whirl when I get home from work.
 

Ogimachi

Member
Mar 28, 2013
1,990
0
0
I can't get that to work on mine now. Any ideas? I have 16x Aniso forced in both Global and the FC4 profile, yet I'm clearly not getting 16x. Maybe I'll try backing up my gamerprofile.xml.. deleting the orginal and let FC4 rebuilt it. There's something fishy going on.

I can't do the DisableMip thing. Too many textures look like 'Low' settings for me. The performance is wonderful with that setting however.

Oh, anymore opinions on having GPUMaxBufferedFrames on 3 vs. 1? I've yet to try it, but I think I'll give it a whirl when I get home from work.
Make sure you didn't choose any AF mode, there's one which lists Far Cry 3 as an example which actually turned it off for me. But yeah, try getting a new gameprofile.xml as well.
MaxBufferedFrames did improve the stuttering for me, but not much. That was before I tried disablemip, which was the only thing that actually solved it.

My AF test was the AJM 9 pistol. Without it, the texture looks blurry as hell and not a beautiful gun. If you manage to force AF, you'll notice the difference right away.