• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • Hey Guest. Check out the NeoGAF 2.2 Update Thread for details on our new Giphy integration and other new features.

Far Cry 4 PC performance thread

Calmine

Member
Jan 3, 2012
1,064
0
0
United Kingdom
Bought a few days ago and the performance was pretty bad. I had to play at 1920x1080 on my 1440p monitor and it looks really awful and pixelated? No idea played lots of other titles at 1080p on my monitor and they've been fine.

Anyway's the patch was actually a surprising improvement for me on my HD7970 ghz and i5 3570k with 16GB RAM.

The stuttering is pretty much gone and the acceleration is gone too, but I did make sure I turned off all the smoothing options in the ini just to be sure.

Now actually enjoying it at 1440p on Ultra without that Tree setting, and while I'm not getting 60FPS I'm enjoying it. I would get 60FPS if I dropped to 1920x1080 but it just looks awful at that resolution as said.

Still the performance is worse than Far Cry 3 and graphics quality of the game isn't much of a step up from Far Cry 3 to be honest. Guess it's Ubisoft Kiev to blame on that.
 

InfYn

Neo Member
Oct 24, 2013
127
0
0
Can't wait for these mythical Catalyst Omega drivers from AMD, apparently dropping tomorrow. The Beta2 drivers they made with the FC4 support turn my monitor off randomly if I leave it idle for 5 or-so minutes.
 

SliChillax

Member
Aug 1, 2014
3,999
188
485
Tirana, Albania
Can't wait for these mythical Catalyst Omega drivers from AMD, apparently dropping tomorrow. The Beta2 drivers they made with the FC4 support turn my monitor off randomly if I leave it idle for 5 or-so minutes.

Don't get your hopes up, if it's not working well for Nvidia cards it'll be just as worse for AMD. This is an Nvidia sponsored game after all.
 

zephervack

Member
Apr 12, 2010
7,162
1
0
Canada
www.neogaf.com
Tried the patch the game crashes as soon as I start it. I get this message

Did you update to 1.5? The patch was probably tested on 1.4 and might be incompatible with today's patch, I havent tried the patch, so I dont know if its working, just a suggestion.
 

laxu

Member
Jan 10, 2013
2,174
0
345
Finland
Seems to run a bit better after the patch. Loading times seem much improved even with an SSD. Hairworks fur looks surprisingly great actually.
 

SliChillax

Member
Aug 1, 2014
3,999
188
485
Tirana, Albania
Did you update to 1.5? The patch was probably tested on 1.4 and might be incompatible with today's patch, I havent tried the patch, so I dont know if its working, just a suggestion.

Yeah I'm on 1.5

Seems to run a bit better after the patch. Loading times seem much improved even with an SSD. Hairworks fur looks surprisingly great actually.

Since it's working for you I guess it has nothing to do with the fact that I'm on 1.5, it just doesn't work for me.
 

coolbrys

Member
Oct 6, 2006
88
0
0
Can't wait for these mythical Catalyst Omega drivers from AMD, apparently dropping tomorrow. The Beta2 drivers they made with the FC4 support turn my monitor off randomly if I leave it idle for 5 or-so minutes.

I've been trying to track down an issue where my PC freezes/reboots after 5-10 minutes of idle. Never happened before the drivers.... now I'm wondering if that's what is causing it. I've been having tons of crossfire problems recently so I assumed it was one of any number of things.


(I "fixed" it by downloading a mouse jiggler program that makes my computer never stay idle.)
 

jongkookie

Member
Apr 15, 2012
4,090
0
425
1.3GB patch?

This better be worth it haha.

I'll see if the mousefix and nointro mod works... just gimme 5 mins to download the patch lol.
 

jongkookie

Member
Apr 15, 2012
4,090
0
425
1.3gb for the addition of Hairworks, nothing else seems to be fixed.

I have no clue what the hell that is lol.

Anyway, the mod still works on my end. Hopefully there's gonna be some performance improvements in this patch besides the "hairworks" or whatever it is.
 

Sax Russel

Banned
Jun 10, 2004
4,506
5
1,550
I wonder what's changed in the patch posted in guru3d, he didn't give away any details about the changes that have been made, I'm curious if the spontaneous fps boost is there because of a ninja mipmap set to 1 in a custom gamerprofile.xml

Here's some screens

Ultra


Ultra + mipmap setting changed


Ultra + user patch


I'm thinking all he did was bake the mipmap change into the default settings, and repackaged the patch files for it. Nothing like downloading a gig to do the same thing changing a "0" to a "1" does in the xml =P
 

rBose

Banned
Aug 9, 2013
403
0
0
Here's some screens

Ultra


Ultra + mipmap setting changed


Ultra + user patch


I'm thinking all he did was bake the mipmap change into the default settings, and repackaged the patch files for it. Nothing like downloading a gig to do the same thing changing a "0" to a "1" does in the xml =P

I was expecting this, thanks for the tests man.
 
Nov 9, 2010
1,044
0
475
Florida
And my wireless 360 controller STILL doesn't work in the latest patch. This game is unplayable for me. I play my games in my living room from my couch. Ubisoft needs to get their shit together, this is crazy. I can launch any other Ubisoft game (and any other controller supported game) and play with my controller just fine.
 

SliChillax

Member
Aug 1, 2014
3,999
188
485
Tirana, Albania
And my wireless 360 controller STILL doesn't work in the latest patch. This game is unplayable for me. I play my games in my living room from my couch. Ubisoft needs to get their shit together, this is crazy. I can launch any other Ubisoft game (and any other controller supported game) and play with my controller just fine.

Have you tried turning on the controller before launching the game?
 

SilentRage47

Member
Nov 10, 2011
246
0
0
No big improvements for me, it still stutters on my 970 and 2500k.Mouse acceleration is also still broken, this game is just a waste of money.
 

Gormenghast

Member
Sep 7, 2014
814
18
285
I took another bunch of screenshots at default Ultra and with mipmap disabled and screenshots come out IDENTICAL.

You can notice a very slight blurriness for example where rocks meet grass, but otherwise only textures that are right in your face show any change.

The patch itself improves NOTHING. Stutter is still present, not even reduced. I still get "shutter" black bug, and I even got some green flashes that before I only noticed on some youtube videos, though it only happened when I enabled the fur, and never on the normal settings.

So, if anything I've seen more things going wrong in patch 1.5 than in 1.4.

It's really "fur patch" and nothing else.
 

daninthemix

Member
Jul 7, 2010
3,619
719
985
Would love it if anyone had any advice on overcoming the 5 minute load times and constant black screens that I have to alt-tab out and back in to progress.

Unplugging USB devices - my mouse, keyboard, gamepad, wireless NIC - is not an option even if it works because I need all those things.

Come on Ubisoft, this is embarrassing, surely?
 

Gormenghast

Member
Sep 7, 2014
814
18
285
Also, for me the periodic stutters aren't even a texture issue (only).

I get stutters every 20-30 seconds even if I don't touch anything. Being just still. If you stay at some spot where cars are spawned you notice that there's a small stutter and dip in framerate every time a car spawns. This is regular.

If you camp a road you notice that every few seconds a car goes through, and if you notice there's a stutter a second or so before a car comes on screen.

So, at least SOME of the stutters are due to these spawning of cars and other entities.

It's just a very badly programmed engine.
 
Nov 9, 2010
1,044
0
475
Florida
Have you tried turning on the controller before launching the game?

Yes, the controller even works on the "press any button" intro screen before the main menu. It also switches UI to controller buttons when any input is pressed on the controller but nothing actually works. I can't even navigate the menu.

I've tried unplugging every other USB device. Reinstalled the MS wireless accessories drivers. I even stopped all my Logitech services in hopes of a conflict there. Nothing works. This is the only game I've ever run into an issue on. The controller works perfectly everywhere else.
 

SliChillax

Member
Aug 1, 2014
3,999
188
485
Tirana, Albania
Yes, the controller even works on the "press any button" intro screen before the main menu. It also switches UI to controller buttons when any input is pressed on the controller but nothing actually works. I can't even navigate the menu.

I've tried unplugging every other USB device. Reinstalled the MS wireless accessories drivers. I even stopped all my Logitech services in hopes of a conflict there. Nothing works. This is the only game I've ever run into an issue on. The controller works perfectly everywhere else.

I would go crazy if this happened to me because I mostly game with my controller, try verifying the game files that's the only thing I can suggest :/ sorry

Also, for me the periodic stutters aren't even a texture issue (only).

I get stutters every 20-30 seconds even if I don't touch anything. Being just still. If you stay at some spot where cars are spawned you notice that there's a small stutter and dip in framerate every time a car spawns. This is regular.

If you camp a road you notice that every few seconds a car goes through, and if you notice there's a stutter a second or so before a car comes on screen.

So, at least SOME of the stutters are due to these spawning of cars and other entities.

It's just a very badly programmed engine.

I remember having the same issue back when Far Cry 3 came out, Dunia is really a buggy engine.
 
Nov 9, 2010
1,044
0
475
Florida
So I finally nailed down a solution on my end to an unresponsive 360 controller. Previously I could hit A to progress past the "Press any button" screen, but the controller would not work on the title screen or in game. The UI elements would switch between kb/m and controller, but no inputs would seem to register beyond that.

It turned out that the Nintendo Wii wireless drivers for playing Dolphin with a wireless nunchuck controller were the culprit. I simply went to Devices and Printers and removed this device. I hope this helps anyone else that may have the same issue.
 

SliChillax

Member
Aug 1, 2014
3,999
188
485
Tirana, Albania
So I finally nailed down a solution on my end to an unresponsive 360 controller. Previously I could hit A to progress past the "Press any button" screen, but the controller would not work on the title screen or in game. The UI elements would switch between kb/m and controller, but no inputs would seem to register beyond that.

It turned out that the Nintendo Wii wireless drivers for playing Dolphin with a wireless nunchuck controller were the culprit. I simply went to Devices and Printers and removed this device. I hope this helps anyone else that may have the same issue.

This makes me think how buggy this game is. Has anyone tried running this game with no stuff attached to the computer, no drivers, sunny weather etc and see if it works properly?
 

conman

Member
Aug 12, 2007
4,591
0
0
Man. I've been waiting to purchase this until after a fix for the widespread stuttering. But at this rate, it seems like it will never happen.

Has Ubi at least acknowledged the problem and said that they're working on it?
 

SliChillax

Member
Aug 1, 2014
3,999
188
485
Tirana, Albania
Man. I've been waiting to purchase this until after a fix for the widespread stuttering. But at this rate, it seems like it will never happen.

Has Ubi at least acknowledged the problem and said that they're working on it?

Yeah it was supposed to be fixed in the patch that came out today.
 

LilJoka

Member
Dec 22, 2013
6,122
2
0
London, UK
For me the 360 pad hardly works.
Uplay detects it, converts the Uplay interface to use 360 icons. Try press A to start FC4, nothing. Manually click play, controller doesnt work in game at all.
I literally have to reboot a few times to get it to work.

I had the same problem in The Crew beta.

I have no problem playing any of the other 100 games i have.
 

RankFTW

Unconfirmed Member
Sep 4, 2013
802
0
0
Scotland
Game is stutter free for me now on my 980 and ROG Swift at max settings with MLAA. Before the 1.5 patch the game would stutter quite a lot with GPU usage going down to zero for a split second. Now it's constantly at 100% all the time and feels way smoother.
 

LilJoka

Member
Dec 22, 2013
6,122
2
0
London, UK
Game is stutter free for me now on my 980 and ROG Swift at max settings with MLAA. Before the 1.5 patch the game would stutter quite a lot with GPU usage going down to zero for a split second. Now it's constantly at 100% all the time and feels way smoother.

Thats good news, on my 970 it was dropping to like 20% and big stutter when driving.
 

zXe

Member
Jan 20, 2014
314
0
390
Bristol
On my MSI 970 I haven't been able to tell what hairworks actually does, simulated animal fur looks same as before when fur setting was just On. Performance seems worse overall to me, especially in vehicles. Stutter I don't notice personally, but drops I do. Not feeling very optimistic atm.
 

jongkookie

Member
Apr 15, 2012
4,090
0
425
Been playing for 2 hours and yeah, I don't see much of an performance improvement over here.

I mean I guess I got like a 5fps increase over 1.4, but that doesn't matter much to me since I've got it capped at 30fps anyway.

Also I don't think I've experienced these stutters everyone seems to be getting. Walking around and it drops to 28fps and anything I'm going around pretty fast like a car, boat, whatever it'll drop to 20fps for a split second to load the environment, but other than I don't seem to run into any issues.

That, or I'm just blind and I can't see crap lol.
 
Nov 9, 2010
1,044
0
475
Florida
For me the 360 pad hardly works.
Uplay detects it, converts the Uplay interface to use 360 icons. Try press A to start FC4, nothing. Manually click play, controller doesnt work in game at all.
I literally have to reboot a few times to get it to work.

I had the same problem in The Crew beta.

I have no problem playing any of the other 100 games i have.

The game seems to have really odd issues with other USB devices and wireless controllers. I had to delete drivers for something I never use (the Nintendo Wii remote) to get my controller functioning at all. Try unplugging devices and removing drivers for other devices. I've read that some people have found that unplugging or disabling their USB Bluetooth receivers fixed their problems as well.
 

Pancakes

hot, steaming, as melted butter slips into the cracks, drizzled with sticky sweet syrup OH GOD
Mar 18, 2008
13,901
0
0
steamcommunity.com
I'm not sure if it's because I upgraded to Windows 8.1 or because of the new patch (probably a combination). But my overall framerate has gone from 50-70 to a solid 60-80. Exact same settings.
 

plc268

Member
May 8, 2010
2,487
0
0
Texas
I still get some occasional hitching when I'm using SLI. If I disable one card, it feels like all the hitching is gone, but I either lose 30fps or am forced to drop everything down from the Ultra/Gameworks settings to high. The hitching is at least manageable now, and the game finally feels playable.

Oh, and 21:9 support. Finally.
 

daninthemix

Member
Jul 7, 2010
3,619
719
985
OK, my black screen / 5 minute loading time issues are because of the 360 controller. If I unplug it before launching the game loads as intended.

What the hell Ubisoft?
 

TheFNEffecT

Member
Sep 16, 2013
1,147
0
345
Chino Hills, CA
Still no crossfire, but it's definitely an upgrade! The stuttering seems to be gone as well, not sure if it was just a product the new AMD Omega + new patch or what but I'm enjoying this game a lot more with less wonkyness, I put everything on high, enhanced fur, fog, trees relief and no AA. Seems to be never dip below 65 which is fine for me.


Where dat crossfire at Ubisoft/AMD???

I'll take the fur for now....lol

 

daninthemix

Member
Jul 7, 2010
3,619
719
985
Seriously, does any tech savvy folk have a solution to the 360 controller problem causing black screens and long loads? Why does this affect some but not others?
 

Rox598

Member
Apr 22, 2013
4,074
35
510
Don't get your hopes up, if it's not working well for Nvidia cards it'll be just as worse for AMD. This is an Nvidia sponsored game after all.

Is his confirmed to be happening? I have the current beta drivers installed atm didn't seem to make much difference.
 

riflen

Member
Feb 12, 2013
2,402
0
0
Well 1.5 solved stuttering on my system. I can now set ultra textures with mipmap0 enabled. Finally I can play this game.

Those people who are still having problems, does the game still peg a CPU core to 100% and leave others on 40% or less? If so, make sure to change the CPU affinity of FarCry4.exe using task manager. If a clogged up CPU thread is causing hitches on your system, this could help.

Also (captain obvious) do close all programmes that aren't completely necessary. I found that a utility I've used for years to monitor temperatures and control fans, was causing regular spikes in CPU usage. Closing it helped smooth this game out.
 

riflen

Member
Feb 12, 2013
2,402
0
0
Does this fix crushed blacks

For sli users?

If by "this" you mean the 1.5 patch, then no, it does not.
Ubisoft commented on their forums that a fix for that problem would likely have to come from Nvidia.

You can avoid the loss of detail in dark areas by using different SLI bits (FarCry3), but this introduces other artifacts for some configurations and doesn't scale quite as well as the Far Cry 4 bits.

I'm not sure who the fix for completely broken TXAA will have to come from, or the SMAA+SLI ghost frame bug. Perhaps one day this game will be in a state where all the shipped features actually work.