Fallout 4 PC Performance Thread

Oct 23, 2011
16,850
0
0
Getting better performance on my GTX 770 by lowering the shadow detail and distance to Medium. Everything else is on the preset the game picked for me at first launch (most everything is on high with some Ultras, like Textures).

More consistent 60 fps. I even got 60 fps in Diamond City with just very few drops. However, I do still get the occasional drop when I shouldn't so it's not like the game doesn't have performance problems.

I hope they patch the game to address performance because it really seems like it's too inconsistent. Too many instances where frames drop and barely anything is happening on screen.
 
Dec 27, 2011
721
0
0
So I need help. Friend got this gifted on steam. Her pc is under min requirements. Laptop with 4gb i3 and Intel hd3000. When you start from the launcher, it just completely crashes. We get a checking for fix from windows(7.) And nothing. Event log shows events at path to the exe, and module to the .exe.

So I do a verify cache in steam. Doesn't help. I move the install over the network to my pc. I'm on an AMD 8350 OC'ED 4.3, 8 gb, 280x. I get the same crash.

So we delete and reinstall on her laptop thinking it might be a bad install. Redownload and the same thing happens on her laptop.

I even try installing a crack to see if that helps.

Both machines are up to date on all drivers.

I cannot figure out what the issue is. Any suggestions? I have it on PS4, but she is a HUGE fan and super bummed we can't get it to run.
 
Aug 20, 2014
4,459
0
0
Chicago, IL
So I need help. Friend got this gifted on steam. Her pc is under min requirements. Laptop with 4gb i3 and Intel hd3000. When you start from the launcher, it just completely crashes. We get a checking for fix from windows(7.) And nothing. Event log shows events at path to the exe, and module to the .exe.

So I do a verify cache in steam. Doesn't help. I move the install over the network to my pc. I'm on an AMD 8350 OC'ED 4.3, 8 gb, 280x. I get the same crash.

So we delete and reinstall on her laptop thinking it might be a bad install. Redownload and the same thing happens on her laptop.

I even try installing a crack to see if that helps.

Both machines are up to date on all drivers.

I cannot figure out what the issue is. Any suggestions? I have it on PS4, but she is a HUGE fan and super bummed we can't get it to run.
See if it created the INI files in Documents/My Games/Fallout4 and delete them if so.
 
May 11, 2012
1,492
0
0
Did I read earlier in this thread to not change FOV from the default? I really need to change it if doing so doesn't break things.

I've got a gun now that is almost covering the entire right side of the screen. Doesn't work for me. Need to change that FOV!
 
Nov 20, 2010
2,959
0
0
It was 70 by default in the tweaker, but I changed and tried a few values but none of them seemed to change anything for me really
Yeah, I can't seem to change the FOV. Tried the .ini tweaks but they were too vague. Download the automatic fixer but I'm not sure if my messing with the first .ini file messed that up too. Nothing seems to work.
 
Jul 23, 2007
399
0
0
NJ
Yup, it seems to be an issue tied to the 3rd person analog movement. Why do I think this? It doesn't happen if you use mouse and keyboard in third person, at all.

It's not random either, it happens during the transition between animations, you can easily test this by moving the camera sideways slowly, and then making the character go left and right over and over. Everytime the character starts moving in the other direction and the animation switches, the camera locks up for a second.

It's super fucking annoying, and I just want to be able to get this issue acknowledged by the devs so they can fix it. Idk the best way to do this, I posted on the official FO4 forums but idk if the devs even read that shit.
Have you tried contacting support about it? -

https://help.bethesda.net/app/ask/p/695/pf/PC
 
Jun 8, 2013
6,895
0
0
Australia
Beyond the obvious glitch fest, has a Bethesda game ever performed poorly on PC?
Yes, Oblivion was and still is atrocious for it's supposed recommended specs (Irrelevent these days), Morrowind was even worse, Gamebryo has never been a lenient engine. Skyrim actually runs better than Oblivion overall, and Fallout 3 ran better than them both despite it looking pretty much like beta Skyrim.
 
Oct 21, 2012
4,918
1
0
Toronto, CA
It's basically a slideshow in the larger city areas at times for me. The dumb part is I don't really notice a difference in FPS going from Low to a mix of High/Ultra.

I did a Fraps benchmark test through the same city area a few times on my High settings and a few times on Low and the average on Low was only 7 FPS higher. Both suffered from the same slowdowns in the same areas with FPS hitting the single digits.

This is the first game that's made me feel like I desperately need to upgrade my entire setup.
 

welly_59

Neo Member
Mar 2, 2014
95
0
0
It's basically a slideshow in the larger city areas at times for me. The dumb part is I don't really notice a difference in FPS going from Low to a mix of High/Ultra.

I did a Fraps benchmark test through the same city area a few times on my High settings and a few times on Low and the average on Low was only 7 FPS higher. Both suffered from the same slowdowns in the same areas with FPS hitting the single digits.

This is the first game that's made me feel like I desperately need to upgrade my entire setup.
What cpu?
 

ABK

Banned
Aug 10, 2014
59
0
0
It's basically a slideshow in the larger city areas at times for me. The dumb part is I don't really notice a difference in FPS going from Low to a mix of High/Ultra.

I did a Fraps benchmark test through the same city area a few times on my High settings and a few times on Low and the average on Low was only 7 FPS higher. Both suffered from the same slowdowns in the same areas with FPS hitting the single digits.

This is the first game that's made me feel like I desperately need to upgrade my entire setup.
I'm having the same problems with an i5 2500k and a Radeon 6950 2gb. Just got to the big city area around Diamond City and the game at one point was running at 2fps.
 
Jul 28, 2014
8,919
0
0
France
Still very early in the game, just completed the "when freedom calls" quest and so far the game runs very well, hitting 60fps more often than not but there is still stutter from time to time. Everything maxed except god rays, I'll try lowering the shadow distance to high.
Game installed on an SSD, loading times so far are very fast.
 
May 11, 2012
1,492
0
0
It's basically a slideshow in the larger city areas at times for me. The dumb part is I don't really notice a difference in FPS going from Low to a mix of High/Ultra.

I did a Fraps benchmark test through the same city area a few times on my High settings and a few times on Low and the average on Low was only 7 FPS higher. Both suffered from the same slowdowns in the same areas with FPS hitting the single digits.

This is the first game that's made me feel like I desperately need to upgrade my entire setup.
Post/handle
 
R

Rösti

Unconfirmed Member
As my GPU isn't supported (apparently) I'm forced to run the game via the Microsoft Basic Render Driver (by disabling my GPU). I've been tinkering around with a few settings (the game is very unstable under this), and I noticed that it's perfectly possible to disable all textures (as in Skyrim) by simply deleting or, better, moving the following files to a separate folder:


  • Fallout4 - Textures1.ba2
  • Fallout4 - Textures2.ba2
  • Fallout4 - Textures3.ba2
  • Fallout4 - Textures4.ba2
  • Fallout4 - Textures5.ba2
  • Fallout4 - Textures6.ba2
  • Fallout4 - Textures7.ba2
  • Fallout4 - Textures8.ba2
  • Fallout4 - Textures9.ba2
They are usually found in Fallout 4>Data. I tried also moving Fallout4 - Shaders.ba2 to a separate folder, but the game didn't wanna run then.

Here is a low res screenshot (640x480) of how this looks:



Performance was increased quite a bit in this "mode", but I also experienced a strange bug with my character not wanting to move (Pip-Boy worked however). Maybe someone could replicate this and see if the bug happens?

I realize the above is likely irrelevant to most, but perhaps can be of use to someone running the game on an outdated/unsupported GPU.
 
Oct 30, 2009
5,313
0
0
Asked in the main thread but didn't get much of a response. How CPU intensive is the game? I'd be looking to run it with a Phenom II 840, a bit below the minimum requirements. I'm good to go with everything else.

Would I be ok on PC or should I go console?
 
Nov 28, 2014
599
0
0
USA
www.blurbusters.com
Shadow distance seems to be bugged, at least I think it is.

Here I am standing on the roof of the police station looking to the south and getting maximum fps (I capped my fps to 72 so it's actually more than that.

I turn around 180° and suddenly my fps drop to around 30

Here's mine looking at the same place near the same time of day:

Game is running maxed (Godrays included) @1080p default FOV, with a 60 fps cap via RTSS. Game is installed on SSD. No ini overrides are applied.

As can be seen in the screen, I'm at a locked 60 fps; my GPU usage isn't even hitting 50%.

My Specs:

OS: Windows 10 64-bit
nVidia Driver: 358.91
Motherboard: ASRock Z87 Extreme4
Power Supply: EVGA SuperNOVA 750W G2
CPU: i7-4770k @4.2GHz (HT Enabled)
Heatsink: Hyper 212 Evo w/2x Noctua NF-F12 Fans
GPU: GIGABYTE GTX 980 Ti G1 Gaming 6GB
RAM: 16GB G.SKILL Sniper @1866MHz
SSD (OS): 256GB Samsung 850 Pro
HDD (Games): 1TB Western Digital Caviar Black 7200 RPM

You didn't list your setup in your post, but it does look like you've modified the FOV a bit. In my testing, the game is tuned to the default 80. The higher you set it, the lower GPU usage gets, which drops the framerate.

If it's not the FOV, a highly modified ini, or serious downsampling (though your screenshot looks native 1080), I'm not sure what's going on there.
 
Nov 21, 2010
5,871
1
0
Virginia, USA
Rösti;185383826 said:
As my GPU isn't supported (apparently) I'm forced to run the game via the Microsoft Basic Render Driver (by disabling my GPU). I've been tinkering around with a few settings (the game is very unstable under this), and I noticed that it's perfectly possible to disable all textures (as in Skyrim) by simply deleting or, better, moving the following files to a separate folder:


  • Fallout4 - Textures1.ba2
  • Fallout4 - Textures2.ba2
  • Fallout4 - Textures3.ba2
  • Fallout4 - Textures4.ba2
  • Fallout4 - Textures5.ba2
  • Fallout4 - Textures6.ba2
  • Fallout4 - Textures7.ba2
  • Fallout4 - Textures8.ba2
  • Fallout4 - Textures9.ba2
They are usually found in Fallout 4>Data. I tried also moving Fallout4 - Shaders.ba2 to a separate folder, but the game didn't wanna run then.

Here is a low res screenshot (640x480) of how this looks:



Performance was increased quite a bit in this "mode", but I also experienced a strange bug with my character not wanting to move (Pip-Boy worked however). Maybe someone could replicate this and see if the bug happens?

I realize the above is likely irrelevant to most, but perhaps can be of use to someone running the game on an outdated/unsupported GPU.
Honest question: what's the point of even playing the game like that? I can understand that "graphics" aren't everything but at that point you're pretty much missing a ton of vital information that makes the game.
 
Oct 21, 2014
16,130
1
0
Rösti;185384360 said:
ATI Radeon 3000 Graphics, 252 MB dedicated memory.
I see. Apparently is a bit of an understatement. You could buy a better card for little more than the price of the game.

Honest question: what's the point of even playing the game like that? I can understand that "graphics" aren't everything but at that point you're pretty much missing a ton of vital information that makes the game.
Not to mention that the game is already a bitch to the CPU, adding more load via software rendering is folly.
 
R

Rösti

Unconfirmed Member
Honest question: what's the point of even playing the game like that? I can understand that "graphics" aren't everything but at that point you're pretty much missing a ton of vital information that makes the game.
I bought the game knowing that my GPU likely wouldn't be supported and that some tweaking would be required. But at least I can play the game, I don't care how it looks. Interest in wasting $49.99 I have not.
 

Einchy

semen stains the mountaintops
Jun 21, 2010
23,756
0
690
Rosti, is it a hobby trying to see how awful you can make a game look? You do the same with WoW


All of these constant FPS drops to 30 when in cities are a huge bummer. It makes combat really shitty since if I look an inch to the left I'll go up to 60 but an inch to the right and I'm back down to 30.
 
Mar 1, 2010
971
0
0
39
Outside your window
Man, you guys weren't kidding with the performance issues in Lexington. Went from a pretty constant 60 to constant drops to 30 :(
I actually had to turn the game off after spending 10 minutes there. The FPS swings where giving me some serious eye strain.

The Gamebryo is notoriously shitty when it comes to lighting and shadow problems, see Skyrim.
 
Mar 28, 2013
1,990
0
0
I'm actually giving a thumbs up to my computer screen right now in honor of this post. This really cleaned up the performance for me.
Glad it worked for you as well.

For those who didn't see it, give these changes a try. Found it on the guru3d forums and it worked for everyone I've talked to:

I changed in [Display] from Fallout4Prefs.ini
bTopMostWindow=0
bMaximizeWindow=0
bBorderless=0
bFull Screen=1

and in Fallout4.ini:

[General]
iFPSClamp=60

(To make sure it'd work, I made these changes in all 4 .ini files)

It did wonders here. I'm always skeptical and expect most ini tweaks to be placebos, but the difference is real. No more microstuttering and much better performance in Lexington, which was the one place with major drops and stuttering so far (not in DC yet).
Also, according to Notepad++, both files are changed everytime I start the game, but I didn't bother to check what values. Anyway, I recommend making both read-only.
Also, if you have a G-Sync monitor as well, turn G-Sync off and cap the framerate at 60. The game runs faster at 72fps.
 
Oct 21, 2012
4,918
1
0
Toronto, CA
Glad it worked for you as well.

For those who didn't see it, give these changes a try. Found it on the guru3d forums and it worked for everyone I've talked to:



Also, if you have a G-Sync monitor as well, turn G-Sync off and cap the framerate at 60. The game runs faster at 72fps.
Where are the 4 files located?

My Games -> Fallout 4 and where else?
 
Mar 28, 2013
1,990
0
0
Where are the 4 files located?

My Games -> Fallout 4 and where else?
The steam folder has Fallout_default.ini, and within that folder there's another one called Fallout4, with a Fallout4Prefs.ini inside.
I don't think it's necessary, graphics tweaks seem to work with the Fallout4Prefs in My Games already, but I changed them just in case.
 
Feb 24, 2013
9,323
0
0
I'm on i7-4790k and 970. Everything ultra but godrays on medium. In the city area my fps many times drops noticeably and it's jarring so I'd rather lower more settings to have constant 60fps. What settings nets me the best returns if lowered?
 
Jun 7, 2013
20,288
0
0
I'm on i7-4790k and 970. Everything ultra but godrays on medium. In the city area my fps many times drops noticeably and it's jarring so I'd rather lower more settings to have constant 60fps. What settings nets me the best returns if lowered?
Shadow Distance. Try it on high. Medium is a big boost too but it makes shadows pop up all the time and takes away a lot of the look.
 
Oct 21, 2012
4,918
1
0
Toronto, CA
The steam folder has Fallout_default.ini, and within that folder there's another one called Fallout4, with a Fallout4Prefs.ini inside.
I don't think it's necessary, graphics tweaks seem to work with the Fallout4Prefs in My Games already, but I changed them just in case.
Ok, thanks! I was having trouble tracking them all down. I'll give it a spin tonight or tomorrow.

edit: My Fallout4Prefs.ini settings were already set to that. Bummer.
 
Nov 10, 2011
6,321
0
0
Whatever's happening is definitely something inherent to the game and not something that a high-end card can just muscle its way through. You guys with 980ti's seem to be getting around the same performance as my 680, and that ain't right.
 
Jan 29, 2013
5,767
0
0
I'm so confused...
This is on a GTX 980ti.
Very poor occlusion culling I bet.
I have a 980 Ti too and I get awful framerates when looking at lots of geometry. I thought it was my older CPU at first, but others are getting problems with this too. I haven't seen it go as low as 19 though. Into the 40s is the lowest I recall.