Metal Gear Solid V: The Phantom Pain PC performance thread

So, I have everything on max and just played through the prologue.

There were three moments where the game kicked my ass: The very first scene you see on boot up(I think it's just literally a shot of a mirror),
Ishmael moving your body as you see the first soldier gun down the hospital worker
and the close up of a reflection on a soldier's helmet.

Otherwise it's been rock solid 60 for gameplay with the (very) rare dips during cutscenes. The last three stuck out to me though because they were particularly extreme dips, anywhere from 30s to, I think I straight up saw the number 9 at one point. The reflections I can understand, although I don't really know what the hell was going on to cause a drop during the Ishmael moment. If it keeps popping up in cutscenes, I guess I'll try to lower post processing or something.

Otherwise, GZ levels of performance with even crazier visuals. Great port, at least as far as performance is concerned.

i5 4570
GTX 980
12GB RAM
SSD
Windows 10
So, I guess as a small update, I'm 20 hours into the game, and the only time I've noticed the framerate drop beyond the prologue was once. But that once was a major once. The minor cutscene for the very first time your chopper drops you in Africa
(Mission 13)
chugged real god damn hard.

I'm guessing much like the other moments my framerate tanked, that was a weird bug that a bunch of people experienced and not necessarily tied to what I had my settings set to(I tested the mirror/soldiers helmet/
Ishmael moving your body
scenes early on at everything set to High instead of Very High and they all ran equally as poorly)

Otherwise, locked 60 oohhh yeah.
 
So, I guess as a small update, I'm 20 hours into the game, and the only time I've noticed the framerate drop beyond the prologue was once. But that once was a major once. The minor cutscene for the very first time your chopper drops you in Africa
(Mission 13)
chugged real god damn hard.

I'm guessing much like the other moments my framerate tanked, that was a weird bug that a bunch of people experienced and not necessarily tied to what I had my settings set to(I tested the mirror/soldiers helmet/
Ishmael moving your body
scenes early on at everything set to High instead of Very High and they all ran equally as poorly)

Otherwise, locked 60 oohhh yeah.
My fps also chugged on the first time landing in
Africa
. Im assuming it is a bug because I have had no other issues when getting dropped other than that one time.
 
Okay so judging by this thread these settings should give me a solid 60 fps on a GTX 970/i5 4690:

-1440p DSR
-Extra High on most settings
-Set the effects setting to high instead of extra high due to tons of overlapping alpha effecting performance. (By the way, how much of an actual visual difference does this make?)
-Set Post-processing off (or to low? What is everything that's tied to this setting?) because the DSR should be a good substitute for Anti-aliasing.
-Potentially turn off volumetric clouds for a performance boost?
-Turn off in game AO and turn on "quality" AO in the Nvidia Control Panel to get HBAO+

Did I miss anything? Can't try it out till I get back home on Sunday, just want to make sure I have settings straight so set-up can take up minimal time on Sunday night.
 
Okay so judging by this thread these settings should give me a solid 60 fps on a GTX 970/i5 4690:

-1440p DSR
-Extra High on most settings
-Set the effects setting to high instead of extra high due to tons of overlapping alpha effecting performance. (By the way, how much of an actual visual difference does this make?)
-Set Post-processing off (or to low? What is everything that's tied to this setting?) because the DSR should be a good substitute for Anti-aliasing.
-Potentially turn off volumetric clouds for a performance boost?
-Turn off in game AO and turn on "quality" AO in the Nvidia Control Panel to get HBAO+

Did I miss anything? Can't try it out till I get back home on Sunday, just want to make sure I have settings straight so set-up can take up minimal time on Sunday night.
That's mostly fine, but don't turn off post processing as that will remove DOF. Also AA is definitely still necessary even with DSR.
 

Alo81

Low Poly Gynecologist
Okay so judging by this thread these settings should give me a solid 60 fps on a GTX 970/i5 4690:

-1440p DSR
-Extra High on most settings
-Set the effects setting to high instead of extra high due to tons of overlapping alpha effecting performance. (By the way, how much of an actual visual difference does this make?)
-Set Post-processing off (or to low? What is everything that's tied to this setting?) because the DSR should be a good substitute for Anti-aliasing.
-Potentially turn off volumetric clouds for a performance boost?
-Turn off in game AO and turn on "quality" AO in the Nvidia Control Panel to get HBAO+

Did I miss anything? Can't try it out till I get back home on Sunday, just want to make sure I have settings straight so set-up can take up minimal time on Sunday night.
I have a 970. I get FPS drops in dense areas at 1440p, I'd recommend sticking to 1080 if you want to max the settings.

Instead of setting post-processing to off, I would personally just do the little mod tweak to disable FXAA on Extra High so you don't lose the other goodies.
 
I have a 970. I get FPS drops in dense areas at 1440p, I'd recommend sticking to 1080 if you want to max the settings.

Instead of setting post-processing to off, I would personally just do the little mod tweak to disable FXAA on Extra High so you don't lose the other goodies.
Personally, I just dropped it a notch to 2351x1323. Seems to be solid with only a few rare unnoticeable fps dips to the high 50s and everything else maxxed, including HBAO. Is there something wrong with the in between resolutions that I'm not aware of? ;o
 

Alo81

Low Poly Gynecologist
Anyone figure out how to turn off the ingame frame limiter yet?
I think these lines in the init.lua file will have something to do with it
Code:
if e=="directx11"then
FoxGameFrame.SetGameFrameWaitType"VirtualVsyncDx11"else
FoxGameFrame.SetGameFrameWaitType"VirtualVsync"end
end
I'm just not certain what to replace that with. In Ground Zeroes we simply had to erase that part of the file from start.lua
 
That's mostly fine, but don't turn off post processing as that will remove DOF. Also AA is definitely still necessary even with DSR.
Got it. This will be my first time using DSR so I assumed it would be a good subsititute for AA, but I guess not!

I have a 970. I get FPS drops in dense areas at 1440p, I'd recommend sticking to 1080 if you want to max the settings.

Instead of setting post-processing to off, I would personally just do the little mod tweak to disable FXAA on Extra High so you don't lose the other goodies.
I'll try out 1440p with a few settings turned down to high from extra high and see how it works out I guess, and go to 1080p if I can't find a decent compromise.

And I see! Can you point me toward that mod tweak?

So I should disable the in game AA and force better AA through Nvidia control panel?
 
Does anyone else have the issue where dropping even a single frame below 60 causes crazy input lag, and stuttering? It's almost like the game activates some sort of triple buffering. I've had this issue in a few games, and I've no idea what causes it or how to solve it.
 
So I should disable the in game AA and force better AA through Nvidia control panel?
After I disabled the in-game AA (via unpacking/repacking the data1.dat file, as explained by Alo81 earlier in this thread), I messed around with SweetFX on my 980 Ti at 1440p DSR...

I found that SMAA had slightly more accurate edge coverage, when compared to the in-game AA, and was much sharper of course. However, as expected, SMAA did a worse job at reducing sub-pixel shimmering, like on grates, shiny surfaces, etc. SweetFX FXAA (the same solution as Nvidia Control Panel's FXAA, but with no aggressive sub-pixel coverage, which gives traditional FXAA most of its signature blur) was slightly less blurry than the in-game FXAA, but had about the same coverage as the game's AA, and noticeably distorted the UI.

I tried applying SweetFX SMAA and FXAA over the existing in-game AA also. SMAA caused artifacts, and double FXAA just blurred the image more, with no further reduction of aliasing.

So basically, if you want a sharper image with slightly better edge detection, disable in-game AA and inject SMAA, and if you have the extra GPU power to use DSR, it really does help solidify the sub-pixel details (railing, fences, grates, powerlines). As for forcing AA in the Nvidia Control panel, other than FXAA, it's a no go. This game uses DX11, which means there is no way to force traditional MSAA unless the game supports it natively; this one does not.
 

Alo81

Low Poly Gynecologist
Got it. This will be my first time using DSR so I assumed it would be a good subsititute for AA, but I guess not!



I'll try out 1440p with a few settings turned down to high from extra high and see how it works out I guess, and go to 1080p if I can't find a decent compromise.

And I see! Can you point me toward that mod tweak?

So I should disable the in game AA and force better AA through Nvidia control panel?
I force better AA using SweetFx 1.5.1. Enable SMAA.

The mod:
  1. Download MGSV_QAR_Tool.
  2. Extract it to "MGS_TPP\master" folder.
  3. Follow the readme instructions on unpacking Phantom Pain PC

    For PC version of MGS TPP (unpack):
    MGSV_QAR_Tool data1.dat -r

    For PC version of MGS TPP (pack):
    MGSV_QAR_Tool data1.inf -r
  4. After you extract open up the following file in your text editor of choice.

    MGS_TPP\master\data1\Fox\Scripts\Gr\gr_init_dx11.lua
  5. Ctrl + F to find the FXAA settings

    {settingName="PluginFxaa",settingTable={{name="G7",EnableFilter=1},{name="G8E",EnableFilter=1},{name="Default",EnableFilter=1},{name="Off",EnableFilter=0},{name="Low",EnableFilter=0},{name="High",EnableFilter=1},{name="ExtraHigh",EnableFilter=1}}},
  6. Change {name="ExtraHigh",EnableFilter=1} to {name="ExtraHigh",EnableFilter=0}
  7. Save the file, then repack the data1.dat file with the following command.

    MGSV_QAR_Tool data1.inf -r

After that, FXAA will be disabled in Extra High.

Now you can use SweetFx to enable whatever AA you want. Nvidia Control Panel FXAA may work as well, I've not tested that yet.
 
This game would have benefited so much from a Temporal AA solution. when moving fast the motion blur and the DOF handle the jaggies pretty well, but once a static image or slow pans the horror shows itself.
 

Alo81

Low Poly Gynecologist
This game would have benefited so much from a Temporal AA solution. when moving fast the motion blur and the DOF handle the jaggies pretty well, but once a static image or slow pans the horror shows itself.
Definitely agree. Aliasing is my biggest problem visually with the game
 
Älg;177625241 said:
Does anyone else have the issue where dropping even a single frame below 60 causes crazy input lag, and stuttering? It's almost like the game activates some sort of triple buffering. I've had this issue in a few games, and I've no idea what causes it or how to solve it.
Same thing here. I've had to lower my resolution drastically just to ensure it never dips below a constant 60, because even 40-50 is unplayable for some reason. For some reason a locked 30 FPS in TPP feels more like how 15-20 FPS feels in other games
 
Älg;177625241 said:
Does anyone else have the issue where dropping even a single frame below 60 causes crazy input lag, and stuttering? It's almost like the game activates some sort of triple buffering. I've had this issue in a few games, and I've no idea what causes it or how to solve it.
Yep, this is why I'm using the 30 fps lock. It's not perfect (unfortunately the frametime is not solid) but the mouse feels so much more responsive compared to having the frame rate unlocked.
 
Uh, wtf just happened?

I was running the pre-MGSV drivers, two 980s SLI, 4k/60fps only frame drops here and there. I upgrade to the latest Nvidia drivers and suddenly I'm getting worse performance with the framerate not really holding at any compound with 4k/60fps, on top of that the plants are flickering in night vision.

AND MOST OF ALL 2 hours into a mission, when I beat the mission and the score screen began to appear to total my score MY COMPUTER SHUT DOWN FROM OVERHEATING.

This is really weird because I'm not running any overclocks and I played the game for like 6 hours straight yesterday and it didn't get this hot. It's like the new drivers are making it run even hotter, seems like a glitch. I did express installation, so I'm gonna uninstall the drivers and re-install them. But man, first I'm gonna check and see if I lost all 2 hours of progress and have to redo the entire mission. If I have to do that ARGHGHHGHGH
 
3570k stock
970 overclocked
16GB RAM
Windows 10

Playing at 1080p, everything maxed out, except DOF (off) and motion blur (off) and HBAO+ forced through control panel, and not dropped a single frame yet, having put 10 hours into the game, be it cut-scene or otherwise.

Kojima is a wizard.
 
Once the beta patch came out my old Phenom 2 is running the game good enough for me. No frame drops with low-med settings. Only part of my PC that isn't 8 years old is my vid card, and that is a 960 ssc.
 
I get these weird blue horizontal lines that will flicker every once and awhile. Is that intentional or my GPU artifacting? I think I've only noticed it at night, but they don't look like lens flare, though its the same color blue. They're very thin.

980 Ti, all settings maxed.
 
I get these weird blue horizontal lines that will flicker every once and awhile. Is that intentional or my GPU artifacting? I think I've only noticed it at night, but they don't look like lens flare, though its the same color blue. They're very thin.

980 Ti, all settings maxed.
Might be a spotlight moving over you briefly.
 
I did a complete wipe/reinstall of the current NVIDIA drivers and GeForce Experience and I still can't use the "optimize" settings for this game. Seems like there's a long history of people having this issue with certain games but I haven't seen a proper fix and it seems to be more something on NVIDIA's end.
 
Same thing here. I've had to lower my resolution drastically just to ensure it never dips below a constant 60, because even 40-50 is unplayable for some reason. For some reason a locked 30 FPS in TPP feels more like how 15-20 FPS feels in other games
Yep, this is why I'm using the 30 fps lock. It's not perfect (unfortunately the frametime is not solid) but the mouse feels so much more responsive compared to having the frame rate unlocked.
Alright, good to know it's not just me at least. Have you guys experienced this issue in other games as well, or is it just TPP?

It's really annoying too, I can run almost everything on Extra High, save for the situations where you look over a large, lit, structure. There I need to lower either Shadows or Lighting to High.
 
Älg;177648461 said:
Alright, good to know it's not just me at least. Have you guys experienced this issue in other games as well, or is it just TPP?

It's really annoying too, I can run almost everything on Extra High, save for the situations where you look over a large, lit, structure. There I need to lower either Shadows or Lighting to High.
I know that lighting at extra high at 1440p on my 970 consistently causes drops to 50 for me.
 
Älg;177648461 said:
Alright, good to know it's not just me at least. Have you guys experienced this issue in other games as well, or is it just TPP?

It's really annoying too, I can run almost everything on Extra High, save for the situations where you look over a large, lit, structure. There I need to lower either Shadows or Lighting to High.
As far as I can tell it's just TPP. I was playing GZ the day before TPP came out and it felt totally fine even when the frame rate dropped below 60.

Also, I would not recommend dropping either of those two settings if you're after more performance. You'll get a noticeable increase in frame rate but the Extra High settings for Lighting and Shadows offer a lot more than the next setting down.

Nvidia's Shadow Comparison
Nvidia's Lightning Comparison
 
Also, I would not recommend dropping either of those two settings if you're after more performance. You'll get a noticeable increase in frame rate but the Extra High settings for Lighting and Shadows offer a lot more than the next setting down.

Nvidia's Shadow Comparison
Nvidia's Lightning Comparison
Yeah I know, that's why this suck so much for me. There really aren't any other things that I can reduce that give a siginificant enough increase in performance. I already have post processing and effects on High, and I really don't want to lose DoF.
 

TronLight

Everybody is Mikkelsexual
As far as I can tell it's just TPP. I was playing GZ the day before TPP came out and it felt totally fine even when the frame rate dropped below 60.

Also, I would not recommend dropping either of those two settings if you're after more performance. You'll get a noticeable increase in frame rate but the Extra High settings for Lighting and Shadows offer a lot more than the next setting down.

Nvidia's Shadow Comparison
Nvidia's Lightning Comparison
Did somebody mess it up here? It looks more like Extra Hight vs Normal. Wow.
 
Performance on this game is great, I got near locked 60 FPS on a 660ti at 1080p by just dropping shadows and post-processing to high, and disabling volumetric shadows. My FPS would drop whenever my camera is near an alpha effect so I ended up dropping effects to high as well and now it's locked 60 FPS pretty much, with a mixture of very high and high, on a 660ti. That's pretty good I would say.
 
Älg;177649895 said:
Yeah I know, that's why this suck so much for me. There really aren't any other things that I can reduce that give a siginificant enough increase in performance. I already have post processing and effects on High, and I really don't want to lose DoF.
Volumetric Clouds are a big hit on my framerate as well. You got those off?
 

TronLight

Everybody is Mikkelsexual
Älg;177650009 said:
It's more a case of Extra High being really extra. Seriously, the distance at which shadows and lights render at Extra High is pretty god damn impressive.
I love that Extra High is really extra, but in that comparison, lights and shadows just like 10 meters away are gone on High, I can't imagine having those tents and trees casting a shadow whould kill the framerate.
 
Volumetric Clouds are a big hit on my framerate as well. You got those off?
Hmm, didn't think of that actually. Should probably try that. I usually never drop below 55, do you reckon that it'll be enough? It pretty much only happens when I'm overlooking a large building with many lights on it at night.

I love that Extra High is really extra, but in that comparison, lights and shadows just like 10 meters away are gone on High, I can't imagine having those tents and trees casting a shadow whould kill the framerate.
Yeah, they could probably get away with some more agressive quality scaling on the shadows.
 
I force better AA using SweetFx 1.5.1. Enable SMAA.

The mod:
  1. Download MGSV_QAR_Tool.
  2. Extract it to "MGS_TPPmaster" folder.
  3. Follow the readme instructions on unpacking Phantom Pain PC


  4. After you extract open up the following file in your text editor of choice.


  5. Ctrl + F to find the FXAA settings


  6. Change {name="ExtraHigh",EnableFilter=1} to {name="ExtraHigh",EnableFilter=0}
  7. Save the file, then repack the data1.dat file with the following command.


After that, FXAA will be disabled in Extra High.

Now you can use SweetFx to enable whatever AA you want. Nvidia Control Panel FXAA may work as well, I've not tested that yet.
I thought that injecting effects doesnt work with Ground Zeroes and TPP because they have a build in protection against something like that. Any comparision screens?
 
Älg;177650153 said:
Hmm, didn't think of that actually. Should probably try that. I usually never drop below 55, do you reckon that it'll be enough? It pretty much only happens when I'm overlooking a large building with many lights on it at night.
Volumetric clouds seems to have a 3-5 FPS hit on my system, no matter the scene, so it may be what's pushing you over the edge. Try having it off and see if the drops are slightly more subdued.
 
Something's not right here. Particularly their shadow comparison. I am playing with everything set to Extra high EXCEPT shadows, and my game looks worlds better than that.

1080p
i5 4690 + 980
I noticed that it really depends on the scene, it's pretty cool how the Fox Engine optimizes stuff and I guess that's how they achieved 60fps on consoles.

When there's a lot of dynamic lighting / objects in the scene, the shadow draw distance is smaller. But when the scene is sparser, the engine automatically draws shadows more far away when there is performance to spare.
 
question: are the save files easily accessible so i can make a back up? i fancy starting the game again from the start (progression and all), but i want to keep my complete save file on hand if i feel like futzing around in the completed game until my new save file is in a similar place
 
Personally, I just dropped it a notch to 2351x1323. Seems to be solid with only a few rare unnoticeable fps dips to the high 50s and everything else maxxed, including HBAO. Is there something wrong with the in between resolutions that I'm not aware of? ;o
In my opinion, DSR looks weird unless down sampling from 3840x2160 (2:1 ratio in both height and width) or 2880x1620 (3:2 ratio in both height and width). Even 2560x1440 (4:3 ratio) looks a bit weird to me. Is there any way to downsample in just one direction? I used to run pcsx2 at 3840x1080 and it looked great when downsampled to 1920x1080.
 
I noticed that it really depends on the scene, it's pretty cool how the Fox Engine optimizes stuff and I guess that's how they achieved 60fps on consoles.

When there's a lot of dynamic lighting / objects in the scene, the shadow draw distance is smaller. But when the scene is sparser, the engine automatically draws shadows more far away when there is performance to spare.
Oh really? That sounds incredibly... dynamic. Helluva engine then. Guess I should crank some settings then...